Subject: [anonsec] Why use self-signed certs at all?

From: Atul.Sharma at nokia.com ([email-masked])
Date: Fri Nov 19 11:13:54 2004

I agree self signed certificates provide no more trust than
a secret and increase the complexity.

If the secrets have life-time then SAs can be reestablished during
its lifetime....same as during a cert's lifetime.

Besides, I do not feel that a use of self-signed certs forces BTNS
into PKI4IPSEC realm. Self-signed certs is not PKI, so why force
BTNS into a PKI-specific work? It sounds bizarre to me.

Atul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of ext Joe Touch
> Sent: Friday, November 19, 2004 1:43 PM
> To: Discussions of anonymous Internet security.
> Subject: Re: [anonsec] Why use self-signed certs at all?
> 
> 
> 
> 
> Paul Hoffman / VPNC wrote:
> > At 10:07 AM -0800 11/19/04, Joe Touch wrote:
> > 
> >> FWIW, this is what I had originally assumed (e.g., "OPEN 
> SECRET" as 
> >> the shared secret). I've discussed the issue of 
> self-signed certs, and 
> >> it seems like it unnecessarily depends on additional 
> mechanism (cert 
> >> signing system) pre-installed and configured. It'd be 
> useful to avoid 
> >> as much of that sort of requirement/assumption as possible.
> > 
> > 
> > If that's true at all, then the discussion of moving this 
> to PKI4IPSEC 
> > is very out of scope. If we later decide that we really are using 
> > self-signed certs, we can consider the move then.
> 
> FWIW, others care about the use of a persistent ID, and 
> assume that the 
> self-signed cert is where that ID lives. I don't understand 
> why that's 
> required per se; it seems that we should be able to place or refer to 
> IDs by something other than an X.509 cert.
> 
> I.e., IDs inside X.509 are some sort of names. If that's the 
> case, then 
> the use of the name ought not require X.509 per se. IMO, using "X.509 
> cert" where we mean "the name the X.509 cert authenticates" is a 
> mistake, and binds us to a level of complexity we don't always need.
> 
> Joe
>

---

From: Nicolas.Williams at sun.com (Nicolas Williams)
Date: Fri Nov 19 11:22:20 2004

> BTNS into a PKI-specific work? It sounds bizarre to me.

First, the proposal from Sam was to re-charter PKI4IPSEC, so please
let's stop arguing over whether its charter fits BTNS or not -- if we
agree to place BTNS there then the charter *will* fit it.

Some reasons: overlap of attendees, cost to the IETF of spinning up a
new WG, risk of scheduling conflicts, etc...

---

From: kent at bbn.com (Stephen Kent)
Date: Fri Nov 19 14:27:22 2004

>a secret and increase the complexity.

the comparison was not to a secret, but to an "open secret" which is 
probably not secret at all.  of source, maybe we don't really know 
what is meant by this latter term so ...

>its lifetime....same as during a cert's lifetime.

a cert has the advantage that it discloses no info that enables a 
passive wiretapper to pose as the cert holder, during the time that 
the public key from the cert is used to secure other keys, etc. 
however, if one sends the open secret via IKE's encrypted SA, I guess 
you can argue that it's not exposed to passive intercept, although it 
is exposed to attacks that cause you to connect to the wrong 
destination,

>BTNS into a PKI-specific work? It sounds bizarre to me.

somewhat tongue in cheek, a self signed cert represents a very small PKI :-)

Steve

---

From: Nicolas.Williams at sun.com (Nicolas Williams)
Date: Fri Nov 19 21:04:23 2004

> somewhat tongue in cheek, a self signed cert represents a very small PKI :-)

Heh!