Subject: [Dcrup] WG call for adoption https://tools.ietf.org/html/draft-srose-dkim-ecc-00

From: "Salz, Rich" <[email-masked]>
Date: Sat, 20 May 2017 22:38:57 +0000

This was brought up when the WG was just created and I wanted to wait a bit.  Thanks to JohnL for nudging me.

Should the WG adopt https://tools.ietf.org/html/draft-srose-dkim-ecc-00  ?  Please respond by next Friday.

--
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: [email-masked] Twitter: RichSalz

---

From: Russ Housley <[email-masked]>
Date: Tue, 23 May 2017 11:41:47 -0400

A lot more needs to be said to define Ed25519 or Ed448 to be used with DKIM.  As they are being used in the CURDLE WG, they do not accept a hash value and an input for signing.

I think it is important that the WG define an ECC solution, so I do not mind starting with this document, but there is a good bit of work needed.

Russ

> On May 20, 2017, at 6:38 PM, Salz, Rich <[email-masked]> wrote:
> 
> Should the WG adopt https://tools.ietf.org/html/draft-srose-dkim-ecc-00 <https://tools.ietf.org/html/draft-srose-dkim-ecc-00>  ?  Please respond by next Friday.
>  
>  
>  
> --  
> IM: [email-masked] <mailto:[email-masked]> Twitter: RichSalz

---

From: "Rose, Scott" <[email-masked]>
Date: Tue, 23 May 2017 13:47:54 -0400

I-D author here,
Yes - I agree.  It needs work.  It was my attempt to just have something 
to start the conversation, not knowing the conversation had started 
earlier.

If it is accepted as a WG doc, I will continue to edit it with WG input. 
  I believe it is something that is needed and will go about updating 
it.

Scott

On 23 May 2017, at 11:41, Russ Housley wrote:

> A lot more needs to be said to define Ed25519 or Ed448 to be used with 
> DKIM.  As they are being used in the CURDLE WG, they do not accept a 
> hash value and an input for signing.
>
> I think it is important that the WG define an ECC solution, so I do 
> not mind starting with this document, but there is a good bit of work 
> needed.
>
> Russ
>
>
>> Should the WG adopt 
>> https://tools.ietf.org/html/draft-srose-dkim-ecc-00 
>> <https://tools.ietf.org/html/draft-srose-dkim-ecc-00>  ?  Please 
>> respond by next Friday.
>>
>>
>>
>> --

> _______________________________________________
> Dcrup mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dcrup

===================================
Scott Rose
NIST ITL
[email-masked]
+1-301-975-8439
GV: +1-571-249-3671
===================================