Subject: Re: [dispatch] draft-weinronk-dispatch-last-diverting-line-id

From: N WEINRONK <[email-masked]>
Date: Wed, 9 Mar 2016 11:05:08 +0000 (GMT)

Thank you for your comments on this Internet Draft – I will
try and answer your points.
Do you believe it is legacy from the early ISDN definitions or do you
believe it is new? 
Neither it a consequence of the way ETSI ISDN was
implemented in the UK in the 1990s that is still in use today – see below.
Note: I assume by early ISDN definitions you mean where ETSI ISDN was mapped to DASS and I am not talking about this.
Can you explain where a proposed UK requirement comes from that is not
contained within the ETSI and ITU-T service definitions for the ISDN? 
This comes from current implementations in the UK based on
NICC ND1007.
In UK ISUP there is a parameter optional in the IAM – Last
Diverted Line Identity in additional to the ITU/ETSI parameter Redirecting
Number.
There are times when these parameters are both present and
can hold different information.
You could see this as being analogous to FROM and
P-Asserted-Id headers in SIP with the Last Diverted Line Identity parameter being
the ‘network asserted identity’ used by networks other that the network
diverting the call to verify service and the Redirecting Number parameter being
the ‘presentation number’.
The cases I am aware of where these parameters can hold
different information come from ETSI ISDN diversion scenarios – Call Forwarding
Unconditional / Call Forwarding Busy / Call Forwarding No Reply / Call
Deflection / Partial Rerouting.
For Partial Rerouting the Last Diverted Line Identity
parameter is based on the ‘administration number’ as understood by the network
doing the diversion and the network doing the verification and billing for
these calls. The Redirecting Number parameter is set from the lastReroutingNr
from the ASN.1 the private network sets in the Q.931 SETUP message – these can/will be different.
For Call Forwarding Unconditional / Call Forwarding Busy /
Call Forwarding No Reply / Call Deflection the Last Diverted Line Identity parameter
is based on the ‘administration number’ as understood by the network doing the
diversion and the network doing the verification and billing for these calls.
The Redirecting Number parameter is set to the Called Party Number used to reach
the diverting party – these are not necessarily the same.
I’d also note that I believe if this is required then an addition to the
History-Info header field would be more appropriate. 
We (myself and the UK NICC SIP Task Group) did consider
using the History-Info header for this but as the mappings are already defined
from Redirecting Number parameter to History-Info by the IETF / ETSI / ITU it
was felt this would be confusing and make the mappings complicated.
Also I would expect this header to (like the Last Diverted
Line Identity parameter in UK ISUP) be limited in where it can be sent ie.
between network operators and not to end users again making use of History-Info
more complicated.
Nigel Weinronk
----Original message----
>From : [email-masked]
Date : 09/03/2016 - 02:47 (GMTST)
To : [email-masked], [email-masked]
Subject : Re: [dispatch] draft-weinronk-dispatch-last-diverting-line-id
Can you explain where a proposed UK requirement comes from that is not contained within the ETSI and ITU-T service definitions for the ISDN?
 
Do you believe it is legacy from the early ISDN definitions or do you believe it is new?
 
I’d also note that I believe if this is required then an addition to the History-Info header field would be more appropriate.
 
Regards
 
Keith Drage
 
From: dispatch [mailto:[email-masked]]
On Behalf Of EXT Hutchison, Phil
Sent: 04 March 2016 08:20
To: [email-masked]'
Subject: [dispatch] draft-weinronk-dispatch-last-diverting-line-id
 
Hi,
 
I believe that this is required in the UK, and therefore would like to see the draft accepted.
 
Regards
 
Phil
~~~~~~~~~~~~~~~~~
Phil Hutchison
Liberty Global CAO
 - Communications Architecture
Mobile +447775 938827 | Soft Client +44(0)3703 900464 | Email
[email-masked]
Meet Me Conference:
0808 1074444  [+44 1723204444]
PIN 1256450#
Visit
www.virginmedia.co.uk for more information, and more fun
Save paper - do you really need to print this email?
 
--------------------------------------------------------------------
Save Paper - Do you really need to print this e-mail?
Visit www.virginmedia.com for more information, and more fun.
This email and any attachments are or may be confidential and legally privileged
and are sent solely for the attention of the addressee(s). If you have received this
email in error, please delete it from your system: its use, disclosure or copying is
unauthorised. Statements and opinions expressed in this email may not represent
those of Virgin Media. Any representations or commitments in this email are
subject to contract. 
Registered office: Media House, Bartley Wood Business Park, Hook, Hampshire, RG27 9UP
Registered in England and Wales with number 2591237

---

From: Michael Hammer <[email-masked]>
Date: Wed, 9 Mar 2016 17:20:08 +0000

There is a danger here that this purpose could be supported by two different headers 

(a new header or an old header) with potential negative consequences.

Please show what prevents you from supporting this purpose with History-Info?

The argument that because A is supported by B, therefore C is not supported by B, is illogical.

________________________________

Michael Hammer

[email-masked] <mailto:[email-masked]> 

+1 408 202 9291

© 2016 Yaana Technologies, LLC. All Rights Reserved. Email confidentiality notice. This message is private and confidential. If you have received this message in error, please notify us and remove it from your system.

From: dispatch [mailto:[email-masked]] On Behalf Of N WEINRONK
Sent: Wednesday, March 09, 2016 6:05 AM
To: [email-masked]; [email-masked]
Subject: Re: [dispatch] draft-weinronk-dispatch-last-diverting-line-id

Thank you for your comments on this Internet Draft – I will try and answer your points.

Neither it a consequence of the way ETSI ISDN was implemented in the UK in the 1990s that is still in use today – see below.

This comes from current implementations in the UK based on NICC ND1007.

In UK ISUP there is a parameter optional in the IAM – Last Diverted Line Identity in additional to the ITU/ETSI parameter Redirecting Number.

There are times when these parameters are both present and can hold different information.

You could see this as being analogous to FROM and P-Asserted-Id headers in SIP with the Last Diverted Line Identity parameter being the ‘network asserted identity’ used by networks other that the network diverting the call to verify service and the Redirecting Number parameter being the ‘presentation number’.

The cases I am aware of where these parameters can hold different information come from ETSI ISDN diversion scenarios – Call Forwarding Unconditional / Call Forwarding Busy / Call Forwarding No Reply / Call Deflection / Partial Rerouting.

For Partial Rerouting the Last Diverted Line Identity parameter is based on the ‘administration number’ as understood by the network doing the diversion and the network doing the verification and billing for these calls. The Redirecting Number parameter is set from the lastReroutingNr from the ASN.1 the private network sets in the Q.931 SETUP message – these can/will be different.

For Call Forwarding Unconditional / Call Forwarding Busy / Call Forwarding No Reply / Call Deflection the Last Diverted Line Identity parameter is based on the ‘administration number’ as understood by the network doing the diversion and the network doing the verification and billing for these calls. The Redirecting Number parameter is set to the Called Party Number used to reach the diverting party – these are not necessarily the same.

We (myself and the UK NICC SIP Task Group) did consider using the History-Info header for this but as the mappings are already defined from Redirecting Number parameter to History-Info by the IETF / ETSI / ITU it was felt this would be confusing and make the mappings complicated.

Also I would expect this header to (like the Last Diverted Line Identity parameter in UK ISUP) be limited in where it can be sent ie. between network operators and not to end users again making use of History-Info more complicated.

Nigel Weinronk

----Original message----
>From : [email-masked] <mailto:[email-masked]> 
Date : 09/03/2016 - 02:47 (GMTST)
To : [email-masked] <mailto:[email-masked]> , [email-masked] <mailto:[email-masked]> 
Subject : Re: [dispatch] draft-weinronk-dispatch-last-diverting-line-id

Regards

Keith Drage

From: dispatch [mailto:[email-masked]] On Behalf Of EXT Hutchison, Phil
Sent: 04 March 2016 08:20
To: [email-masked]'
Subject: [dispatch] draft-weinronk-dispatch-last-diverting-line-id

Hi,

Regards

Phil 

~~~~~~~~~~~~~~~~~ 

Phil Hutchison 

Liberty Global CAO - Communications Architecture 

Mobile +447775 938827 | Soft Client +44(0)3703 900464 | Email  <mailto:[email-masked]> [email-masked] 

Meet Me Conference: 0808 1074444  [+44 1723204444] PIN 1256450#

Visit  <http://www.virginmedia.co.uk/> www.virginmedia.co.uk for more information, and more fun 

Visit www.virginmedia.com <http://www.virginmedia.com>  for more information, and more fun.