Subject: Re: [dispatch] Proposed CBOR / CDDL WG

From: Alexey Melnikov <[email-masked]>
Date: Fri, 25 Nov 2016 15:43:37 +0000

Hi Cullen,

On 24/10/2016 03:25, Cullen Jennings wrote:
>
>> On Oct 18, 2016, at 8:58 AM, Alexey Melnikov 
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>
>> In parallel to the work on CDDL, the WG will examine the
>> Internet-Drafts draft-jroatch-cbor-tags and 
>> draft-bormann-cbor-tags-oid that
>> use CBOR's extensibility mechanisms to provide additional data types 
>> as used in certain applications.  Where these proposals are deemed 
>> useful and do not require significant new
>> development, the CBOR WG might complete these specifications as well.
>
> Would it be possible to write this up in a way that said what the WG 
> would accomplish vs which drafts it would adopt ?
>
Ok, I suggest changing the above paragraph to read something like this:

In parallel to the work on CDDL, the WG will examine the
   CBOR extension for tagging of Typed Arrays (based on 
draft-jroatch-cbor-tags)
   and the CBOR extension for tagging of Object Identifiers and UUIDs
   (based on draft-bormann-cbor-tags-oid) that use CBOR's extensibility
   mechanisms to provide additional data types as used in certain 
applications.
   Where these proposals are deemed useful and do not require 
significant new
   development, the CBOR WG will complete these specifications as well.

Is this better?

Best Regards,
Alexey

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 28 Nov 2016 09:54:46 -0700

> On Nov 25, 2016, at 8:43 AM, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi Cullen,
> 
>>> On Oct 18, 2016, at 8:58 AM, Alexey Melnikov <[email-masked]> wrote:
>>> 
>>> 
>>> Internet-Drafts draft-jroatch-cbor-tags and draft-bormann-cbor-tags-oid that
>>> use CBOR's extensibility mechanisms to provide additional data types as used in certain applications.  Where these proposals are deemed useful and do not require significant new
>> Would it be possible to write this up in a way that said what the WG would accomplish vs which drafts it would adopt ?
>> 
>   CBOR extension for tagging of Typed Arrays (based on draft-jroatch-cbor-tags)
>   mechanisms to provide additional data types as used in certain applications.
>   Where these proposals are deemed useful and do not require significant new

Looks good to me. Thanks