Subject: Re: [httpwg/http-extensions] Incorporate feedback on httpbis-client-hints-03 (#305)

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Feb 2017 04:44:39 -0800

yoavweiss approved this pull request.

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/305#pullrequestreview-23880870

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Feb 2017 21:04:45 -0800

mnot requested changes on this pull request.

> @@ -130,7 +130,7 @@ Further, depending on the used hint, the server can emit additional response hea
 
 ### Advertising Support for Client Hints {#accept-ch}
 
-Servers can advertise support for Client Hints using the Accept-CH header field or an equivalent HTML meta element with http-equiv attribute ({{W3C.REC-html5-20141028}}).
+Servers should advertise support for Client Hints using the Accept-CH header field or an equivalent HTML meta element with http-equiv attribute ({{W3C.REC-html5-20141028}}).

"should" is a special word in the IETF -- do you mean SHOULD (i.e., an RFC2119 requirement)? If not, "can" is better. 

SHOULD is a bit problematic here, because typically when you use it, you should define the circumstances when the requirement can be violated.

> @@ -116,7 +116,7 @@ A Client Hint request header field is a HTTP header field that is used by HTTP c
 
 ## Sending Client Hints
 
-Clients control which Client Hint headers and their respective header fields are communicated, based on their default settings, user configuration and/or preferences. The user can be given the choice to enable, disable, or override specific hints.
+Clients control which Client Hint headers and their respective header fields are communicated, based on their default settings, user configuration and/or preferences. Implementers might provide user choice mechanisms so that users may balance privacy concerns with bandwidth limitations. Implementations specific to certain use cases or threat models might avoid transmitting these headers altogether, or limit them to secure contexts or authenticated sessions. Implementers should be aware that explaining the privacy implications of passive fingerprinting or network information disclosure may be challenging.

"Clients control which Client Hint headers and their respective header fields are communicated" -- this wording is odd. Suggest:

"Clients control which Client Hints are sent in requests, based..."

> @@ -233,7 +233,7 @@ If Viewport-Width occurs in a message more than once, the last value overrides a
 
 # The Downlink Client Hint {#downlink}
 
-The "Downlink" request header field is a number that indicates the client's maximum downlink speed in megabits per second (Mbps), as defined by the "downlinkMax" attribute in the W3C Network Information API ({{NETINFO}}).
+The "Downlink" request header field is a number that indicates the client's maximum downlink speed in megabits per second (Mbps). For example, as defined by the "downlinkMax" attribute in the W3C Network Information API ({{NETINFO}}).

I don't think defining the semantics in a "For example" is going to fly here. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/305#pullrequestreview-23913445

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Feb 2017 21:41:22 -0800

@igrigorik pushed 1 commit.

1e0c2d2  cleanup based on feedback

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/305/files/a2bb64184fce9986ddebf37db1a1a5a8e497a431..1e0c2d272dd5c4829aa6502a8a0e22411b2f0eec

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Feb 2017 21:41:40 -0800

@mnot thanks for the review, updated.. ptal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/305#issuecomment-282632973

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Feb 2017 21:45:33 -0800

mnot approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/305#pullrequestreview-23915976

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Feb 2017 21:48:39 -0800

Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/305#issuecomment-282633845

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Feb 2017 21:48:32 -0800

Merged #305.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/305#event-977810149