Subject: Re: [httpwg/http-extensions] Persistence (#291)

From: HTTP issue updates <[email-masked]>
Date: Mon, 20 Mar 2017 17:25:42 -0700

origin set is defined per connection not (ironically) per origin.. so I'm not sure how this would work.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/291#issuecomment-287939402

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 20 Mar 2017 17:28:37 -0700

2 loadbalanced hosts could have different sets of certs even if they answered to the same SNI on the same (public) IP..  I don't know how you could persist that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/291#issuecomment-287939805

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 20 Mar 2017 17:33:40 -0700

Yeah. I think there are a lot of ways we could mess up here. 

If you think of the binding as between a set of origins and a connection, AIUI what's being posited here is that it might be interesting to re-attach that binding to a new connection.

It might be interesting if the server could associate a token with a particular set, and then have a dance where its use can be explicitly negotiated. Question is whether it's worth the effort (we've already tried to over-engineer this thing a few times).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/291#issuecomment-287940593

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:37:47 -0700

Agreed that persisting across connections seems like it may add too much risk and complexity and further additional interactions, especially if we include hosts not found through the DNS.  (And doesn't even make sense with some of the changes made to not always rely on DNS.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/291#issuecomment-290729979