Subject: Re: [httpwg/http-extensions] Definition of Expect-CT is a little unclear (#318)

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 08:07:37 -0700

If it is supposed to be a list of directives (some of which may be name=value), then it should be
```
   Expect-CT       = #directive
   directive       = directive-name [ "=" directive-value ]
   directive-name  = token
   directive-value = token / quoted-string
```
If it is supposed to be a list of directives with optional name=value parameters to each directive, then
```
   Expect-CT       = #directive
   directive       = directive-name *( OWS ";" OWS parameter ) 
   directive-name  = token
   parameter       = token / ( token "=" quoted-string )
```
I guess we could also use some examples in the specification.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/318#issuecomment-290738269

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 08:08:35 -0700

@martinthomson  what you suggested *does* change the wire syntax...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/318#issuecomment-290738568

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 08:10:35 -0700

I also disgree with the statement:

> The convention for HTTP is to define header fields as follows:

That depends on the type of the field. It's definitively not true universally right now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/318#issuecomment-290739149

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 08:10:38 -0700

BTW, that would be to match the standard HTTP/1.x syntax for most header fields. I don't think it is appropriate to use the experimental common structure, which is still just a proposal, unless folks want to make this header field a guinea pig.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/318#issuecomment-290739172

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 08:12:56 -0700

https://greenbytes.de/tech/webdav/rfc7838.html#rfc.section.3 might be a good template.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/318#issuecomment-290739878