Subject: Re: [httpwg/http-extensions] Expect-CT uses cookie syntax (#316)

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:35:13 -0700

Does it? I don't think so:

> Expect-CT-Directives = directive *( OWS ";" OWS directive )
> directive            = directive-name [ "=" directive-value ]
> directive-name       = token
> directive-value      = token / quoted-string

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#issuecomment-290729250

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:36:36 -0700

What is the definition for `Expect-CT` itself?  Because you are right, this looks fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#issuecomment-290729633

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:42:42 -0700

This seems to be the ABNF for the field value (good), but the prose could be a bit more clear about that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#issuecomment-290731333

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:43:03 -0700

We can close this (invalid) and I will open a smaller issue about the definition of `Expect-CT` itself.  That can be just editorial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#issuecomment-290731435

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:43:03 -0700

Closed #316.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#event-1024206993

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:52:32 -0700

No, it is supposed to be a list.  It is defined as a semicolon-separated list.  That's the cookie syntax.

It should be

```
   Expect-CT       = #directive
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#issuecomment-290734075

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:58:04 -0700

:-) just because it doesn't use list syntax doesn't make it like cookies. For instance, that would make Content-Type "cookie-like" as well.

That said: yes, this might be a candidate for list syntax.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#issuecomment-290735612

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 31 Mar 2017 07:58:45 -0700

I agree that the current text is incredibly opaque.  I think that #318 is OK to replace this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/316#issuecomment-290735816