Subject: [httpwg/http-extensions] Expect-CT report-uri should be quoted (#312)

From: HTTP issue updates <[email-masked]>
Date: Tue, 14 Mar 2017 14:25:46 -0700

The report-uri syntax in Section 2.1.1 should quote the `absolute-URI`. This would most closely match HPKP, for which the report-uri syntax is not specified but all given examples are quoted. (https://tools.ietf.org/html/rfc7469#section-2.1.5)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/312

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 14 Mar 2017 14:29:49 -0700

Actually, it should be silent on this.

Any parameter should take *either* token *or* quoted-string, without exception.

If the type of the parameter always requires to use quoted-string, that's fine and is something the sender needs to be aware of. That said, it should not be enforced in the grammar.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/312#issuecomment-286566829