Subject: Re: [httpwg/http-extensions] define Accept-CH-Lifetime (#313)

From: HTTP issue updates <[email-masked]>
Date: Tue, 21 Mar 2017 18:24:42 -0700

Looks good overall. 

`Accept-CH-Lifetime` changes the semantics of `Accept-CH`. Not only does it effectively put `Accept-CH` on subsequent responses from the same origin for the given lifetime, it **also** suggests that Client Hints should be added to requests _to_ that origin, no matter where the requesting page has come from.

Not a problem, but right now it's conveyed almost as an aside. This needs to be clearly specified so it isn't missed / misunderstood.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/313#issuecomment-288270322

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 23 Mar 2017 11:42:22 -0700

@igrigorik pushed 1 commit.

937227c  clarify accept-ch-lifetime scope

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/313/files/22fb1ddb9c8d41f29f5219a252683fde953ae859..937227cca3bccdece4cccc05f330b261c91be2ea

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 23 Mar 2017 11:43:00 -0700

@mnot updated, PTAL. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/313#issuecomment-288822022

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Mar 2017 10:11:13 -0700

mnot approved this pull request.

This is better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/313#pullrequestreview-29074485

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Mar 2017 10:30:48 -0700

Thanks Mark!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/313#issuecomment-289300643

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 26 Mar 2017 10:31:01 -0700

Merged #313.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/313#event-1015747971