Subject: [Json] I-JSON Topic #1: Media Types?

From: Matt Miller <[email-masked]>
Date: Mon, 28 Apr 2014 13:45:35 -0600

"Should there be an I-JSON media type, or a application/*+i-json
suffix?  Draft i-json-01 calls for it, but this is at best controversial."

If you are in favor -- or not -- of an I-JSON media type or media type
suffice, please respond to this thread with your reasoning.

- -- 
- - m&m

Matt Miller < [email-masked] >
Cisco Systems, Inc.

* "How to Argue about I-JSON" <
http://www.ietf.org/mail-archive/web/json/current/msg02775.html >

---

From: Nico Williams <[email-masked]>
Date: Mon, 28 Apr 2014 14:56:16 -0500

> suffice, please respond to this thread with your reasoning.

To me this is closely related to the top-level type question.  For
both I have this reply:

ISTM that the top-level-must-be-an-object requirement is really for
indicating schema information in-band.  But we already rely on
indicating format out of band (via MIME type).  I find in-band schema
signalling in JSON to be a bad idea, especially when we can do it
out-of-band anyways.

Question: can schema information be encoded as a parameter to the
application/json media type?

Something like Content-Type: application/json; schema=FooBar .

Nico
--

---

From: Tim Bray <[email-masked]>
Date: Mon, 28 Apr 2014 13:16:57 -0700

Having thought some more about this, I can’t actually imagine a scenario in
which the media type (or suffix) would add value. I say lose it from the
draft.

On Mon, Apr 28, 2014 at 12:45 PM, Matt Miller <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA512
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.22 (Darwin)
> Comment: GPGTools - https://gpgtools.org
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>
> iQEcBAEBCgAGBQJTXq/fAAoJEDWi+S0W7cO1n9cH/0MGVK3lZn5c1C65Wpoa6jhK
> U7vfd7EUC8+W9T8qn3sR16A1MnGSnUvrSw1M4krYwjZfVTiMyEUBpuD8IGcPPj7B
> +7dM2WTk1GgJOwAjpBSmRksbfC+W4rzoZO/XTdz4FvgDNHZ+4MuK9P1wcXRY0ahy
> IpEky0RVv3osXLkGraUVos6DGVV9op6vR6uZw8wH9RuLSVzoVjGlQ56RkigmSA3O
> OjfK9Xo5cHmahHMvuyPXDldyfKWFlfYtA//4z8dRHF42KkoDv6Qv3LtsGSNQoTzq
> l0IOyb3e8eqDO6C9mqlLceniiZbFrxbUL4c2fxvt6FI1pGZbNe5grUVbtEVdI10=
> =JG8k
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>

---

From: mike amundsen <[email-masked]>
Date: Mon, 28 Apr 2014 16:21:37 -0400

if you have differences in validation or well-formed-ness between
application/json and I-JSON, you need a new media-type identifier to make
sure the right parser kicks in (both on the sender and receiver sides).

mamund
+1.859.757.1449
skype: mca.amundsen
http://amundsen.com/blog/
http://twitter.com/mamund
https://github.com/mamund
http://linkedin.com/in/mamund

On Mon, Apr 28, 2014 at 4:16 PM, Tim Bray <[email-masked]> wrote:

> Having thought some more about this, I can’t actually imagine a scenario
> in which the media type (or suffix) would add value. I say lose it from the
> draft.
>
>

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 29 Apr 2014 10:26:13 -0700

<no hat>

> suffix?  Draft i-json-01 calls for it, but this is at best controversial."

No. A receiver can check whatever data it gets against whatever rules it wants. I-JSON is a standardized set of rules that an emitter probably wants to follow. And emitter saying "Look! I followed those rules!" cannot be trusted anyway.

--Paul Hoffman

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 30 Apr 2014 13:40:09 +0900

+1. I have given my arguments already months ago, and they are much the 
same as given here recently by many.

Regards,   Martin.

---

From: Stefan Drees <[email-masked]>
Date: Wed, 30 Apr 2014 07:50:09 +0200

+1 from my side also
Am 30.04.14 06:40, schrieb "Martin J. Dürst":
>> No. A receiver can check whatever data it gets against whatever rules
>> it wants. I-JSON is a standardized set of rules that an emitter
>> probably wants to follow. And emitter saying "Look! I followed those
>> rules!" cannot be trusted anyway.
>>
>> --Paul Hoffman