Subject: [Json] New JSON Text Sequence I-D submitted

From: Nico Williams <[email-masked]>
Date: Mon, 28 Apr 2014 14:26:13 -0500

https://datatracker.ietf.org/doc/draft-ietf-json-text-sequence/

---

From: "Manger, James" <[email-masked]>
Date: Tue, 29 Apr 2014 10:41:23 +1000

> https://datatracker.ietf.org/doc/draft-ietf-json-text-sequence/

Short & simple — looks good.

1.
One missing feature is that a file containing only whitespace should be a valid JSON text sequence. Suggested changes:

FROM:  JSON-sequence = *(JSON-text 1*(ws))
TO  :  JSON-sequence = *(ws) *(JSON-text 1*(ws))

P.S. Do you need the brackets in *(ws)?

FROM:  A JSON text sequence is a sequence of JSON texts
TO  :  A JSON text sequence is a sequence of zero, one, or more JSON texts

2.
We can't have a <ws> ABNF production that is different from RFC7159 JSON. ws in JSON is unfortunate, but we have to live with it.
json-seq:  ws =    %x20 / %x09 / %x0A / %x0D
json    :  ws = *( %x20 / %x09 / %x0A / %x0D )

I would be tempted to write the ABNF using <value>, instead of <JSON-text>.

  JSON-sequence = *whitespace *(value 1*whitespace)
  whitespace = %x20 / %x09 / %x0A / %x0D
  value = <given by RFC7159>

--
James Manger

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 29 Apr 2014 10:10:13 +0900

> TO  :  A JSON text sequence is a sequence of zero, one, or more JSON texts

Can we make that:
TO  :  A JSON text sequence is a sequence of zero or more JSON texts

Regards,   Martin.

---

From: Nico Williams <[email-masked]>
Date: Mon, 28 Apr 2014 23:29:19 -0500

> Short & simple — looks good.

Thanks.

> One missing feature is that a file containing only whitespace should be a valid JSON text sequence. Suggested changes:

I think that's implied, but I'll make that explicit.

> TO  :  JSON-sequence = *(ws) *(JSON-text 1*(ws))

OK.

> P.S. Do you need the brackets in *(ws)?

No, I didn't.

> TO  :  A JSON text sequence is a sequence of zero, one, or more JSON texts

Sure.

>   value = <given by RFC7159>

Good point.  Though to be fair I don't think the RFC7159 ABNF should
be commingled with this one...

Nico
--