Subject: RE: [midcom] Reminder: Comments due to list on draft-ietf-midcom- protocol-eval -00.txt by Monday June 10th, noon CST

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 10 Jun 2002 16:09:58 -0400

One point caught my eye, about alarms.  See below.

-----Original Message-----
From: Christopher A. Martin [mailto:[email-masked]]
Sent: Monday, June 10, 2002 3:58 PM

[... snip]]

2.1.7 Reliability in SNMP is achieved by retransmissions and timers, this
mechanism 
applies only if the messages have a reply, in case of TRAPs this is not the
case. 
Therefore IMO this requirement is not met. 
 
[CM] in 2.1.7 Middlebox can generate unsolicited messages, the fact that a
response is not recieved to acknowledge the trap may be low risk due to the
fact that typically traps do not stop until alarm is mitigated. So it is
reliable unless you cant even communicate over the trap path (such as a WAN
link), in which event all protocols would fail this test. [CM]

[PTT] Middlebox notifications won't necessarily have the flavour of alarms.
I would hate to find that someone has to clear an alarm every time such a
notification occurs.

[snip]

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: "Christopher A. Martin" <[email-masked]>
Date: Mon, 10 Jun 2002 15:16:49 -0500

Agree....it is usually due to an event that a trap is sent out ... alarm may
have been a poor choice of word.

Can you tell I used to fight lots o fires.... :^)

What types of traps do we think may be used by a middlebox?

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Monday, June 10, 2002 3:10 PM
To: [email-masked]'; Cedric Aoun; Mary Barnes;
[email-masked]
Subject: RE: [midcom] Reminder: Comments due to list on
draft-ietf-midcom- protocol-eval -00.txt by Monday June 10th, noon CST

-----Original Message-----
From: Christopher A. Martin [mailto:[email-masked]]
Sent: Monday, June 10, 2002 3:58 PM

[... snip]]

[snip]

---

From: "Bob Penfield" <[email-masked]>
Date: Mon, 10 Jun 2002 17:00:30 -0400

----- Original Message -----
From: "Christopher A. Martin" <[email-masked]>

> What types of traps do we think may be used by a middlebox?
I think asyncronous notifications will include things that affect state in
the midcom agent (e.g. the middlebox just removed a ruleset that expired)
and are things that the application will need to take action on (e.g.
sending BYE for SIP sessions).

---

From: "Christopher A. Martin" <[email-masked]>
Date: Mon, 10 Jun 2002 16:08:12 -0500

Good point, I would like to see us develop more of these examples as part of
this exercise since this will be required for any protocol selected. Anyone
agree|disagree?

-----Original Message-----
From: Bob Penfield [mailto:[email-masked]]
Sent: Monday, June 10, 2002 4:01 PM
To: [email-masked]; 'Tom-PT Taylor'; 'Cedric Aoun'; 'Mary
Barnes'; [email-masked]
Subject: Re: [midcom] Reminder: Comments due to list on
draft-ietf-midcom- protocol-eval -00.txt by Monday June 10th, noon CST