Subject: RE: [midcom] Protocol Eval: 2.2.3 Ruleset Groups - COPS

From: "Cedric Aoun" <[email-masked]>
Date: Thu, 27 Jun 2002 16:21:36 +0200

Juergen,

The COPS RFC indicates that the handle is used as the reference to the
synchronized
state between the PDP and PEP.  Both PDP and PEP can indicate changes to
the content of the state by sending COPS messages between them in a
synchronized transactional manner.
The content of the state is not restricted by the protocol at all.
Hence the protocol is flexible to be applied to meet the Midcom
requirements.

The PDP can also request the PEP to create a new COPS Handle to be used
if a new state is required.  Notice new Handles can only be created by the
PEP.

I just noticed that I did a mistake in my previous posting:
"the COPS PDP can requests a new state to be added under an existing handle
already allocated by the Middlebox."
It should actually be "The COPS PDP can request a new property (or modify an
existing property) to be added under the state indexed by an existing handle
already allocated by the Middlebox"

Cedric

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]]
Sent: 27 June 2002 15:12
To: Aoun, Cedric [QPD:MA01:EXCH]; 'Martin Stiemerling'; Barnes, Mary
[NGC:B602:EXCH]
Cc: [email-masked]
Subject: RE: [midcom] Protocol Eval: 2.2.3 Ruleset Groups - COPS

Cedric,

Thank you for this clarification. I tried hard to find a
statement on this in one of the COPS RFCs, but I failed.

Can you give me a hint where to find information on how
the COPS PDP issues such a request?

    Juergen

--On 27 June 2002 14:31 +0200 Cedric Aoun <[email-masked]>
wrote:

>
> Martin,
> I disagree with you, the COPS PDP can requests a new state to be added
under an existing handle already allocated by the Middlebox.
>
> The COPS statement is accurate it should stay as is.
> The agent is the decision point it doesn't beg for resources to be booked
or lights to get green ;)
> Cedric
>
> -----Original Message-----
> From: Martin Stiemerling [mailto:[email-masked]]
> Sent: 26 June 2002 12:05
> To: Barnes, Mary [NGC:B602:EXCH]
> Cc: [email-masked]
> Subject: Re: [midcom] Protocol Eval: 2.2.3 Ruleset Groups - COPS
>
> Mary Barnes wrote:
>> Hi Martin,
>>
>> I don't understand your point, as the COPS description for 2.2.3 suggests
>
> Sorry for being so unspecific. Here is a more detailed description of
> the problem:
> The COPS RFC says, that handle states can be installed from the PEP at
> the PDP. This means that the middlebox can install groups and tell this
> the agent. But the agent can not influence the generation and deletion
> of groups at all, i.e. the agent depends fully on the "grace" of the
> middlebox.
> I don't know if an agent will be able to request groups on its own with
> an appropriate PIP defintion.
>
>
>> the use of the HANDLE STATE.  My understanding is that this is something
>> already defined for COPS. So, I propose to leave this one as it is.
>>
>> Mary.
>>
>> -----Original Message-----
>> From: Martin Stiemerling [mailto:[email-masked]]
>> Sent: Monday, June 24, 2002 7:23 AM
>> To: [email-masked]
>> Subject: [midcom] Protocol Eval: 2.2.3 Ruleset Groups
>>
>>
>> - COPS
>> The MIDCOM grouping functionality can be build via a particular PIP
>> defintion. The same is possible with SNMP, but SNMP got only a 'P+'.
>> I.e. COPS should get 'P+' as well.
>>
>
>
> --
> Martin Stiemerling
>
> NEC Europe Ltd. -- Network Laboratories  [email-masked]
> IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de
>
> _______________________________________________
> midcom mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/midcom

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 27 Jun 2002 16:42:28 +0200

> The PDP can also request the PEP to create a new COPS Handle to be used

How is the message called, with that a PDP can ask the PEP for a new 
COPS handle? Please give my a hint.

> if a new state is required.  Notice new Handles can only be created by 
> the PEP.

That's the intial reason of my question.

> "the COPS PDP can requests a new state to be added under an existing 
> handle already allocated by the Middlebox."
> It should actually be "The COPS PDP can request a new property (or 
> modify an existing property) to be added under the state indexed by an 
> existing handle already allocated by the Middlebox"
> 
> Cedric
> 
> --On 27 June 2002 14:31 +0200 Cedric Aoun 
> <[email-masked]> wrote:
> 
>  >
>  > Martin,
>  > I disagree with you, the COPS PDP can requests a new state to be 
> added under an existing handle already allocated by the Middlebox.
> 
>  >
>  > The agent is the decision point it doesn't beg for resources to be 
> booked or lights to get green ;)
>  > Cedric
>  >

-- 
Martin Stiemerling

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 27 Jun 2002 16:56:32 +0200

Cedric,

Thank you again for clarification. Now there is one one small piece
left that I still miss, because I am not familiar enough with COPS:

How does the PDP request the PEP to create a new COPS Handle?

    Juergen

--On 27 June 2002 16:21 +0200 Cedric Aoun <[email-masked]> wrote:

>
> Juergen,
>
> The COPS RFC indicates that the handle is used as the reference to the synchronized
> Hence the protocol is flexible to be applied to meet the Midcom requirements.
>
> if a new state is required.  Notice new Handles can only be created by the PEP.
>
> "the COPS PDP can requests a new state to be added under an existing handle already allocated by the Middlebox."
> It should actually be "The COPS PDP can request a new property (or modify an existing property) to be added under the state indexed by an existing handle already allocated by the Middlebox"
>
> Cedric
>
> --On 27 June 2002 14:31 +0200 Cedric Aoun <[email-masked]> wrote:
>
>>
>> Martin,
>> I disagree with you, the COPS PDP can requests a new state to be added under an existing handle already allocated by the Middlebox.
>
>>
>> The agent is the decision point it doesn't beg for resources to be booked or lights to get green ;)
>> Cedric
>>