Subject: RE: [midcom] SNMP In The Evaluation

From: "Mary Barnes" <[email-masked]>
Date: Wed, 12 Jun 2002 20:08:22 -0500

Bob et al,

I think Tom's point was that MEGACO, COPS and DIAMETER defined the
compliancy to be Partial where extensions were required.  I've not seen
anyone else express an opinion either way, but I don't have a problem adding
another category. I do feel that the current text sufficiently covers the
level of "Partial Compliancy" and there are very few Partials that aren't
extension/package/MIB flavored.  However, a new category does add a
sufficient level of differentiation that could be useful.  So, I'll propose
P+ for those that are partially compliant that could be made compliant with
extensions, packages, MIBs,etc. and a P- for those that require more
significant changes to the protocol.  I do plan to get the updated document
out before CoB this Friday, so if you have any concerns with this proposal,
please bring them to the list within the next 24 hours.

Thanks,
Mary. 

-----Original Message-----
From: Bob Penfield [mailto:[email-masked]]
Sent: Monday, June 10, 2002 3:22 PM
To: Juergen Quittek; Barnes, Mary [NGC:B602:EXCH]; Taylor, Tom-PT
[CAR:B602:EXCH]; [email-masked]
Subject: Re: [midcom] SNMP In The Evaluation

To be fair, the other protocols require extensions in order to comply to
some of the requirements. For example, MEGACO requires the definition of a
new Package to support MIDCOM. Do we need another category besides Total,
Partial, and Failed compliance for those requirements that are easily
covered by the extensibility already built into the protocol? (e.g a new
Package for MEGACO, or a new MIB for SNMP).

cheers,
(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "Juergen Quittek" <[email-masked]>
To: "Mary Barnes" <[email-masked]>; "Tom-PT Taylor"
<[email-masked]>; <[email-masked]>
Sent: Monday, June 10, 2002 9:34 AM
Subject: RE: [midcom] SNMP In The Evaluation

> Mary,
>
> --On 03 June 2002 13:21 -0500 Mary Barnes <[email-masked]>
wrote:
>
> >
> > Hi all,
> >
> > I haven't seen any further discussion on this one, but as Editor, I
think I have to agree with Tom.  Clearly, there exists an inconsistency in
the evaluations as far as the Total Compliance versus Partial Compliance.
There had been a brief email thread
> > on the difference in classifying between these two and the conclusion
had been that if extensions are required then the protocol is partially
compliant:
http://www1.ietf.org/mail-archive/working-groups/midcom/current/msg02083.htm
l
> > Thus, I'm going to propose the change to the SNMP evaluation as Tom has
suggested unless there is strong opinions suggesting otherwise.
> >
> > I don't believe this changes the author's overall conclusion that SNMP
meets the requirements as the MIDCOM protocol with the design of a MIDCOM
MIB module. However, it would require changing some of the statements in
section 3.
> >
> > I would propose the following:
> > Changing
> > "The SNMP management framework as evaluated matches all specified Midcom
requirements".
> > to say something like:
> > "The SNMP management framework meets all the specified Midcom protocol
requirements with the design of a MIDCOM MIB module".
>
> I fully agree.
>
> Maybe we can even improve phrasing by writing "appropriate design"
> instead of just "design".
>
>     Juergen
>
> >
> > and then removing the last sentence from that paragraph.
> >
> > Regards,
> > Mary H. Barnes
> > [email-masked]
> > 972-684-5432
> > Wireless 817-703-4806
> >
> > -----Original Message-----
> > From: Taylor, Tom-PT [CAR:B602:EXCH]
> > Sent: Thursday, May 30, 2002 8:55 AM
> > To: 'Juergen Quittek'; [email-masked]'
> > Subject: RE: [midcom] SNMP In The Evaluation
> >
> > This is a matter of consistent treatment of the protocols in the
evaluation.
> > For DIAMETER, for instance, the necessary data types have probably all
been
> > defined in Base, but it will be necessary to define the messages
containing
> > them.  I think you are saying that in the SNMP case you can point to
> > specific object types you can import but it will be necessary to define
a
> > new module to provide a context for them.  These may not be at the same
> > level of activity, but I think they are sufficiently analogous that both
> > protocols should be classified in the same way.
> >
> > -----Original Message-----
> > From: Juergen Quittek [mailto:[email-masked]]
> > Sent: Thursday, May 30, 2002 8:51 AM
> > To: Taylor, Tom-PT [CAR:B602:EXCH]; [email-masked]'
> > Subject: Re: [midcom] SNMP In The Evaluation
> >
> > Tom,
> >
> > --On 29 May 2002 09:15 -0400 Tom-PT Taylor wrote:
> >>
> >> SNMP fit to requirements is overstated relative to the other
> >> protocols.  For consistency, every requirement which refers to
> >> "an appropriate definition of a Midcom MIB module" should be
> >> rated as "partially met".
> >
> > I agree, that the statements are to general. Would you be fine
> > if I provide more concrete arguments, why these requirements
> > are clearly met. This is much more appropriate than moving to
> > partially met.
> >
> > Take for example "2.2.2 Support of multiple Middlebox types".
> > SNMP has several means to do so, starting from the standard
> > sysObjectID indicating the 'kind of box' to managed objects
> > defining the type in more general terms, e.g. NAT, NAT-PT, NAPT,
> > packet filter, ...
> > Also box type specific support by specific managed objects
> > is something which SNMP/SMI was built for. It definitely
> > meets these requirement fully, not partially.
> >
> >     Juergen
> > --
> > Juergen Quittek     [email-masked]     Tel: +49 6221 90511-15
> > NEC Europe Ltd.,    Network Laboratories     Fax: +49 6221 90511-55
> > Adenauerplatz 6, 69115 Heidelberg, Germany   http://www.ccrle.nec.de
> >>
> >> Tom Taylor
> >> [email-masked]
> >> Ph. +1 613 736 0961 (ESN 396 1490)
> >>
> >
> >
> > _______________________________________________
> > midcom mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/midcom
>
>
>
> _______________________________________________
> midcom mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/midcom
>

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 14 Jun 2002 11:14:32 +0200

Mary,

I support your proposal. The differentiation between two kinds
of partial compliancy make the evaluation much clearer.

    Juergen

--On 12 June 2002 20:08 -0500 Mary Barnes <[email-masked]> wrote:

>
> Bob et al,
>
> I think Tom's point was that MEGACO, COPS and DIAMETER defined the compliancy to be Partial where extensions were required.  I've not seen anyone else express an opinion either way, but I don't have a problem adding another category. I do feel that the
> current text sufficiently covers the level of "Partial Compliancy" and there are very few Partials that aren't extension/package/MIB flavored.  However, a new category does add a sufficient level of differentiation that could be useful.  So, I'll
> propose P+ for those that are partially compliant that could be made compliant with extensions, packages, MIBs,etc. and a P- for those that require more significant changes to the protocol.  I do plan to get the updated document out before CoB this
> Friday, so if you have any concerns with this proposal, please bring them to the list within the next 24 hours.
>
> Thanks,
> Mary.
>