Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change score

From: "Louis-Nicolas Hamer" <[email-masked]>
Date: Wed, 7 Aug 2002 15:44:17 -0400

-----Original Message-----
From: Christopher A. Martin [mailto:[email-masked]]
Sent: Wednesday, August 07, 2002 3:38 PM
To: Hamer, Louis-Nicolas [WDLN2:AN22:EXCH]; Taylor, Tom-PT [CAR:B602:EXCH];
Aoun, Cedric [GOLF:MA01:EXCH]; [email-masked]; [email-masked]
Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change score

> I concur with that, but was under the impression that it was a bulkier
process/mechansim
[Louis-Nicolas Hamer] Why? What gave you this impression. 
 
 > ...I will read more in order to comment further, but what do you think of
the comment, valid|not valid?
[Louis-Nicolas Hamer] If you are refering to pibs being a bulkier process,
my answer is Not valid. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Louis-Nicolas Hamer
Sent: Wednesday, August 07, 2002 2:34 PM
To: Tom-PT Taylor; Cedric Aoun; [email-masked]'; [email-masked]'
Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change score

Tom, 

since you did not comment on COPS-PR, I will. 
COPS-PR is comparable to SNMP as it is extensible without any changes to 
the protocol itself. Exactly like in SNMP where you can create new MIBS, you
can 
create new PIBs for COPS-PR. 

L-N 

> -----Original Message----- 
> From: Taylor, Tom-PT [CAR:B602:EXCH] 
> Sent: Tuesday, August 06, 2002 2:40 PM 
> To: Aoun, Cedric [GOLF:MA01:EXCH]; [email-masked]'; 
> [email-masked]' 
> Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change 
> score 
> 
> 
> 
> To summarize, you are saying that some protocols (most, in fact) have 
> explicit extensibility mechanisms, where others (RSIP in 
> particular) do not. 
> 
> If I were to rank the candidates by readiness for 
> extensibility this is how 
> I would see it.  I omit COPS because I'm not familiar with it, and I'm 
> taking risks with RSIP because I'm not really familiar with it either: 
> 
> SNMP (most extensible): extensions require absolutely no change to the 
> protocol itself. 
> 
> DIAMETER: extension mechanism provided, does mean protocol 
> changes, but 
> extensions can be handled by other DIAMETER entities without being 
> understood.  (Actually not sure that this property is 
> relevant or useful in 
> the MIDCOM case.) 
> 
> MEGACO: extension mechanism provided, does mean protocol 
> changes, both ends 
> have to understand the extensions. 
> 
> RSIP: no formal extension mechanism; extensions have to be 
> designed into the 
> protocol from scratch. 
> 
> 
> -----Original Message----- 
> From: Aoun, Cedric [GOLF:MA01:EXCH] 
> Sent: Tuesday, August 06, 2002 2:16 PM 
> To: [email-masked]'; [email-masked]' 
> Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to 
> change score 
> 
> 
> If we want to be honest with other protocol evaluations, 
> I don't see how RSIP's extensibility mechanisms would be 
> graded in the same 
> way as the other evaluated protocols. 
> The other protocols have extensibility mechanisms were the 
> base protocol 
> messages 
> are not always required to be extended to include new 
> parameters (or even to 
> create new messages). 
> The other protocols use a certain "envelop" where the 
> application (in this 
> case Middlebox control) 
> specific properties are contained, this provides a better extension 
> mechanism than the RSIP protocol. 
> IMHO I don't think we should grade RSIP to T, to be fair it 
> has to have a 
> lower grade than 
> the other protocols. 
> Cedric 
> -----Original Message----- 
> From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: 05 August 2002 20:28 
> To: midcom 
> Subject: [midcom] Protocol eval: 2.2.1 RSIP - proposal to 
> change score 
> 
> 
> Middlebox experts, 
> As I have said in a previous e-mail, RSIP clearly was designed to be 
> extensible. The evaluation text of RSIP for this requirement explains 
> how this works in more detail than the evaluation text for the other 
> protocols. 
> RSIP is currently scored a P+ on this requirement when it should, in 
> my opinion, clearly be a T: it has a degree of extensibility 
> comparable 
> to the other protocols, and they were scored a T. 
> I propose that the score of RSIP for this requirement be 
> changed to T. 
> I don't think there's any need to change the expanatory text. 
> Comments expected and welcome. 
> Jim 
> 
> 
> _______________________________________________ 
> midcom mailing list 
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/midcom
<https://www1.ietf.org/mailman/listinfo/midcom>  
> 
> _______________________________________________ 
> midcom mailing list 
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/midcom
<https://www1.ietf.org/mailman/listinfo/midcom>

---

From: "Christopher A. Martin" <[email-masked]>
Date: Wed, 07 Aug 2002 15:01:09 -0500

RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change scoreI am
remembering coments to this effect, and would like to refresh on COPS again
to verify why...your opinion, being more versed in it than I, was what I was
looking for.

Thanks.
Chris

I will continue to review.
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Louis-Nicolas Hamer
  Sent: Wednesday, August 07, 2002 2:44 PM
  To: [email-masked]'; Tom-PT Taylor; Cedric Aoun;
[email-masked]; [email-masked]
  Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change score

    -----Original Message-----
    From: Christopher A. Martin [mailto:[email-masked]]
    Sent: Wednesday, August 07, 2002 3:38 PM
    To: Hamer, Louis-Nicolas [WDLN2:AN22:EXCH]; Taylor, Tom-PT
[CAR:B602:EXCH]; Aoun, Cedric [GOLF:MA01:EXCH]; [email-masked];
[email-masked]
    Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change
score

process/mechansim

     > ...I will read more in order to comment further, but what do you
think of the comment, valid|not valid?
    [Louis-Nicolas Hamer] If you are refering to pibs being a bulkier
process, my answer is Not valid.
      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]]On Behalf Of
Louis-Nicolas Hamer
      Sent: Wednesday, August 07, 2002 2:34 PM
      To: Tom-PT Taylor; Cedric Aoun; [email-masked]';
[email-masked]'
      Subject: RE: [midcom] Protocol eval: 2.2.1 RSIP - proposal to change
score

      Tom,

      since you did not comment on COPS-PR, I will.
      COPS-PR is comparable to SNMP as it is extensible without any changes
to
      the protocol itself. Exactly like in SNMP where you can create new
MIBS, you can
      create new PIBs for COPS-PR.

      L-N

      > From: [email-masked] [mailto:[email-masked]]