Subject: RE: [midcom] RE: Protocol Eval - 2.2.1 - RSIP Extensibility - P + -> T ? ( wa s RE: Proposed changes to RSIP evaluation

From: "Sanjoy Sen" <[email-masked]>
Date: Wed, 7 Aug 2002 16:00:13 -0500

Speaking from Megaco perspective, I don't understand why it would be any
less extensible than either SNMP or COPS, as packages doesn't need any
changes in base protocol. Can somebody educate me on this? 

-----Original Message-----
From: Barnes, Mary [NGC:B602:EXCH] 
Sent: Wednesday, August 07, 2002 3:51 PM
To: 'midcom'
Subject: [midcom] RE: Protocol Eval - 2.2.1 - RSIP Extensibility - P+ -> T ?
( wa s RE: Proposed changes to RSIP evaluation

Hi all,

Based upon the responses to Jim's email thread on this topic, I think there
is general concensus to change 2.2.1 to T for RSIP.  

In addition, this thread highlighted a key aspect as to the level or
readiness of extensibility with the following summary, which I've liberally
copied from Tom's email and added COPS:

SNMP and COPS (most extensible): extensions require absolutely no change to
the 
protocol itself. 
 
DIAMETER: extension mechanism provided, does mean protocol 
changes, but extensions can be handled by other DIAMETER entities without
being 
understood.  (Actually not sure that this property is relevant or useful in 
the MIDCOM case.) 

MEGACO: extension mechanism provided, does mean protocol changes, both ends 
have to understand the extensions. 

RSIP: no formal extension mechanism; extensions have to be designed into the

protocol from scratch.  

My proposal to ensure that we capture this aspect of the evaluation and
include some text in the conclusion, following the controversial table
capturing this information, to highlight that this is key to considering the
impact of P+ for a specific protocol. I'll propose specific text when I get
down to editting again early tomorrow. Folks that participated in this
thread are also welcome to craft the proposed text.

Regards,
Mary.

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 7 Aug 2002 17:05:43 -0400

Note that I said protocol changes, not base protocol changes.  To add a
package in Megaco you have to update your parser to start with, and also be
prepared to provide the package name in response to audits.  I know the work
is similar for a MIB, in a way, but in Megaco the package elements are mixed
right in with the other elements of the protocol.

-----Original Message-----
From: Sen, Sanjoy [NGC:B677:EXCH] 
Sent: Wednesday, August 07, 2002 5:00 PM
To: Barnes, Mary [NGC:B602:EXCH]; 'midcom'
Subject: RE: [midcom] RE: Protocol Eval - 2.2.1 - RSIP Extensibility - P +
-> T ? ( wa s RE: Proposed changes to RSIP evaluation

-----Original Message----- 
From: Barnes, Mary [NGC:B602:EXCH] 
Sent: Wednesday, August 07, 2002 3:51 PM 
To: 'midcom' 
Subject: [midcom] RE: Protocol Eval - 2.2.1 - RSIP Extensibility - P+ -> T ?

Hi all, 

protocol from scratch.

---

From: "Sanjoy Sen" <[email-masked]>
Date: Wed, 7 Aug 2002 16:21:46 -0500

> From: Taylor, Tom-PT [CAR:B602:EXCH] 
> Sent: Wednesday, August 07, 2002 4:06 PM
> To: Sen, Sanjoy [NGC:B677:EXCH]; Barnes, Mary 
> [NGC:B602:EXCH]; 'midcom'
> Subject: RE: [midcom] RE: Protocol Eval - 2.2.1 - RSIP 
> Extensibility - P + -> T ? ( wa s RE: Proposed changes to 
> RSIP evaluation
> 
> 
> 
> Note that I said protocol changes, not base protocol changes. 
>  To add a package in Megaco you have to update your parser to 
> start with, and also be prepared to provide the package name 
> in response to audits.  I know the work is similar for a MIB, 
> in a way, but in Megaco the package elements are mixed right 
> in with the other elements of the protocol.
> 

I thought so too (that the work is similar for MIB or PIB). 

I wouldn't consider this (mixed with elements of the protocol)
sufficient reason to deem Megaco any less extensible than COPS or SNMP.

Thanks,
Sanjoy

> Subject: RE: [midcom] RE: Protocol Eval - 2.2.1 - RSIP 
> Extensibility - P + -> T ? ( wa s RE: Proposed changes to 
> RSIP evaluation
> 
> 
> Speaking from Megaco perspective, I don't understand why it 
> would be any less extensible than either SNMP or COPS, as 
> packages doesn't need any changes in base protocol. Can 
> somebody educate me on this? 
> 
> Subject: [midcom] RE: Protocol Eval - 2.2.1 - RSIP 
> Extensibility - P+ -> T ? ( wa s RE: Proposed changes to RSIP 
> evaluation
> 
> 
> Hi all, 
> Based upon the responses to Jim's email thread on this topic, 
> I think there is general concensus to change 2.2.1 to T for RSIP.  
> In addition, this thread highlighted a key aspect as to the 
> level or readiness of extensibility with the following 
> summary, which I've liberally copied from Tom's email and 
> added COPS: SNMP and COPS (most extensible): extensions 
> require absolutely no change to the 
> protocol itself. 
>   
> changes, but extensions can be handled by other DIAMETER 
> entities without being 
> My proposal to ensure that we capture this aspect of the 
> evaluation and include some text in the conclusion, following 
> the controversial table capturing this information, to 
> highlight that this is key to considering the impact of P+ 
> for a specific protocol. I'll propose specific text when I 
> get down to editting again early tomorrow. Folks that 
> participated in this thread are also welcome to craft the 
> proposed text. Regards, 
> Mary.