Subject: [midcom] Wildcarding/reservations

From: Melinda Shore <[email-masked]>
Date: Tue, 25 Mar 2003 18:36:32 -0500

These two issues have become intermingled in our discussions
of the semantics document, and so they may require
discussion together, at least at first.

There are two questions that need to be resolved for the
semantics document (and, indeed, for the protocol):

1) should the midcom protocol support wildcards?, and
2) should the process of installing a rule be broken into
   two steps, a reservation request and and a request to
   enable a reservation?

Thanks,

Melinda
_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: Jiri Kuthan <[email-masked]>
Date: Wed, 26 Mar 2003 01:35:46 +0100

>1) should the midcom protocol support wildcards?, and

There are applications which need that.

>   two steps, a reservation request and and a request to

I'm not sure if there is a benefit in doing so. I guess it makes sense if 
- the application is of request-response style
- with request tied to a midcom reservation and response tied to a midcom commit
- and some additional security value one can infer from the response

-Jiri

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 26 Mar 2003 19:57:31 +0100

> 1) should the midcom protocol support wildcards?, and

I think in the end of the session there was an agreement
that wildcarding is needed.

>    two steps, a reservation request and and a request to

I think it is needed for firewalls that implement
highly protective security policies. For less protective
policies it is not required.

    Juergen

---

From: Melinda Shore <[email-masked]>
Date: Mon, 31 Mar 2003 11:44:33 -0500

> 1) should the midcom protocol support wildcards?, and

There's clear consensus that it should, but

>    two steps, a reservation request and and a request to

several people have raised points on this but there's no
clear sense of the group.  In order to continue to make
progress, I'd like to leave this in the hands of the
document editors and if there's a problem with it please
bring it up when the revision comes out or during WG last
call (although remember that it's always better to identify
problems sooner rather than later).

Thanks,

Melinda