Subject: [midcom] MIDCOM Protocol Semantics <-> SNMPv3

From: [email-masked]
Date: Mon, 24 Nov 2003 14:55:47 +0100

Dear MIDCOM experts

The "semantics draft" is now going for informational RFC in my
understanding. SNMPv3 was recommended as MIDCOM protocol end of last
year to my knowledge.
I'm wondering whether
(1) SNMPv3 is used as "MIDCOM protocol syntax" for the "MIDCOM Protocol
Semantics"?
and
(2) if yes, will there be an additional "MIB plane" for provisioning
midcom boxes (besides the dynamic configuration actions according
"MIDCOM Protocol Semantics")?

Thanks,
Albrecht Schwarz
ALCATEL

_______________________________________________
midcom mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/midcom

---

From: [email-masked]
Date: Mon, 24 Nov 2003 15:53:02 +0100

Melinda & Martin,

thanks for your quick and precise responses!

Kind regards,
Albrecht

----- Forwarded by Albrecht SCHWARZ/DE/ALCATEL on 24.11.2003 15:51 -----
                                                                                                                                                    
                      Melinda Shore                                                                                                                 
                      <[email-masked]         To:      Martin Stiemerling <[email-masked]>                                        
                      m>                       cc:      Albrecht SCHWARZ/DE/ALCATEL@ALCATEL, [email-masked]                                        
                      Sent by:                 Subject: Re: [midcom] MIDCOM Protocol Semantics <-> SNMPv3                                           
                      midcom-admin@iet                                                                                                              
                      f.org                                                                                                                         

                      24.11.2003 15:33                                                                                                              

On Monday, November 24, 2003, at 09:03 AM, Martin Stiemerling wrote:
> and
> | (2) if yes, will there be an additional "MIB plane" for provisioning
> | midcom boxes (besides the dynamic configuration actions according
> | "MIDCOM Protocol Semantics")?
> That's a question to the WG chair.

I think it's actually a question for somebody else.  Provisioning
is clearly out of scope for this working group.  There's not any
work going on that I'm aware of (modulo the NAT MIB, which is NAT-
specific).

Melinda

|---------+--------------------------------->
|         |           Martin Stiemerling    |
|         |           <Martin.Stiemerling@cc|
|         |           rle.nec.de>           |
|         |           Sent by:              |
|         |           [email-masked] |
|         |                                 |
|         |                                 |
|         |           24.11.2003 15:03      |
|         |                                 |
|---------+--------------------------------->
  >------------------------------------------------------------------------------------------------------------|
  |                                                                                                            |
  |        To:      Albrecht SCHWARZ/DE/ALCATEL@ALCATEL                                                        |
  |        cc:      [email-masked]                                                                            |
  |        Subject: Re: [midcom] MIDCOM Protocol Semantics <-> SNMPv3                                          |
  >------------------------------------------------------------------------------------------------------------|

Hi,

| Dear MIDCOM experts
|
| The "semantics draft" is now going for informational RFC in my
| understanding. SNMPv3 was recommended as MIDCOM protocol end of last
| year to my knowledge.

Yes, it is. SNMPv3 is the MIDCOM protocol.

| I'm wondering whether
| (1) SNMPv3 is used as "MIDCOM protocol syntax" for the "MIDCOM Protocol
| Semantics"?

The MIDCOM protocol will be implemented as a MIB module.

| and
| (2) if yes, will there be an additional "MIB plane" for provisioning
| midcom boxes (besides the dynamic configuration actions according
| "MIDCOM Protocol Semantics")?

That's a question to the WG chair.

 Martin

Martin Stiemerling

NEC Europe Ltd. -- Network Laboratories  [email-masked]
PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
IPv4: http://www.ccrle.nec.de  IPv6: http://www.ipv6.ccrle.nec.de

---

From: "Harrington, David" <[email-masked]>
Date: Mon, 24 Nov 2003 11:50:14 -0500

Hi Albrecht,

The terminology you use in your question means different things to
different people. 
Let me try to answer what I think you're asking.

The MIDCOM MIB work is designed to enable the dynamic changes to
firewalls and NATs for discrete uses as described in the semantics
document. The design team is utilizing existing mib modules where
possible, and supplementing those mib modules with a midcom-specific mib
module. 

The MIDCOM MIB will help coordinate the dynamic changes to the
configuration in the leveraged mib modules for midcom-specific purposes.
For example, the MIDCOM MIB will be used to coordinate the length and
owner of a midcom session, concepts not naturally part of a firewall or
a NAT or SNMPv3 permissions.

For firewall management, the design team will leverage the capabilities
of the IPSP MIB, including rule specification and rule groupings. For
NAT management, the design team will leverage the NAT MIB, including
public and private addresses and binds. For security, the design team
will leverage the security features of SNMPv3, including which midcom
agents are authorized to modify which mib modules.

These "leveraged" mibs will allow you to provision firewalls and NATS
and permissions, beyond that for midcom purposes (depending of course on
what you're trying to provision). 

So for provisioning of firewalls, look at the IPSP MIB. This has expired
in the I-D respository, and is in the process of being rewritten into
three smaller mib modules, which hopefully will be published soon, and
announced to the midcom WG.

For NAT provisioning, look for draft-ietf-nat-natmib-07.txt.

I hope this helps,
dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Monday, November 24, 2003 8:56 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [midcom] MIDCOM Protocol Semantics <-> SNMPv3
> 
> 
> 
> 
> 
> 
> 
> Dear MIDCOM experts
>