Subject: Re: [netext] I-D Action: draft-ietf-netext-wifi-epc-eap-attributes-00.txt

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 17 May 2012 14:19:26 -0500

On Fri, Apr 27, 2012 at 11:53 AM, Sri Gundavelli <[email-masked]> wrote:
> Mac address is bound to the EAP identity. The Wireless LAN Controller/Access
> Point has the Mac to identity binding, which has association in the BUL
> entry.

What if EAP is not used?

Anyways, read the draft.

Behcet

>
>
>
> Sri
>
>
> On 4/27/12 9:51 AM, "Behcet Sarikaya" <[email-masked]> wrote:
>
>> On Fri, Apr 27, 2012 at 11:45 AM, Sri Gundavelli <[email-masked]> wrote:
>>>> I wonder how do you map to a single receiver if there are more than
>>>> one receivers, i.e. the correct receiver?
>>>
>>> L3-Multicast, L2 unicast to a given node. RFC 6085. This is standard stuff;
>>> There is no issue here.
>>>
>>
>> I read RFC 6085.
>>
>> I had that question and I could not find an answer for that? How does
>> the AP know "the given node"?
>>
>> Anyways, I repeat my plea for documenting this issue in Netext and
>> clearing the air once and for all.
>>
>> Behcet
>>>
>>>
>>> Sri
>>>
>>>
>>>
>>>
>>>
>>>
>>> On Apr 27, 2012, at 9:43 AM, Behcet Sarikaya wrote:
>>>
>>>> Hi Sri,
>>>>
>>>> Thanks for chipping in your valuable views on this.
>>>> Basavaraj seems to disagree that there is a problem there but I don't know
>>>> why?
>>>>
>>>> On Fri, Apr 27, 2012 at 11:15 AM, Sri Gundavelli <[email-masked]> wrote:
>>>>> Hi Behcet:
>>>>>
>>>>> Sorry to jump in to this thread. I'm going to respond/clarify only on one
>>>>> specific comment (may be tangential to your discussion), as I'm not
>>>>> following this thread/rest of the discussion. I want to clarify only that
>>>>> one part though about WLAN, PMIPv6 and SaMOG.
>>>>>
>>>>>
>>>>>
>>>>>>> Why? Are you saying that the current link model for PMIP6 allows only a
>>>>>>> single MN to attach to a WiFi AP (as an example)?
>>>>>>> What is the basis for saying that having many MNs attach to a MAG in a
>>>>>>> hotspot (assuming wifi) will result in problems?
>>>>>>> Is there any work that you have done to make such a statement?
>>>>>>
>>>>>>
>>>>>> As you know similar concerns have been voiced over and over again in
>>>>>> Netext.
>>>>>>
>>>>>> Isn't it time to do something on this?
>>>>>>
>>>>>> Clarify that everything will work fine
>>>>>
>>>>>
>>>>>
>>>>> It is true, WLAN access is a shared media and what we need in Proxy
>>>>> Mobile IPv6 is essentially the ability for the MAG to advertise unicast
>>>>> RA's/or in general keep multicast traffic map to a single receiver (as
>>>>> clarified in RFC-6085). This is today the case on WLAN access
>>>>> networks. A client when it sends a multicast/broadcast packet, that
>>>>> packet is not sensed by the other receivers directly on the air interface,
>>>>> as in the case of ethernet, but rather it hits the access point and its the
>>>>> function if the access point to stream it down with using the correct
>>>>> multicast keys; this in essence is giving the model that we needed, as l
>>>>> ong as the access point/WLC blocks multicast traffic from wireless
>>>>> clients from other wireless clients.  All most every WLAN deployment is
>>>>> typically configured to operate it this way. The SaMOG architecture (or
>>>>> the WLAN IWK document that I've published), makes that assumption
>>>>> with impact to link model, else SaMOG architecture (with either of S2a
>>>>> protocol interfaces) is broken and un deployable.
>>>>>
>>>>
>>>> I wonder how do you map to a single receiver if there are more than
>>>> one receivers, i.e. the correct receiver?
>>>>
>>>> You mentioned WLAN IWK document, can you provide the link?
>>>>
>>>> As you know there are also Layer 2 solutions.
>>>>
>>>> I think we need to document it in Netext, maybe the chairs can add a
>>>> milestone on this to the charter?
>>>>
>>>> Regards,
>>>>
>>>> Behcet
>>>>
>>>>
>>>>>
>>>>>
>>>>> Regards
>>>>> Sri
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> On Apr 27, 2012, at 8:34 AM, Behcet Sarikaya wrote:
>>>>>
>>>>>> Hi Basavaraj,
>>>>>>
>>>>>> Pls see inline.
>>>>>>
>>>>>> On Thu, Apr 26, 2012 at 10:44 AM,  <[email-masked]> wrote:
>>>>>>>
>>>>>>> Inline:
>>>>>>>
>>>>>>> On 4/26/12 9:59 AM, "ext Behcet Sarikaya" <[email-masked]> wrote:
>>>>>>>
>>>>>>>> Hi Basavaraj,
>>>>>>>>
>>>>>>>>>> 2. As I said above, the draft's main concern is MN authentication on
>>>>>>>>>> Wi-Fi links. As we all know, PMIPv6 is based on point-to-point links
>>>>>>>>>> and Wi-Fi link is a shared link.
>>>>>>>>>> Does this raise any concerns to you?
>>>>>>>>>
>>>>>>>>> No.
>>>>>>>>
>>>>>>>> Really?
>>>>>>>>
>>>>>>>> Imagine MAG as defined in RFC 5213 (which assumes that each MN is on a
>>>>>>>> point-to-point link) is connected to a shared link.
>>>>>>>
>>>>>>> We all understand the link model requirements for PMIP6. Nothing is being
>>>>>>> changed there.
>>>>>>>
>>>>>>>> I think the result will be disastrous.
>>>>>>>
>>>>>>> Why? Can you elaborate?
>>>>>>>
>>>>>>>> If there is only one MN, it may
>>>>>>>> be OK but as more MNs join, especially in hot spots then the problems
>>>>>>>> start.
>>>>>>>
>>>>>>> Why? Are you saying that the current link model for PMIP6 allows only a
>>>>>>> single MN to attach to a WiFi AP (as an example)?
>>>>>>> What is the basis for saying that having many MNs attach to a MAG in a
>>>>>>> hotspot (assuming wifi) will result in problems?
>>>>>>> Is there any work that you have done to make such a statement?
>>>>>>
>>>>>>
>>>>>> As you know similar concerns have been voiced over and over again in
>>>>>> Netext.
>>>>>>
>>>>>> Isn't it time to do something on this?
>>>>>>
>>>>>> Clarify that everything will work fine
>>>>>>
>>>>>> or
>>>>>>
>>>>>> if not, then propose solutions.
>>>>>>
>>>>>> If you look at SaMOG work in 3GPP, they repeatedly said WiFi should
>>>>>> provide point to point link to UEs.
>>>>>>
>>>>>> Why do you think they said so if they anticipated no problems?
>>>>>>
>>>>>> Behcet
>>>>>> _______________________________________________
>>>>>> netext mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/netext
>>>>>
>>>
>

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 17 May 2012 16:49:59 -0700

I thought the discussion was about the case when EAP is in use. Any case, my point is JUST about how L2 unicast semantics can be used by the MAG on the WLAN access. How the MAG learns about that L2 identity is a different consideration; if there is always EAP or some thing I commented on …

Sri