Subject: [RTG-DIR] Thinking about Routing Directorate reviews

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 26 Aug 2013 15:47:56 +0100

Hi,

Currently the Routing Directorate does reviews for the ADs roughly during IETF
last call. They only review on request, and they only focus on:
- documents from other areas that the ADs think might have an impact on routing
- routing area I-Ds that the ADs want help with (i.e., not all routing area
I-Ds)

I've been getting a little uncomfortable with the level of issues I raise during
AD review (when publication is requested). Possibly this is happening because I
am a picky bugger who complains about too much stuff. Possibly it is happening
because WG development and last call is not catching enough issues.

It is reasonable to expect the ADs to continue to perform detailed review at
publication request, but this is a substantial load on the ADs and I wonder that
it must be frustrating to the author and WGs to get this level of review after
the WG process has completed.

I see two options here:

1. AD review to take place during WG last call.
Downside is that this is quite a small window to get AD time in.
Downside is that the document may get recycled considerably as a result of WG
last call so the AD is not reviewing the "best" product of the WG.
Upside is that the WG is fully involved in results of the AD review.
Upside is that the process is more streamlined.

2. Routing directorate review takes place during WG last call.
Downside is that the document may get recycled considerably as a result of WG
last call so the review does not catch the "best" product of the WG.
Upside  is that the WG is fully involved in results of the directorate review.
Upside is that the document should be in better condition when the AD sees it.

Combining options 1 and 2 is also possible.

Do y'all have any thoughts on this?

Thanks,
Adrian

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 26 Aug 2013 20:18:59 +0000

Hi Adrian,

In general, I think that early (as well as cross-area) thorough reviews have great return. However, for the actual stage in the process you are concerned with (after/during WGLC and before sending to the IESG), what's the role of the "document quality" section of the Shepherd write-up?

I guess I see value in #2 (directorate review during WGLC for RTG docs), but I wonder:
1. How much is that a requisite to WGLC from the shepherd role?
2. How would you choose which document -- every doc?

Sorry I contributed more questions than answers :-)

Thanks,

-- Carlos.

---

From: <[email-masked]>
Date: Tue, 27 Aug 2013 08:00:54 +0000

Hello Adrian,

One question: in the case of (2), would the set of I-Ds subjected to a 
directorate review be different from what we have today ?
Assuming that this set does not change, I think (2) is a good idea (not 
preventing (1) for some specific draft for which AD would find it 
relevant to do).

One suggestion, valid for both (1) and (2): the downside mentioned below 
(that a review by the directorate might be a bit premature for some 
drafts) may be partially avoided by asking WG chairs whether they expect 
a lot of respin during WG LC, and postponing directorate/AD review in 
that case.

-Thomas

> Do y'all have any thoughts on this?

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Loa Andersson <[email-masked]>
Date: Tue, 27 Aug 2013 11:22:12 +0200

Adrian,

I agree that the AD will need to do an AD review at the time of
publication request.

I also agree that we should do anything we can do to improve the
quality of the documents we request publication for. My take is
also that I won't expect more than one review of the AD for any
"normal" document.

I'm not certain about the argument "that the document may get recycled 
considerably as a result of WG" and consequently the AD or the
directorate will not review the best of the product from the working
group. I find it slightly cross-purpose; the working group last call is
there (partly) to bring the document up to a point where it is of such
quality that the publication request is possible. Kind of saying that we
are still in a "improvement phase".

At least the the mpls wg we "freezes" the document during anything that
is a review team effort or a wglc. We want all reviewers to look at the
same version of the document.

When the wglc is closed - there is also one phase that needs to involve
reviewers. The authors will address the comments, and before that phase
is done we require that a reviewer acknowledge that the comments he/she
had is correctly addressed.

My proposal would be that we try this:

1. When the working group chairs start a working group last call, this
    is also sent to the AD (normal practice today) and the the chair of
    the directorate.
2. AD and chair of directorate decided whether the directorate will or
    will not review the document during wglc.
3. The comments of someone that been assigned to a directorate review
    during wglc is sent to the rest of the directorate and to the working
    group(s).
4. When the comments during wglc has been addressed, the directorate
    reviewer acknowledge that he/she is comfortable with how his/her
    comments has been addressed (same as any other reviewer).

I don't think there is a problem of too much "churn" during the wglc
phase; at least it is possible to manage.

I also don't see why the AD can't request a review from the directorate
of any document where "help is needed" after the publication request,
the only thing that is needed is that we probably should take care not
to assign the same review to the same person twice.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 27 Aug 2013 09:31:12 +0000

Loa, Adrian and all,
I concur with Loa. The process he proposes looks quite reasonable to me.
Of course, there is always a possibility of the WG LC missing some serious issues with the document (with or without additional reviewers from RTG-DIR :-), leaving it to the AD to catch what should be caught much earlier. Hopefully this would be a rare case, and involving the RTG-DIR review in the WG LC (where found appropriate) would help.
 
My 2c,
     Sasha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Loa Andersson
> Sent: Tuesday, August 27, 2013 12:22 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [RTG-DIR] Thinking about Routing Directorate reviews
> 
> Adrian,
> 

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Tue, 27 Aug 2013 15:09:24 +0000

Hi Adrian, All,

RAD review would better take place during WG LC (opt.2) in particular when WG LC comments are limited. 

The downside pointed here below can be circumvented by asking the reviewer to take a look at the revised document (and points to possibly remaining issues but this is often the case when addressing LC comments).

Thanks,
-dimitri.

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Adrian Farrel
> Sent: Monday, August 26, 2013 16:48
> To: [email-masked]; [email-masked]
> Subject: [RTG-DIR] Thinking about Routing Directorate reviews
> 
> Hi,
>

---

From: "Russ White" <[email-masked]>
Date: Wed, 28 Aug 2013 13:44:19 -0400

> I concur with Loa. The process he proposes looks quite reasonable to me.

I would agree with this, as well... 

Russ

---

From: Alia Atlas <[email-masked]>
Date: Wed, 28 Aug 2013 13:53:27 -0400

+1 for all the content that adds :-)

---

From: Acee Lindem <[email-masked]>
Date: Wed, 28 Aug 2013 17:57:04 +0000

Loa's proposal is fine with me as well.
Acee

On Aug 28, 2013, at 1:53 PM, Alia Atlas wrote:

Russ