Subject: Re: [RTG-DIR] Routing Directorate Web Pages now a Wiki

From: Ross Callon <[email-masked]>
Date: Mon, 2 Jun 2014 21:27:40 +0000

One comment: the Wiki is slightly out of date. There is a place where it lists documents currently under review. However, it is lacking:

	draft-ietf-isis-fs-lsp-01.txt

Was I supposed to fix this myself as the routing directorate reviewer for draft-ietf-isis-fs-lsp-01.txt?

Thanks, Ross

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, April 17, 2014 12:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: [RTG-DIR] Routing Directorate Web Pages now a Wiki

Hi,

Alia and I have moved the Routing Directorate web pages into the Routing Area
wiki.

You can get there from http://www.ietf.org/iesg/directorate/ or from
http://trac.tools.ietf.org/area/rtg/trac/wiki
Or you can go there direct at
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

We would love your thoughts on the whole Area wiki and on the Directorate wiki.
Alternatively, since we are a contribution-driven organisation, and since this
is a wiki - just get on and edit it!

There are some specific pages we hope you will "embrace"

http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDirExperience give a place for
you to briefly list your areas of interest and experience. This will help
Deborah, John, and us to know where to best dispatch documents for review. Could
you please update this page (use the format of the example) as soon as
convenient.

http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDirDocRev will list documents
currently under review. This gives you an opportunity to contribute additional
reviews if you have some spare time or an interest in a particular topic. We
heard from several of you that this might be a good idea, so we hope it takes
off.  It would help everyone if you could add your name to the list if you
intend doing an additional review. 

Three other notes...
- The description of the way the Directorate works is out of date. We'll work to
polish that.
- The "document mentors" program is a work in progress
- English review is not a Directorate process, but we are adding this on its own
pages of the Area wiki.

Thanks,
Alia and Adrian

---

From: Jonathan Hardwick <[email-masked]>
Date: Tue, 3 Jun 2014 07:32:14 +0000

Hi Ross

Thanks for the catch.  I should have added this document to the list when you agreed to review it, my apologies for dropping this.  I've added it now.

When reviewers have completed their reviews, they should move the document into the "documents previously reviewed" table and add a link to their comments.  I've pasted the relevant guidance from the wiki below.

Best regards
Jon

========
When a draft is assigned for review, it should be added to the Documents Currently Under Review by the Coordinator. If an additional reviewer wishes to add their name or a draft and name, they may.

When a review is done, the reviewer in addition to sending the email should move the draft to the top of Documents Previously Reviewed and add in a link to the message in the mail archive where the review was sent. If any issues were found, then the Issues Resolved should start as No and be resolved to Yes with the date by the reviewer when they have been resolved (draft number can be useful too).
========

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: 02 June 2014 22:28
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [RTG-DIR] Routing Directorate Web Pages now a Wiki

Thanks, Ross

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, April 17, 2014 12:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: [RTG-DIR] Routing Directorate Web Pages now a Wiki

Hi,

Three other notes...

Thanks,
Alia and Adrian

---

From: Loa Andersson <[email-masked]>
Date: Tue, 03 Jun 2014 10:45:10 +0200

Jonathan,

Do we have any statistics over how many reviews we done over
e.g. the last 18 months?

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Alia Atlas <[email-masked]>
Date: Tue, 3 Jun 2014 10:02:05 -0400

Hi Jon,

It might be a good idea to add this reminder and pointer to the wiki to
requests for a while,
until reviewers get into the swing of it.

Alia

On Tue, Jun 3, 2014 at 3:32 AM, Jonathan Hardwick <
[email-masked]> wrote:

> Hi Ross
>
> Thanks for the catch.  I should have added this document to the list when
> you agreed to review it, my apologies for dropping this.  I've added it now.
>
> When reviewers have completed their reviews, they should move the document
> into the "documents previously reviewed" table and add a link to their
> comments.  I've pasted the relevant guidance from the wiki below.
>
> Best regards
> Jon
>
> ========
> When a draft is assigned for review, it should be added to the Documents
> Currently Under Review by the Coordinator. If an additional reviewer wishes
> to add their name or a draft and name, they may.
>
> When a review is done, the reviewer in addition to sending the email
> should move the draft to the top of Documents Previously Reviewed and add
> in a link to the message in the mail archive where the review was sent. If
> any issues were found, then the Issues Resolved should start as No and be
> resolved to Yes with the date by the reviewer when they have been resolved
> (draft number can be useful too).
> ========
>
>
> One comment: the Wiki is slightly out of date. There is a place where it
> lists documents currently under review. However, it is lacking:
>

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 3 Jun 2014 15:23:11 +0000

Hi Loa,

There have been 52 review requests since Jan. 2013. There have been 170 since we started the review process in 2/2010. This year, we had 20 since January, so the number is increasing.

Before the wiki page was introduced in April, we were using Trac. I don't think anyone looked at it except Dan and me. Most of the drafts are entered on it, except for the last couple of months with the transition from Dan to Jon. I've been keeping track of the requests during this time while we are considering if we continue with it or not. Trak is quite frustrating for what we are using it for,  e.g. it takes 4 steps to simply assign a reviewer to a draft and then another 3 steps to close out the ticket when the review is done. And at each step, emails are generated. We found that it was much more effective to simply send a personal email to a reviewer to request a review, then have the tool generated request as no one responded. Most of the spam filters ate the mails, so very unreliable. Here's the link:
http://trac.tools.ietf.org/area/rtg/trac/report/6#

The wiki page may be all that we need going forward. Jon and I are looking at what to do as we also heard of another tool being used.

Deborah

-----Original Message-----
From: rtg-dir [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Tuesday, June 03, 2014 4:45 AM
To: Jonathan Hardwick
Cc: [email-masked]
Subject: [RTG-DIR] statistics ? - Re: Routing Directorate Web Pages now a Wiki

Jonathan,

/Loa

--

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 03 Jun 2014 12:02:47 -0400

The odds of my remembering to do this wiki update step are very slim.
If you want us to do this step, please include it in the review request. 
  I am willing to try to do so.  With the reminder, the odds are at 
least 50% that I will remember.

Yours,
Joel

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 3 Jun 2014 12:26:29 -0400

As an additional reminder, this should also be added to the review
instructions at the top of
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDirGuidance .

Cheers,
Andy

On Tue, Jun 3, 2014 at 12:02 PM, Joel M. Halpern <[email-masked]>
wrote:

>  I am willing to try to do so.  With the reminder, the odds are at least
> 50% that I will remember.
>
> Yours,
> Joel
>
>
>> When reviewers have completed their reviews, they should move the
>> document into the "documents previously reviewed" table and add a link to
>> their comments.  I've pasted the relevant guidance from the wiki below.
>>
>> Best regards
>> Jon
>>
>> ========

---

From: Jonathan Hardwick <[email-masked]>
Date: Wed, 4 Jun 2014 06:51:17 +0000

All,

Agreed, we should include a reminder in the review requests from now on.  (I will try to remember to do so!)

I think it would be good if we could automate some of these manual steps.  I’m going to investigate this.

Cheers
Jon

From: rtg-dir [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: 03 June 2014 17:26
To: Joel M. Halpern
Cc: Jonathan Hardwick; Ross Callon; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [RTG-DIR] Routing Directorate Web Pages now a Wiki

As an additional reminder, this should also be added to the review instructions at the top of http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDirGuidance .

Cheers,
Andy

On Tue, Jun 3, 2014 at 12:02 PM, Joel M. Halpern <[email-masked]<mailto:[email-masked]>> wrote:
The odds of my remembering to do this wiki update step are very slim.
If you want us to do this step, please include it in the review request.  I am willing to try to do so.  With the reminder, the odds are at least 50% that I will remember.

Yours,
Joel

Best regards
Jon

========

-----Original Message-----
From: rtg-dir [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ross Callon
Sent: 02 June 2014 22:28
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [RTG-DIR] Routing Directorate Web Pages now a Wiki

Thanks, Ross

-----Original Message-----
From: rtg-dir [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Adrian Farrel
Sent: Thursday, April 17, 2014 12:54 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [RTG-DIR] Routing Directorate Web Pages now a Wiki

Hi,

Three other notes...

Thanks,
Alia and Adrian

---

From: Alia Atlas <[email-masked]>
Date: Wed, 4 Jun 2014 10:32:17 -0400

Good idea :-)

Alia

On Wed, Jun 4, 2014 at 2:51 AM, Jonathan Hardwick <
[email-masked]> wrote:

> *From:* rtg-dir [mailto:[email-masked]] *On Behalf Of *Andrew
> G. Malis
> *Sent:* 03 June 2014 17:26
> *To:* Joel M. Halpern
> *Cc:* Jonathan Hardwick; Ross Callon; [email-masked];
> [email-masked]; [email-masked]
>
> *Subject:* Re: [RTG-DIR] Routing Directorate Web Pages now a Wiki
>
>
>