Subject: RE: a question of sctp setup

From: "Lei Zhang" <[email-masked]>
Date: Wed, 6 Aug 2003 21:14:25 +0200

Randall Stewart:

Still about the question oringinally proposed:

In COOKIE_WAIT state, before an INIT_ACK being accepted I don't think application should start to send data in buffer. Because, in case that an application has been set as having 3 out-substreams, but an incoming INIT_ACK only has 1 in-substreams, then after a negociation with INIT_ACK, the application should be changed as 1 out-substream supported. 

So, I think there might be a problem:

In COOKIE-WAIT explicitly all you have to do is find the association and 
accept
any sends into your send-buffer... then when the INIT-ACK arrives just 
bundle
any chunks in the send-buffer...

What if the application (in COOKIE-WAIT but has not got INIT-ACK yet) sends data to buffer via 2nd substream that will be cancelled?

I don't know, actually, confused:((

Thanks for the patience

Lei  

-----Original Message-----
From: Randall Stewart (cisco) [mailto:[email-masked]]
Sent: Tuesday, August 05, 2003 10:49 PM
To: Lei Zhang
Cc: [email-masked]
Subject: Re: a question of sctp setup

Lei Zhang wrote:

>Hi, 
>
>Before the entire sctp being created, for instance in COOKIE-WAIT state, if only packet from the first substream can be inserted into "send-buffer" ? That means, before setup  finished, application should not send any packets on substeams except the first one?
>
>Thanks!
>
>Lei
>
>
>  
>
Lei Zhang:

I have a hard time following your question...

You can send anything you want bundled on the cookie-echo or cookie-ack. 
I will
admit that generally the cookie-ack will not have anything bundled with 
it .. but that
is due to the app.

In COOKIE-WAIT explicitly all you have to do is find the association and 
accept
any sends into your send-buffer... then when the INIT-ACK arrives just 
bundle
any chunks in the send-buffer...

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Wed, 06 Aug 2003 15:18:25 -0500

>I don't know, actually, confused:((
Lei:

What the KAME-SCTP stack does in this situation is:

1) Send the INIT--->
2) Allow the users to queue to any of the streams (say 0-4)
3) When the INIT-ACK arrives and says there are only 2 streams
     then any data chunks waiting to be sent on streams 2,3,and 4 are
     reported to the upper layer as unsent and failed.. .with a ULP 
notification.
4) Any other valid data to streams 0/1 are bundled with the cookie-echo

R