Subject: Re: a question of sctp setup

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Tue, 05 Aug 2003 15:48:36 -0500

Lei Zhang wrote:

>Hi, 
>
>Before the entire sctp being created, for instance in COOKIE-WAIT state, if only packet from the first substream can be inserted into "send-buffer" ? That means, before setup  finished, application should not send any packets on substeams except the first one?
>
>Thanks!
>
>Lei
>
>
>  
>
Lei Zhang:

I have a hard time following your question...

You can send anything you want bundled on the cookie-echo or cookie-ack. 
I will
admit that generally the cookie-ack will not have anything bundled with 
it .. but that
is due to the app.

In COOKIE-WAIT explicitly all you have to do is find the association and 
accept
any sends into your send-buffer... then when the INIT-ACK arrives just 
bundle
any chunks in the send-buffer...

R

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

---

From: "Lei Zhang" <[email-masked]>
Date: Wed, 6 Aug 2003 10:11:33 +0200

Randall Stewart;

Thanks for the reply. You are right, I have found I made a mistake. In COOKIE-WIAT after a receiving of INIT-ACK, a negociation of out-stream and in-stream has been done. Therefore, any data from app can be bundled. 

Regards

Lei