Subject: RE: Summary of If header eval tests

From: "Lisa Dusseault" <[email-masked]>
Date: Sun, 2 Feb 2003 20:56:13 -0800

Julian it's great that you've done this research. It helps to get some
real data into our planning!

> So contrary to what we believed, protecting conditional PUTs 
> using strong
> etags currently does not interoperate well at all.
>
> How do we move forward on this issue?

I'm not sure.  Here's my guess:
 - Decide that preventing lost updates is actually important
 - Decide that strong ETags is the only way to do that effectively 
 - Exhort server implementors to do a better job of Etags and If header
 - Put the tests in Litmus -- which I understand you're already doing --
and announce
 - Hold another interoperability event where we record the results of
this effort

That holds back draft standard until we can hold another interop event,
but if we hold another summer interop as we have the last two years,
draft standard would probably take that long anyway.

Any other ideas? 

Lisa

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 3 Feb 2003 13:37:17 +0100

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Lisa Dusseault
> Sent: Monday, February 03, 2003 5:56 AM
> To: 'Julian Reschke'; [email-masked]
> Subject: RE: Summary of If header eval tests
>
>
>

Thanks.

> > So contrary to what we believed, protecting conditional PUTs using
strong
>  - Decide that preventing lost updates is actually important

I don't think we need to decide that :-)

>  - Decide that strong ETags is the only way to do that effectively

...the best...

>  - Put the tests in Litmus -- which I understand you're already doing --

Nope, I'm currently not doing it. Joe Orton, are you listening?

> draft standard would probably take that long anyway.

I think it's sufficient to add the test cases to Litmus and make sure that
clients submit correct If headers. This can be tested without a specific
face-to-face meeting...

Julian

--
<green/>bytes GmbH -- http://www.greenbytes.de -- tel:+492512807760

---

From: Joe Orton <[email-masked]>
Date: Mon, 3 Feb 2003 12:56:48 +0000

> Nope, I'm currently not doing it. Joe Orton, are you listening?

Only with one ear - you'd like all the tests in the update-tests.js file
you posted re-implemented in litmus?

joe

---

From: "Julian Reschke" <[email-masked]>
Date: Mon, 3 Feb 2003 14:10:55 +0100

> [mailto:[email-masked]]On Behalf Of Joe Orton
> Sent: Monday, February 03, 2003 1:57 PM
> To: [email-masked]
> Subject: Re: Summary of If header eval tests
> 
> 
> 

Right. Basically it's a sequence of

- create locked resource
- various conditional updates (using PUT)
- UNLOCK
- some more tests involving if-match and etag

Julian