Subject: shares

From: Andre John Mas <[email-masked]>
Date: Wed, 12 Feb 2003 15:56:13 -0500

Hi,

I would like to know whether with webdav there is any provision
to advertising the shares available on a given server? The idea,
with the, conjunction of a technology such as Rendezvous, would
be to list the servers with 'shares' in local area and then list
the webdav resources being made available by the server.

regards

Andre

---

From: Brian Korver <[email-masked]>
Date: Wed, 12 Feb 2003 15:19:18 -0800

> the webdav resources being made available by the server.

Ander,

No, there isn't.  It would be nice tho'.

-brian
[email-masked]

---

From: Andre John Mas <[email-masked]>
Date: Thu, 13 Feb 2003 11:45:29 -0500

> No, there isn't.  It would be nice tho'.

If this indeed the case, maybe this is something that should be
examined?  Maybe a simple solution to this (note - two second
analysis ;) would be an XML file at the root. The file would
have a standard name, maybe something such as webdav.xml and
would list the shares:

   <webdav version="x.x">
     <description text="my shares"/>
     <shares>
        <share name="music" description="my music for you to discover"
           guest="yes"/>
        <share name="docs" description="development docs" guest="no"/>
      </shares>
   </webdav>

The server would have the option of dynamically changing the published
xml file depending on whether the file was request with a user name or
without. With this in mind, any client should probably support a
redirection to another URL which provides the data - this is in order
to allow retrofitting of this functionality to existing servers, and
maybe even indicating that the server has been moved?

   <webdav version="x.x">
      <redirection path="/servlets/sharelist"/>
   </webdav>

   <webdav version="x.x">
      <moved url="http://myserver/" message="server has been moved"/>
   </webdav>

   <webdav version="x.x">
      <unavailable message="this server be taken out of service"/>
   </webdav>

Although there is probably a lot that could be done, hopefully
this should serve as a seed for future work?

Andre

---

From: "Lisa Dusseault" <[email-masked]>
Date: Thu, 13 Feb 2003 11:56:58 -0800

There's another potential technology for this kind of thing besides
Rendezvous: the Service Location Protocol. It's not exactly the same,
but it's useful in its own way.
http://www.srvloc.org/

lisa

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Brian Korver
> Sent: Wednesday, February 12, 2003 3:19 PM
> To: Andre John Mas
> Cc: [email-masked]
> Subject: Re: shares
> 
> 
>