Subject: displayname and uniqueness

From: Brian Korver <[email-masked]>
Date: Thu, 29 Jul 2004 17:11:22 -0700

2518 doesn't address whether the displaynames on
resources within a given collection must be unique.
I presume there is no uniqueness constraint, but
besides stating that, should the spec give some
guidance to clients on what to do when there are
duplicates?  What would that guidance be?

-brian
[email-masked]

---

From: Geoffrey M Clemm <[email-masked]>
Date: Fri, 30 Jul 2004 07:27:27 -0400

Brian wrote on 07/29/2004 08:11:22 PM:

> I presume there is no uniqueness constraint,

That is correct.

> but besides stating that,

Since we cannot enumerate all constraints that do not hold,
we would only do so if this has turned out to be a source
of non-interoperability.  Is this the case?

> should the spec give some

I'm not sure what kind of guidance you have in mind here.
Could you provide an example?

Cheers,
Geoff