Subject: WebDAV over SSL

From: "Charlie Smith" <[email-masked]>
Date: Mon, 19 Jul 2004 09:37:06 -0600

Does WebDAV work over SSL?

Sorry if I'm repeating question that has been asked before.

If WebDAV does not work over SSL, is there a timeframe for getting 
that to work?

Charlie ;)
7/19/04

------------------------------------------------------------------------------
This message may contain confidential information, and is
intended only for the use of the individual(s) to whom it
is addressed.
------------------------------------------------------------------------------

---

From: Stefan Eissing <[email-masked]>
Date: Mon, 19 Jul 2004 17:48:45 +0200

> Does WebDAV work over SSL?

Yes.

----------------------
This message was written as is and may or may not reflect the opionion 
of its author, the public at large or any ethnic minorities. It just 
is, was and will be again.

---

From: Frank Lowney <[email-masked]>
Date: Mon, 26 Jul 2004 10:00:11 -0400

>>Does WebDAV work over SSL?

But do all clients work successfully with WebDAV via SSL?  It used to be that the MacOS X client built into the OS would not.  Has that changed?  What does the score card for other OSs look like?

Under what circumstances does WebDAV over SSL make sense?  If I am simply working on a public web site, intercepting the info en route is no big deal but changing it en route would be.

-- 
=====================================================================
Dr. Frank Lowney  [email-masked]
    Director, Electronic Instructional Services, a unit of the
    Office of Information and Instructional Technology,
    Professional Pages: http://www.gcsu.edu/oiit/eis/
    Personal Pages: http://www.faculty.de.gcsu.edu/~flowney
Voice: (478) 445-5260
NOTICE: Please be advised that I am hearing impaired and communicate most effectively via e-mail.  Follow-up summaries of telephone conversations by e-mail are most appreciated.
=====================================================================
We don't make instruction effective, we make effective instruction more accessible.

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 27 Jul 2004 13:13:04 +0200

On Jul 26, 2004, at 16:00, Frank Lowney wrote:

> But do all clients work successfully with WebDAV via SSL?  It used to 
> be that the MacOS X client built into the OS would not.  Has that 
> changed?  What does the score card for other OSs look like?

MacOSX WebDAV client does not handle DAV over SSL.

    paf

---

From: Joachim Feise <[email-masked]>
Date: Tue, 27 Jul 2004 10:11:39 -0700

Frank Lowney wrote on 7/26/2004 7:00:
> Under what circumstances does WebDAV over SSL make sense?

Whenever you use authentication to control access.
Using Basic Authentication without SSL is completely useless,
since username and password are transmitted in clear text with
just a trivial encoding.

-Joe