Subject: [Anima-bootstrap] bootstrap design team

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Wed, 18 May 2016 14:10:47 +0000

Greetings,

Today’s bootstrap design team notes can be found from the wiki:
	https://trac.tools.ietf.org/wg/anima/trac/wiki/Bootstrap

But a quick summary of what we’ve been doing:

1. Implementation experience and editing feedback was captured in a number of EDNOTES into the document. We have been going through these EDNOTES and deciding how to resolve them. 

2. In the most recent call the format of the onwire messages was discussed. Kent Watson joined and we went through the formats from netconf/anima with a goal of aligning these formats to the point where a single common message type can be used. 

Cheers, 

- max

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 19 May 2016 11:50:59 +1200

> 2. In the most recent call the format of the onwire messages was discussed. Kent Watson joined and we went through the formats from netconf/anima with a goal of aligning these formats to the point…

Looking at the notes, I assume that you will end up with something like a YANG or JSON
construct. Just a reminder, the only constraint for GRASP is that the 'value' can be
encoded in CBOR, which is not really much of a constraint at all and makes either
YANG or JSON fine. The mappings are documented already:
https://tools.ietf.org/html/draft-veillette-core-yang-cbor-mapping
https://tools.ietf.org/html/rfc7049#section-4

Regards
   Brian