Subject: [avtext] I-D Action: draft-ietf-avtext-multiple-clock-rates-02.txt

From: [email-masked]
Date: Tue, 03 Jan 2012 08:39:34 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Audio/Video Transport Extensions Working Group of the IETF.

	Title           : Support for multiple clock rates in an RTP session
	Author(s)       : Marc Petit-Huguenin
	Filename        : draft-ietf-avtext-multiple-clock-rates-02.txt
	Pages           : 13
	Date            : 2012-01-03

   This document clarifies the RTP specification when different clock
   rates are used in an RTP session.  It also provides guidance on how
   to interoperate with legacy RTP implementations that use multiple
   clock rates.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-avtext-multiple-clock-rates-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtext-multiple-clock-rates-02.txt

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 03 Jan 2012 08:45:14 -0800

I looked at 4 FOSS implementations of RTP and found that the (timestamp =
capture_time * clock_rate) formula was used by 3 of them, with the 4th changing
SSRC when the clock_rate changes.  So I re-added the legacy non-monotonic
formula in the draft, and listed all the libraries analyzed in a new appendix.

Next step will be to find consensus on section 4.

Changelog:

   o  Readded the non-monotonic methods that was removed in a previous
      version.
   o  Added analysis of FOSS RTP stacks.
   o  Changed author affiliation.
   o  Added AVTEXT area.

> ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtext-multiple-clock-rates-02.txt

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org