Subject: [calsify] Olympic thoughts

From: "Tim Hare" <[email-masked]>
Date: Thu, 2 Aug 2012 20:57:38 -0400

Looking at some of the Olympic events pages (for example this one:
http://www.london2012.com/hockey/event/women/match=how400b12/index.html)  I
see lots of room for improvement in the calendar sense:   times which don't
indicate the timezone (assuming it's whatever daylight savings time is in
the UK) and no opportunities to open an event and add it to my own calendar
- that I could find, anyway.

I seem to see this all the time - either there's no iCalendar support,
what's there is in pieces (individual events, but no file for the team's
schedule or other grouped events); or it's not well done - no locations, or
descriptions bad, etc.

Do you think there's something lacking in calendar standards or tools that
causes this to happen?  Specifically  a lack of add-ons that can take event
information from where someone is editing it and publishing it as iCalendar
stuff?

Trying for a broad spectrum of thought on this from calendar folks so that's
why the cross posting.

Tim Hare

Interested Bystander, Non-Inc.

---

From: Patrice Scattolin <[email-masked]>
Date: Fri, 03 Aug 2012 09:02:39 -0400

There simply isn't a compelling use case from end users to create offer 
from service providers. This likely stems from the fact that there 
aren't really must have calendar applications that one depends on for 
their daily life!

Frankly ( and it saddens me to admit this) I could certainly live 
without an electronic calendar. Sure it would be nice that all the 
scheduling would magically come together but that it doesn't isn't a bad 
enough problem I need to solve.

To a certain extent this has been fixed in the contacts field and the 
void (at least in my experience) has been filled in either by facebook 
or linkedin. The "must have" application is the smart phone addressbook 
and it's a must have simply because no one can remember that many phone 
numbers to call, email or IM. The resulting integration of the live 
address book that are either of these service providers and my phone 
makes the entire experience worth while from the user's perspective and 
quite rightly.

But I simply don't have that many meetings to attend...

 From a pragmatic point of view, CalDav is simply to complicated to 
configure and clients aren't well behaved in case of errors (in my 
experience they are useless at indicating you what you need to fix).

So something that would fix provisioning of external calendars should 
help so that content management applications builders could add an icon 
to their toolbars that mobile device would react to properly and 
provision the external calendar on the device's calendar application. 
This way providing access to external calendar would be trivial to 
website designers since it would be built in feature of their content 
management package and it would be trivial for the end users to 
subscribe to the calendar since clicking on the icon would provision the 
calendar in their clients.

But if that would lead to a ubiquitous calendar icon as popular as the 
little facebook or pinterest icons, that's a business problem I won`t 
attempt to address, that's simply out of my depth.

On 02/08/2012 8:57 PM, Tim Hare wrote:
> http://www.london2012.com/hockey/event/women/match=how400b12/index.html)  
> I see lots of room for improvement in the calendar sense:   times 
> which don't indicate the timezone (assuming it's whatever daylight 
> savings time is in the UK) and no opportunities to open an event and 
> add it to my own calendar - that I could find, anyway.
>
>  what's there is in pieces (individual events, but no file for the 
> team's schedule or other grouped events); or it's not well done - no 
> locations, or descriptions bad, etc.
>
> Do you think there's something lacking in calendar standards or tools 
> that causes this to happen?  Specifically  a lack of add-ons that can 
> take event information from where someone is editing it and publishing 
> it as iCalendar stuff?
>
> Trying for a broad spectrum of thought on this from calendar folks so 
> that's why the cross posting.
>
> Tim Hare
>
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify

---

From: "Nigel Swinson" <[email-masked]>
Date: Fri, 3 Aug 2012 16:16:45 +0100

For me, the "Must have" applications for electronic calendaring are just as much about what you are doing as they are about those you interact with.  As a married man, electronic calendaring would provide me with access into what my wife has planned in evenings; and therefore permit us to know if we are both free in an evening by referencing a digital calendar.  Or at least that would be the case if I could get my wife to use a digital calendar ;o)  Better still to be able to quickly schedule a team meeting, without having to say "which Thursday evenings are you all free over the next 2 months".

However to get to that digtal calendaring nirvana; such a lot of technology needs to work, with such good interoperability across all the various mobile platforms.

Well get there :o)

I think olympic events, or tv listings come after these other "must have" applications.  I think some kind of well recognized logo which would produce an .ics file for an event would be helpful.  I've done this in the past with (.ics) links after the relevant event, but it would be better to have the facebook style "Like" or +1 style logos.

Nigel
  ----- Original Message ----- 
  From: Patrice Scattolin 
  To: [email-masked] 
  Sent: Friday, August 03, 2012 2:02 PM
  Subject: Re: [calsify] Olympic thoughts

  There simply isn't a compelling use case from end users to create offer from service providers. This likely stems from the fact that there aren't really must have calendar applications that one depends on for their daily life!

  Frankly ( and it saddens me to admit this) I could certainly live without an electronic calendar. Sure it would be nice that all the scheduling would magically come together but that it doesn't isn't a bad enough problem I need to solve. 

  To a certain extent this has been fixed in the contacts field and the void (at least in my experience) has been filled in either by facebook or linkedin. The "must have" application is the smart phone addressbook and it's a must have simply because no one can remember that many phone numbers to call, email or IM. The resulting integration of the live address book that are either of these service providers and my phone makes the entire experience worth while from the user's perspective and quite rightly. 

  From a pragmatic point of view, CalDav is simply to complicated to configure and clients aren't well behaved in case of errors (in my experience they are useless at indicating you what you need to fix). 

  So something that would fix provisioning of external calendars should help so that content management applications builders could add an icon to their toolbars that mobile device would react to properly and provision the external calendar on the device's calendar application. This way providing access to external calendar would be trivial to website designers since it would be built in feature of their content management package and it would be trivial for the end users to subscribe to the calendar since clicking on the icon would provision the calendar in their clients.

  But if that would lead to a ubiquitous calendar icon as popular as the little facebook or pinterest icons, that's a business problem I won`t attempt to address, that's simply out of my depth.

  On 02/08/2012 8:57 PM, Tim Hare wrote: 
    Looking at some of the Olympic events pages (for example this one: http://www.london2012.com/hockey/event/women/match=how400b12/index.html)  I see lots of room for improvement in the calendar sense:   times which don't indicate the timezone (assuming it's whatever daylight savings time is in the UK) and no opportunities to open an event and add it to my own calendar - that I could find, anyway.

    I seem to see this all the time - either there's no iCalendar support,  what's there is in pieces (individual events, but no file for the team's schedule or other grouped events); or it's not well done - no locations, or descriptions bad, etc.

    Do you think there's something lacking in calendar standards or tools that causes this to happen?  Specifically  a lack of add-ons that can take event information from where someone is editing it and publishing it as iCalendar stuff?

    Trying for a broad spectrum of thought on this from calendar folks so that's why the cross posting.

    Tim Hare

     

------------------------------------------------------------------------------