Subject: [calsify] Call for adoption for draft-jenkins-jscalendar

From: Daniel Migault <[email-masked]>
Date: Mon, 11 Dec 2017 16:11:59 -0500

Hi,

This mail starts a Call for Adoption for draft-jenkins-jscalendar [1]:
"JSCalendar: A JSON representation of calendar data".

Please indicate whether you support or not the adoption by December 25.

Yours,
Philipp, Donald and Daniel

https://tools.ietf.org/html/draft-jenkins-jscalendar-02

---

From: Ken Murchison <[email-masked]>
Date: Mon, 11 Dec 2017 16:12:56 -0500

I fully support adoption.

On 12/11/2017 04:11 PM, Daniel Migault wrote:
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify

-- 
Kenneth Murchison
Cyrus Development Team
FastMail Pty Ltd

---

From: Marten Gajda <[email-masked]>
Date: Mon, 11 Dec 2017 22:17:32 +0100

I fully support the adoption of this draft.

Cheers,

Marten

-- 
Marten Gajda
CEO

dmfs GmbH
Schandauer Straße 34
01309 Dresden
GERMANY

phone: +49 177 4427167
email: [email-masked]

Managing Director: Marten Gajda
Registered address: Dresden
Registered No.: AG Dresden HRB 34881
VAT Reg. No.: DE303248743

---

From: [email-masked]
Date: Mon, 11 Dec 2017 14:02:00 -0800

I fully support adoption of this draft.

Dave

> On Dec 11, 2017, at 13:11, Daniel Migault <[email-masked]> wrote:
> 
> Hi,
> 
> This mail starts a Call for Adoption for draft-jenkins-jscalendar [1]: "JSCalendar: A JSON representation of calendar data".
> 
> https://tools.ietf.org/html/draft-jenkins-jscalendar-02 <https://tools.ietf.org/html/draft-jenkins-jscalendar-02>
>

---

From: Ronald Tse <[email-masked]>
Date: Mon, 11 Dec 2017 22:25:51 +0000

_____________________________________

Ronald Tse
Ribose Inc.

On Dec 12, 2017, at 5:12 AM, Daniel Migault <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Yours,

_______________________________________________
calsify mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/calsify

---

From: Michael Douglass <[email-masked]>
Date: Mon, 11 Dec 2017 18:50:24 -0500

I support adoption of this draft

---

From: Bron Gondwana <[email-masked]>
Date: Tue, 12 Dec 2017 11:27:53 +1100

Bron.

On Tue, 12 Dec 2017, at 08:11, Daniel Migault wrote:
> "JSCalendar: A JSON representation of calendar data".> 
> Please indicate whether you support or not the adoption by
> December 25.> 
> Yours, 

> _________________________________________________
> calsify mailing list
> [email-masked]

--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]

---

From: Adrian Apthorp <[email-masked]>
Date: Tue, 12 Dec 2017 15:00:46 +0800

Hi,

I’ve just been through the draft and see a few things which I believe need correcting before adoption. Also, there are some obvious all be it minor errors which should be corrected at the same time.

> 3.3.4 
> ...

> A map of of location id to Location objects,...

Presumably “ A map of location ids to Location objects,...”?

And similarly in section 3.3.5 

> A map of of link id to Link objects,...

Also, in section 3.3.5

> *rel*: "String"(optional, defaults to "related")

“related” doesn’t seem to be defined.

> The features supported by locations with rel-type "virtual" are:

Looks like a cut & paste error from 3.3.4.

> *properties*: "String[String|null]|null"(optional, defaults to "null") Extra metadata stored by a client about a link.

And not stored by the server?

Section 3.4.5. *rsvpResponse*:

> * "declined": The participant may attend. 
> * "tentative": The participant will not attend.

Will cause all sorts of confusion...

> 4.2.7

> *timestamp*: "UTCDate" Describes the latest time when the participant updated her progress.

their rather than her?

Section 5.4 - “keywords” “Corresponds to the COLOR property...” doesn’t sound right to me. Presumably this should refer to “color” and “keywords” relate to “CATEGORIES”?

Also, I still notice a bias towards events, even though the draft discusses both task and event objects:

> *rsvpResponse*:
> ...
> "accepted": The participant will attend.

Is better put as “The participant will participate.”

Similarly the description of “owner”, “attendee” and “chair” roles (3.4.5) only refer to events when presumably they may apply to tasks?

Presumably 3.5.1 useDefaultAlerts (plus a few others) apply to tasks as well as events.

I’m assuming that the whole topic of statuses and comments will be addressed by a separate draft and won’t comment on it further here.

Cheers

Adrian

> On 12 Dec 2017, at 5:11 AM, Daniel Migault <[email-masked]> wrote:
> 
> Hi,
>

---

From: Thomas Schäfer <[email-masked]>
Date: Tue, 12 Dec 2017 07:46:34 +0000

Thomas

Von: calsify <[email-masked]> im Auftrag von Daniel Migault <[email-masked]>
Datum: Montag, 11. Dezember 2017 um 22:12
An: "[email-masked]" <[email-masked]>
Betreff: [calsify] Call for adoption for draft-jenkins-jscalendar

Hi,

Yours,

---

From: Robert Stepanek <[email-masked]>
Date: Tue, 12 Dec 2017 09:45:23 +0100

Hi Adrian,

On Tue, Dec 12, 2017, at 08:00, Adrian Apthorp wrote:
> I’ve just been through the draft and see a few things which I believe
> need correcting before adoption. Also, there are some obvious all be
> it minor errors which should be corrected at the same time.
Thanks for the review feedback. Expect an updated draft by tomorrow.

> Also, I still notice a bias towards events, even though the draft
> discusses both task and event objects:> [...]
Just to be clear: Any properties listed in section 3 (JSCalendar
properties) apply to both tasks and events. Any object-type specific
properties are described in section 4. Looking at your feedback I
realize we still haven't got rid of the event-bias in all descriptions
in section 3 and I will revisit the section to change that.
Cheers,
Robert

---

From: Robert Stepanek <[email-masked]>
Date: Wed, 13 Dec 2017 12:23:15 +0100

I've just uploaded draft version 03 [1], which fixes typos and rephrases
descriptions. It does not introduce new or alter existing property
semantics.
The complete list of changes is available on Github [2]

Cheers,
Robert

[1] https://tools.ietf.org/html/draft-jenkins-jscalendar-03
[2] https://github.com/CalConnect/PUBLIC_DRAFTS/commits/master/jscalendar

On Tue, Dec 12, 2017, at 09:45, Robert Stepanek wrote:
>> it minor errors which should be corrected at the same time.> 
>> discusses both task and event objects:>> [...]
>> Presumably 3.5.1 useDefaultAlerts (plus a few others) apply to tasks
>> as well as events.> 
> in section 3 and I will revisit the section to change that.> 
> Cheers,
> Robert

---

From: Adrian Apthorp <[email-masked]>
Date: Fri, 15 Dec 2017 20:53:21 +0800

Adoption supported

> On 13 Dec 2017, at 7:23 PM, Robert Stepanek <[email-masked]> wrote:
> 
> I've just uploaded draft version 03 [1], which fixes typos and rephrases descriptions. It does not introduce new or alter existing property semantics.
> 
>>> [...]
>> Just to be clear: Any properties listed in section 3 (JSCalendar properties) apply to both tasks and events. Any object-type specific properties are described in section 4. Looking at your feedback I realize we still haven't got rid of the event-bias in all descriptions in section 3 and I will revisit the section to change that.
>> 
>> Cheers,
>> Robert