Subject: [Casm] review for draft-kumar-casm-problem-and-use-cases-00

From: "Liushucheng (Will)" <[email-masked]>
Date: Mon, 6 Feb 2017 02:53:02 +0000

Hi all,

Below please find our review on draft-kumar-casm-problem-and-use-cases-00 as I promised last week.

In general, we believe it's a good work with problem and use cases to continue the discussions about IP address management started last year. Thanks for the efforts. However the scope and some use cases are not clear enough and may need more details.

Abstract
>   The organisations use IP Address Space Management (IPAM) tools to
>   manage their IP address space, often with proprietary database and
>   interfaces.  This document describes evolution of IPAM into a
>   standardized interfaces for centralized management of IP addresses.

It seems the scope was limited to IPAM while I remember in our discussion IPAM is one part, we should also consider other address management device such as BRAS.

The reason for evolution need to be mentioned. I propose the below text: "However, current approaches for address management often result in sub-optimal allocation efficiency and significant complexity for using, sharing and sharing such resources."

"often with proprietary database and   interfaces " do you mean "often with database and *proprietary* interfaces? "

Section 1
Propose to add more solid reasons sth like:
"The increase in number, diversity and complexity of modern network devices and services bring new challenges for the management of IP addresses.

     o Low allocation efficiency due to pre-allocation
     o Manual configuration of address policy, with risk for consistancy in applying policy
               o Complexity in making real-time changes to assignment
     o Lack of an open, programmable interface between systems which
                  requires IP addresses and the Management Systems handling the
                  respective IP address resources
"

Section 4
> 4.  Address Space Management Use cases  . . . . . . . . . . . . .   3
>     4.1.  DHCP server pool  . . . . . . . . . . . . . . . . . . . .   3
>     4.2.  Static address configuration  . . . . . . . . . . . . . .   3
>     4.3.  Public IP address pool  . . . . . . . . . . . . . . . . .   4
>     4.4.  Multicast IP address pool . . . . . . . . . . . . . . . .   4
>     4.5.  SDN controllers . . .

The category of the five use cases seems to be confusing. e.g., Controller vs Static address configuration.
In  Section 4.2, there is no clear why we need CASM in static address scenario nor how to use it.
In section 4.4, there is no clear text about the scenario.

> There is an absolute requirement that a network
>    operator must find a way to assign address to these devices.
Need to elaborate the scope of "these devices", as this is the key for CASM scope.

>   Some devices or functions do not rely on DHCP protocols to obtain an
>   IP address.
Not clear, please elaborate the scope of devices and functions as aforementioned.

Section 5
> 5.  Legacy address space management (IPAM) systems
Should be sth like "Legacy Address Management problem"?

>   o  MAC address and network segment (VLAN) does not given enough
>      information about user or usages
I failed to understand the meaning of this one. What's the relationship between IP address usages with MAC/VLAN?

>Lack of integration with name services such as DNS
In the use case above there is no related words about DNS. Need more details here.

Regards,
Will (Shucheng LIU)

---

From: Rakesh Kumar <[email-masked]>
Date: Mon, 6 Feb 2017 03:33:21 +0000

Hi Will,

Thanks for the comments, please find the responses below with [Rakesh].
I would appreciate if you and others take the -00 version and update it with suggested changes and send for review with -01 version.
I would like it to be joint effort.

Regards,
Rakesh

From: "Liushucheng (Will)" <[email-masked]>
Date: Sunday, February 5, 2017 at 6:53 PM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: review for draft-kumar-casm-problem-and-use-cases-00
Resent-From: <[email-masked]>
Resent-To: Rakesh Kumar <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Sunday, February 5, 2017 at 6:53 PM

Hi all,

In general, we believe it’s a good work with problem and use cases to continue the discussions about IP address management started last year. Thanks for the efforts. However the scope and some use cases are not clear enough and may need more details.

Abstract

[Rakesh] As I mentioned in my previous comments, any networking deployment and use-case would need IP address management. Basically every element need and address no matter what are the networks used for (BNG, Metro, 3GPP etc.).

The reason for evolution need to be mentioned. I propose the below text: “However, current approaches for address management often result in sub-optimal allocation efficiency and significant complexity for using, sharing and sharing such resources.”

“often with proprietary database and   interfaces “ do you mean “often with database and *proprietary* interfaces? ”
[Rakesh] Correct.

Section 1
Propose to add more solid reasons sth like:
“The increase in number, diversity and complexity of modern network devices and services bring new challenges for the management of IP addresses.

”
[Rakesh]  Sure.

Section 4

[Rakesh] Basically users (use-cases), who are the entities that would use address services. The static IP address assignment is independent of whether a controller is used in the network or not. The “CASM” can be used for assigning/registering static IP address instead of maintaining cheat sheets. Please propose changes to text if something can be made more clear.

>    operator must find a way to assign address to these devices.
Need to elaborate the scope of “these devices”, as this is the key for CASM scope.

Not clear, please elaborate the scope of devices and functions as aforementioned.
[Rakesh] What we mean is that DHCP is not always used.

Section 5
> 5.  Legacy address space management (IPAM) systems
Should be sth like “Legacy Address Management problem”?
[Rakesh] Sure,

>      information about user or usages
I failed to understand the meaning of this one. What’s the relationship between IP address usages with MAC/VLAN?
[Rakesh] The IP address may be allocated based on MAC/VLAN property. For example, a device giving it MAC address or network segment (VLAN) may request for an IP address (similar to DHCP).

[Rakesh] We will do

Regards,
Will (Shucheng LIU)