Subject: [Casm] review of draft-kumar-casm-requirements-and-framework

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Thu, 23 Feb 2017 12:21:21 +0000

Hi all,

Below please find our review of draft-kumar-casm-requirements-and-framework.

**** Technical ****

* Section 4

I would suggest to put requirement section into the use case draft.

*Section 5

>       +----------------+ +------+ +----+ +-----+ +-----------------------+

>       |Interface for   | |SDN/  | |OSS/| |ADMIN| |Interface for logs,    |

>       |managing address| |Legacy| |BSS | |     | |DHCP, DNS, NAT, Address|

>       |space and pools | |      | |    | |     | |allocation records     |

>       +--------+-------+ +--+---+ +-+--+ +--+--+ +----------+------------+

o   |            |       |       |               ^

o   |            |       |       |               |

o   |            |       |       |               |

o   |            |       |       |               |

o   v            v       v       v               |

>       +---+------------+-------+-------+---------------+------+

>       |    Address Space Management (IPAM) System             |

>       |      +-----------+ +----------+ +--------+            |

>       |      | Pool      | |Address   | |Database|            |

>       |      | Management| |Management| |        |            |

>       |      +-----------+ +----------+ +--------+            |

>       |                                                       |

>       +-------------------------+-----------------------------+

o   |

>       +-----------v------------+

>       |Address Helper Plug|ins |

>       +----+--+------+-----+---+

>       |  |         |     |--------------------+

>       |  +----+    |                          |

>       |       |     ------------+             |

>       v       +----|            |             |

>       +--------+    +-----+  +----------+   +--------+

>       | DNS    |    |NAT  |  |  Address |   | DHCP   |

>       | Servers|    |     |  |  Mapping |   | Servers|

>       |        |    |     |  |  Systems |   |        |

>       +--------+    +-----+  +----------+   +--------+

As this is the framework draft, our main comments are about this figure:

1.      Given all the use cases in two use case draft, it seems this figure cannot cover all of the use cases.

2.      IPAM in the middle usually referred to IPAM tools, here I suggest use CASM system in the middle box if it's different from IPAM tools.

3.      There seems missing the NE at the bottom of this figure? Do you mean there is no direct interface toward NE?

**** Editorial ****

* Section 4

>       The requirements should be able to meet the

>       various use-cases identified in the draft.

s/in the draft/in use case draft , and better refer to use case draft here, as there is no use cases in this draft.

Regards,
Will LIU (LIU Shucheng)

---

From: Rakesh Kumar <[email-masked]>
Date: Mon, 27 Feb 2017 18:36:56 +0000

Hi Will,

Please see answers below with [Rakesh].

Thanks
Rakesh

From: CASM <[email-masked]> on behalf of "Liushucheng (Will Liu)" <[email-masked]>
Date: Thursday, February 23, 2017 at 4:21 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "Pengtao (Tony)" <[email-masked]>, "Xuweiping (David)" <[email-masked]>
Subject: [Casm] review of draft-kumar-casm-requirements-and-framework

Hi all,

**** Technical ****

* Section 4

[Rakesh] We wanted to maintain separation between two drafts. One draft that summarizes possible use-cases for “CASM” and other creates a high level requirement in generic manner (not related any use-case in particular) and also propose a reference architecture.

*Section 5

o    |            |       |       |               ^

o    |            |       |       |               |

o    |            |       |       |               |

o    |            |       |       |               |

o    v            v       v       v               |

o    |

[Rakesh] This is a reference architecture based on high level requirements. We should first see, whether the requirements generated from the use-case in mind are captured, once captured we should see how to fit this into same reference architecture.

2.       IPAM in the middle usually referred to IPAM tools, here I suggest use CASM system in the middle box if it’s different from IPAM tools.

[Rakesh] I agree; I would say this was a “typo”.

[Rakesh] What do you mean “NE”? Is it networking element? If so, any device that request an IP address must either do through protocol (DHCP) or some proprietary mechanism. The proprietary system would interact with “CASM” at northbound side in the figure (interface for managing address).

**** Editorial ****

* Section 4

>         various use-cases identified in the draft.

s/in the draft/in use case draft, and better refer to use case draft here, as there is no use cases in this draft.

[Rakesh] Will do.

Regards,
Will LIU (LIU Shucheng)