Subject: Re: [Casm] Which interfaces does CASM plan on standardizing?

From: "Xie Chongfeng" <[email-masked]>
Date: Wed, 15 Feb 2017 22:09:51 +0800

Hi，Benoit and all,

This subject was originally raised by China Telecom, our use case is clear and straightforward.  In CT's network, there are tens of thousands of BRAS equipments，which are the major gateway to the broadband users. When the vBRAS was introduced, the volume will be even higher. Network operation team needs configure manaually IP address pool in each  
BRAS/vBRAS, which are time-consuming and low -efficient. Can DHCP solve this problem? The answer is NO, since DHCP deals with address allocation for end users.   

In order to autimate the configuration process and improve the IP adress usage, a centralized address pool managment approach may be more reasonable. We discucssed with verdors and carriers, we found that there have been some proprioritary inplementations, they differ in the south-bound interface, so  we propose to standardize the south-bound interface in the early stage, which will benefit to all the players.

Since the requirements are pressing to CT, we begun the filed trial last year and 3 vendors have implementated the interface defined in draft-sun-i2apm-address-pool-management-yang, luckily they all passed the field test by our joint efforts.

As mentioned in other drafts of CASM, the address management capability will be  opened to other applications,such as SDN and Cloud , the  north-bound interface will be standanized as well.  

Of course, in order to define the interface and its relatvie workflow, a unified framwork or architecture will need to be defined in advance.

Thank you!

Chongfeng Xie 

[email-masked]
 
From: Marc Blanchet
Date: 2017-02-14 20:24
To: Rakesh Kumar
CC: Liushucheng; Xie Chongfeng
Subject: Re: IPAM design from microsoft
will look into it. were you able to get Bloomsberg or else to support the work?
Marc.
On 14 Feb 2017, at 6:57, Rakesh Kumar wrote:
HI,
 
I found a very good document on the web from Microsoft about IPAM. This is good document that explains some of the concept we have listed in the drafts.
I thought, you guys might want to take a look at this for your reference.
 
Thanks & Regards
Rakesh

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 28 Feb 2017 12:54:23 +1300

Hi Chongfeng,

> Network operation team needs configure manaually IP address pool in each  
> BRAS/vBRAS

Obviously that is a hopeless task. That's exactly why this is one
of the test cases for ANIMA. So can you please comment on the
level of detail needed in that interface? Is it similar to
https://tools.ietf.org/html/draft-ietf-anima-prefix-management-02#section-6.1
That is an example for an IPRAN operator.

Note, I'm not asking about technical details - just about the
level of abstraction.

Regards
   Brian Carpenter

On 16/02/2017 03:09, Xie Chongfeng wrote:
> _______________________________________________
> CASM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/casm
>

---

From: "Xie Chongfeng" <[email-masked]>
Date: Tue, 28 Feb 2017 09:20:59 +0800

Hi,  Carpenter，

It is nice to receive your comments.　

CASM and ANIMA differ with each otherin the following aspects. 

Firstly, ANIMA is a self-managing in  
AUTONOMIC networking environment, the configurations to network elements 
are mainly done by the network elements themselves. while in CASM, in order 
to make the task easier, we propose the use centralizedserver or platform to do 
the configuration task, of course, the server may be distributed physically. 

Secondly, they have different use case, more the 3 
years ago, I had a long talk with Dr. Jiang Sheng in Beijing, and propose 
that the IP RAN may be a suitable use case to ANIMA, although the name 
didn't exist yet.  the primary use case for CASM is the address pool 
configuration for broadband IP network, CT has implemented the whole system 
based on the current CASM　dratfs, and 3 vendors have joined the field test 
last year. The field trial prove this approach can solve the issues we 
are concernd with.

The detailed description of the interface is shown in,
https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang/

Thank you!

Chongfeng  

发件人： Brian E Carpenter
发送时间： 2017-02-28 07:54
收件人： Xie Chongfeng; [email-masked]; bclaise; [email-masked]
抄送： [email-masked]; 'Liushucheng (Will)'; [email-masked]; draft-ietf-anima-prefix-management
主题： Re: [Casm] Which interfaces does CASM plan on standardizing?
Hi Chongfeng,

 
 
Regards
   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 28 Feb 2017 14:57:11 +1300

Hi,

> the configuration task, of course, the server may be distributed physically. 

Yes, I understand the different models. What I hope is that the two approaches
can be consistent as far as possible. So if you can express the policy to
a CASM system, and we can express the policy to an Autonomic Service Agent,
we get similar results. That's why I asked about the level of abstraction,
not about the details.
 
> last year. The field trial prove this approach can solve the issues we 

I have no doubt of that, and Anima is not yet a mature technology. However,
the Anima solution can be much broader than the IPRAN case - any device roles
that involve prefix delegation could easily be covered. So I think it is
quite important to have comparable policy options.
> https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang/

OK, I will try to study that.

Regards
   Brian

---

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Feb 2017 21:47:37 +0100

Hi Chongfeng,
> https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang/
3 vendor implementations. Great. That's a lot of experience.
So the end goal is to standardize this 
draft-sun-i2apm-address-pool-management-yang draft?
You had some support for this in OPSAWG for a WG document, if I recall 
correctly...
Or maybe you learned from this development experience?

Regards, Benoit

>
>
> Thank you!
>
> Chongfeng
>
>
> ------------------------------------------------------------------------
>     *发件人：* Brian E Carpenter <mailto:[email-masked]>
>     *发送时间：* 2017-02-28 07:54
>     *收件人：* Xie Chongfeng <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>;
>     bclaise <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
>     *抄送：* [email-masked]
>     <mailto:[email-masked]>; 'Liushucheng (Will)'
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>;
>     draft-ietf-anima-prefix-management
>     <mailto:[email-masked]>
>     *主题：* Re: [Casm] Which interfaces does CASM plan on standardizing?
>     Hi Chongfeng,
>     > This subject was originally raised by China Telecom, our use
>     case is clear and straightforward.  In CT's network, there are
>     tens of thousands of BRAS equipments，which are the major gateway
>     to the broadband users. When the vBRAS was introduced, the volume
>     will be even higher. Network operation team needs configure
>     manaually IP address pool in each
>     > BRAS/vBRAS, which are time-consuming and low -efficient. Can
>     DHCP solve this problem? The answer is NO, since DHCP deals with
>     address allocation for end users.
>     >
>     > In order to autimate the configuration process and improve the
>     IP adress usage, a centralized address pool managment approach may
>     be more reasonable. We discucssed with verdors and carriers, we
>     found that there have been some proprioritary inplementations,
>     they differ in the south-bound interface, so  we propose to
>     standardize the south-bound interface in the early stage, which
>     will benefit to all the players.
>     >
>     > Since the requirements are pressing to CT, we begun the filed
>     trial last year and 3 vendors have implementated the interface
>     defined in draft-sun-i2apm-address-pool-management-yang, luckily
>     they all passed the field test by our joint efforts.
>     >
>     > As mentioned in other drafts of CASM, the address management
>     capability will be  opened to other applications,such as SDN and
>     Cloud , the  north-bound interface will be standanized as well.
>     >
>     > Of course, in order to define the interface and its relatvie
>     workflow, a unified framwork or architecture will need to be
>     defined in advance.
>     >
>     > Thank you!
>     >
>     > Chongfeng Xie
>     >
>     >
>     >
>     >
>     >
>     >
>     > I found a very good document on the web from Microsoft about
>     IPAM. This is good document that explains some of the concept we
>     have listed in the drafts.