Subject: [Casm] CASM BoF request just posted to BoF wiki

From: "Liushucheng (Will)" <[email-masked]>
Date: Thu, 9 Feb 2017 03:56:28 +0000

Hi all,

I’m writing to notify you that the CASM BoF request was just posted in the bof wiki. https://trac.tools.ietf.org/bof/trac/
Many thanks for the efforts from Marc, Adrian, Rakesh and Chongfeng.

Please help to review it and let us know your thoughts. I’m copying it below.

--start--

Centralized Address Management (CASM)

  *   Description: Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. This work intends to evolve IPAM into standardized interfaces for centralized management of IP addresses, specially in the context of SDN/NFV networks. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage (reallocation in case of no more in use) and/or user intent (for specific services).

  *   Agenda
     *   Problem statement and use cases
     *   Requirements and framework
     *   Possible charter goals and milestones
     *   Next steps
  *   Status: WG Forming
  *   Responsible AD: OPS (Benoit Claise, Joel Jaeggli)
  *   BoF proponents: Chongfeng Xie(China Telecom), Rakesh Kumar (Juniper), Ying Cheng(China Unicom), Will Liu(Huawei)
  *   BoF chairs: TBD
  *   Number of people expected to attend: 100
  *   Length of session (1, 1.5, 2, or 2.5 hours): 1.5 hours
  *   Conflicts to avoid (whole Areas and/or WGs): intarea, opsawg, anima, supa, dhc, nfvrg
  *   Mailing List: ​​https://www.ietf.org/mailman/listinfo/casm<https://www.ietf.org/mailman/listinfo/casm>
  *   Draft charter: TBD
  *   Relevant drafts:
     *   ​https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases<https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases>
     *   ​https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management<https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management>
     *   ​https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework<https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework>
     *   ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch>
     *   ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang>
--end--

Regards,
Will (LIU Shucheng)

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 9 Feb 2017 16:00:12 -0000

Thanks for posting this ahead of time, Will. It's helpful to be able to read it and think about it.
 
Picking up on a point raised on the list and using Joel's suggestion...
 
Do you want to change "Centralized Address Management (CASM)" to "Coordinated Address Management (CASM)"? That does not preclude centralized solutions, but it also allows some degree of delegation as suggested by Brian.
 
Thanks,
Adrian
 
From: CASM [mailto:[email-masked]] On Behalf Of Liushucheng (Will)
Sent: 09 February 2017 03:56
To: [email-masked]
Subject: [Casm] CASM BoF request just posted to BoF wiki
 
Hi all,

 
--start--
Centralized Address Management (CASM)
*	Description: Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. This work intends to evolve IPAM into standardized interfaces for centralized management of IP addresses, specially in the context of SDN/NFV networks. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage (reallocation in case of no more in use) and/or user intent (for specific services).
*	Agenda 
*	Problem statement and use cases
*	Requirements and framework
*	Possible charter goals and milestones
*	Next steps
*	Status: WG Forming
*	Responsible AD: OPS (Benoit Claise, Joel Jaeggli)
*	BoF proponents: Chongfeng Xie(China Telecom), Rakesh Kumar (Juniper), Ying Cheng(China Unicom), Will Liu(Huawei)
*	BoF chairs: TBD
*	Number of people expected to attend: 100
*	Length of session (1, 1.5, 2, or 2.5 hours): 1.5 hours
*	Conflicts to avoid (whole Areas and/or WGs): intarea, opsawg, anima, supa, dhc, nfvrg
*	Mailing List: ​ <https://www.ietf.org/mailman/listinfo/casm> ​https://www.ietf.org/mailman/listinfo/casm
*	Draft charter: TBD
*	Relevant drafts: 
*	 <https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases> ​https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases
*	 <https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management> ​https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management
*	 <https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework> ​https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework
*	 <https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch> ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch
*	 <https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang> ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang
--end--
 
Regards,
Will (LIU Shucheng)

---

From: Ralph Droms <[email-masked]>
Date: Thu, 9 Feb 2017 11:12:01 -0500

> On Feb 9, 2017, at 11:00 AM, Adrian Farrel <[email-masked]> wrote:
> 

+1

> Do you want to change "Centralized Address Management (CASM)" to "Coordinated Address Management (CASM)"? That does not preclude centralized solutions, but it also allows some degree of delegation…

Also +1

Prior work in this area from the dhc WG, esp. in DHCP failover protocols, may be of interest.

- Ralph

> I’m writing to notify you that the CASM BoF request was just posted in the bof wiki. https://trac.tools.ietf.org/bof/trac/ <https://trac.tools.ietf.org/bof/trac/>
> Description: Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. This work intends to evolve IPAM into standardized interfaces for centralized management of IP addresses, specially in the context of SDN/NFV networks. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage (reallocation in case of no more in use) and/or user intent (for specific services).
> Agenda
> Problem statement and use cases
> Requirements and framework
> Possible charter goals and milestones
> Next steps
> Status: WG Forming
> Responsible AD: OPS (Benoit Claise, Joel Jaeggli)
> BoF proponents: Chongfeng Xie(China Telecom), Rakesh Kumar (Juniper), Ying Cheng(China Unicom), Will Liu(Huawei)
> BoF chairs: TBD
> Number of people expected to attend: 100
> Length of session (1, 1.5, 2, or 2.5 hours): 1.5 hours
> Conflicts to avoid (whole Areas and/or WGs): intarea, opsawg, anima, supa, dhc, nfvrg
> Mailing List: ​​https://www.ietf.org/mailman/listinfo/casm <https://www.ietf.org/mailman/listinfo/casm>
> Draft charter: TBD
> Relevant drafts:
> ​https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases <https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases>
> ​https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management <https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management>
> ​https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework <https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework>
> ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch <https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch>
> ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang <https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang>
> --end--
>  
> Regards,
> Will (LIU Shucheng)
>  
> _______________________________________________
> CASM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/casm

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Feb 2017 08:57:57 +1300

Will,

One other small wording comment:

> standardized interfaces for centralized management of IP addresses, specially in the context of SDN/NFV networks.

I agree that SDN/NFV should be supported, in fact any software/virtual
mechanisms should be supported, but why "specially"? So my rewrite would be

 standardized interfaces for coordinated management of IP addresses, including SDN/NFV networks
 and other forms of virtualization.

Regards
   Brian

---

From: "Marc Blanchet" <[email-masked]>
Date: Thu, 09 Feb 2017 15:13:37 -0500

On 9 Feb 2017, at 14:57, Brian E Carpenter wrote:

>> standardized interfaces for centralized management of IP addresses, 
>> specially in the context of SDN/NFV networks.
>

agreed. my bad: french to english bad translation…  changed on the 
wiki.

thanks.

Marc.

>> I’m writing to notify you that the CASM BoF request was just posted 
>> in the bof wiki. https://trac.tools.ietf.org/bof/trac/
>>   *   Description: Organizations use IP Address Space Management 
>> (IPAM) tools to manage their IP address space, often with proprietary 
>> database and interfaces. This work intends to evolve IPAM into 
>> standardized interfaces for centralized management of IP addresses, 
>> specially in the context of SDN/NFV networks. Use cases include 
>> dynamic allocation and release of IP addresses and prefixes based on 
>> usage (reallocation in case of no more in use) and/or user intent 
>> (for specific services).
>>
>>   *   Agenda
>>   *   BoF proponents: Chongfeng Xie(China Telecom), Rakesh Kumar 
>> (Juniper), Ying Cheng(China Unicom), Will Liu(Huawei)
>>   *   BoF chairs: TBD
>>   *   Mailing List: 
>> ​​https://www.ietf.org/mailman/listinfo/casm<https://www.ietf.org/mailman/listinfo/casm>
>>   *   Draft charter: TBD
>>   *   Relevant drafts:
>>      *   
>> ​https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases<https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases>
>>      *   
>> ​https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management<https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management>
>>      *   
>> ​https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework<https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework>
>>      *   
>> ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch>
>>      *   
>> ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang>
>> --end--
>>
>> Regards,
>> Will (LIU Shucheng)
>>
>>
>>

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Fri, 10 Feb 2017 03:04:55 +0000

Hi Adrian and all,

Thanks for your comments. The proponents discussed and agreed with “coordinated”.

However, seems we missed the “Space” in title ?  Should be *“Coordinated Address Space Management”* instead of “Coordinated Address Management”. I  just fixed this on wiki.

Regards,
Will (LIU Shucheng)

From: Adrian Farrel [mailto:[email-masked]]
Sent: Friday, February 10, 2017 12:00 AM
To: Liushucheng (Will) <[email-masked]>; [email-masked]
Subject: RE: [Casm] CASM BoF request just posted to BoF wiki

Thanks,
Adrian

From: CASM [mailto:[email-masked]] On Behalf Of Liushucheng (Will)
Sent: 09 February 2017 03:56
To: [email-masked]<mailto:[email-masked]>
Subject: [Casm] CASM BoF request just posted to BoF wiki

Hi all,

--start--

Centralized Address Management (CASM)
·     Description: Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. This work intends to evolve IPAM into standardized interfaces for centralized management of IP addresses, specially in the context of SDN/NFV networks. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage (reallocation in case of no more in use) and/or user intent (for specific services).
·     Agenda
o  Problem statement and use cases
o  Requirements and framework
o  Possible charter goals and milestones
o  Next steps
·     Status: WG Forming
·     Responsible AD: OPS (Benoit Claise, Joel Jaeggli)
·     BoF proponents: Chongfeng Xie(China Telecom), Rakesh Kumar (Juniper), Ying Cheng(China Unicom), Will Liu(Huawei)
·     BoF chairs: TBD
·     Number of people expected to attend: 100
·     Length of session (1, 1.5, 2, or 2.5 hours): 1.5 hours
·     Conflicts to avoid (whole Areas and/or WGs): intarea, opsawg, anima, supa, dhc, nfvrg
·     Mailing List: ​​https://www.ietf.org/mailman/listinfo/casm<https://www.ietf.org/mailman/listinfo/casm>
·     Draft charter: TBD
·     Relevant drafts:
o  ​https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases<https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases>
o  ​https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management<https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management>
o  ​https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework<https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework>
o  ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch>
o  ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang>
--end--

Regards,
Will (LIU Shucheng)

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Fri, 10 Feb 2017 03:07:08 +0000

Hi all,

I’m forwarding the updated version of  CASM BoF request on behalf of other proponents. Please feel free to ask questions and provide comments. Thanks!

--start--

Coordinated Address Space Management (CASM)

  *   Description: Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. This work intends to evolve IPAM into standardized interfaces for coordinated management of IP addresses, including SDN/NFV networks and other forms of virtualization. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage (reallocation in case of no more in use) and/or user intent (for specific services).

  *   Agenda

--end--

Regards,
Will (LIU Shucheng)

From: CASM [mailto:[email-masked]] On Behalf Of Liushucheng (Will)
Sent: Thursday, February 09, 2017 11:56 AM
To: [email-masked]
Subject: [Casm] CASM BoF request just posted to BoF wiki

Hi all,

--start--

  *   Agenda

Regards,
Will (LIU Shucheng)