Subject: [Casm] Which interfaces does CASM plan on standardizing?

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Feb 2017 18:29:44 +0100

Dear all,

Joel, Warren, and I have been discussing CASM.

Reading the two drafts, and we're wondering...

        draft-kumar-casm-problem-and-use-cases-00: This document describes evolution of IPAM into a
        standardized_interfaces _for centralized management of IP addresses.

        draft-kumar-casm-requirements-and-framework-00: There is a pressing need to define a new address management system
        which can meet these diverse set of requirements.  Such a system must
        be built with well defined_interfaces _so users can easily migrate
        from one vendor to another without rewriting their network management
        systems.

We see static address, public IP address pool, multicast IP address 
pool, pool initializing or resizing, etc.
We see DHCP server, DNS server, NAT service. And I guess there are 
controllers up there somewhere.
So which interfaces does CASM plan on standardizing?

         +----------------+ +------+ +----+ +-----+ +-----------------------+
         |Interface for   | |SDN/  | |OSS/| |ADMIN| |Interface for logs,    |
         |managing address| |Legacy| |BSS | |     | |DHCP, DNS, NAT, Address|
         |space and pools | |      | |    | |     | |allocation records     |
         +--------+-------+ +--+---+ +-+--+ +--+--+ +----------+------------+
                  |            |       |       |               ^
                  |            |       |       |               |
                  |            |       |       |               |
                  |            |       |       |               |
                  v            v       v       v               |
         +---+------------+-------+-------+---------------+------+
         |    Address Space Management (IPAM) System             |
         |      +-----------+ +----------+ +--------+            |
         |      | Pool      | |Address   | |Database|            |
         |      | Management| |Management| |        |            |
         |      +-----------+ +----------+ +--------+            |
         |                                                       |
         +-------------------------+-----------------------------+
                     |
         +-----------v------------+
         |Address Helper Plug|ins |
         +----+--+------+-----+---+
           |  |         |     |--------------------+
           |  +----+    |                          |
           |       |     ------------+             |
           v       +----|            |             |
         +--------+    +-----+  +----------+   +--------+
         | DNS    |    |NAT  |  |  Address |   | DHCP   |
         | Servers|    |     |  |  Mapping |   | Servers|
         |        |    |     |  |  Systems |   |        |
         +--------+    +-----+  +----------+   +--------+

All of them in this figure? A subset of those interfaces?
This group should be clear what it plans on working on.
And which IPAM vendors are involved in CASM, for a definition of IPAM 
related to this figure?

Note: similar comments as last time btw. See 
https://www.ietf.org/mail-archive/web/opsawg/current/msg04613.html

Regards, Benoit

---

From: Rakesh Kumar <[email-masked]>
Date: Wed, 15 Feb 2017 08:03:46 +0000

Hi,

Thanks for the review. We want to standardize three interfaces as defined in the section 5 of draft https://tools.ietf.org/html/draft-kumar-requirements-and-framework-00.

Pool/address management interface, Log interface and integration interfaces with other naming services.

Thanks

Rakesh

________________________________
From: CASM <[email-masked]> on behalf of Benoit Claise <[email-masked]>
Sent: Tuesday, February 14, 2017 9:29 AM
To: [email-masked]
Subject: [Casm] Which interfaces does CASM plan on standardizing?

Dear all,

   draft-kumar-casm-problem-and-use-cases-00: This document describes evolution of IPAM into a
   standardized interfaces for centralized management of IP addresses.

   draft-kumar-casm-requirements-and-framework-00: There is a pressing need to define a new address management system
   which can meet these diverse set of requirements.  Such a system must
   be built with well defined interfaces so users can easily migrate
   from one vendor to another without rewriting their network management
   systems.

We see static address, public IP address pool, multicast IP address pool, pool initializing or resizing, etc.
We see DHCP server, DNS server, NAT service. And I guess there are controllers up there somewhere.
So which interfaces does CASM plan on standardizing?

All of them in this figure? A subset of those interfaces?
This group should be clear what it plans on working on.
And which IPAM vendors are involved in CASM, for a definition of IPAM related to this figure?

Note: similar comments as last time btw. See https://www.ietf.org/mail-archive/web/opsawg/current/msg04613.html

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Wed, 15 Feb 2017 14:15:38 +0100

Hi Rakesh,
>
> Hi,
>
>
> Thanks for the review. We want to standardize three interfaces as 
> defined in the section 5 of draft 
> https://tools.ietf.org/html/draft-kumar-requirements-and-framework-00.
>
>
> Pool/address management interface, Log interface and 
> integration interfaces with other naming services.
>
Fine, but it's still vague to me. Can you point me those in your figure?

In my mind, an interface is a set of API between two end points.

Regards, Benoit
>
>
> Thanks
>
> Rakesh
>
> ------------------------------------------------------------------------
> *From:* CASM <[email-masked]> on behalf of Benoit Claise 
> <[email-masked]>
> *Sent:* Tuesday, February 14, 2017 9:29 AM
> *To:* [email-masked]
> *Subject:* [Casm] Which interfaces does CASM plan on standardizing?
> Dear all,
>