Subject: [Casm] Possible charter goals and milestones

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Feb 2017 18:37:13 +0100

Dear all,

"Possible charter goals and milestones" is mentioned in the BoF Wiki, 
but I fail to see which deliverables you have in mind, next to the 
framework?
Is/are your deliverable(s) based on 
draft-sun-i2apm-address-pool-management-yang, so (a) YANG module(s) that 
would specify the interface and facilitate the automation?
The BoF WIKI mentions "WG forming", but without a clear view on those 
deliverables, that's difficult.

Tough question: If the solution is this YANG module, based on 
draft-sun-i2apm-address-pool-management-arch, should we jump directly to 
the solution? In other words, what is the BoF added value? Note: I 
thought that those two drafts received some (mild) support in OPSAWG 
already in IETF 94.

If one of your deliverables is about the DHCP protocol, then I hope we 
all agree that it should be done in the dhc WG.

Regards, Benoit

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Wed, 15 Feb 2017 02:41:47 +0000

Hi Benoit and all,

Thanks for your guidance. After offline discussions among all the proponents, we changed the BoF to non-WG forming in the wiki.  https://trac.tools.ietf.org/bof/trac/

We also added the purpose of the BoF in the description:
The purpose of the BoF is to gather a common set of requirements from a larger set of operators and, if needed, possible protocol work milestones and scope.

I’m copying the updated version below for your convenience.

--start—

Coordinated Address Space Management (CASM)

  *   Description: Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. This work intends to evolve IPAM into standardized interfaces for coordinated management of IP addresses, including SDN/NFV networks and other forms of virtualization. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage (reallocation in case of no more in use) and/or user intent (for specific services). The purpose of the BoF is to gather a common set of requirements from a larger set of operators and, if needed, possible protocol work milestones and scope.

  *   Agenda
     *   Problem statement and use cases
     *   Requirements and framework
     *   Possible charter goals and milestones
     *   Next steps
  *   Status: non-WG Forming
  *   Responsible AD: OPS (Benoit Claise, Joel Jaeggli, Warren Kumari)
  *   BoF proponents: Chongfeng Xie(China Telecom), Rakesh Kumar (Juniper), Ying Cheng(China Unicom), Will Liu(Huawei)
  *   BoF chairs: TBD
  *   Number of people expected to attend: 100
  *   Length of session (1, 1.5, 2, or 2.5 hours): 1.5 hours
  *   Conflicts to avoid (whole Areas and/or WGs): intarea, opsawg, anima, supa, dhc, nfvrg
  *   Mailing List: ​​https://www.ietf.org/mailman/listinfo/casm<https://www.ietf.org/mailman/listinfo/casm>
  *   Draft charter: TBD
  *   Relevant drafts:
     *   ​https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases<https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases>
     *   ​https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management<https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management>
     *   ​https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework<https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework>
     *   ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch>
     *   ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang<https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang>

--end--

Regards,
Will (LIU Shucheng)

From: CASM [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, February 15, 2017 1:37 AM
To: [email-masked]
Subject: [Casm] Possible charter goals and milestones

Dear all,

"Possible charter goals and milestones" is mentioned in the BoF Wiki, but I fail to see which deliverables you have in mind, next to the framework?
Is/are your deliverable(s) based on draft-sun-i2apm-address-pool-management-yang, so (a) YANG module(s) that would specify the interface and facilitate the automation?
The BoF WIKI mentions "WG forming", but without a clear view on those deliverables, that's difficult.

Tough question: If the solution is this YANG module, based on draft-sun-i2apm-address-pool-management-arch, should we jump directly to the solution? In other words, what is the BoF added value? Note: I thought that those two drafts received some (mild) support in OPSAWG already in IETF 94.

If one of your deliverables is about the DHCP protocol, then I hope we all agree that it should be done in the dhc WG.

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Wed, 15 Feb 2017 14:25:01 +0100

Hi Liushucheng,
>
> Hi Benoit and all,
>
> Thanks for your guidance. After offline discussions among all the 
> proponents, we changed the BoF to non-WG forming in the wiki. 
> https://trac.tools.ietf.org/bof/trac/
>
> The purpose of the BoF is to gather a common set of requirements from 
> a larger set of operators and, if needed, possible protocol work 
> milestones and scope.
>
Protocol work?  Which protocol?  Can you expand on what is needed?
I thought the work was about interfaces.
> I’m copying the updated version below for your convenience.
I believe this is better.

Regards, Benoit
>
> --start—
>
> *Coordinated Address Space Management (CASM)*
>
>   * Description: Organizations use IP Address Space Management (IPAM)
>     tools to manage their IP address space, often with proprietary
>     database and interfaces. This work intends to evolve IPAM into
>     standardized interfaces for coordinated management of IP
>     addresses, including SDN/NFV networks and other forms of
>     virtualization. Use cases include dynamic allocation and release
>     of IP addresses and prefixes based on usage (reallocation in case
>     of no more in use) and/or user intent (for specific services). The
>     purpose of the BoF is to gather a common set of requirements from
>     a larger set of operators and, if needed, possible protocol work
>     milestones and scope.
>
>   * Agenda
>       o Problem statement and use cases
>       o Requirements and framework
>       o Possible charter goals and milestones
>       o Next steps
>   * Status: non-WG Forming
>   * BoF proponents: Chongfeng Xie(China Telecom), Rakesh Kumar
>     (Juniper), Ying Cheng(China Unicom), Will Liu(Huawei)
>   * BoF chairs: TBD
>   * Mailing List: ​​https://www.ietf.org/mailman/listinfo/casm
>   * Draft charter: TBD
>   * Relevant drafts:
>       o ​https://datatracker.ietf.org/doc/draft-kumar-casm-problem-and-use-cases
>       o ​https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management
>       o ​https://datatracker.ietf.org/doc/draft-kumar-casm-requirements-and-framework
>       o ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch
>       o ​https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang
>
> --end--
>
> Regards,
>
> Will (LIU Shucheng)
>
> *From:*CASM [mailto:[email-masked]] *On Behalf Of *Benoit Claise
> *Sent:* Wednesday, February 15, 2017 1:37 AM
> *To:* [email-masked]
> *Subject:* [Casm] Possible charter goals and milestones
>
> Dear all,
>
> draft-sun-i2apm-address-pool-management-yang, so (a) YANG module(s) 
> that would specify the interface and facilitate the automation?
> draft-sun-i2apm-address-pool-management-arch, should we jump directly 
> to the solution? In other words, what is the BoF added value? Note: I 
> _______________________________________________
> CASM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/casm

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Thu, 16 Feb 2017 14:45:10 +0000

Hi Benoit,

Please see below inline.

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, February 15, 2017 9:25 PM
To: Liushucheng (Will); [email-masked]
Cc: 'Ying Cheng'; 'Xie Chongfeng'; 'Rakesh Kumar'; [email-masked]; Marc Blanchet; [email-masked]
Subject: Re: [Casm] Possible charter goals and milestones

Hi Liushucheng,
Hi Benoit and all,

[Will] Thanks for the comments. As answered by Rakesh and Chongfeng, currently only interfaces are considered.

Cheers,
Will (Shucheng LIU)

---

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Feb 2017 21:53:38 +0100

On 2/16/2017 3:45 PM, Liushucheng (Will) wrote:
>
> Hi Benoit,
>
> Please see below inline.
>
> *From:*Benoit Claise [mailto:[email-masked]]
> *Sent:* Wednesday, February 15, 2017 9:25 PM
> *To:* Liushucheng (Will); [email-masked]
> *Cc:* 'Ying Cheng'; 'Xie Chongfeng'; 'Rakesh Kumar'; [email-masked]; 
> Marc Blanchet; [email-masked]
> *Subject:* Re: [Casm] Possible charter goals and milestones
>
> Hi Liushucheng,
>
>     Hi Benoit and all,
>
>     The purpose of the BoF is to gather a common set of requirements
>     from a larger set of operators and, if needed, possible protocol
>     work milestones and scope.
>
> */[Will] Thanks for the comments. As answered by Rakesh and Chongfeng, 
> currently only interfaces are considered./*
>
OK, to make sure we speak the same language, what do you call an 
interface in this context?
     - A protocol between A and B (with some negotiation, for example)?
     - A data model? 
https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang/ 
has been mentioned
- An API?
     - etc.

Regards, Benoit
> *//*
> *//*