Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

From: "Liushucheng (Will)" <[email-masked]>
Date: Fri, 3 Feb 2017 06:26:18 +0000

Hi Rakesh,

Many thanks for your efforts!

No worries. Let's review and update in next version. And maybe another online meeting in next week. 

Btw, there are also some old work on this area as we discussed:
https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management/
https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch/
https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang/

Would you please let the audience know about the differences between new ones and old ones?

Regards,
Will (LIU Shucheng)

-----Original Message-----
From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
Sent: Monday, January 30, 2017 9:02 PM
To: Rakesh Kumar <[email-masked]>
Cc: [email-masked]
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

On 30 Jan 2017, at 1:43, Rakesh Kumar wrote:

> It looks like we messed up on the name. My mistake.
>
> It should have been
> “draft-kumar-casm-requirements-and-framework-00” instead of 
> “draft-kumar-requirements-and-framework-00”.
> Is there a way to correct it?

yeah. no big deal. we shall fix it for the new rev.

Marc.

>
> Thanks
> Rakesh
>
> On 1/29/17, 8:03 PM, "CASM on behalf of Rakesh Kumar" 
> <[email-masked] on behalf of [email-masked]> wrote:
>
>
>
>     On 1/29/17, 7:53 PM, "[email-masked]" 
> <[email-masked]> wrote:
>
>
>         A new version of I-D,
> draft-kumar-requirements-and-framework-00.txt
>         has been successfully submitted by Marc Blanchet and posted to 
> the
>         IETF repository.
>
>         Name:		draft-kumar-requirements-and-framework
>         Revision:	00
>         Title:		Centralized Address Space Management(CASM) 
> Requirements and Framework
>         Document date:	2017-01-29
>         Group:		Individual Submission
>         Pages:		8
>         URL:            
> https://www.ietf.org/internet-drafts/draft-kumar-requirements-and-framework-00.txt
>         Status:         
> https://datatracker.ietf.org/doc/draft-kumar-requirements-and-framework/
>         Htmlized:       
> https://tools.ietf.org/html/draft-kumar-requirements-and-framework-00
>
>
>         Abstract:
>            The organizations use IP Address Space Management (IPAM) 
> tools to
>            manage their IP address space, often with proprietary 
> database and
>            interfaces.  This document describes evolution of IPAM into 
> a
>            standardized interfaces for centralized management of IP 
> addresses.
>
>
>
>
>         Please note that it may take a couple of minutes from the time 
> of submission
>         until the htmlized version and diff are available at 
> tools.ietf.org.
>
>         The IETF Secretariat
>
>
>
>     _______________________________________________
>     CASM mailing list
>     [email-masked]
>     https://www.ietf.org/mailman/listinfo/casm
>
>
> _______________________________________________
> CASM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/casm

_______________________________________________
CASM mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/casm

---

From: Rakesh Kumar <[email-masked]>
Date: Fri, 3 Feb 2017 06:37:27 +0000

Hi Will,

The draft we wrote was based on the slide set we had presented earlier, that details a comprehensive approach to address management including with other address services such as DNS and NAT. We have also introduced the concept of interfaces based on user requirements.

I think, it would be good idea to combine all ideas into one set of drafts.

I think, CASM would also be useful for mining data for security related analytics.

Thanks
Rakesh

On 2/2/17, 10:26 PM, "CASM on behalf of Liushucheng (Will)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Rakesh,

    

    Regards,
    Will (LIU Shucheng)

    -----Original Message-----
    From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
    Sent: Monday, January 30, 2017 9:02 PM
    To: Rakesh Kumar <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

    
    
    Marc.

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Fri, 3 Feb 2017 06:52:24 +0000

Thanks for your prompt response. I have a better understanding now. 

Just took a glance and below please find the abstracts of two PS drafts, one requirement form the old one:

----draft-xie-ps-centralized-address-management-01----
Abstract

   The increase in number, diversity and complexity of devices and 
   services in modern networks bring new challenges for the management 
   of network resources, such as IP addresses, network prefixes, bandwidth, 
   and services that utilize such resources. This draft contains a problem 
   statement for IP address management and defines requirements with 
   practical use cases provided by operators.

...

5. Requirements

   Based on the analysis above, some requirements for IP address
   management can be highlighted as following:

   1) An integrated, centralized IP address management is desirable as it offers 
   an aggregated view on all stages of the life cycle of IP address resources, from 
   selection, allocation, assignment to reclaiming them into to free resources 
   in an optimized and efficient way.
---cut---

-----draft-kumar-casm-problem-and-use-cases-00-----
Abstract

   The organisations use IP Address Space Management (IPAM) tools to
   manage their IP address space, often with proprietary database and
   interfaces.  This document describes evolution of IPAM into a
   standardized interfaces for centralized management of IP addresses.
---cut---

From the text above I guess the two draft shares the same target:  A centralized IP address management.  
As there are already detailed use cases and requirements written in the old PS draft, I would suggest that maybe we should combine them together if applicable... My 0.02

Btw, I will do finish review and send my detailed comments earlier next week. 

Regards,
Will (LIU Shucheng) 

-----Original Message-----
From: Rakesh Kumar [mailto:[email-masked]] 
Sent: Friday, February 03, 2017 2:37 PM
To: Liushucheng (Will) <[email-masked]>; Marc Blanchet <[email-masked]>; Xie Chongfeng <[email-masked]>
Cc: [email-masked]
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

Hi Will,

Thanks
Rakesh

    Hi Rakesh,

    

    Regards,
    Will (LIU Shucheng)

    -----Original Message-----
    From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
    Sent: Monday, January 30, 2017 9:02 PM
    To: Rakesh Kumar <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

    
    
    Marc.

---

From: Rakesh Kumar <[email-masked]>
Date: Fri, 3 Feb 2017 16:34:17 +0000

Hi Will,

I agree that we should have one set of drafts reflecting our ideas.
Actually Marc suggested that we write these draft and circulate so that others can contribute and start the discussion going.

Regards,
Rakesh

On 2/2/17, 10:52 PM, "Liushucheng (Will)" <[email-masked]> wrote:

    
    ----draft-xie-ps-centralized-address-management-01----
    Abstract

    ...
    
    5. Requirements

    ---cut---
    
    -----draft-kumar-casm-problem-and-use-cases-00-----
    Abstract
    
    ---cut---

    
    Regards,
    Will (LIU Shucheng) 

    -----Original Message-----
    From: Rakesh Kumar [mailto:[email-masked]] 
    Sent: Friday, February 03, 2017 2:37 PM
    To: Liushucheng (Will) <[email-masked]>; Marc Blanchet <[email-masked]>; Xie Chongfeng <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt
    
    Hi Will,

    
    
    Thanks
    Rakesh

        Hi Rakesh,

        

        Regards,
        Will (LIU Shucheng)

        -----Original Message-----
        From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
        Sent: Monday, January 30, 2017 9:02 PM
        To: Rakesh Kumar <[email-masked]>
        Cc: [email-masked]
        Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

        
        
        Marc.

---

From: "Xie Chongfeng" <[email-masked]>
Date: Sun, 5 Feb 2017 10:35:10 +0800

Yes, I agree to  combine all ideas into one set of drafts to push forward this work. 

BUT  I didn't find any major difference between CASM and the old drafts, major use cases of centralized address management has been considered in the old PS draft (https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management/), including the DNS and NAT. CT put forward the use case of address management in metro network,  Ian and norman of DT raised the case of address management for OpenStack, OSS,etc.

So, I think it is necessary to clarify the relationship of these drafts. Thank you!

Chongfeng   

[email-masked]
 
From: Rakesh Kumar
Date: 2017-02-03 14:37
To: Liushucheng (Will); Marc Blanchet; Xie Chongfeng
CC: [email-masked]
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt
Hi Will,

 
 
Thanks
Rakesh

    Hi Rakesh,

    

    Regards,
    Will (LIU Shucheng)

    -----Original Message-----
    From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
    Sent: Monday, January 30, 2017 9:02 PM
    To: Rakesh Kumar <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

    
    
    Marc.

---

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Feb 2017 16:50:09 +0100

Chongfeng,

For my understanding...
So the plan is to stop working on these three drafts in OPSAWG?

    draft-xi-ps-centralized-address-management
    <http://tools.ietf.org/html/draft-xi-ps-centralized-address-management>
    expired
    draft-sun-i2apm-address-pool-management-arch
    <http://tools.ietf.org/html/draft-sun-i2apm-address-pool-management-arch>
    expired
    draft-sun-i2apm-address-pool-management-yang
    <http://tools.ietf.org/html/draft-sun-i2apm-address-pool-management-yang>
    expired

Regards, Benoit
> BUT  I didn't find any major difference between CASM and the old 
> drafts, major use cases of centralized address management has been 
> considered in the old PS draft 
> (https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management/), 
> including the DNS and NAT. CT put forward the use case of address 
> management in metro network,  Ian and norman of DT raised the case of 
> address management for OpenStack, OSS,etc.
>
> ------------------------------------------------------------------------
>     *From:* Rakesh Kumar <mailto:[email-masked]>
>     *Date:* 2017-02-03 14:37
>     *To:* Liushucheng (Will) <mailto:[email-masked]>; Marc
>     Blanchet <mailto:[email-masked]>; Xie Chongfeng
>     <mailto:[email-masked]>
>     *CC:* [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Casm] New Version Notification for
>     The draft we wrote was based on the slide set we had presented
>     earlier, that details a comprehensive approach to address
>     management including with other address services such as DNS and
>     NAT. We have also introduced the concept of interfaces based on
>     user requirements.
>     On 2/2/17, 10:26 PM, "CASM on behalf of Liushucheng (Will)"
>     <[email-masked] on behalf of [email-masked]> wrote:
>         Hi Rakesh,
>         Subject: Re: [Casm] New Version Notification for

---

From: "Xie Chongfeng" <[email-masked]>
Date: Wed, 15 Feb 2017 09:27:08 +0800

Hi, Benoit, 

Thank you for your notififying me. we are updating the 3 drafts and will submit them soon.

Best regards
Chongfeng 

From: Benoit Claise
Date: 2017-02-14 23:50
To: Xie Chongfeng; Rakesh Kumar; 'Liushucheng (Will)'; [email-masked]
CC: ian.farrer; normen.kowalewski; [email-masked]
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt
Chongfeng,

For my understanding...
So the plan is to stop working on these three drafts in OPSAWG?
draft-xi-ps-centralized-address-management      expired
draft-sun-i2apm-address-pool-management-arch  expired 
draft-sun-i2apm-address-pool-management-yang   expired 
Regards, Benoit
Yes, I agree to  combine all ideas into one set of drafts to push forward this work. 

Chongfeng   

From: Rakesh Kumar
Date: 2017-02-03 14:37

 
 
Thanks
Rakesh

    Hi Rakesh,

    

    Regards,
    Will (LIU Shucheng)

    -----Original Message-----
    From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
    Sent: Monday, January 30, 2017 9:02 PM
    To: Rakesh Kumar <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

    
    
    Marc.

---

From: Benoit Claise <[email-masked]>
Date: Wed, 15 Feb 2017 14:29:08 +0100

> Thank you for your notififying me. we are updating the 3 drafts and 
Does it mean that you consider those 3 drafts as potential outcomes for 
CASM?
If yes, here is a question I asked to the mailing list:

    If the solution is this YANG module, based on
    draft-sun-i2apm-address-pool-management-arch, should we jump
    directly to the solution? In other words, what is the BoF added
    value? Note: I thought that those two drafts received some (mild)
    support in OPSAWG already in IETF 94.

Or maybe the 3 drafts are not complete. So what's missing?

Trying to understand.

Regards, Benoit
>     *From:* Benoit Claise <mailto:[email-masked]>
>     *Date:* 2017-02-14 23:50
>     *To:* Xie Chongfeng <mailto:[email-masked]>; Rakesh
>     Kumar <mailto:[email-masked]>; 'Liushucheng (Will)'
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
>     *CC:* ian.farrer <mailto:[email-masked]>; normen.kowalewski
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
>>     drafts, major use cases of centralized address management has
>>     been considered in the old PS draft
>>     management in metro network,  Ian and norman of DT raised the
>>     case of address management for OpenStack, OSS,etc.
>>
>>         *To:* Liushucheng (Will) <mailto:[email-masked]>;
>>         Marc Blanchet <mailto:[email-masked]>; Xie
>>         Chongfeng <mailto:[email-masked]>
>>         The draft we wrote was based on the slide set we had
>>         presented earlier, that details a comprehensive approach to
>>         address management including with other address services such
>>         as DNS and NAT. We have also introduced the concept of
>>         interfaces based on user requirements.
>>             No worries. Let's review and update in next version. And
>>         maybe another online meeting in next week.
>>             Would you please let the audience know about the
>>         differences between new ones and old ones?
>>             Regards,
>>             Will (LIU Shucheng)

---

From: Ralph Droms <[email-masked]>
Date: Wed, 15 Feb 2017 10:12:38 -0500

> On Feb 15, 2017, at 8:29 AM, Benoit Claise <[email-masked]> wrote:
> 
> Does it mean that you consider those 3 drafts as potential outcomes for CASM?
> If the solution is this YANG module, based on draft-sun-i2apm-address-pool-management-arch, should we jump directly to the solution? In other words, what is the BoF added value? Note: I thought that those two drafts received some (mild) support in OPSAWG already in IETF 94.

Benoit - what do you mean by "jump directly to the solution"?  Go directly to WG formation?

- Ralph

---

From: Benoit Claise <[email-masked]>
Date: Wed, 15 Feb 2017 16:50:53 +0100

> Benoit - what do you mean by "jump directly to the solution"?  Go directly to WG formation?
No. I meant progressing draft-sun-i2apm-address-pool-management-yang

Quoting Chongfeng Xie (China Telecom):

    Since the requirements are pressing to CT, we
    begun the filed trial last year and 3 vendors have implementated the interface defined
    in draft-sun-i2apm-address-pool-management-yang, luckily they all passed the field test by our joint efforts.

It seems that some operators know what they want already.

Regards, Benoit
> .