Subject: Re: [Casm] I-D Action: draft-kumar-casm-requirements-and-framework-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 8 Feb 2017 16:40:31 +1300

Hi,

> This document describes evolution of IPAM into a
> standardized interfaces for centralized management of IP addresses.

> CASM:   Centralized Address Space Management

Please delete 'centralized'. It isn't necessary (as mentioned in my
previous message) and it has the effect of limiting the range of
solutions that can be considered. I will consider the document as
if this word does not appear...

And in fact I like the draft. I simply observe that this part of the model:

        +---+------------+-------+-------+---------------+------+
        |    Address Space Management (IPAM) System             |
        |      +-----------+ +----------+ +--------+            |
        |      | Pool      | |Address   | |Database|            |
        |      | Management| |Management| |        |            |
        |      +-----------+ +----------+ +--------+            |
        |                                                       |
        +-------------------------+-----------------------------+

*does not need to be centralized* except for two points: providing
the initial pool to the distributed system, and providing policy
intent to the distributed system.

And there's a draft describing a distributed solution, for a subset
of the problem space:
https://tools.ietf.org/html/draft-ietf-anima-prefix-management-02
I understand that it's too soon for this list to discuss solutions,
but I really do want the distributed approach to be on the table, since
this is one of the early use cases for the Anima WG.

Regards
   Brian Carpenter

---

From: Rakesh Kumar <[email-masked]>
Date: Wed, 8 Feb 2017 04:46:25 +0000

Hi Brian,

Thanks a lot for review and comments.
I apologize for missing your previous message (not sure if I saw it). Anyway, we had some private discussions before this email alias was created, some folks wanted to keep the word “centralized” to emphasize that a central entity should be responsible for managing network addresses. One of the benefit is single pane of glass that can be used for other use cases such as tracking a device/user through the network in real-time. 

But after seeing your comments, I am beginning to think that may be not all aspects of address management need to be centralized. If we were to develop an address management service, what can/should/must be centralized and what should be left up to implementations. I think it should be a good topic for debates and discussions and then decide how to address this in the draft.

I would really appreciate your help in driving this draft.

Thanks 
Rakesh
On 2/7/17, 7:40 PM, "CASM on behalf of Brian E Carpenter" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    

    

    Regards
       Brian Carpenter
    
    _______________________________________________
    CASM mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/casm

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 8 Feb 2017 18:00:47 +1300

On 08/02/2017 17:46, Rakesh Kumar wrote:> Hi Brian,
> I apologize for missing your previous message (not sure if I saw it)

It was just a few minutes before:

https://mailarchive.ietf.org/arch/msg/casm/XqeWMDlbcSWev8ZsWr2Ji6L9-SE

Regards
   Brian

---

From: joel jaeggli <[email-masked]>
Date: Tue, 7 Feb 2017 21:02:02 -0800

> if this word does not appear...

Coordinated if you like.

---

From: Rakesh Kumar <[email-masked]>
Date: Wed, 8 Feb 2017 05:08:04 +0000

Aha! Looks like your first comment went to my “Clutter” folder.

I see your comments now.

Do you want to help us drive this draft?

Thanks
Rakesh

On 2/7/17, 9:00 PM, "Brian E Carpenter" <[email-masked]> wrote:

    
    
    Regards
       Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 9 Feb 2017 08:22:08 +1300

> Do you want to help us drive this draft?

My time is limited, but I do intend to follow this work.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 9 Feb 2017 08:24:21 +1300

Joel,

"Coordinated" is perfect. It is essential, and it allows for both
centralized and distributed solutions.

    Brian