Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

From: Rakesh Kumar <[email-masked]>
Date: Sun, 5 Feb 2017 22:02:56 +0000

Hi Dr Xie, Will

We put two drafts based on earlier discussions.

1.       https://tools.ietf.org/html/draft-kumar-casm-problem-and-use-cases-00 : Basically draft identifies the traditional  IP address management tools (proprietary and open source) and what they lack. I think, almost every network deployment would need some sort of address management so talked about use-cases not from deployment but from implementation perspective. Basically approach taken in this draft regarding problem and use-cases is a bit different than https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management.

2.       https://tools.ietf.org/html/draft-kumar-casm-requirements-and-framework-00 : We have listed a set of requirement from a modern address management system that can be used for diverse set of deployments (Data Center, Metro Access, BNG, 3GPP, Enterprise branch & campus etc.). We have also specified an architecture framework to define and develop “CASM”.

In summary, at top level this work looks similar to the earlier one but there are differences in approaches.

Thanks & Regards,
Rakesh

From: Xie Chongfeng <[email-masked]>
Date: Saturday, February 4, 2017 at 6:35 PM
To: Rakesh Kumar <[email-masked]>, "'Liushucheng (Will)'" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "ian.farrer" <[email-masked]>, "normen.kowalewski" <[email-masked]>
Subject: Re: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

Yes, I agree to  combine all ideas into one set of drafts to push forward this work.

BUT  I didn't find any major difference between CASM and the old drafts, major use cases of centralized address management has been considered in the old PS draft (https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management/), including the DNS and NAT. CT put forward the use case of address management in metro network,  Ian and norman of DT raised the case of address management for OpenStack, OSS,etc.

So, I think it is necessary to clarify the relationship of these drafts. Thank you!

Chongfeng

________________________________
[email-masked]

From: Rakesh Kumar<mailto:[email-masked]>
Date: 2017-02-03 14:37
To: Liushucheng (Will)<mailto:[email-masked]>; Marc Blanchet<mailto:[email-masked]>; Xie Chongfeng<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt
Hi Will,

The draft we wrote was based on the slide set we had presented earlier, that details a comprehensive approach to address management including with other address services such as DNS and NAT. We have also introduced the concept of interfaces based on user requirements.

I think, it would be good idea to combine all ideas into one set of drafts.

I think, CASM would also be useful for mining data for security related analytics.

Thanks
Rakesh

On 2/2/17, 10:26 PM, "CASM on behalf of Liushucheng (Will)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Rakesh,

    Many thanks for your efforts!

    No worries. Let's review and update in next version. And maybe another online meeting in next week.

    Btw, there are also some old work on this area as we discussed:
    https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management/
    https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-arch/
    https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang/

    Would you please let the audience know about the differences between new ones and old ones?

    Regards,
    Will (LIU Shucheng)

    -----Original Message-----
    From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
    Sent: Monday, January 30, 2017 9:02 PM
    To: Rakesh Kumar <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

    On 30 Jan 2017, at 1:43, Rakesh Kumar wrote:

    > It looks like we messed up on the name. My mistake.
    >
    > It should have been
    > “draft-kumar-casm-requirements-and-framework-00” instead of
    > “draft-kumar-requirements-and-framework-00”.
    > Is there a way to correct it?

    yeah. no big deal. we shall fix it for the new rev.

    Marc.

    >
    > Thanks
    > Rakesh
    >
    > On 1/29/17, 8:03 PM, "CASM on behalf of Rakesh Kumar"
    > <[email-masked] on behalf of [email-masked]> wrote:
    >
    >
    >
    >     On 1/29/17, 7:53 PM, "[email-masked]"
    > <[email-masked]> wrote:
    >
    >
    >         A new version of I-D,
    > draft-kumar-requirements-and-framework-00.txt
    >         has been successfully submitted by Marc Blanchet and posted to
    > the
    >         IETF repository.
    >
    >         Name: draft-kumar-requirements-and-framework
    >         Revision: 00
    >         Title: Centralized Address Space Management(CASM)
    > Requirements and Framework
    >         Document date: 2017-01-29
    >         Group: Individual Submission
    >         Pages: 8
    >         URL:
    > https://www.ietf.org/internet-drafts/draft-kumar-requirements-and-framework-00.txt
    >         Status:
    > https://datatracker.ietf.org/doc/draft-kumar-requirements-and-framework/
    >         Htmlized:
    > https://tools.ietf.org/html/draft-kumar-requirements-and-framework-00
    >
    >
    >         Abstract:
    >            The organizations use IP Address Space Management (IPAM)
    > tools to
    >            manage their IP address space, often with proprietary
    > database and
    >            interfaces.  This document describes evolution of IPAM into
    > a
    >            standardized interfaces for centralized management of IP
    > addresses.
    >
    >
    >
    >
    >         Please note that it may take a couple of minutes from the time
    > of submission
    >         until the htmlized version and diff are available at
    > tools.ietf.org.
    >
    >         The IETF Secretariat
    >
    >
    >
    >     _______________________________________________
    >     CASM mailing list
    >     [email-masked]
    >     https://www.ietf.org/mailman/listinfo/casm
    >
    >
    > _______________________________________________
    > CASM mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/casm

    _______________________________________________
    CASM mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/casm
    _______________________________________________
    CASM mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/casm

---

From: "Xie Chongfeng" <[email-masked]>
Date: Wed, 8 Feb 2017 21:51:59 +0800

One of the basic requirments of centralized address management is that the mechanism shouled be aligned with the routing system, for instance, when one address block is allocated to an network equiment, the routing entry correspondent to this address block will be broadcasted accordingly, otherwise, the network will not work correctly.  Similarly,when one address block is withdrawl from an given network equipment, the routing entry will be withdrawl as well.  

Chongfeng Xie  

From: Rakesh Kumar
Date: 2017-02-06 06:02
To: Xie Chongfeng; 'Liushucheng (Will)'; [email-masked]
CC: [email-masked]; ian.farrer; normen.kowalewski; Rakesh Kumar
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt
Hi Dr Xie, Will

 
 
Thanks & Regards,
Rakesh

 

Chongfeng   

From: Rakesh Kumar
Date: 2017-02-03 14:37
To: Liushucheng (Will); Marc Blanchet; Xie Chongfeng
CC: [email-masked]
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt
Hi Will,

 
 
Thanks
Rakesh

    Hi Rakesh,

    

    Regards,
    Will (LIU Shucheng)

    -----Original Message-----
    From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
    Sent: Monday, January 30, 2017 9:02 PM
    To: Rakesh Kumar <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

    
    
    Marc.

---

From: "Marc Blanchet" <[email-masked]>
Date: Wed, 08 Feb 2017 08:54:56 -0500

On 8 Feb 2017, at 8:51, Xie Chongfeng wrote:

> One of the basic requirments of centralized address management is that 
> the mechanism shouled be aligned with the routing system, for 
> instance, when one address block is allocated to an network equiment, 
> the routing entry correspondent to this address block will be 
> broadcasted accordingly, otherwise, the network will not work 
> correctly.

well, yes. but that route injection can be done by the network equipment 
into the routing realm. So in this case, the route injection is not 
centralized per se.

Marc.

> Similarly,when one address block is withdrawl from an given network 
> equipment, the routing entry will be withdrawl as well.
>
> Chongfeng Xie
>
>
>
> Subject: Re: [Casm] New Version Notification for 
> 1.       
> https://tools.ietf.org/html/draft-kumar-casm-problem-and-use-cases-00 
> : Basically draft identifies the traditional  IP address management 
> tools (proprietary and open source) and what they lack. I think, 
> almost every network deployment would need some sort of address 
> management so talked about use-cases not from deployment but from 
> implementation perspective. Basically approach taken in this draft 
> regarding problem and use-cases is a bit different than 
> https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management.
> 2.       
> https://tools.ietf.org/html/draft-kumar-casm-requirements-and-framework-00 
> : We have listed a set of requirement from a modern address management 
> system that can be used for diverse set of deployments (Data Center, 
> Metro Access, BNG, 3GPP, Enterprise branch & campus etc.). We have 
> also specified an architecture framework to define and develop 
> “CASM”.
>
> To: Rakesh Kumar <[email-masked]>, "'Liushucheng (Will)'" 
> <[email-masked]>, "[email-masked]" 
> <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "ian.farrer" 
> <[email-masked]>, "normen.kowalewski" 
> <[email-masked]>
> Subject: Re: Re: [Casm] New Version Notification for 
> BUT  I didn't find any major difference between CASM and the old 
> drafts, major use cases of centralized address management has been 
> considered in the old PS draft 
> (https://datatracker.ietf.org/doc/draft-xie-ps-centralized-address-management/), 
> including the DNS and NAT. CT put forward the use case of address 
> management in metro network,  Ian and norman of DT raised the case of 
> address management for OpenStack, OSS,etc.
>
> Subject: Re: [Casm] New Version Notification for 
> The draft we wrote was based on the slide set we had presented 
> earlier, that details a comprehensive approach to address management 
> including with other address services such as DNS and NAT. We have 
> also introduced the concept of interfaces based on user requirements.
>
> On 2/2/17, 10:26 PM, "CASM on behalf of Liushucheng (Will)" 
> <[email-masked] on behalf of [email-masked]> wrote:
>
>     Hi Rakesh,
>
>     Subject: Re: [Casm] New Version Notification for

---

From: "Xie Chongfeng" <[email-masked]>
Date: Wed, 8 Feb 2017 21:59:54 +0800

From our experience, the centralized address management system need to verify this by communicating with the routing system, to avoid any abnormity.
Chongfeng 

From: Marc Blanchet
Date: 2017-02-08 21:54
To: Xie Chongfeng
CC: Rakesh Kumar; Liushucheng; [email-masked]; ian.farrer; [email-masked]
Subject: Re: [Casm] New Version Notification for draft-kumar-requirements-and-framework-00.txt

 
Marc.

---

From: "Marc Blanchet" <[email-masked]>
Date: Wed, 08 Feb 2017 09:09:42 -0500

On 8 Feb 2017, at 8:59, Xie Chongfeng wrote:

> From our experience, the centralized address management system need to 
> verify this by communicating with the routing system, to avoid any 
> abnormity.

sure. I’m just trying to say that route injection does not have to be 
centralized. up to the operator.

Marc.

>>     >            standardized interfaces for centralized management 
>> of
>> IP
>>     > addresses.
>>     >
>>     >
>>     >
>>     >

---

From: Rakesh Kumar <[email-masked]>
Date: Wed, 8 Feb 2017 16:01:49 +0000

HI Marc, Dr Xie,

I find these last few email exchanges a bit confusing. 
Are we discussing centralization because of Brian’s earlier comment about removing “centralized”?

To me, as long as there is accurate information related to address space in one place (central repository), it does not matter how all the parts of “address management system” work.  

I would like someone to propose what a distributed/hybrid approach look like for address management. I mean an architectural framework so that we can understand and debate it. 

Thanks
Rakesh

On 2/8/17, 6:09 AM, "Marc Blanchet" <[email-masked]> wrote:

    
    
    Marc.

---

From: "Marc Blanchet" <[email-masked]>
Date: Wed, 08 Feb 2017 11:07:00 -0500

On 8 Feb 2017, at 11:01, Rakesh Kumar wrote:

> To me, as long as there is accurate information related to address 
> space in one place (central repository), it does not matter how all 
> the parts of “address management system” work.

right. indirectly, you are saying the same thing as I tried to say. 
Route injection may happen at various places, various policies.

Marc.

>
> I would like someone to propose what a distributed/hybrid approach 
> look like for address management. I mean an architectural framework so 
> that we can understand and debate it.

>     >> One of the basic requirments of centralized address management 
> is
>     >> that
>     >> In summary, at top level this work looks similar to the earlier 
> one
>     >> but there are differences in approaches.
>     >>
>     >> Thanks & Regards,
>     >> Rakesh
>     >>
>     >> Yes, I agree to  combine all ideas into one set of drafts to 
> push
>     >> forward this work.
>     >>
>     >> So, I think it is necessary to clarify the relationship of 
> these
>     >> drafts. Thank you!
>     >>
>     >> Chongfeng
>     >>
>     >>
>     >>
>     >> I think, it would be good idea to combine all ideas into one 
> set of
>     >> drafts.
>     >>
>     >>     No worries. Let's review and update in next version. And 
> maybe
>     >> another online meeting in next week.
>     >>
>     >>     Would you please let the audience know about the 
> differences
>     >> between new ones and old ones?
>     >>
>     >>     Regards,
>     >>     Will (LIU Shucheng)
>     >>
>     >>
>     >>     >         has been successfully submitted by Marc Blanchet 
> and
>     >> posted to
>     >>     > the
>     >>     >         IETF repository.
>     >>     >
>     >>     >            The organizations use IP Address Space 
> Management
>     >> (IPAM)
>     >>     > tools to
>     >>     >            interfaces.  This document describes evolution 
> of
>     >> IPAM into
>     >>     > a
>     >>     >         Please note that it may take a couple of minutes 
> from
>     >> the time
>     >>     > of submission

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 9 Feb 2017 08:37:32 +1300

> One of the basic requirments of centralized address management is that the mechanism shouled be aligned with the routing system, for instance, when one address block is allocated to an network equi…

That is correct, but it doesn't need to be centralised. The route(s) to a
prefix are announced by the router(s) that handle that prefix, in every routing
protocol that I know. So that is intrinsically distributed. If prefix assignment
decisions are centralized or distributed, that doesn't change anything for
the router. Somebody gives it a prefix, that's all it cares about.

You can look at Homenet (RFC7788 and RFC7695) for a fully distributed model
of assignment. That probably doesn't meet the CASM requirements because it's
designed for operator-free networks. The Anima work is directed at enterprise
networks with a NOC.

    Brian