Subject: Re: [Casm] Possible charter goals and milestones

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Wed, 1 Mar 2017 09:02:34 +0000

Hi Benoit,

Thanks for reply. This is a good question to help the group make the goal clearer. Chongfeng and Rakesh, please correct me if I misunderstood:

1.      From the discussion on the list, we can see that Chongfeng answered this by referring to the data model draft.

2.      However, the framework figure in Rakesh’s draft show a more broader scope including APIs.

3.      Protocol? So far no new protocol or extensions have been raised. Or at least this is my understanding. ☺
To get aligned we will discuss this topic at the upcoming online meeting.

Regards,
Will (Shucheng LIU)

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, March 01, 2017 4:54 AM
To: Liushucheng (Will Liu) <[email-masked]>; [email-masked]
Cc: 'Ying Cheng' <[email-masked]>; 'Xie Chongfeng' <[email-masked]>; 'Rakesh Kumar' <[email-masked]>; [email-masked]; Marc Blanchet <[email-masked]>; [email-masked]
Subject: Re: [Casm] Possible charter goals and milestones

On 2/16/2017 3:45 PM, Liushucheng (Will) wrote:
Hi Benoit,

Please see below inline.

From: Benoit Claise [mailto:[email-masked]]
Sent: Wednesday, February 15, 2017 9:25 PM
To: Liushucheng (Will); [email-masked]<mailto:[email-masked]>
Cc: 'Ying Cheng'; 'Xie Chongfeng'; 'Rakesh Kumar'; [email-masked]<mailto:[email-masked]>; Marc Blanchet; [email-masked]<mailto:[email-masked]>
Subject: Re: [Casm] Possible charter goals and milestones

Hi Liushucheng,
Hi Benoit and all,

Thanks for your guidance. After offline discussions among all the proponents, we changed the BoF to non-WG forming in the wiki.  https://trac.tools.ietf.org/bof/trac/

We also added the purpose of the BoF in the description:
The purpose of the BoF is to gather a common set of requirements from a larger set of operators and, if needed, possible protocol work milestones and scope.
Protocol work?  Which protocol?  Can you expand on what is needed?
I thought the work was about interfaces.
[Will] Thanks for the comments. As answered by Rakesh and Chongfeng, currently only interfaces are considered.
OK, to make sure we speak the same language, what do you call an interface in this context?
    - A protocol between A and B (with some negotiation, for example)?
    - A data model?  https://datatracker.ietf.org/doc/draft-sun-i2apm-address-pool-management-yang/ has been mentioned
    - An API?
    - etc.

Regards, Benoit

Cheers,
Will (Shucheng LIU)

---

From: "Xie Chongfeng" <[email-masked]>
Date: Thu, 2 Mar 2017 07:28:13 +0800

I think that the interaction between address management entity and network element needs to be defined, it is a kind of protocol, if my understanding is right.

Chongfeng Xie

[email-masked]
 
From: Liushucheng (Will Liu)
Date: 2017-03-01 17:02
To: Benoit Claise; [email-masked]; Xie Chongfeng; Rakesh Kumar
CC: 'Ying Cheng'; [email-masked]; Marc Blanchet; [email-masked]
Subject: RE: [Casm] Possible charter goals and milestones
Hi Benoit,
 
3.      Protocol? So far no new protocol or extensions have been raised. Or at least this is my understanding. J
 
Regards,
Will (Shucheng LIU)

 
Please see below inline.
 
From: Benoit Claise [mailto:[email-masked]] 
Sent: Wednesday, February 15, 2017 9:25 PM
To: Liushucheng (Will); [email-masked]
Cc: 'Ying Cheng'; 'Xie Chongfeng'; 'Rakesh Kumar'; [email-masked]; Marc Blanchet; [email-masked]
Subject: Re: [Casm] Possible charter goals and milestones
 
Hi Liushucheng,
Hi Benoit and all,

Regards, Benoit

Cheers,
Will (Shucheng LIU)

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 2 Mar 2017 13:41:25 +1300

> I think that the interaction between address management entity and network element needs to be defined, it is a kind of protocol, if my understanding is right.

That's exactly where the Anima solution could be applied, if you want something
that is automatic and has more distributed intelligence than CLI or Netconf.

    Brian

> _______________________________________________
> CASM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/casm
>