Subject: Re: [Casm] slides for CASM bof

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Sun, 26 Mar 2017 21:40:38 +0000

Hi Rakesh,

(Copying the list.)

Thanks for the slides and explanation. I think it’s now much clearer. I reviewed them and here are my comments:

l  Page 3, suggest to add “Lack of common set of standard interfaces across IPAM system vendors” and “Lack of integration with DHCP server to get address records”

l  Page 6, suggest to add “Aggregated view, Dynamic allocation and reclaiming , Generic address assignment policies” and “Address pools: Unicast(Private/Public v4 addresses, v6 addresses), Multicast”

l  What do you mean “DNS mapping” on page 6?

l  Page 7, suggest to replace “ADDRESS SPACE MANAGEMENT (IPAM) SYSTEM” to “Coordinated Address Space Management System (CASM) ”, please see the architecture slides I sent.

l  Page 7 , what does “SDN/Legacy ” mean here? Does “SDN” in the architecture draft means SDN controller? Is the SDN controller place beside, up or down to the CASM System？

l  Would you please provide a use case for SDN scenario?

Cheers,
Will (Shucheng LIU)

From: Rakesh Kumar [mailto:[email-masked]]
Sent: Friday, March 24, 2017 12:46 AM
To: Liushucheng (Will Liu); Marc Blanchet; Ralph Droms; Fioccola Giuseppe; 'ian.farrer'; 'BOUCADAIR Mohamed IMT/OLN'; Benoit Claise; Georgios Karagiannis; John Strassner; [email-masked]; 'Luis M. Contreras'; Jun Bi
Cc: [email-masked]; 解冲锋; 'chengying10'; [email-masked]; [email-masked]; Xuweiping (David); Pengtao (Tony); Rakesh Kumar
Subject: Re: slides for CASM bof

Hi Will,

After looking at the attached slides and the one I created earlier (attached here for everyone’s reference). I see one difference and that may help us in converging our thought process. Please look at slide#7 from the attached deck. Here is my take on it:

1.       I look at “CASM” as means to solve a common problem of address management for multiple use-case (although not shown in the slide 7).

2.       I look at “CASM” users not from use-case perspective such as BNG but rather from the perspective of implementation aspects. The most common users from my perspective would be

a.       In a virtualized DC, SDN controller need to assign IP addresses to workloads and virtual networks

b.       In a legacy data center (built with physical elements) proprietary tools/script to assign IP addresses to servers and network and firewall elements

c.       OSS/BBS to initialize/allocate/divide address poos

d.       Admin to allocate IP addresses if for some reason there is need to reserve addresses (may be, someone want to assign static address in an old fashion manner)

3.       Of course, we could draw/put another layer at top that shows BNG/3GPP/etc. But I did not put it intentionally since our CASM architecture does not stop any end use-case/market segment from using it.  After all, we all agree that this is the most common thing to solve wherever networks and a requirement for addressing scheme exist.

I hope, I am able to explain my thoughts behind the proposal and slide deck and the draft we had presented.

Thanks
Rakesh

From: "Liushucheng (Will Liu)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 23, 2017 at 3:07 AM
To: Marc Blanchet <[email-masked]<mailto:[email-masked]>>, Ralph Droms <[email-masked]<mailto:[email-masked]>>, Rakesh Kumar <[email-masked]<mailto:[email-masked]>>, Fioccola Giuseppe <[email-masked]<mailto:[email-masked]>>, "'ian.farrer'" <[email-masked]<mailto:[email-masked]>>, 'BOUCADAIR Mohamed IMT/OLN' <[email-masked]<mailto:[email-masked]>>, Benoit Claise <[email-masked]<mailto:[email-masked]>>, Georgios Karagiannis <[email-masked]<mailto:[email-masked]>>, John Strassner <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "'Luis M. Contreras'" <[email-masked]<mailto:[email-masked]>>, Jun Bi <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, 解冲锋 <[email-masked]<mailto:[email-masked]>>, 'chengying10' <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Xuweiping (David)" <[email-masked]<mailto:[email-masked]>>, "Pengtao (Tony)" <[email-masked]<mailto:[email-masked]>>
Subject: slides for CASM bof

Dear all,

After an online meeting today among proponents, we updated the preliminary version slides according to the CASM preparation online meeting yesterday. We’re sending them for wider discussion. The slides tried to cover and merge all the CASM documents,  for the bof to use. There are still some updating work to do before our f2f preparation meeting. Please help to review and let us know your thought.

(Please DON’T FORGET TO FILL THE DOODLE Marc sent http://doodle.com/poll/mqnsisi6zfyz35p2, note that you need to choose the time zone of Chicago, which is central time of US.)

Dear Rakesh, There are still some missing part and we’ve marked them with red color in the slides. Please help.

Regards,
Will (Shucheng LIU)
----------------------------------------------------------------------------------------------
Shucheng LIU (刘树成Will), Ph.D.
Senior Researcher & Standard Representative, Project Manager
Huawei Technologies Co.,Ltd
[email-masked]<mailto:[email-masked]>
http://www.linkedin.com/in/shucheng
----------------------------------------------------------------------------------------------

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Sun, 26 Mar 2017 22:06:11 +0000

Hi Rakesh,

Besides comments for your slides, here are my comments to your email below. Please see below in-line with [Will]

Cheers,
Will (Shucheng LIU)

Hi Will,

1.      I look at “CASM” as means to solve a common problem of address management for multiple use-case (although not shown in the slide 7).
[Will]: In the latest slides of Use case, we’re trying to put them into these category. Please let us know your thought.
•   Address pools configuration on BNGs / IPv6 transition devices
– DHCP server pool
– Static address configuration
•   Address configuration API of IPAM
•   NAT & CGN
– Public IP address pool
•   SDN scenarios
•   Others

2.      I look at “CASM” users not from use-case perspective such as BNG but rather from the perspective of implementation aspects. The most common users from my perspective would be
[Will]: I understand your different way of dividing use cases now. However, in IETF, we usually put use cases in categories according to “use-case perspective”, right? So please see whether the above covered your thought.

a.      In a virtualized DC, SDN controller need to assign IP addresses to workloads and virtual networks
[Will]: I agree. Would you provide a more detailed use case to put into use case slides?

b.      In a legacy data center (built with physical elements) proprietary tools/script to assign IP addresses to servers and network and firewall elements
[Will]: Is your “legacy” in arch figure referring to legacy data center? If not, then It’s not clear to me whether it’s NBI or SBI. Would you provide a figure with workflow?

c.      OSS/BBS to initialize/allocate/divide address poos
[Will] : This is the NBI to OSS/BSS, however, the current OSS/BSS may not support this?

d.      Admin to allocate IP addresses if for some reason there is need to reserve addresses (may be, someone want to assign static address in an old fashion manner)
[Will]: Not sure whether this scenario is practical? Is there any requirement for this from Operators/Campas?

I hope, I am able to explain my thoughts behind the proposal and slide deck and the draft we had presented.
[Will] Yes. Much clearer. Only some clarifying question above.

Regards,
Will