Subject: [Casm] minutes of CASM meeting on March 22

From: "Pengtao (Tony)" <[email-masked]>
Date: Thu, 23 Mar 2017 02:18:45 +0000

Hi all,

Please find the minutes of yesterday’s WebEx meeting below.

Regards,

彭韬
Tao PENG (Tony), Ph.D.
Senior Researcher
Huawei Technologies Co.,Ltd
[email-masked]<mailto:[email-masked]>
www.linkedin.com/in/tao-peng

Minutes CASM 2017/3/22
Host: Marc Blanchet
Attendees:
Agustin Formoso
Benoit Claise
Telecom Italia: Giuseppe Fioccola
ZDNS: Declan Ma
China Telecom:  Chen Li, Chongfeng Xie
China Unicom: Ying Cheng
Huawei: (David) Weiping XU, Will Liu, (Tony)

Marc: it is not yet clear about the scope and deliverables.

Li explained the draft “casm-pool-management-arch” - address management procedure and showed slides to explain the architecture.

Marc: Architecture in Figure 1 seems from Rakesh, which is broader. We need to get things converged.

Benoit: what you explained seems to be a subset.

Ma: you may also consider the RPKI system (Resource Public Key Infrastructure). After the prefixes are allocated, certificates need to be generated. This should connect with IPAM.

Benoit: what are the building blocks that you touch in the figure (slide 2)?

Xie: the south bound of ASMS system should be defined and standardized. A portal may be used for address configuration. A north bound interface could be defined.

Benoit: what is the flow among these entities (DHCP message/Yang?).

Xie: if we deploy centralized interface, there is only interaction between BNG and our management server. Currently, there is no management server; the configuration is done on BNG.

Benoit: I see disconnection between requirement and current implementation, which is a subset.

Xie: this architecture can cover several use cases. For example, it can be used on DHCP configuration, IPTV.

Benoit: do these people want to work on the full scope, or the scope is to only have BNG interaction?

Xie: address allocation in the cloud may be considered in the architecture. It is very important; some automatic mechanisms can be used.

Giuseppe: dynamic service creation could be an important use case. The application is crucial.

Liu: I was looking at the draft from Rakesh. Chen Li addressed most of the scenarios in Rakesh’s draft.

Benoit: how the use cases are covered by your draft? What is the current interaction flow from operator to network elements (BNG/DHCP…)? Do we have meeting agenda?

TODO:
1, identify the details on south/north bound interfaces
2, show how the use cases are covered
3, consider the interaction flow of Address Space Management & Control
4, chairs decide the topics during BoF
5, start a thread to find a timeslot for a meeting on Sunday for better preparation

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 23 Mar 2017 17:44:44 -0000

Tony,
Thanks for this write-up.
Very helpful for those of us unable to be on the call.
Adrian
 
From: CASM [mailto:[email-masked]] On Behalf Of Pengtao (Tony)
Sent: 23 March 2017 02:19
To: [email-masked]
Subject: [Casm] minutes of CASM meeting on March 22
 
Hi all,

Regards,
 
彭韬
Tao PENG (Tony), Ph.D.
Senior Researcher
[email-masked]

Li explained the draft “casm-pool-management-arch” - address management
procedure and showed slides to explain the architecture.
 
Marc: Architecture in Figure 1 seems from Rakesh, which is broader. We need to
get things converged.

Ma: you may also consider the RPKI system (Resource Public Key Infrastructure).
After the prefixes are allocated, certificates need to be generated. This should
connect with IPAM.

Xie: the south bound of ASMS system should be defined and standardized. A portal
may be used for address configuration. A north bound interface could be defined.

Xie: if we deploy centralized interface, there is only interaction between BNG
and our management server. Currently, there is no management server; the
configuration is done on BNG.
 
Benoit: I see disconnection between requirement and current implementation,
which is a subset. 
 
Xie: this architecture can cover several use cases. For example, it can be used
on DHCP configuration, IPTV.
 
Benoit: do these people want to work on the full scope, or the scope is to only
have BNG interaction?
 
Xie: address allocation in the cloud may be considered in the architecture. It
is very important; some automatic mechanisms can be used.
 
Giuseppe: dynamic service creation could be an important use case. The
application is crucial.
 
Liu: I was looking at the draft from Rakesh. Chen Li addressed most of the
scenarios in Rakesh’s draft.
 
Benoit: how the use cases are covered by your draft? What is the current
interaction flow from operator to network elements (BNG/DHCP…)? Do we have
meeting agenda?
 
TODO:
5, start a thread to find a timeslot for a meeting on Sunday for better
preparation