Subject: [Casm] casm proposed charter v20170807

From: "Marc Blanchet" <[email-masked]>
Date: Mon, 07 Aug 2017 13:44:38 -0400

Hello,
  following our informal meeting during last IETF, I took the token to 
start writing a charter for CASM. I know it is not complete, but would 
like to get comments, proposals, suggestions, reviews at this point.

Regards, Marc.

==========

Coordinated Address Space Management (CASM)
Proposed Charter, v20170807

Organizations use IP Address Space Management (IPAM) tools to manage 
their IP address space, often with proprietary database and interfaces. 
This work is to evolve IPAM into standardized interfaces for coordinated 
management of IP addresses, including SDN/NFV networks and other forms 
of virtualization. Use cases include dynamic allocation and release of 
IP addresses and prefixes based on usage and queries to RIR to receive 
the allocated prefixes to the requestor.  The interfaces will be 
specified as Yang models. The scope of the system is within a single 
autonomous system.
Future work, not part of the current charter, could include intent-based 
northbound interfaces and additional interactions with RIR.

Milestones
- Problem Statement and Architecture
- Yang model for IP prefix management
- Yang model for RIR Internet Number Resource requests

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 12 Aug 2017 09:59:51 +0800

Hi, Marc,

Thank you! I think the charter for CASM  you proposed is ok , and we will modify our drafts about the Architecture and YANG models of interfaces, and then we could have a discussion about them.

Best Regards

Chen Li

李  晨  Li Chen
中国电信北京研究院 网络技术与规划部 网络演进与规划中心
电话：010-50902891/18910853955
邮箱：[email-masked]
只为成功找方法，不为失败找借口
==============================
Chen  Li
Network Evolution and Planning Center
Network Technology & Planning Department
China Telecom Corporation Limited Beijing Research Institute
Email：[email-masked]
Tel: +86-10-50902891
Mobile: +86-18910853955
 
From: Marc Blanchet
Date: 2017-08-08 01:44
To: casm
Subject: [Casm] casm proposed charter v20170807
Hello,
  following our informal meeting during last IETF, I took the token to 
start writing a charter for CASM. I know it is not complete, but would 
like to get comments, proposals, suggestions, reviews at this point.
 
Regards, Marc.
 
==========

 
Milestones
 
_______________________________________________
CASM mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/casm