Subject: Re: [Casm] casm proposed charter v20170807

From: xiechf <[email-masked]>
Date: Fri, 11 Aug 2017 17:26:31 +0800

Hi, Marc,

I think the charter text you proposed is fine.  I also made some small modifications which is in red as below.

Thank you!

Chongfeng 
  
Coordinated Address Space Management (CASM) Proposed Charter, v20170807

Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. 
This work is to evolve IPAM into standardized interfaces for coordinated management of IP addresses, including legacy IP neworks, SDN/NFV networks and other forms of virtualization. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage and queries to RIR to receive the allocated prefixes to the requestor. The interfaces will be specified as Yang models. The scope of the system is within a single autonomous system.

Future work, not part of the current charter, could include intent-based northbound interfaces and additional interactions with RIR.

Milestones
- Problem Statement and Architecture
- Yang model for IP prefix management
- Yang model for RIR Internet Number Resource requests

> 
> -----Original Message-----
> From: CASM [mailto:[email-masked]] On Behalf Of Marc Blanchet
> Sent: Tuesday, August 08, 2017 1:45 AM
> To: casm <[email-masked]>
> Subject: [Casm] casm proposed charter v20170807
> 
> Hello,
>  following our informal meeting during last IETF, I took the token to start writing a charter for CASM. I know it is not complete, but would like to get comments, proposals, suggestions, reviews at this point.
> 
> Regards, Marc.
> 
> ==========
> 
> Coordinated Address Space Management (CASM) Proposed Charter, v20170807
> 
> Organizations use IP Address Space Management (IPAM) tools to manage their IP address space, often with proprietary database and interfaces. 
> This work is to evolve IPAM into standardized interfaces for coordinated management of IP addresses, including SDN/NFV networks and other forms of virtualization. Use cases include dynamic allocation and release of IP addresses and prefixes based on usage and queries to RIR to receive the allocated prefixes to the requestor.  The interfaces will be specified as Yang models. The scope of the system is within a single autonomous system.
> Future work, not part of the current charter, could include intent-based northbound interfaces and additional interactions with RIR.
> 
> Milestones
> - Problem Statement and Architecture
> - Yang model for IP prefix management
> - Yang model for RIR Internet Number Resource requests
> 
> _______________________________________________
> CASM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/casm

---

From: Benoit Claise <[email-masked]>
Date: Fri, 11 Aug 2017 14:55:29 +0200

Dear all,

While it's good to discuss charter text, let's not forget that 
discussing CASM open issues on the mailing list and developing drafts is 
important. Even more important. Feel free to self organize: no need to 
wait for a WG for that.

Regards, Benoit
> Organizations use IP Address Space Management (IPAM) tools to manage 
> their IP address space, often with proprietary database and interfaces.
> This work is to evolve IPAM into standardized interfaces for 
> coordinated management of IP addresses, including legacy IP neworks, 
> SDN/NFV networks and other forms of virtualization. Use cases include 
> dynamic allocation and release of IP addresses and prefixes based on 
> usage and queries to RIR to receive the allocated prefixes to the 
> requestor. The interfaces will be specified as Yang models. The scope 
> of the system is within a single autonomous system.
>
> Future work, not part of the current charter, could include 
> intent-based northbound interfaces and additional interactions with RIR.
>
> Milestones
>> To: casm <[email-masked] <mailto:[email-masked]>>
>>  following our informal meeting during last IETF, I took the token to 
>> start writing a charter for CASM. I know it is not complete, but 
>> would like to get comments, proposals, suggestions, reviews at this 
>> point.
>>
>> Regards, Marc.
>>
>> ==========
>>
>> Organizations use IP Address Space Management (IPAM) tools to manage 
>> their IP address space, often with proprietary database and interfaces.
>> This work is to evolve IPAM into standardized interfaces for 
>> coordinated management of IP addresses, including SDN/NFV networks 
>> and other forms of virtualization. Use cases include dynamic 
>> allocation and release of IP addresses and prefixes based on usage 
>> and queries to RIR to receive the allocated prefixes to the 
>> requestor.  The interfaces will be specified as Yang models. The 
>> scope of the system is within a single autonomous system.
>> Future work, not part of the current charter, could include 
>> intent-based northbound interfaces and additional interactions with RIR.
>>
>> Milestones
>> [email-masked] <mailto:[email-masked]>