Subject: [cin] Aviation Networks

From: Terry Davis <[email-masked]>
Date: Fri, 6 Jul 2012 16:13:27 +0000

All

For some background, today's global air traffic management relies on mostly very narrowband networks that operate from 2 kilobits to 40 kilobits (yes I do mean 40,000 bits per second); a few services run into the low 100's of kilobits..  Messages are formatted and routed between ground infrastructure and aircraft using modified OSI protocols from the early 80's.  And the services have rigorously qualified to provide safety of flight communications.

Every commercial aircraft in service around the globe uses these standards.  Modifications to any parts of the messaging or new message types are required to be completely "non-impacting" to aircraft already in service with equipment that does not support the changes.  Simply it cannot be upgraded.

International air traffic is governed by the International Civil Aviation Organization (ICAO) which is a United Nations organization operating under the Chicago Convention treaty of 1944 and is headquartered in Montreal.  ICAO establishes the standards by which International air transportation is governed.   ICAO governed by the 140+ member nations.

ICAO also provides and manages the addressing using OSI addresses for all digital communications with the aircraft ensuring that each aircraft has a unique designator and address.  And over the past decade we have been slowly beginning to publish new ICAO standards for the newer higher bandwidth communications services that will form the basis for the next generation of global air traffic management networks.  At present the high level definitions to utilize IPv6, IPsec, and PKI have been made.  Implementation guidelines will be developed over the next few years, defining addressing, address allocation processes, routing, certificate usages and formats, network services, etc.  This will definitely be a "critical infrastructure network".

During the short existence of the "Connexion by Boeing" service that provided the initial aircraft passenger Internet service, we discovered that aircraft flying international and long haul flights have a special ability to create problems in Internet routing.  As the aircraft's onboard networks transition of between ground stations during the flight, massive updates of the BGP tables, especially on intercontinental flights.  With just over a 150 aircraft in service, Connexion generated 20% of the churn in the global BGP tables.  And admittedly most all of the churn is due to intercontinental satellite ground station handoffs; not 3G/4G tower transitions.

In 2008, initial meetings were held with representatives from ICAO, ICANN, ARIN, FAA, and Eurocontrol all present.  Discussions left it clear that aircraft internet service, including the new next generation air traffic management networks, could be highly disruptive to the global Internet.  No formal agreements resulted though it was suggested that aviation needed to isolate the Internet from disruptions caused by their global aircraft network movements.

Ideally ICAO could define a "closed/isolated" network architecture that would both make their network operation easier to manage and isolate the Internet from any routing disturbances.

Two problems immediately come up with this path:

-          Current standards don't readily support the concept of closed or isolate networks.

-          And as any of you that operate large networks, especially globally with millions of nodes, know, they are always cross-wired somewhere.  And thus defining a scheme to protect the Internet BGP tables from disruption is going to be very challenging.  And don't forgot, there will not be a single network operator; most of the 140 nations will operate their own part of it.

Today there are more than 20,000 commercial aircraft operating around the globe; that is projected to be near 30,000 in a decade.  At the end of a decade, almost every single one of those 30,000 aircraft will have one or more separate Internet services onboard.

Take care

Terry L Davis, P.E.  |  Chief Scientist |  iJet Onboard
(Formerly: Chief Network Engineer| Connexion by Boeing)
[email-masked]<mailto:[email-masked]>
o. 206.805.6263  c. 425-503-5511
www.ijetonboard.com<http://www.ijetonboard.com/>

PS: I also work with critical infrastructure as well; critical infrastructure network designers are looking for the same type of architectures.

This message and its attachments are the property of iJet Technologies, Inc. and are intended solely for the use of the designated recipient(s) and their appointed delegates. This email may contain information that is confidential. If you are not the intended recipient, you are prohibited from printing, copying, forwarding or saving any portion of the message or attachments. Please delete the message and attachments and notify the sender immediately. Thank you for your cooperation.

---

From: Ronald Bonica <[email-masked]>
Date: Wed, 11 Jul 2012 10:38:38 -0400

Terry,

I am not sure that I agree with your first statement. Why couldn't you build a closed network using OTS gear that implements current IETF standards?  Are there not many examples of such networks (e.g., SIPRNET )?

The second problem is more interesting. The CIN might want to standardize a BGP policy with the following characteristics:

-          Enforces a globally agreed routing policy

-          Does not fail in a catastrophic way when one node/country does something that does not comply with policy
                                                                                            Ron

From: [email-masked] [mailto:[email-masked]] On Behalf Of Terry Davis
Sent: Friday, July 06, 2012 12:13 PM
To: [email-masked]
Subject: [cin] Aviation Networks

---

From: Terry Davis <[email-masked]>
Date: Fri, 13 Jul 2012 21:57:29 +0000

Ron

Keeps in mind that the aviation network will have 140+ designers and operators (each nation-state member) and only high level architectural guidance from ICAO at the top.   SIPRNET is a highly controlled environment and as I recall it still depends on traffic filter access lists on the routers to control entry.?

I think we will have similar problems with a "policy" approach.

Look forward to the discussions in Vancouver.

Take care
Terry

From: Ronald Bonica [mailto:[email-masked]]
Sent: Wednesday, July 11, 2012 7:39 AM
To: Terry Davis; [email-masked]
Subject: RE: Aviation Networks

Terry,

                                                                                            Ron

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Terry Davis
Sent: Friday, July 06, 2012 12:13 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [cin] Aviation Networks