Subject: [cin] Random Notes

From: Eric Burger <[email-masked]>
Date: Wed, 1 Aug 2012 15:38:25 -0700

These are NOT minutes from the meeting. They are random notes. They don't even capture who was there. It would be nice if someone who took copious notes could consolidate things.

The main action item is for Terry Davis and Bob Moskowitz to get together and write a problem statement draft in the next six weeks. For the calendar challenged, that would be by September 14.

CIN Bar BOF
Ron Bonica - sponsoring AD
Terry  Davis - iJET
Merike Kaeo - ISC
Robert Moskowitz

Eric Burger taking bad notes, not minutes

SIPRNET example

Scope:
Air transport
Trains (international, too: US, Canada, Mexico)
Power Grid
Enterprise SCADA
Medical - legacy infrastructure, different levels of access, etc.

Airplanes have 8+ networks: today multiple VPNs

Airplane has multiple prefixes. Airplane is multi-homed, and mobile.
How to run secure dynamic DNS?

First WG: Work on problem statement and issues with current solutions

Medical: Body area network
body contact, broadband, narrowband PHYs
802.15.4 (j - narrowband) 802.15.6 (FCC allocated)
In-hospital systems, or prescribed home systems
Hospital: break bottleneck of FDA approval of system, e.g., integrated system has to be approved, not just the components

Wireless devices get attached to patient. Patient moves from prep to OR to recovery to ...; different local controllers. Spectrum is secondary; WS-like sharing of frequency. 

Device needs to prove its identity. Easy for an airplane, but harder for a 20 micro-amp 8-bit CPU. HIP issues and solutions (smart endpoints), LISP issues and solutions (smart network).

Entity mobility
- class of solution: give entities permanent identifiers independent of connectivity
Cost of losing connectivity is exhorbitant

Problem statement: secure reliable mobility

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 2 Aug 2012 16:54:40 -0700

Eric,

See attached for a few terse notes from my vantage point.

Thanks - Fred

From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Burger
Sent: Wednesday, August 01, 2012 3:38 PM
To: [email-masked]
Subject: [cin] Random Notes

CIN Bar BOF

SIPRNET example

Scope:
Air transport

Entity mobility

---

From: Terry Davis <[email-masked]>
Date: Fri, 3 Aug 2012 03:29:38 +0000

All

I will try to combine the sets of notes into a set of minutes.

Thanks

Take care
Terry

From: [email-masked] [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Thursday, August 02, 2012 4:55 PM
To: Eric Burger; [email-masked]
Subject: Re: [cin] Random Notes

Eric,

Thanks - Fred

CIN Bar BOF

SIPRNET example

Scope:
Air transport

Entity mobility

This message and its attachments are the property of iJet Technologies, Inc. and are intended solely for the use of the designated recipient(s) and their appointed delegates. This email may contain information that is confidential. If you are not the intended recipient, you are prohibited from printing, copying, forwarding or saving any portion of the message or attachments. Please delete the message and attachments and notify the sender immediately. Thank you for your cooperation.

---

From: Ronald Bonica <[email-masked]>
Date: Sun, 5 Aug 2012 12:18:31 -0400

Fred,

For the benefit of the archive, please repost this message, transferring its content from an attachment to the body of the message. Our email archiving tools don't archive attachments.

                                                                                                   Ron

From: [email-masked] [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Thursday, August 02, 2012 7:55 PM
To: Eric Burger; [email-masked]
Subject: Re: [cin] Random Notes

Eric,

Thanks - Fred

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Eric Burger
Sent: Wednesday, August 01, 2012 3:38 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [cin] Random Notes

CIN Bar BOF

SIPRNET example

Scope:
Air transport

Entity mobility

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 6 Aug 2012 09:24:44 -0700

Hi Ron,

Below are the notes inline:

Thanks - Fred

Criticial Infrastructure Network (cin) Bar-BoF (IETF84 - July 30, 2012)
- Ron Bonica - facilitating AD
- Do we want to publish things? Through AD sponsorship? Form a working group?
- Need a problem statement to form a working group, plus a real BoF at an upcoming meeting
- Terry Davis cited introductory note sent on the [email-masked] list earlier in the day
- Aviation network considerations:
                - aviation still using OSI
                - can't get security with OSI
                - 140+ nation states with stakes in aviation comm's
                - how do we apply filters/ACLs/etc. to enforce boundaries?
                - or, is it a "loosly allied" confederation of networks?
- other use cases include railroad industry, power grid, SCADA systems, medical systems, vehicular networks, first responder networks, etc.
- problems include mobility, multihoming, security, etc.
- Locator/ID-split mentioned
- medical devices and body-area networking (IEEE 802.15.6) as critical infrastructure
- HIP, IRON and LISP mentioned briefly (noted as solution-space topics)
- facilitating AD reiterated need for problem statement as next step

From: Ronald Bonica [mailto:[email-masked]]
Sent: Sunday, August 05, 2012 9:19 AM
To: Templin, Fred L; [email-masked]
Subject: RE: [cin] Random Notes

Fred,

                                                                                                   Ron

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Thursday, August 02, 2012 7:55 PM
To: Eric Burger; [email-masked]<mailto:[email-masked]>
Subject: Re: [cin] Random Notes

Eric,

Thanks - Fred

CIN Bar BOF

SIPRNET example

Scope:
Air transport

Entity mobility

---

From: Terry Davis <[email-masked]>
Date: Mon, 6 Aug 2012 17:58:35 +0000

All

On the aviation side we do one huge concern that didn't get on the notes so far.

BGP!  Our routing implementation solution aviation has to be bullet-proof to any of the 140+ plus nation-states tying our aircraft in-flight routing service to the global BGP updates.

With less than 150 aircraft using Connexion-by-Boeing, we generated 20% of the global BGP table updates.

Take care
Terry

From: [email-masked] [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Monday, August 06, 2012 9:25 AM
To: Ronald Bonica; [email-masked]
Subject: Re: [cin] Random Notes

Hi Ron,

Thanks - Fred

- Terry Davis cited introductory note sent on the [email-masked]<mailto:[email-masked]> list earlier in the day

From: Ronald Bonica [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Sunday, August 05, 2012 9:19 AM
To: Templin, Fred L; [email-masked]<mailto:[email-masked]>
Subject: RE: [cin] Random Notes

Fred,

                                                                                                   Ron

Eric,

Thanks - Fred

CIN Bar BOF

SIPRNET example

Scope:
Air transport

Entity mobility

---

From: Ronald Bonica <[email-masked]>
Date: Tue, 7 Aug 2012 13:17:16 -0400

Terry,

Are we looking to deploy an new routing protocol? Or are we looking to devise a routing architecture, using existing protocols, that supports mobility without causing global churn?

                                                                                                                                                  Ron

From: Terry Davis [mailto:[email-masked]]
Sent: Monday, August 06, 2012 1:59 PM
To: Templin, Fred L; Ronald Bonica; [email-masked]
Subject: RE: [cin] Random Notes

All

Take care
Terry

---

From: Terry Davis <[email-masked]>
Date: Thu, 9 Aug 2012 02:06:58 +0000

Ron

I don't the answer at this point.

Whatever we come up with, it has to be bullet-proof so that one of the 140 nations cannot easily inter-tie networks and accidentally begin feeding global aircraft routing into the BGP infrastructure and even if we choose, OSPF or ISIS they could still inadvertently be re-distributed to BGP.

Base network encryption might take care of it if done right.

Take care
Terry

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ronald Bonica
Sent: Tuesday, August 07, 2012 10:17 AM
To: Terry Davis; Templin, Fred L; [email-masked]
Subject: Re: [cin] Random Notes

Terry,

                                                                                                                                                  Ron

From: Terry Davis [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Monday, August 06, 2012 1:59 PM
To: Templin, Fred L; Ronald Bonica; [email-masked]<mailto:[email-masked]>
Subject: RE: [cin] Random Notes

All

Take care
Terry