Subject: [conex] ECN in TCP and CWND

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 1 Aug 2011 19:13:15 +0200

Hi

I am digging in an experimental ECN for TCP implemementation. It is supposed to be implemented according to RFC3168.

As I understand things "TCP should not react to congestion indications more than once every window of data" (6.1.3 in RFC3168) 
Sofar so good, sounds very reasonable. 
But what about CWND?, should it be allowed to increase during this time?. 

To me it sounds most reasonable to _not_ allow the CWND to increase during the time that congestion indications are ingored but the code I am staring at does not behave in this way.

What is the correct behavior ?

Regards
Ingemar
=================================
INGEMAR JOHANSSON  M.Sc. 
Senior Researcher

Ericsson AB
Wireless Area Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com
Visit http://labs.ericsson.com !
=================================

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Mon, 22 Aug 2011 14:04:16 +0100

Hi Ingemar,

I believe there was a very similar question recently in TCPM, revolving around TCP-NCR, i.e.

http://www.ietf.org/mail-archive/web/tcpm/current/msg06528.html

My summary was that RFC5681 does allow cwnd to increase whenever an ACK acks new data (as would be the case with ECN); however, the consensus back then was that cwnd should not increase during "exceptional" events (reordering, loss recovery, ecn rtt), even though that may hinder tcp from throttling up when that may be safe...

OTOH, if cwnd is held constant during such events, particular loss recovery may not complete without RTO (and subsequent slow start), or cwnd may reduce to (and kept at) 1 segment for extended periods of time...

But your observation, that many implementations will actually increase cwnd after the cwnd reduction event, was made then too. 

Further note, that this particular behavior may get addressed with draft-mathis-tcpm-proportional-rate-reduction-00, as the cwnd reduction will be spaced out over ~1RTT -  basically a new ACK will not necessarily trigger the sending of a new data segment (and not increase cwnd), when PRR is active.

But you may want to take this question to the tcpm group too...

Best regards,

Richard Scheffenegger

> -----Original Message-----
> From: Ingemar Johansson S [mailto:[email-masked]]
> Sent: Montag, 01. August 2011 19:13
> To: [email-masked]
> Cc: ConEx IETF list
> Subject: [conex] ECN in TCP and CWND
> 
> Hi
> 
> I am digging in an experimental ECN for TCP implemementation. It is
> supposed to be implemented according to RFC3168.
> 
> As I understand things "TCP should not react to congestion indications
> more than once every window of data" (6.1.3 in RFC3168)
> To me it sounds most reasonable to _not_ allow the CWND to increase
> during the time that congestion indications are ingored but the code I
> am staring at does not behave in this way.
> 
> 
> _______________________________________________
> conex mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/conex