Subject: [core] draft-shelby-core-resource-directory: call for adoption

From: Andrew Mcgregor <[email-masked]>
Date: Tue, 21 May 2013 10:25:43 +1000

Consensus of the room in Orlando was to adopt draft-shelby-core-resource-
directory as a working group document.  This email is a call for
confirmation of that consensus.  Please respond if you support the adoption
of this document.

>From the charter:

    5) A definition of how to use CoAP to advertise about or query for a
    Device's description. This description may include the device name and
    a list of its Resources, each with a URL, an interface description URI
    (pointing e.g. to a Web Application Description Language (WADL)
    document) and an optional name or identifier. The name taxonomy used
    for this description will be consistent with other IETF work,
    e.g. draft-cheshire-dnsext-dns-sd.

RFC 6690 has some of this; the resource directory would add protocol
elements on top of CoAP that enhance the "advertise about or query
for" aspect.

• Feb 2014 Submission to IESG of "CoRE Resource Directory" for
  Proposed Standard
-- 
Andrew McGregor | SRE | [email-masked] | +61 4 8143 7128

---

From: "Rahman, Akbar" <[email-masked]>
Date: Mon, 20 May 2013 23:49:47 -0400

+1

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Andrew Mcgregor
Sent: Monday, May 20, 2013 8:26 PM
To: [email-masked]
Subject: [core] draft-shelby-core-resource-directory: call for adoption

Consensus of the room in Orlando was to adopt
draft-shelby-core-resource-directory as a working group document.  This
email is a call for confirmation of that consensus.  Please respond if
you support the adoption of this document.

    5) A definition of how to use CoAP to advertise about or query for a
    Device's description. This description may include the device name
and
    a list of its Resources, each with a URL, an interface description
URI
    (pointing e.g. to a Web Application Description Language (WADL)
    document) and an optional name or identifier. The name taxonomy used
    for this description will be consistent with other IETF work,
    e.g. draft-cheshire-dnsext-dns-sd.

* Feb 2014 Submission to IESG of "CoRE Resource Directory" for
  Proposed Standard

--

---

From: peter van der Stok <[email-masked]>
Date: Tue, 21 May 2013 08:47:34 +0200

I certainly support this, but with the remark that relation to DNS and 
DNS-SD should be clarified in the document.
This concerns how to handle name resolution with respect to information 
stored in resource directory
and text from lynn draft about conversion of attribute values to RR in 
DNS

Peter van der Stok

Rahman, Akbar schreef op 2013-05-21 05:49:
> +1
> 
> Akbar
> 
> FROM: [email-masked] [mailto:[email-masked]] ON BEHALF
> OF Andrew Mcgregor
> SENT: Monday, May 20, 2013 8:26 PM
> TO: [email-masked]
> SUBJECT: [core] draft-shelby-core-resource-directory: call for 
> adoption
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Bert Greevenbosch <[email-masked]>
Date: Wed, 22 May 2013 06:14:53 +0000

+1

Bert

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: 2013年5月21日 11:50
To: Andrew Mcgregor; [email-masked]
Subject: Re: [core] draft-shelby-core-resource-directory: call for adoption

+1

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew Mcgregor
Sent: Monday, May 20, 2013 8:26 PM
To: [email-masked]
Subject: [core] draft-shelby-core-resource-directory: call for adoption

Consensus of the room in Orlando was to adopt draft-shelby-core-resource-directory as a working group document.  This email is a call for confirmation of that consensus.  Please respond if you support the adoption of this document.

From the charter:

* Feb 2014 Submission to IESG of "CoRE Resource Directory" for
  Proposed Standard
--
Andrew McGregor | SRE | [email-masked]<mailto:[email-masked]> | +61 4 8143 7128

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Wed, 22 May 2013 09:32:55 +0000

+1

Matthias

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andrew Mcgregor
Sent: Tuesday, May 21, 2013 2:26
To: [email-masked]
Subject: [core] draft-shelby-core-resource-directory: call for adoption

---

From: Zach Shelby <[email-masked]>
Date: Fri, 24 May 2013 18:03:01 +0300

Peter,

I agree, as discussed in Orlando, we should integrate the DNS-SD mapping to this document. 

Thanks,
Zach 

On May 21, 2013, at 9:47 AM, peter van der Stok <[email-masked]> wrote:

> I certainly support this, but with the remark that relation to DNS and DNS-SD should be clarified in the document.
> This concerns how to handle name resolution with respect to information stored in resource directory
> and text from lynn draft about conversion of attribute values to RR in DNS
> 
> Peter van der Stok
> 
>> SUBJECT: [core] draft-shelby-core-resource-directory: call for adoption

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: Floris Van den Abeele <[email-masked]>
Date: Tue, 28 May 2013 09:36:19 +0200

+1

Floris

---

From: Miika Komu <[email-masked]>
Date: Thu, 30 May 2013 14:57:38 +0300

+1

On 05/28/2013 10:36 AM, Floris Van den Abeele wrote:
>>> I certainly support this, but with the remark that relation to DNS
>>> and DNS-SD should be clarified in the document.

---

From: ma yc <[email-masked]>
Date: Fri, 31 May 2013 09:18:05 +0800

＋1

2013/5/30 Miika Komu <[email-masked]>

>>>>> SUBJECT: [core] draft-shelby-core-resource-**directory: call for
>>>>> adoption
>>>>> draft-shelby-core-resource-**directory as a working group document.
>>>>> This
>>>>> ______________________________**_________________
>>>>> core mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/**listinfo/core<https://www.ietf.org/mailman/listinfo/core>
>>>>>
>>>> ______________________________**_________________
>>>> core mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/**listinfo/core<https://www.ietf.org/mailman/listinfo/core>
>>>>
>>>
>>>  ______________________________**_________________
>> core mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/core<https://www.ietf.org/mailman/listinfo/core>
>>
>>
> ______________________________**_________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/core<https://www.ietf.org/mailman/listinfo/core>
>