Subject: Re: [core] TLS_ECDHE_ECDSA_WITH_AES_128_CCM_8

From: Carsten Bormann <[email-masked]>
Date: Thu, 2 May 2013 20:11:37 +0200

Additional question to implementers of this ciphersuite:

What hash are you using to hash the signed parameters of the server key exchange?

RFC 4492 says:

        ServerKeyExchange.signed_params.sha_hash
            SHA(ClientHello.random + ServerHello.random +
                                              ServerKeyExchange.params);

...
   ...SHA in the above template for sha_hash accordingly may denote a
   hash algorithm other than SHA-1. 

I would expect that we are using SHA-256 here.

Grüße, Carsten

---

From: Don Sturek <[email-masked]>
Date: Thu, 02 May 2013 11:17:19 -0700

We use SHA-256 in ZigBee IP......

Don

On 5/2/13 11:11 AM, "Carsten Bormann" <[email-masked]> wrote:

>_______________________________________________
>core mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/core

---

From: Zach Shelby <[email-masked]>
Date: Thu, 2 May 2013 22:05:07 +0300

Yes, we are using SHA-256 in our CoAP solutions with this suite. 

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: Paul Duffy <[email-masked]>
Date: Thu, 02 May 2013 15:21:27 -0400

IIRC SHA-256 is used for critical infrastructure apps to provide 
compliance with NSA SuiteB Crypto and/or NIST SP 800-131A.

---

From: Robert Cragie <[email-masked]>
Date: Thu, 02 May 2013 21:07:08 +0100

TLS 1.2 specifies SHA-256 as the default hash for use with the PRF it 
defines as well, so it is expedient to use it.

Robert

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 20 May 2013 21:56:15 +0200

Could those who have DTLS implementations please have a very, very close look at Ticket #325?

http://trac.tools.ietf.org/wg/core/trac/ticket/325

Grüße, Carsten