Subject: Re: [core] #329: Ambiguity of Accept option still considered a problem

From: Carsten Bormann <[email-masked]>
Date: Fri, 21 Jun 2013 15:33:51 +0200

My summary of the discussion on this ticket:

Pete doesn't like:

> I have no way as a client to
> say, "I really can only accept format X, and if you can't make format X, I
> don't want something else", and I have no way to distinguish that from "I
> would prefer format X, but am willing to take whatever you can give me."

Some of the ambiguity of Accept comes from the fact that it is an elective option, so any MUST attached to it will be negated by the server always being allowed to ignore the option.

So, this sentence out of Pete's DISCUSS will always be true unless we change Accept to be critical:

> I have to be prepared to throw things away.

In previous discussions, we said that this is not a big issue, as messages are small and the cost of a 4.06 response and an unusable response are not that far apart.

However, the cost of generating a response may be higher for the server, which is why we do have the ability for it to send a 4.06 instead.  Matthias also sees some value in it for debugging.

Solution 1: If that is not a big problem, we can get rid of the 4.06.

Solution 2: We add a variant of Accept that is critical, so (in HTTP terms) we have a way to say
Accept: foo, *  (the elective version)
as well as
Accept: foo     (the critical version)

(Note that, while HTTP is wishy-washy about the requirements here because it doesn't have critical options, we don't have to be.)

Solution 2a: That variant is actually what we always want and it replaces the elective Accept.

Solution 3: _________ (please fill in the blank)

Solution 0: We have WG consensus that we really like what we have and try to explain to Pete why that is so.

Matthias also has made the point that an admonishment might be useful that the Content-Format of the response needs to be checked, which is certainly a useful addition (except for Solution 2a).

Again, I would like to submit -18 very soon, so I would be happy with some quick responses, even if they are only temperature readings.

Grüße, Carsten

---

From: "Rahman, Akbar" <[email-masked]>
Date: Fri, 21 Jun 2013 11:00:00 -0400

Hi Carsten,

My vote is for:

Reasoning: We are in a constrained environment so we should be as simple and precise as possible in client-server interactions and avoid any wasted transactions (of which the equivalent in HTTP may be more tolerable).

Best Regards,

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Friday, June 21, 2013 9:34 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [core] #329: Ambiguity of Accept option still considered aproblem

Pete doesn't like:

> say, "I really can only accept format X, and if you can't make format 
> X, I don't want something else", and I have no way to distinguish that 
> from "I would prefer format X, but am willing to take whatever you can give me."

Grüße, Carsten

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Zach Shelby <[email-masked]>
Date: Mon, 24 Jun 2013 10:09:23 +0300

> Reasoning: We are in a constrained environment so we should be as simple and precise as possible in client-server interactions and avoid any wasted transactions (of which the equivalent in HTTP may…

Well said Akbar, +1.

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: Bert Greevenbosch <[email-masked]>
Date: Mon, 24 Jun 2013 07:50:07 +0000

I am inclined to go for option 2a too. However, since the "accept" option currently is non-repeatable, this means that the server will send the requested content if, and only if, the acceptable content-type is available. Does this justify allowing multiple "accept" options again, such that the server can choose out of multiple acceptable content-types?

Best regards,
Bert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Zach Shelby
Sent: 2013年6月24日 15:09
To: Rahman, Akbar
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [core] #329: Ambiguity of Accept option still considered aproblem

Well said Akbar, +1.

Zach

---

From: "core issue tracker" <[email-masked]>
Date: Thu, 27 Jun 2013 13:38:36 -0000

#329: Ambiguity of Accept option still considered a problem

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [1414]:

 Fix #329

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-core-
  [email-masked]           |  [email-masked]
     Type:  protocol     |      Status:  closed
  defect                 |   Milestone:  post-IESG-1
 Priority:  major        |     Version:
Component:  coap         |  Resolution:  fixed
 Severity:  Submitted    |
  WG Document            |
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: </ticket/329#comment:4>
core <http://tools.ietf.org/core/>