Subject: [core] blog article on Web of Things

From: Jari Arkko <[email-masked]>
Date: Mon, 15 Jul 2013 17:31:28 +0200

FYI - I wrote an article about the Web of Things, i.e., using the web technologies to build Internet of Things applications and devices. Here's the blog:

http://www.ietf.org/blog/2013/07/the-web-of-things/

Thoughts, comments? I suppose the people in this working group believe in this model, if anyone :-) But I'd be interested also in thoughts on how we can make our technologies (such as CoAP as a part of the Web of Things framework) more widely known and understood. I personally believe it is very exciting technology, and worth more attention...

Jari

---

From: Don Sturek <[email-masked]>
Date: Mon, 15 Jul 2013 09:41:22 -0700

Hi Jari,

Many great points in your blog.  I especially agree on having outside
commercial groups (eg, ZigBee, Z-Wave, IPSO) creating profiles using IETF
standards and drafts (including Core).

Any thoughts on how these commercial standards groups can report on
missing (needed) features or additions within the IETF?   One of the
biggest challenges is knowing what group in IETF should be the target of
such requests (or even if a BOF is needed if there is not group).  I can
see some additional features being needed for a full Core deployment (part
of which can be addressed in the DICE group but I am also thinking of work
on forwarding to multicast groups where message distribution does not use
flooding.....)

Don

On 7/15/13 8:31 AM, "Jari Arkko" <[email-masked]> wrote:

>FYI - I wrote an article about the Web of Things, i.e., using the web
>technologies to build Internet of Things applications and devices. Here's
>the blog:
>
>Thoughts, comments? I suppose the people in this working group believe in
>this model, if anyone :-) But I'd be interested also in thoughts on how
>we can make our technologies (such as CoAP as a part of the Web of Things
>framework) more widely known and understood. I personally believe it is
>very exciting technology, and worth more attention...
>
>Jari
>
>_______________________________________________
>core mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/core

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Thu, 18 Jul 2013 12:57:49 +0000

Hey there

I am aware that this is about standardization work, but I just want to add that we should not forget about a very central idea of the Web of Things: physical mashups. It is about light-weight scripting that can connect any-thing to any-thing, also those which were not designed to go together. This leaves the world of device profiles with cryptic identifiers and adds the requirement for self-descriptive, easy-to-use APIs.

Another aspect that was missing---probably because it is still far from commercialization---is semantic descriptions such as RESTdesc. There is a lot of work going on to enable M2M without the traditional, predefined device profiles.

Ciao
Matthias

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Don Sturek
> Sent: Montag, 15. Juli 2013 18:41
> To: Jari Arkko; [email-masked]
> Subject: Re: [core] blog article on Web of Things
> 
> Hi Jari,
> 
> biggest challenges is knowing what group in IETF should be the target of such
> requests (or even if a BOF is needed if there is not group).  I can see some
> additional features being needed for a full Core deployment (part of which
> can be addressed in the DICE group but I am also thinking of work on
> forwarding to multicast groups where message distribution does not use
> flooding.....)
> 
> Don
> 
> 
> >technologies to build Internet of Things applications and devices.
> >Here's the blog:
> >
> >Thoughts, comments? I suppose the people in this working group believe
> >in this model, if anyone :-) But I'd be interested also in thoughts on
> >how we can make our technologies (such as CoAP as a part of the Web of
> >Things

---

From: sylvain Cherrier <[email-masked]>
Date: Fri, 19 Jul 2013 09:33:25 +0200

Hello,

we are very interested in your blog because we are working on the same 
kind of solutions.
Maybe you could take a look at our platform http://bec3.univ-mlv.fr/ ?

We are still working on our framework, but I think that we are in the 
same kind of vision.

We would be pleased to have some comments on it, or some advices.

Sylvain Cherrier
PhD. Student
Université de Marne la Vallée
France

---

From: Jari Arkko <[email-masked]>
Date: Tue, 23 Jul 2013 14:00:34 +0300

Don,

> on forwarding to multicast groups where message distribution does not use

Good question.

I think the standard answer is that first of all, this is not going to happen without some joint participation. So I think it is up to you and others who attend multiple forums to tell us what is missing and make a case for it in the IETF. And talk to your WG chairs and ADs about what is needed.

As we were completing CoAP we've been quite careful about adding new things, both in CORE and elsewhere. Perhaps it is time to do an effort to analyse what if anything is needed in this space, and then add those items to the relevant working groups? It would also be useful to talk to the W3C group, as they are making analysis of what is missing as well. I'd love to see someone write a draft on what the Web of Things still needs! Any takers?

Jari

---

From: Rick Bullotta <[email-masked]>
Date: Tue, 23 Jul 2013 11:06:44 +0000

I think the first step is a presentation/document that describes Core/COAP at a high level but provides a comprehensive overview of the capabilities, but isn't quite as technical as the specs themselves.  

I would be very happy to provide some functional feedback/gap analysis from a  commercial platform perspective. 

Cheers,

Rick Bullotta
ThingWorx

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Jul 2013 13:30:27 +0200

On Jul 23, 2013, at 13:06, Rick Bullotta <[email-masked]> wrote:

> a presentation/document that describes Core/COAP at a high level but provides a comprehensive overview of the capabilities, but isn't quite as technical as the specs themselves.  

Yes, we (as a community, not necessarily as a WG) have to work on more accessible documents.

One such document is http://doi.ieeecomputersociety.org/10.1109/MIC.2012.29 — unfortunately, it is behind the IEEE paywall, but many technical organizations do have access.

Another document that provides some overview (but unfortunately less technical content) is http://tools.ietf.org/html/draft-bormann-core-roadmap-04 — this is due for an update as soon as the Internet-Draft moratorium ends.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Jul 2013 13:39:31 +0200

On Jul 23, 2013, at 13:00, Jari Arkko <[email-masked]> wrote:

> [...] tell us what is missing and make a case for it in the IETF.

I (donning WG chair hat) see little problem in using the CoRE WG mailing list for some requirements discussion, even if it is not clear whether the resulting work will fall into the purview of CoRE or other IETF WGs in the Internet-of-Things cluster.

> And talk to your WG chairs and ADs about what is needed.

Absolutely!

On a short-term timescale, I also would like to hear what additional requirements need to go into the 6LO and DICE BOFs next week.

The current version of the proposed 6LO charter is at: https://github.com/6lo/charter
DICE has its current charter proposal at: http://goo.gl/pSiLc

Grüße, Carsten