Subject: [core] question on draft-softgear-core-coapa-00 (CoAP/A)

From: Olaf Bergmann <[email-masked]>
Date: Mon, 05 Aug 2013 13:25:39 +0200

Hi,

In draft-softgear-core-coapa-00, a simple ASCII encoding for CoAP
messages using base64url is described. This looks straight forward and
useful, so I will definitely give it a try.

One thing is still unclear to me: Given I want to contact an ASCII-only
node (e.g. a sensor listed in my home's RD), where do I know that I need
to encode the request in CoAP/A? (Or, when using transcoding proxies,
where does the proxy know that it has to encode/decode the message?)

Gruesse
Olaf

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Aug 2013 13:46:33 +0200

On Aug 5, 2013, at 13:25, Olaf Bergmann <[email-masked]> wrote:

> Given I want to contact an ASCII-only

If you are a client, that information should come out of the transport selection information in the URI (which we haven't completed discussing).

If you are a server that speaks a protocol like TCP that would be useful for carrying ASCII streams but also for a "native" CoAP version, there probably should be some detection mechanism.
In draft-bormann-core-coap-tcp-00, there are signatures (not in the crypto sense) that could be used for that detection.

The signature that I proposed happens to be valid base64url (except for whitespace (\r\n), which probably should be ignored by a CoAP/A implementation), so it would need to be changed to work as a differentiator.

To make CoAP/A a bit more robust, I also would propose
-- allowing # at the start of a message (effectively, reliably discarding zero-length messages), so implementations can make a habit of start- and end-delimiting messages.
-- considering adding a checksum (Hmm.)

Grüße, Carsten

---

From: 고석갑 <[email-masked]>
Date: Wed, 7 Aug 2013 16:32:26 +0000

Hello olaf.
I used a proxy which has internet connection and ascii only connection to a sensor. The Internet connection was used for CoAP client or HTTP client. The proxy knew the attached sensor list from the (manual) configuration. The proxy translated CoAP URL from client to the own configured sensor's CoAP URL (we called it "local CoAP URL".). Currently, we used a registration server to let clients know sensor's (global) CoAP or HTTP URL. However, CORE WG is discussing about this issue (DNS, regstration server, so on) as Carsten mentioned.

- Softgear ko.

Olaf Bergmann <[email-masked]>님이 작성:

Hi,

Gruesse
Olaf
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core