Subject: Re: [core] draft-bormann-core-coap-tcp

From: Carsten Bormann <[email-masked]>
Date: Thu, 1 Aug 2013 09:52:05 +0200

> I read your coap-tcp draft but I missed any text on TCP header size reduction.

(If you mean as in RFC 6846 header compression, this should be orthogonal.)

A reduced CoAP header is defined in the coap-over-websockets draft and I didn't see a need to invent another one, even though I'm not sure I like the version used in coap-over-websockets.  

Clearly, we would like to have a common way of compactifying the CoAP header for the reliable, connection-oriented transports, if we don't decide to stick with the 4-byte header (which is a bit awkward as it's not clear what to put into the message-ID field).

This very moment I'm listening to the MINION talk by Janardhan Iyengar.
I reference MINION as one possible approach for framing in the coap-over-tcp draft.

Grüße, Carsten

---

From: Andrew Mcgregor <[email-masked]>
Date: Thu, 1 Aug 2013 01:40:59 -0700

I would very much like to support the use of minion in coap-over-tcp, that
will give a very simple deployment path in a very wide variety of
situations.

On 1 August 2013 00:52, Carsten Bormann <[email-masked]> wrote:

> A reduced CoAP header is defined in the coap-over-websockets draft and I
> didn't see a need to invent another one, even though I'm not sure I like
> the version used in coap-over-websockets.
>
> Clearly, we would like to have a common way of compactifying the CoAP
> header for the reliable, connection-oriented transports, if we don't decide
> to stick with the 4-byte header (which is a bit awkward as it's not clear
> what to put into the message-ID field).
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

-- 
Andrew McGregor | SRE | [email-masked] | +61 4 8143 7128