Subject: [core] Do we need a CORE charter item for CoAP support of Sleepy Nodes?

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 1 Aug 2013 11:24:14 -0400

Hi,

Carsten asked me to send this message out to the WG list as we did not
have a chance to discuss the Sleepy Node topic in this IETF due to a
lack of time on the agenda. 

------------------------------------------------------------------------
------

We have several current I-Ds in CORE (and LWIG) that discusses the topic
of Sleepy Nodes.  Among those are:

draft-dijk-core-sleepy-reqs-00
<https://datatracker.ietf.org/doc/draft-dijk-core-sleepy-reqs/> 

draft-dijk-core-sleepy-solutions-01
<https://datatracker.ietf.org/doc/draft-dijk-core-sleepy-solutions/> 

draft-hong-lwig-sleepynode-problem-statement-00
<https://datatracker.ietf.org/doc/draft-hong-lwig-sleepynode-problem-sta
tement/> 

draft-rahman-core-sleepy-03
<https://datatracker.ietf.org/doc/draft-rahman-core-sleepy/> 

Hence the following question to the WG:

*         Should we have a CORE deliverable for CoAP support of Sleepy
Nodes?

Please write back with your thoughts!

Best Regards,

Akbar

---

From: "Dijk, Esko" <[email-masked]>
Date: Mon, 12 Aug 2013 14:00:45 +0000

I do support a CoRE deliverable for Sleepy Nodes!

In my view this should be about a standardized (or 'best practice') way to read resources from, and write resources to, a CoAP server that is asleep during significant/long periods of time. This typically requires the concept of an intermediary node (called "mirror server" in http://datatracker.ietf.org/doc/draft-vial-core-mirror-server/ and "proxy" in http://tools.ietf.org/html/draft-dijk-core-sleepy-reqs-00) to handle the CoAP requests on behalf of the sleepy node.

Other parts of the total solution/architecture that are needed, would be out of scope of CoRE (as Zach and others indicated).
Also for solutions where radio duty cycling provides enough power saving, the above deliverable is not needed. L2 solutions are not in scope. But my wish is for a CoRE solution to support the most energy-constrained nodes - e.g. a sensor that wakes up once a day to briefly transmit a value, and that still needs to be configurable via CoAP.

Esko

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Thursday, August 01, 2013 17:24
To: [email-masked]
Subject: [core] Do we need a CORE charter item for CoAP support of Sleepy Nodes?

Hi,

Carsten asked me to send this message out to the WG list as we did not have a chance to discuss the Sleepy Node topic in this IETF due to a lack of time on the agenda.

------------------------------------------------------------------------------
We have several current I-Ds in CORE (and LWIG) that discusses the topic of Sleepy Nodes.  Among those are:

draft-dijk-core-sleepy-reqs-00<https://datatracker.ietf.org/doc/draft-dijk-core-sleepy-reqs/>

draft-dijk-core-sleepy-solutions-01<https://datatracker.ietf.org/doc/draft-dijk-core-sleepy-solutions/>

draft-hong-lwig-sleepynode-problem-statement-00<https://datatracker.ietf.org/doc/draft-hong-lwig-sleepynode-problem-statement/>

draft-rahman-core-sleepy-03<https://datatracker.ietf.org/doc/draft-rahman-core-sleepy/>

*         Should we have a CORE deliverable for CoAP support of Sleepy Nodes?

Best Regards,

Akbar

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.