Subject: [core] fixing block option names

From: "Peter A. Bigot" <[email-masked]>
Date: Sat, 19 Oct 2013 07:12:13 -0500

I see block-12 says something about an upcoming "grand rewrite".
Would anybody else support a massive rename, viz:

Block1 -> Request-Block
Block2 -> Response-Block
Size1 -> Request-Size
Size2 -> Response-Size

No semantic change, just eliminate the opacity from the option names so
they more clearly reflect their function.  That request- and
response-related options can both appear in both requests and responses
in both descriptive and control roles adds enough confusion without
compounding it by having to remember "1 is the first message which is a
request and 2 is the second message which is a response".

Peter

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 19 Oct 2013 14:29:53 +0200

I'm indeed readying block-13, with the changes suggested by Matthias Kovatsch, in particular closing #211, #253.
(The major change is that this will get rid of the concept of initiative change.)

> Size2 -> Response-Size

We occasionally have discussed this, and it was this discussion that arrived at the current names.

I'll follow what the WG wants to do here, but have to point out that the name Size1 is already stuck in the approved soon-to-be-RFC*) draft-ietf-core-coap.

Grüße, Carsten

*) The two missrefs the RFC editor is waiting for are:
draft-ietf-tls-oob-pubkey (post IETF last call; new version received today; IESG State: Waiting for Writeup)
draft-mcgrew-tls-aes-ccm-ecc (post IETF last call; IESG State: IESG Evaluation; On agenda of 2013-10-24 IESG telechat)

---

From: Thomas Fossati <[email-masked]>
Date: Sat, 19 Oct 2013 14:12:43 +0100

> Would anybody else support a massive rename, viz:

+1

(missrefs resolution timing permitting)