Subject: [core] FYI: Test descriptions for CoAP#4 (including DTLS and 6LoWPAN)

From: Carsten Bormann <[email-masked]>
Date: Mon, 24 Feb 2014 20:20:40 +0100

I just sent the below message to the participants of the CoAP#4 plugtest event March 7-9 in London.
This set of tests is being made publicly available, so it may be used for your private or bilateral tests as well.
We certainly would like to hear opinions about these tests from people who are interested in test descriptions even if you are not able to attend.
(And, if you are and haven’t registered yet, please drop me a line!)

From your experience with the core CoAP spec, and with -block and -observe, what should we add to this test set?
(We are testing interoperability, not conformance, so this is not about checking the response to strange sequences of messages, but about exchanges that might occur in actual interoperation.)

What are the tests that you are most interested in with respect to CoAP’s security modes (called “DTLS tests” in the below)?

Grüße, Carsten

Begin forwarded message:

> From: Carsten Bormann <[email-masked]>
> Subject: Test descriptions for CoAP#4 (including DTLS and 6LoWPAN)
> Date: 24 Feb 2014 19:55:10 +0100
> 
> Good evening,
> 
> I have put up a set of test descriptions for the London COAP Plugtest, based on the ones we used in previous plugtests for both CoAP and 6LoWPAN, at:
> 
> 	https://github.com/cabo/td-coap4
> 
> To facilitate collaboration, the test descriptions are in a git repository.
> You can see each set of test descriptions as an HTML file (that looks like the test descriptions we used in the previous plugtests; click on the link in the README) or as a YAML file that is used to automatically generate the HTML.
> 
> Note that the DTLS tests now have the final allocation for the RPK TLS extensions, but we are still using a provisional cipher suite ID for TLS_ECDHE_ECDSA_WITH_AES_128_CCM_8.
> 
> Apart from testing the 7.31 cancellation for -observe (which I still have to add), is there anything else you would like to see covered?
> 
> You can send corrections and enhancements to me or to the list, or you can use the fork/pull request workflow that is usual with github (accounts for this are easy to create on github.com).
> 
> Grüße, Carsten
> 
> 
>

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Thu, 27 Feb 2014 10:09:37 +0000

Hi

Should we already include  a test for the combination of Observe and Block2?

Ciao
Matthias

> -----Original Message-----
> From: core [mailto:[email-masked]] On Behalf Of Carsten Bormann
> Sent: Montag, 24. Februar 2014 20:21
> To: core
> Subject: [core] FYI: Test descriptions for CoAP#4 (including DTLS and
> 6LoWPAN)
> 
> We certainly would like to hear opinions about these tests from people who
> are interested in test descriptions even if you are not able to attend.
> (And, if you are and haven't registered yet, please drop me a line!)
> 
> From your experience with the core CoAP spec, and with -block and -
> observe, what should we add to this test set?
> (We are testing interoperability, not conformance, so this is not about
> checking the response to strange sequences of messages, but about
> exchanges that might occur in actual interoperation.)
> 
> What are the tests that you are most interested in with respect to CoAP's
> security modes (called "DTLS tests" in the below)?
> 
> Grüße, Carsten
> 
> 
> Begin forwarded message:
> 
> > I have put up a set of test descriptions for the London COAP Plugtest,
> based on the ones we used in previous plugtests for both CoAP and
> 6LoWPAN, at:
> >
> > You can see each set of test descriptions as an HTML file (that looks like the
> test descriptions we used in the previous plugtests; click on the link in the
> README) or as a YAML file that is used to automatically generate the HTML.
> >
> > Note that the DTLS tests now have the final allocation for the RPK TLS
> extensions, but we are still using a provisional cipher suite ID for
> TLS_ECDHE_ECDSA_WITH_AES_128_CCM_8.
> >
> > Apart from testing the 7.31 cancellation for -observe (which I still have to
> add), is there anything else you would like to see covered?
> >
> > You can send corrections and enhancements to me or to the list, or you can
> use the fork/pull request workflow that is usual with github (accounts for this
> are easy to create on github.com).
> >
> > Grüße, Carsten
> >
> >
> >
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core