Subject: [core] I-D Action: draft-ietf-core-observe-12.txt

From: [email-masked]
Date: Fri, 14 Feb 2014 12:25:37 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Constrained RESTful Environments Working Group of the IETF.

        Title           : Observing Resources in CoAP
        Author          : Klaus Hartke
	Filename        : draft-ietf-core-observe-12.txt
	Pages           : 33
	Date            : 2014-02-14

Abstract:
   CoAP is a RESTful application protocol for constrained nodes and
   networks.  The state of a resource on a CoAP server can change over
   time.  This document specifies a simple protocol extension for CoAP
   that enables CoAP clients to "observe" resources, i.e., to retrieve
   a representation of a resource and keep this representation updated
   by the server over a period of time.  The protocol follows a best-
   effort approach for sending new representations to clients and
   provides eventual consistency between the state observed by each
   client and the actual resource state at the server.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-observe/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-core-observe-12

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-core-observe-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Klaus Hartke <[email-masked]>
Date: Wed, 19 Feb 2014 20:14:37 +0100

> http://www.ietf.org/rfcdiff?url2=draft-ietf-core-observe-12

This revision of I-D.ietf-core-observe fixes the issues raised during
the WGLC before the IETF88 meeting and the following two major issues
we discussed in Vancouver:

* The optimized transmission of notifications when there already is an
outstanding notification for the resource to the client is now
OPTIONAL. So implementers can now choose between the original CoAP
message transmission algorithm and the optimized one.

* A mechanism for the proactive cancellation of observations is now
provided in addition to the existing "garbage collection" approach. It
is OPTIONAL for clients and REQUIRED for servers.

* (We decided to leave the treatment of inadvertently reused tokens to
implementations, and to not allow any token reuse beyond the
re-registration of a client's interest in a resource. So no changes
resulted from these issues.)

Best regards,
Klaus

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 22 Feb 2014 22:36:23 +0100

As Klaus writes in http://www.ietf.org/mail-archive/web/core/current/msg05276.html, draft-ietf-core-observe-12.txt closes the remaining issues from the WGLC of -11.

We could just say we are done, but one aspect of -12 may be non-obvious to those that have just followed the mailing list:
The resolution of the pro-active cancellation issue makes use of a new code (7.31) instead of relying on a side-effect of the token re-use handling.  (This is also not among the test cases we tested at the last CoAP interop in Las Vegas.)

Klaus has detailed the reasons for going with that specific solution in http://www.ietf.org/mail-archive/web/core/current/msg05277.html — note that clients can choose to never transmit a 7.31 code (RST is the reactive alternative), but a server that implements Observe now has to implement both RST (message-ID-based reactive) and 7.31 (token-based proactive) cancellation.

This starts an abbreviated working group last call for -observe-12, ending on

	24:00 UTC on Monday, March 3, 2014.

We would like to use a little bit of meeting time in London on March 4 to review any comments, so supplying a slide or two for any non-trivial comment (and possibly finding someone who would speak to it in the room) would be appreciated.

The focus of this Mini-WGLC is on the proactive cancellation, but if there is anything else that needs to be fixed in -observe, now would be a good time to mention that here.

Grüße, Carsten