Subject: [core] Fwd: Coap discovery related questions...

From: Carsten Bormann <[email-masked]>
Date: Fri, 9 May 2014 09:26:28 +0200

[Due to the DMARC disaster, I’m posting this message manually from my address for the original author.
Those of you who are using Yahoo or AOL accounts for mailing lists, please consider subscribing from another account.]

> From: Sudhir Pendse <[email-masked]>
> Subject: Coap discovery related questions...
> Date: 8 May 2014 21:30:32 +0200
> 
> Hello,
> 
> I am just starting to go through the drafts/rfcs to do a simple coap server/client
> implementation and had a question regarding discovery.
> 
> I understand that one can query an existing coap server's "/.well-known/core"
> to get a list of url's along with weblink info for them, but was wondering if there
> is a way to find out if a particular uri supports GET/POST/DELETE/PUT..
> 
> If it is in the list returned, then I would think we could assume that it supports
> GET, but is there any non-destructive way to find out if it supports POST/DELETE/PUT
> (for example sending a request and looking at error codes returned ?)
> 
> Also, if it is not already there, would it be useful to have a core-link attribute
> like method=gpdu to indicate what methods it supports...
> 
> Look forward to hearing your thoughts.  Also if this is not the correct list to
> address this issue, please direct me to the right one.
> 
> Thanks,
> -Sudhir

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 9 May 2014 09:41:50 +0200

Sudhir Pendse <[email-masked]> wrote:

> a way to find out if a particular uri supports GET/POST/DELETE/PUT

There have been a number of proposals to define attributes for discovering the set of methods applicable to a resource.

So far, the sentiment of the WG has been that while this is useful information to discover, it may not really be sufficient to act on it.
Instead, attributes such as “rt=" and “if=" could be used to provide more specific information that is then directly actionable.

Obviously, whether this is the right assessment depends on specific use cases.
(It also depends on a set of resource type/interface description names to be accepted practice.)

Sudhir: Maybe you could describe your use case in more detail so we can discuss this in more specific terms?

Grüße, Carsten