Subject: [core] draft-tcs-coap-no-response-option-07 : Call for WG adoption

From: Abhijan Bhattacharyya <[email-masked]>
Date: Wed, 6 Aug 2014 16:02:25 +0530

Hi,
We have submitted a new version of the No-Response draft. Several editorial corrections have been made. The references have been updated and enhanced. A number for the option has been suggested for IANA consideration .
As there has been continuity of interest in the mailing list discussions and also during the last three WG meetings, may we now ask for the opinion of the Working Group on adoption of the draft please. 

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services Limited
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.	IT Services
Business Solutions
Consulting
____________________________________________

[email-masked] wrote: -----
To: Soma Bandyopadhyay <[email-masked]>, "Abhijan Bhattacharyya" <[email-masked]>, "Arpan Pal" <[email-masked]>, Arpan Pal <[email-masked]>, "Soma Bandyopadhyay" <[email-masked]>, Abhijan Bhattacharyya <[email-masked]>
From: [email-masked]
Date: 08/06/2014 03:44PM
Subject: New Version Notification for draft-tcs-coap-no-response-option-07.txt

A new version of I-D, draft-tcs-coap-no-response-option-07.txt
has been successfully submitted by Abhijan Bhattacharyya and posted to the
IETF repository.

Name:	draft-tcs-coap-no-response-option
Revision:	07
Title:	CoAP option for no server-response
Document date:	2014-08-05
Group:	Individual Submission
Pages:	18
URL:            http://www.ietf.org/internet-drafts/draft-tcs-coap-no-response-option-07.txt
Status:         https://datatracker.ietf.org/doc/draft-tcs-coap-no-response-option/
Htmlized:       http://tools.ietf.org/html/draft-tcs-coap-no-response-option-07
Diff:           http://www.ietf.org/rfcdiff?url2=draft-tcs-coap-no-response-option-07

Abstract:
   There can be typical M2M scenarios where responses from the data
   sink to the data source against request from the source might be
   considered redundant. This kind of open-loop exchange (with no
   reverse path from the sink to the source) may be desired while
   updating resources in constrained systems looking for maximized
   throughput with minimized resource consumption. CoAP already
   provides a non-confirmable (NON) mode of exchange where the
   receiving end-point does not respond with ACK. However, the
   receiving end-point responds the sender with a status code
   indicating "the result of the attempt to understand and satisfy the
   request".

   This draft introduces a header option: 'No-Response' to suppress
   responses from the receiver and discusses exemplary use cases which
   motivated this proposition based on real experience. This option
   also provides granularity by allowing suppression of a typical class
   or a combination of classes of responses. This option may be
   effective for both unicast and multicast scenarios.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 6 Aug 2014 10:38:43 -0400

Hi Abhijan,

+1

As I said in IETF-Toronto, I think that this is a nice value added
feature to have in CoAP.

Best Regards,

Akbar

From: core [mailto:[email-masked]] On Behalf Of Abhijan
Bhattacharyya
Sent: Wednesday, August 06, 2014 6:32 AM
To: [email-masked]
Cc: Arpan Pal
Subject: [core] draft-tcs-coap-no-response-option-07 : Call for WG
adoption

Hi,

We have submitted a new version of the No-Response draft. Several
editorial corrections have been made. The references have been updated
and enhanced. A number for the option has been suggested for IANA
consideration .

As there has been continuity of interest in the mailing list discussions
and also during the last three WG meetings, may we now ask for the
opinion of the Working Group on adoption of the draft please. 

Regards
Abhijan Bhattacharyya
Associate Consultant

[email-masked] wrote: -----

To: Soma Bandyopadhyay <[email-masked]>, "Abhijan
Bhattacharyya" <[email-masked]>, "Arpan Pal"
<[email-masked]>, Arpan Pal <[email-masked]>, "Soma Bandyopadhyay"
<[email-masked]>, Abhijan Bhattacharyya
<[email-masked]>
From: [email-masked]
Date: 08/06/2014 03:44PM
Subject: New Version Notification for
draft-tcs-coap-no-response-option-07.txt

A new version of I-D, draft-tcs-coap-no-response-option-07.txt
has been successfully submitted by Abhijan Bhattacharyya and posted to
the
IETF repository.

Name: draft-tcs-coap-no-response-option
Revision: 07
Title: CoAP option for no server-response
Document date: 2014-08-05
Group: Individual Submission
Pages: 18
URL:
http://www.ietf.org/internet-drafts/draft-tcs-coap-no-response-option-07
.txt
Status:
https://datatracker.ietf.org/doc/draft-tcs-coap-no-response-option/
Htmlized:
http://tools.ietf.org/html/draft-tcs-coap-no-response-option-07
Diff:
http://www.ietf.org/rfcdiff?url2=draft-tcs-coap-no-response-option-07

Abstract:

Please note that it may take a couple of minutes from the time of
submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Thu, 7 Aug 2014 00:13:04 +0530

Hi Akbar,
Thanks for your response.

Regards
Abhijan Bhattacharyya
Associate Consultant

-----"Rahman, Akbar" <[email-masked]> wrote: -----
To: "Abhijan Bhattacharyya" <[email-masked]>, <[email-masked]>
From: "Rahman, Akbar" <[email-masked]>
Date: 08/06/2014 08:08PM
Cc: "Arpan Pal" <[email-masked]>
Subject: RE: [core] draft-tcs-coap-no-response-option-07 : Call for WG adoption

Hi Abhijan,

+1

As I said in IETF-Toronto, I think that this is a nice value added feature to have in CoAP.

Best Regards,

Akbar

From: core [mailto:[email-masked]] On Behalf Of Abhijan Bhattacharyya
Sent: Wednesday, August 06, 2014 6:32 AM
To: [email-masked]
Cc: Arpan Pal
Subject: [core] draft-tcs-coap-no-response-option-07 : Call for WG adoption

Hi,

Regards
Abhijan Bhattacharyya
Associate Consultant

[email-masked] wrote: -----

Abstract:

The IETF Secretariat

---

From: Likepeng <[email-masked]>
Date: Thu, 7 Aug 2014 00:17:47 +0000

+1.

It is simple and useful.

Kind Regards
Kepeng

发件人: core [mailto:[email-masked]] 代表 Abhijan Bhattacharyya
发送时间: 2014年8月6日 18:32
收件人: [email-masked]
抄送: Arpan Pal
主题: [core] draft-tcs-coap-no-response-option-07 : Call for WG adoption

Hi,

Regards
Abhijan Bhattacharyya
Associate Consultant
Mailto: [email-masked]<mailto:[email-masked]>

[email-masked]<mailto:[email-masked]> wrote: -----
To: Soma Bandyopadhyay <[email-masked]<mailto:[email-masked]>>, "Abhijan Bhattacharyya" <[email-masked]<mailto:[email-masked]>>, "Arpan Pal" <[email-masked]<mailto:[email-masked]>>, Arpan Pal <[email-masked]<mailto:[email-masked]>>, "Soma Bandyopadhyay" <[email-masked]<mailto:[email-masked]>>, Abhijan Bhattacharyya <[email-masked]<mailto:[email-masked]>>
From: [email-masked]<mailto:[email-masked]>
Date: 08/06/2014 03:44PM
Subject: New Version Notification for draft-tcs-coap-no-response-option-07.txt
A new version of I-D, draft-tcs-coap-no-response-option-07.txt
has been successfully submitted by Abhijan Bhattacharyya and posted to the
IETF repository.

Abstract:

The IETF Secretariat

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Fri, 8 Aug 2014 01:01:38 +0530

Hi Kepeng,

Regards
Abhijan Bhattacharyya
Associate Consultant

-----Likepeng <[email-masked]> wrote: -----
To: Abhijan Bhattacharyya <[email-masked]>, "[email-masked]" <[email-masked]>
From: Likepeng <[email-masked]>
Date: 08/07/2014 05:48AM
Cc: Arpan Pal <[email-masked]>
Subject: Re: [core] draft-tcs-coap-no-response-option-07 : Call for WG adoption

+1.

It is simple and useful.

Kind Regards

Kepeng

&#21457;&#20214;&#20154;: core [mailto:[email-masked]] &#20195;&#34920; Abhijan Bhattacharyya
&#21457;&#36865;&#26102;&#38388;: 2014&#24180;8&#26376;6&#26085; 18:32
&#25910;&#20214;&#20154;: [email-masked]
&#25220;&#36865;: Arpan Pal
&#20027;&#39064;: [core] draft-tcs-coap-no-response-option-07 : Call for WG adoption

Hi,

Regards
Abhijan Bhattacharyya
Associate Consultant

[email-masked] wrote: -----

Abstract:

The IETF Secretariat