Subject: [core] Real Time Video over CoAP?

From: Abhijan Bhattacharyya <[email-masked]>
Date: Wed, 29 Oct 2014 21:24:08 +0530

Hi All,
Just wonder if some effort is going on regarding transfer of real-time 
video over CoAP.
I could find an old draft on streaming over CoAP: 
https://tools.ietf.org/html/draft-loreto-core-coap-streaming-00

But, has there been any further progress on this recently, or, any effort 
being put on this problem by anyone?

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.   IT Services
                        Business Solutions
                        Consulting
____________________________________________
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 29 Oct 2014 16:41:57 +0000

Hi Abjian

I haven't had almost any cycle to further progress the old proposal since my initial proposal.

However if people are interested in helping and supporting I can resurrect the drag and update
with all the improvements done meanwhile in observe

br
Salvatore

On Oct 29, 2014, at 5:54 PM, Abhijan Bhattacharyya <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,
Just wonder if some effort is going on regarding transfer of real-time video over CoAP.
I could find an old draft on streaming over CoAP: https://tools.ietf.org/html/draft-loreto-core-coap-streaming-00

But, has there been any further progress on this recently, or, any effort being put on this problem by anyone?

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services
Mailto: [email-masked]<mailto:[email-masked]>
Website: http://www.tcs.com<http://www.tcs.com/>
____________________________________________
Experience certainty.        IT Services
                       Business Solutions
                       Consulting
____________________________________________

_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core

---

From: Siddharth Heroor <[email-masked]>
Date: Wed, 29 Oct 2014 10:23:55 -0700

Hi Salvatore, Abhijan

I too interested in seeing more on this. There are several applications 
where streaming are an usecase. However, there are a few questions that 
I have

1. How similar to RTP would this extension be and what would be the 
differences?
2. The old draft does not cover resource capabilities and would that be 
considered?

Thanks and Regards,
Sid

On 29/10/14 9:41 am, Salvatore Loreto wrote:
> On Oct 29, 2014, at 5:54 PM, Abhijan Bhattacharyya 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>> Hi All,
>> But, has there been any further progress on this recently, or, any 
>> effort being put on this problem by anyone?
>>
>> Regards
>> Abhijan Bhattacharyya
>> Associate Consultant
>> <mailto:[email-masked]>
>> Website: http://www.tcs.com <http://www.tcs.com/>
>> [email-masked] <mailto:[email-masked]>
> [email-masked]

---

From: Paul Duffy <[email-masked]>
Date: Wed, 29 Oct 2014 14:01:06 -0400

Same questions.

How do RTP and RTSP not meet your needs?

On 10/29/2014 1:23 PM, Siddharth Heroor wrote:
> Hi Salvatore, Abhijan
>
> I too interested in seeing more on this. There are several 
> applications where streaming are an usecase. However, there are a few 
> questions that I have
>
> 2. The old draft does not cover resource capabilities and would that 
> be considered?
>
> Thanks and Regards,
> Sid
>
>> <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>> Hi All,

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Oct 2014 21:19:01 +0100

> How do RTP and RTSP not meet your needs?

RTP is actually a great protocol for streaming real-time video.

I’m not sure that RTSP is such a great match in a more constrained environment.
(And which RTSP do you like — 1.0 or 2.0?)
Obviously, if you have power and network bandwidth to do video, you are not that constrained.
But I could still imagine a more REST-style way to control the video streams.

Grüße, Carsten

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Thu, 30 Oct 2014 15:23:30 +0530

> RTP is actually a great protocol for streaming real-time video.

This was exactly what came to my mind first up.

> But I could still imagine a more REST-style way to control the video 
streams.

Modeling real-time streaming as RESTful exchange is really a good 
proposition. But, has anyone done any study (may be very specific to some 
usecase) regarding whether there is any scenario where existing stuffs 
like RTP may not be a good choice and would need some new lightweight 
solution (may be on CoAP)? It seems Real-time video streaming for IoT 
applications may find good  traction in future (not yet sure about exact 
usecase people may have).

What I inferred from 
https://tools.ietf.org/html/draft-loreto-core-coap-streaming-00 is that it 
is basically a variation of block-wise transfer over CoAP, but with 
observe relationship. The size of the block (chunk) is not negotiated 
though. Probably it is assumed that chunk-size has direct mapping with the 
Encoder chosen after the discover phase.(?) 
 
Regards
Abhijan Bhattacharyya
Associate Consultant

"core" <[email-masked]> wrote on 10/30/2014 01:49:01 AM:

> From: Carsten Bormann <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Date: 10/30/2014 01:49 AM
> Subject: Re: [core] Real Time Video over CoAP?
> Sent by: "core" <[email-masked]>
>

---

From: "weigengyu" <[email-masked]>
Date: Thu, 30 Oct 2014 20:20:13 +0800

Hi， 

If the CoAP server is supposed to have enough capabilities in terms of power and wireless link,
tranfering streaming data should be considered. 
And, supporting what kind of treaming data should be based on usage scenarios. 

This opinion is based a work serveral years ago.
The work is to develop a communication software between a watch and a smart mobilephone. 
The watch can transfer a file of electrocardiogram to the smart mobilephone after finishing detection. 
There are requirements for real-time monitoring and transfering; 
but, at that time it was regarded  invalid to deliver real time data  due the power and wireless link capacity. 

Best regards,

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Abhijan Bhattacharyya 
Sent: Thursday, October 30, 2014 5:53 PM
To: Carsten Bormann 
Cc: core ; [email-masked] 
Subject: Re: [core] Real Time Video over CoAP?

> But I could still imagine a more REST-style way to control the video streams.

Modeling real-time streaming as RESTful exchange is really a good proposition. But, has anyone done any study (may be very specific to some usecase) regarding whether there is any scenario where existing stuffs like RTP may not be a good choice and would need some new lightweight solution (may be on CoAP)? It seems Real-time video streaming for IoT applications may find good  traction in future (not yet sure about exact usecase people may have). 

What I inferred from https://tools.ietf.org/html/draft-loreto-core-coap-streaming-00 is that it is basically a variation of block-wise transfer over CoAP, but with observe relationship. The size of the block (chunk) is not negotiated though. Probably it is assumed that chunk-size has direct mapping with the Encoder chosen after the discover phase.(?)  
 
Regards
Abhijan Bhattacharyya
Associate Consultant

--------------------------------------------------------------------------------
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Fri, 31 Oct 2014 14:55:44 +0530

> There are requirements for real-time monitoring and transfering; 
That will also be my take. But we need to know how current 
state-of-the-art (like RTP) fares. May be a solution over CoAP will get 
rid of any connection establishment overhead and truely real-time than 
RTP? That is what I felt looking at the CoAP Streaming draft. 

Regards
Abhijan Bhattacharyya
Associate Consultant

"weigengyu" <[email-masked]> wrote on 10/30/2014 05:50:13 PM:

> From: "weigengyu" <[email-masked]>
> To: "Carsten Bormann" <[email-masked]>, "Abhijan Bhattacharyya" 
> <[email-masked]>
> Cc: <[email-masked]>
> Date: 10/30/2014 05:50 PM
> but, at that time it was regarded  invalid to deliver real time data
> due the power and wireless link capacity. 
> 
> Best regards,
> 
> Gengyu WEI
> proposition. But, has anyone done any study (may be very specific to
> some usecase) regarding whether there is any scenario where existing
> stuffs like RTP may not be a good choice and would need some new 
> lightweight solution (may be on CoAP)? It seems Real-time video 
> streaming for IoT applications may find good  traction in future 
> (not yet sure about exact usecase people may have). 
> 
> What I inferred from https://tools.ietf.org/html/draft-loreto-core-
> coap-streaming-00 is that it is basically a variation of block-wise 
> transfer over CoAP, but with observe relationship. The size of the 
> block (chunk) is not negotiated though. Probably it is assumed that 
> chunk-size has direct mapping with the Encoder chosen after the 
> discover phase.(?) 
> 
> Regards
> Abhijan Bhattacharyya
> Associate Consultant