Subject: [core] Group Communication published as RFC 7390

From: "Rahman, Akbar" <[email-masked]>
Date: Fri, 31 Oct 2014 11:15:02 +0000

FYI - As you may have noticed Groupcomm was just published as RFC 7390:

http://tools.ietf.org/html/rfc7390

 Thanks to Carsten, Zach and the many people in the WG who have supported us along the way.

Best Regards,

Akbar & Esko

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, October 30, 2014 8:16 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [core] RFC 7390 on Group Communication for the Constrained Application Protocol (CoAP)

A new Request for Comments is now available in online RFC libraries.

        RFC 7390

        Title:      Group Communication for the Constrained 
                    Application Protocol (CoAP) 
        Author:     A. Rahman, Ed.,
                    E. Dijk, Ed.
        Status:     Experimental
        Stream:     IETF
        Date:       October 2014
        Mailbox:    [email-masked], 
                    [email-masked]
        Pages:      46
        Characters: 106675
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-core-groupcomm-25.txt

        URL:        https://www.rfc-editor.org/rfc/rfc7390.txt

The Constrained Application Protocol (CoAP) is a specialized web transfer protocol for constrained devices and constrained networks.
It is anticipated that constrained devices will often naturally operate in groups (e.g., in a building automation scenario, all lights in a given room may need to be switched on/off as a group).
This specification defines how CoAP should be used in a group communication context.  An approach for using CoAP on top of IP multicast is detailed based on existing CoAP functionality as well as new features introduced in this specification.  Also, various use cases and corresponding protocol flows are provided to illustrate important concepts.  Finally, guidance is provided for deployment in various network topologies.

This document is a product of the Constrained RESTful Environments Working Group of the IETF.

EXPERIMENTAL: This memo defines an Experimental Protocol for the Internet community.  It does not specify an Internet standard of any kind. Discussion and suggestions for improvement are requested.
Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://www.ietf.org/mailman/listinfo/ietf-announce
  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see https://www.rfc-editor.org/search For downloading RFCs, see https://www.rfc-editor.org/rfc.html

Requests for special distribution should be addressed to either the author of the RFC in question, or to [email-masked].  Unless specifically noted otherwise on the RFC itself, all RFCs are for unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 31 Oct 2014 13:04:54 +0100

> http://tools.ietf.org/html/rfc7390

Thanks, Akbar and Esko, for keeping up the flame on this subject!

I have seen considerable interest in making group communication over
CoAP more useful, and this document is a good first start.
I expect that more people will come to the IETF with work in this area.

Gruesse, Carsten