Subject: [core] resource directory example

From: peter van der Stok <[email-masked]>
Date: Mon, 19 Jan 2015 10:29:43 +0100

Hi Zach,

I made a lighting installation example for the resource directory draft.
It became much larger than originally envisaged.
Have a look if you like it like this or that it really is far beyond 
target.

Text is included in section 12 example.
I also included the whole .xml text because I also corrected some other 
nits.

Greetings,

peter
-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked]
www: www.vanderstok.org
tel NL: +31(0)492474673     F: +33(0)966015248

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 19 Jan 2015 11:24:56 +0100

Hi Peter,

in your example luminary are configured with FQDNs.
Is this a realistic assumption (particularly when using the resource
directory).

Ciao
Hannes

On 01/19/2015 10:29 AM, peter van der Stok wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: peter van der Stok <[email-masked]>
Date: Mon, 19 Jan 2015 12:05:41 +0100

Hi Hannes,

thanks for your question.
There are two managers in the example:
1) the IP network manager (responsible for whole building network): who 
uses DNS and will probably use FQDN
2) the lighting manager: who manages the lighting application on the 
network and uses the RD.

I thought that pointing out the existence and separate responsibility of 
both is important.
May be I was not clear enough?
Or do you thing think that IP network managers will not use FQDN.

I did not work out the connection between both managing entities 
following section 9.
Using the Stuart image: in the example they are two ships passing in the 
night.

Greetings,

Peter

---

From: "Dijk, Esko" <[email-masked]>
Date: Mon, 19 Jan 2015 14:26:10 +0000

Peter,

I did not check this in detail - though seeing that you use link-local IPv6 addresses, it may be better to align with use of IPv6 address literals as in the RD draft currently and not to use link-local addresses .  (It uses e.g. <coap://[FDFD::1234]:61616/light/1> ) SLAAC can also configure global Ipv6 addresses.

Esko

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of peter van der Stok
Sent: Monday, January 19, 2015 10:30
To: Zach Shelby; carsten bormann
Cc: Core
Subject: [core] resource directory example

Hi Zach,

I made a lighting installation example for the resource directory draft.
It became much larger than originally envisaged.
Have a look if you like it like this or that it really is far beyond target.

Text is included in section 12 example.
I also included the whole .xml text because I also corrected some other nits.

Greetings,

peter

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.