Subject: Re: [core] 答复: CoAP over SMS Binding and Multiple CoAP Endpoints

From: "FOSSATI, Thomas (Thomas)" <[email-masked]>
Date: Tue, 20 Jan 2015 08:52:22 +0000

Hi Ruinan Sun,

On 20/01/2015 05:47, "Sunruinan" <[email-masked]> wrote:
>Hi all,
>I'm Ruinan Sun from Huawei. Just start to follow COAP work in IETF.
>For this issue, I think SMS protocol has provided one method:
>TP-UD(TP-User Data) can carry the application port information. An
>application entity is uniquely identified by the pair of
>TP-DA(TP-Destination-Address)/TP-OA (TP-Originating-Address)and the port
>address. Simliar as TCP/UDP ports in a TCP/IP network.

Yes, this is the gist of WDP over SMS.

---

From: "weigengyu" <[email-masked]>
Date: Wed, 21 Jan 2015 17:19:06 +0800

Hi,

>Yes, this is the gist of WDP over SMS.

In draft-fossati-dtls-over-gsm-sms-01,
'the Concatenated short messages mechanism SHOULD NOT be used.'

WDP has the capability of Segmentation and Reassembly.
Is it prohibited?

Regards,

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications
-----原始邮件----- 
From: FOSSATI, Thomas (Thomas)
Sent: Tuesday, January 20, 2015 4:52 PM
To: Sunruinan ; Carsten Bormann ; Carey, Timothy (Timothy) ; Maël Auzias
Cc: [email-masked]
Subject: Re: [core] 答复: CoAP over SMS Binding and Multiple CoAP Endpoints

Hi Ruinan Sun,

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: "FOSSATI, Thomas (Thomas)" <[email-masked]>
Date: Thu, 22 Jan 2015 11:42:34 +0000

Hi Gengyu,

>WDP has the capability of Segmentation and Reassembly.

no one prohibits using the UDH SAR IE to do segmentation and reassembly at
the WDP layer.

What is suggested in the DTLS/SMS I-D is to avoid doing SaR in two places
(one of which, DTLS, can't be bypassed).

Cheers, t

---

From: "weigengyu" <[email-masked]>
Date: Thu, 22 Jan 2015 23:16:24 +0800

Hi Thomas,

Thank you for explanation.
It is understood that the suggestion is to avoid doing SaR in two places.

In RFC 6347 Datagram Transport Layer Security Version 1.2,
3.2.3. Message Size
each DTLS handshake message may be fragmented over several DTLS records,
each of which is intended to fit in a single IP datagram.
When considering the default delivery CoAP/DTLS/UDP/IP,
The PMTU constraints the length of a single IP packet,  an UDP datagram, and 
a DTLS record.

When considering CoAP over SMS, the length of SMS functions as PMTU.
It is not clear what the advantage is to use CoAP/DTLS/WDP/SMS than to use 
CoAP/DTLS/UDP/SMS.

Regards,

Gengyu WEI
-----原始邮件----- 
From: FOSSATI, Thomas (Thomas)
Sent: Thursday, January 22, 2015 7:42 PM
To: weigengyu
Cc: [email-masked]
Subject: Re: [core] 答复: CoAP over SMS Binding and Multiple CoAP Endpoints

Hi Gengyu,

Cheers, t