Subject: [core] CoAP Block Transfer issue

From: Sharad Holani <[email-masked]>
Date: Fri, 23 Jan 2015 05:48:51 +0000 (GMT)

In block wise transfer , should the header be part of the payload and then a new header attached to it?

Or every block should have the original header?

Nothing is specified in the RFC about what to do with the header  of the CoAP message when transferring block wise.
If the size of the header itself is larger than blocksize then what should be done?

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 23 Jan 2015 08:09:19 +0100

> then a new header attached to it?

Hi Sharan,

can you be more specific about what you mean by "the header"?

Obviously, each CoAP message needs a header, but you are talking about a
header for the payload?

Grüße, Carsten

---

From: 고석갑 <[email-masked]>
Date: Fri, 23 Jan 2015 07:21:40 +0000

Hello Sharan,

In the block wise transfer, SZX or Block size considers payload size. We don't count CoAP HEADER(+pptions).
Every subsequent messages also have each different CoAP headers for example, 2.31 continue header in response messages.

- Softgear Ko

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Friday, January 23, 2015 4:09 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [core] CoAP Block Transfer issue

Hi Sharan,

Obviously, each CoAP message needs a header, but you are talking about a header for the payload?

Grüße, Carsten

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core