Subject: [core] Use of CON messages in Observe - who would this work in reliable transport bindings (TCP, Websockets)

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 17 Apr 2015 11:21:47 +0000

Team,

I was reading the current observe draft (draft-ietf-core-observe-16) and in section 4.5 transmission there is some text that I didn't quite understand how the processing would work without CON message support.

Specifically how can I meet this MUST without a CON?

A server that transmits notifications mostly in non-confirmable
messages MUST send a notification in a confirmable message instead of
a non-confirmable message at least every 24 hours. This prevents a
client that went away or is no longer interested from remaining in
the list of observers indefinitely.

It also seems like the messaging layer is very much part application layer (Request/Reply) - In fact the draft in section 4.5 says:

A notification can be sent in a confirmable or a non-confirmable
message. The message type used is typically application-dependent
and may be determined by the server for each notification
individually.
For example, for resources that change in a somewhat predictable or
regular fashion, notifications can be sent in non-confirmable
messages; for resources that change infrequently, notifications can
be sent in confirmable messages. The server can combine these two
approaches depending on the frequency of state changes and the
importance of individual notifications.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 17 Apr 2015 13:39:52 +0200

> the list of observers indefinitely.

Good point.  The TCP draft should probably point out that this
requirement is implicitly met by TCP's ACKs (a connection to a
non-existent host will time out at some point after sending data on it).

Grüße, Carsten

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 17 Apr 2015 12:16:21 +0000

Carsten,

Thanks for responding - the problem is that Observe blurs the message layer with the application layer processing.

This was one example others are in section 3.5 and 3.6 from the client perspective.
I guess we would have to also address these as well...

Almost like a matrix of CON message mappings (i.e., ACK, RST),  to the Reliable transport mechanism.

BR,
Tim

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Friday, April 17, 2015 6:40 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked] WG
Subject: Re: [core] Use of CON messages in Observe - who would this work in reliable transport bindings (TCP, Websockets)

> the list of observers indefinitely.

Good point.  The TCP draft should probably point out that this requirement is implicitly met by TCP's ACKs (a connection to a non-existent host will time out at some point after sending data on it).

Grüße, Carsten