Subject: [core] Asking about CoAP over WebSockets

From: "William" <[email-masked]>
Date: Tue, 31 May 2016 22:11:57 +0900

Hi,

I am trying to do an experiment with one client communicating with multiple
CoAP servers for some real scenarios.

Does anyone have experience or can figure out how can a client can make
multiple websocket connections to multiple CoAP servers at the same time?

Hope to have your support!

Many thanks,

William

Smart Furniture <http://cuddlyhomeadvisors.com/best-recliners/>  IoT
Research

---

From: Bill Silverajan <[email-masked]>
Date: Wed, 1 Jun 2016 01:07:17 +0300

Hi William,

If you meant a CoAP+WS client making multiple, independent connections 
to several CoAP+WS servers simultaneously with a 1:1 relationship, I'm 
not particularly aware of any client-side limitations that would impede 
such an implementation from being realised.

CoAP itself does not impose any such constraints, and the CoAP over 
WebSockets draft does not cover connection multiplexing in a single 
WebSocket session.

Perhaps it might help if you could provide a more concrete example of 
how or where the actual challenge lies?

Regards,
Bill

On 31/05/16 16:11, William wrote:
> Hi,
>
>
>
> I am trying to do an experiment with one client communicating with
> multiple CoAP servers for some real scenarios.
>
> Smart Furniture <http://cuddlyhomeadvisors.com/best-recliners/> IoT Research
>
>
>
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: "weigengyu" <[email-masked]>
Date: Wed, 1 Jun 2016 12:15:43 +0800

Hi Bill and William,

> If you meant a CoAP+WS client making multiple, independent connections to 
> several CoAP+WS servers simultaneously with a 1:1 relationship, I'm not 
> particularly aware of any client-side limitations that would impede such 
> an implementation from being realised.

Right!

>> multiple CoAP servers for some real scenarios.
Assume that it is not a group communications.
So you actually have multiple logic CoAP clients to communicate with CoAP 
severs each by each.

> WebSockets draft does not cover connection multiplexing in a single 

The draft needs little works.
When a Websockect Client at ( the CoAP) Client side setup a session with 
Websocket server side at a proxy,
One CoAP message can be sent in one Websocket frame along the same Websocket 
session.
The proxy does not need special awareness.

We are doing works of CoAP over Websocket by extending Californium.

Regards,

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications
-----原始邮件----- 
From: Bill Silverajan
Sent: Wednesday, June 01, 2016 6:07 AM
To: William ; [email-masked]
Subject: Re: [core] Asking about CoAP over WebSockets

Hi William,

Regards,
Bill