Subject: [core] 🔔 Working Group Adoption of draft-koster-core-coap-pubsub

From: Jaime Jiménez <[email-masked]>
Date: Mon, 15 Aug 2016 15:10:25 +0000

Dear CoRE-WG,

As we discussed at last IETF96, working group adoption has been requested for draft-koster-core-coap-pubsub. At the IETF meeting the room consensus was strongly supporting adoption (~10 people). Please reply to the list with your comments, including although not limited to whether or not you support adoption. Non-authors are especially encouraged to comment.

Since there are several concurrent WGA calls, we will end the call on August 26, 2016.

Thanks,
Jaime and Carsten

---

From: Christian Groves <[email-masked]>
Date: Fri, 26 Aug 2016 13:53:43 +1000

Hello,

I think pub sub functionality is useful for CoAP. Whilst the draft does 
need some work its appropriate to start a WG item.

Regards, Christian

On 16/08/2016 1:10 AM, Jaime Jiménez wrote:
> Dear CoRE-WG,
>
> As we discussed at last IETF96, working group adoption has been 
> requested for draft-koster-core-coap-pubsub. At the IETF meeting the 
> room consensus was strongly supporting adoption (~10 people). Please 
> reply to the list with your comments, including although not limited 
> to whether or not you support adoption. Non-authors are 
> especially encouraged to comment.
>
> Since there are several concurrent WGA calls, we will end the call on 
> *August 26, 2016*.
>
> Thanks,
> Jaime and Carsten
>
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: peter van der Stok <[email-masked]>
Date: Tue, 30 Aug 2016 12:34:55 +0200

Hi Michael,

I do support the draft, but have some questions after a first reading.

section 4 before 4.1; the operations are the functions?

In the discover section 4.1 the base location /ps is nowhere returned, 
only in the example this becomes clear.
Is this base /ps compulsory?
In the resource directory the base location is returned and the value 
/rd is recommended.
Would it not be better to recommend the value /ps here as well?
Does the resource type core.ps need to be declared to IANA?

The concept of "link to it's pubsub function set" is a bit complex for 
me; why not write /.well-known/core and /ps
Otherwise I recommend to introduce the "link to the pubsub function set" 
in section 2.

In section 4.2 Create.
If I understand correctly, "CREATE" <topic> creates a resource at the 
broker with path name /ps/topic
Why not describe it like that?

I do have problems with understanding what the value of the created 
resource is.
Is that a list of messages, or is that a set of named values described 
in the messages.
That is important to understand the most recent published value of a 
topic.
The content format of a the messages belonging to a topic is specified, 
but its contents is free.

Suppose a topic uses content formats application/json and 
application/merge-patch+json

Suppose two messages arrive at the broker
First message: application/json with {"name" : "topic1", "value" : 10}
Second message: application/merge-patch+json with {"name" : "topic2"}

The content of the  last message to subscribers is clear; but what does 
the READ return; Should that be {"name" : "topic2", "value" : 10}
or {"name" : "topic2"}, or both messages?

The answer is important with respect to section 6.

My personal preference is that the value of a pubsub resource is a set 
of messages.

Greetings,

peter

---

From: James Nguyen <[email-masked]>
Date: Tue, 30 Aug 2016 14:41:54 -0400

Hi,

I support this I-D as I think it's useful.

I have a question.

Section 3.5 Brokerless pubsub

- I suggest to move this section to section 3.1.

- This architecture is more applicable to CoAP Proxy.

- I also suggest to add the pubsub capability at CoAP Proxy.

James

On Mon, Aug 15, 2016 at 11:10 AM, Jaime Jiménez <[email-masked]>
wrote:

> Dear CoRE-WG,
>
> As we discussed at last IETF96, working group adoption has been requested
> for draft-koster-core-coap-pubsub. At the IETF meeting the room consensus
> was strongly supporting adoption (~10 people). Please reply to the list
> with your comments, including although not limited to whether or not you
> support adoption. Non-authors are especially encouraged to comment.
>
> Since there are several concurrent WGA calls, we will end the call on *August
> 26, 2016*.
>
> Thanks,
> Jaime and Carsten
>
>

-- 
James Nguyen
Email: [email-masked]

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 31 Aug 2016 12:23:44 +0200

Dear all,

+1 on the adoption of this draft. For me, the PubSub functionality is essential and without it we’re leaving a big hole in the CoAP realm.

There are of course things which we should discuss, and most have been pointed out by the other supporters. 

A point on which we should be aware is that if we want application level security, this will imply the use of Asymmetric keys / Certificates. If we want to keep PSK as a way of authentication, then probably we should provide some mechanisms for the Broker to be used as a trusted third-party, which validates the end-devices.

Best,
Alexander

> Le 30 août 2016 à 20:41, James Nguyen <[email-masked]> a écrit :
> 
> Hi,
> 
> On Mon, Aug 15, 2016 at 11:10 AM, Jaime Jiménez <[email-masked] <mailto:[email-masked]>> wrote:
> Dear CoRE-WG,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/core <https://www.ietf.org/mailman/listinfo/core>
> 
> 
> 
> 
> -- 
> James Nguyen
> Email: [email-masked] <mailto:[email-masked]>_______________________________________________
> core mailing list
> [email-masked]