Subject: [core] CoAP Content format encoding for structures syntax and format parameters

From: Michael Koster <[email-masked]>
Date: Fri, 19 Aug 2016 15:12:20 -0700

Hi,

What is the curent thought wrt the CoAP content-format encoding for structured syntax media identifiers, like link-format+json, senml+cbor? 

Does each combination need to have its own IANA registered code, or is there a scheme for structured identifier codes in CoAP?

Likewise, what is the preferred way to transmit media type parameters, for example with "application/senml+json; version=2" how do we transmit the version=2 part?

Best regards,

Michael

---

From: Christian Groves <[email-masked]>
Date: Fri, 26 Aug 2016 16:12:09 +1000

Hello Michael,

The current senml draft requests 6 identifiers for the various 
senml+(encoding) options. Looking at 
https://www.iana.org/assignments/media-types/media-types.xhtml 
registering each structured syntax suffix seems to be the practise.

With regards to the parameters wouldn't the parameters first have to be 
defined by the content-format registration? As senml+json doesn't have 
parameters "version=2" would not be possible. If you wanted to define 
parameters I suppose new link attribute would be needed?

Regards, Christian

On 20/08/2016 8:12 AM, Michael Koster wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>