Subject: [core] 🔔 Working Group Adoption call for draft-somaraju-core-sid

From: Jaime Jiménez <[email-masked]>
Date: Mon, 15 Aug 2016 15:06:40 +0000

Dear CoRE-WG,

As we discussed at last IETF96, working group adoption has been requested for draft-somaraju-core-sid. At the IETF meeting the room consensus was for adoption (3 people), since not too many people had read the draft we have to take it to the list. Please reply with your comments, including although not limited to whether or not you support adoption. Non-authors are especially encouraged to comment.

Since there are several concurrent WGA calls, we will end the call on August 26, 2016.

Thanks,
Jaime and Carsten

---

From: peter van der Stok <[email-masked]>
Date: Mon, 15 Aug 2016 17:26:47 +0200

Hi All,

Andy and I are preparing drafts which present alternatives (complements) 
to SID.
Also we are preparing a draft which specifies a a content format that 
specifies the payload format for that alternative.

Although I approve of the work done in the SID draft, I think that we 
first need to discuss the cited coming drafts because they may have an 
impact on the presentation
and scope of the SID draft.

Peter

Jaime Jiménez schreef op 2016-08-15 17:06:
> Dear CoRE-WG,
> 
> As we discussed at last IETF96, working group adoption has been
> requested for draft-somaraju-core-sid. At the IETF meeting the room
> consensus was for adoption (3 people), since not too many people had
> read the draft we have to take it to the list. Please reply with your
> comments, including although not limited to whether or not you support
> adoption. Non-authors are especially encouraged to comment.
> 
> Since there are several concurrent WGA calls, we will end the call on
> AUGUST 26, 2016.
> 
> Thanks,
> Jaime and Carsten
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 17 Aug 2016 16:22:25 +0200

Dear Peter,

Thanks for approving the work on the SID draft. 

It is indeed the generic work which follows a KISS rule - provide a ultra-light way of assigning ranges. This leaves the flexibility (and complexity) particular instances may wish to additional specification (e.g. be it the registry policy, or other).

Best,
Alexander

> Le 15 août 2016 à 17:26, peter van der Stok <[email-masked]> a écrit :
> 
> Hi All,
> 
> Andy and I are preparing drafts which present alternatives (complements) to SID.
> Also we are preparing a draft which specifies a a content format that specifies the payload format for that alternative.
> 
> Although I approve of the work done in the SID draft, I think that we first need to discuss the cited coming drafts because they may have an impact on the presentation

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 23 Aug 2016 10:37:12 +0200

Dear all,

I want to confirm my support for the adoption of the document draft-somaraju-core-sid (a.k.a. the SID draft).

I do so for the following main reasons:
- We need a way to represent YANG identifiers for the draft-ietf-core-yang-cbor. The SID draft provides just this. We must adopt the document if we want to move forward with the work on this WG item.
- The SID draft is the result of more than a year and a half of discussions with people from CoRE, NETMOD, IANA and other SDOs.
- It is a straightforward and simple document, which provides the minimal structure on top of which IDs can be allocated.
- It provides for a way of having multiple independent registries, keeping all interoperable, and relieving IANA from the need to do overcomplicated, per-device allocations.
- Running code. There is a tool and a registry which are already used for prototyping. 

The SID draft is aimed at:
- Interoperability (having devices with modules from different registries on a single network). 

- Future-proof. The authors understand that today there are less than 2000 YANG modules. Yet, the ranges which will be allocated are FOREVER. This means, that in 2046, we’ll still be allocating IDs from the ranges we provide today. Independently of the size of identifiers, delta-encoding provides for ultra-efficient data transfer. However, once we move over the 32-bit identifiers, we’ll be taking a 8-byte penalty hit per request. The SID draft provides for a very straightforward and simple way of allocating blocks of IDs as necessary for a module.

- Constrained-device and constrained-network oriented (if needed) - after months of discussions we have confirmed that the most efficient way of representing the data items is with delta-encoding. When retrieving more than one item, the IDs take one byte on the wire in most cases. The allocation of IDs can be manual, automatic, or other - this is not enforced. What the draft enables is the users to make use of this ultra-efficient identifier representation - if they need it. 
  - If not needed - an alternative mapping scheme can be used, e.g. trading interoperability and ultra-efficiency for compatibility with existing implementations.

In conclusion, we need the SID draft to be able to move forward with our WG item - the YANG-CBOR draft. 

Best,
Alexander

Disclaimer: I am one of the authors of the draft. I believe we could make adjustments after the adoption OR decide to have specific drafts for specific use-cases, but we should not spend too much time getting back-and-fourth in changing the WG draft. 

> Le 15 août 2016 à 17:06, Jaime Jiménez <[email-masked]> a écrit :
> 
> Dear CoRE-WG,
>

---

From: Michel Veillette <[email-masked]>
Date: Tue, 23 Aug 2016 20:35:23 +0000

+1

I also want to confirm my support for the adoption of (https://datatracker.ietf.org/doc/draft-somaraju-core-sid/) .

This draft is a fundamental building block for bringing YANG data models to CORE.
This draft is a prerequisite for the following works:

- CBOR encoding of YANG data model (https://datatracker.ietf.org/doc/draft-ietf-core-yang-cbor/)
- CoAP operation/function set (https://datatracker.ietf.org/doc/draft-veillette-core-cool/)
- YANG data model discovery (https://datatracker.ietf.org/doc/draft-veillette-core-cool-library/)

The alternate assignment algorithm of IDs based on murmur3 and improved description texts
proposed by Andy in (https://datatracker.ietf.org/doc/draft-bierman-core-yid/) don't fundamentally change
the registration process defined by the SID draft. These proposed improvements can be addressed during the review process.

Regards,
Michel Veillette

From: Alexander Pelov [mailto:[email-masked]]
Sent: Tuesday, August 23, 2016 4:37 AM
To: Jaime Jiménez <[email-masked]>
Cc: [email-masked] WG <[email-masked]>; [email-masked]
Subject: Re: [core] 🔔 Working Group Adoption call for draft-somaraju-core-sid

Dear all,

Best,
Alexander

Le 15 août 2016 à 17:06, Jaime Jiménez <[email-masked]<mailto:[email-masked]>> a écrit :

Dear CoRE-WG,

Thanks,
Jaime and Carsten

_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core

---

From: "Turner, Randy" <[email-masked]>
Date: Tue, 23 Aug 2016 21:37:35 +0000

+1

Confirming support for https://datatracker.ietf.org/doc/draft-somaraju-core-sid

This document is required capability for realizing extensible management frameworks and provides the basis
for a number of other constrained-friendly technology, including CBOR encoding of YANG models and reuse of CoAP
to carry these payloads. This work has been extensively reviewed and discussed on the mailing list(s) and at multiple plenaries
and the disposition of this work is considered ready for adoption.

BR,
Randy

On Aug 23, 2016, at 4:35 PM, Michel Veillette <[email-masked]<mailto:[email-masked]>> wrote:

+1

Regards,
Michel Veillette

From: Alexander Pelov [mailto:[email-masked]]
Sent: Tuesday, August 23, 2016 4:37 AM
To: Jaime Jiménez <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [core] 🔔 Working Group Adoption call for draft-somaraju-core-sid

Dear all,

Best,
Alexander

Dear CoRE-WG,

Thanks,
Jaime and Carsten

---

From: peter van der Stok <[email-masked]>
Date: Wed, 24 Aug 2016 08:39:47 +0200

Some comments based on the arguments below:

> - CBOR encoding of YANG data model
> (https://datatracker.ietf.org/doc/draft-ietf-core-yang-cbor/)
I have argued already for some time that the text about SIDs does not 
belong in the yang to cbor draft.
It reduces its independence from the CoMI work.
Given that CBOR is not to be changed, Putting the SID text in a content 
format draft seems more appropriate.
> 
> The alternate assignment algorithm of IDs based on murmur3 and
> improved description texts  proposed by Andy in
> (https://datatracker.ietf.org/doc/draft-bierman-core-yid/) don't
> fundamentally change the registration process defined by the SID draft.

I should like to wait till this agreement is visible on this mailing 
list.

Peter

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 24 Aug 2016 09:57:10 +0200

Dear Peter,

> Le 24 août 2016 à 08:39, peter van der Stok <[email-masked]> a écrit :
> 
> I have argued already for some time that the text about SIDs does not belong in the yang to cbor draft.
> Given that CBOR is not to be changed, Putting the SID text in a content format draft seems more appropriate.

There are two types of identifiers supported by draft-ietf-core-yang-cbor - textual (for full compatibility with RESTConf/NETCONF names) and delta-encoded integers (a.k.a. SIDs). The former could be used when network constraints are not so stringent, while the latter is the preferred way of using this encoding in constrained networks.

We should keep it simple. Having several content formats to express the same thing - especially when this is not necessary - is adding complexity for no reason. 

The SID draft allows for having ranges of SIDs be managed by independent registries and have different rules of assignment. No need to use different Content Formats necessary to solve overlapping of the integer values. Moreover, as of the time of this writing, we have 3 different Content-Formats for the CoOL/CoMI draft. Adding an alternative Content-Format for the interpretation of the integers would multiply this by 2, e.g. 6 content formats, where half are doing the same thing.

If you have a server with mixed modules (e.g. ones using SID and ones using a different interpretation of the IDs), the Content-Format will force you to chose ONE or ANOTHER. There is no possibility in one request to read or write values from different modules. This effectively removes all interoperability between the two, making one of the two redundant. 

Best,
Alexander

> I should like to wait till this agreement is visible on this mailing list.
> 
> Peter
>

---

From: Michel Veillette <[email-masked]>
Date: Wed, 24 Aug 2016 14:38:46 +0000

Hi Peter

What do you means by "content format draft"?
Is it something different than "draft-ietf-core-yang-cbor"?
And if so, how do we make the split?

The current work is based on the same approach used by https://tools.ietf.org/html/draft-ietf-netmod-yang-json-10.
In draft-ietf-netmod-yang-json, naming is fully defined.
If this is not done, we won’t be able to define the mapping of the following instances and datatypes: container, list, identityref , instance-identifier.

Regards,
Michel

-----Original Message-----
From: peter van der Stok [mailto:[email-masked]] 
Sent: Wednesday, August 24, 2016 2:40 AM
To: Michel Veillette <[email-masked]>
Cc: Jaime Jiménez <[email-masked]>; [email-masked] WG <[email-masked]>
Subject: Re: [core] 🔔 Working Group Adoption call for draft-somaraju-core-sid

Peter

---

From: Laurent Toutain <[email-masked]>
Date: Fri, 26 Aug 2016 11:50:46 +0200

Hi,

I support also the adoption. SID is a very compact notation needed for
constraint networks.

Laurent

On Mon, Aug 15, 2016 at 5:06 PM, Jaime Jiménez <[email-masked]>
wrote:

> Dear CoRE-WG,
>
> As we discussed at last IETF96, working group adoption has been requested
> for draft-somaraju-core-sid. At the IETF meeting the room consensus was for
> adoption (3 people), since not too many people had read the draft we have
> to take it to the list. Please reply with your comments, including although
> not limited to whether or not you support adoption. Non-authors are
> especially encouraged to comment.
>
> Since there are several concurrent WGA calls, we will end the call on *
> August 26, 2016*.
>
> Thanks,
> Jaime and Carsten
>
>

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 26 Aug 2016 11:55:51 +0000

Same here;

I support the adoption of draft-somaraju-core-sid

Pascal

From: core [mailto:[email-masked]] On Behalf Of Laurent Toutain
Sent: vendredi 26 août 2016 11:51
To: Jaime Jiménez <[email-masked]>
Cc: [email-masked]; [email-masked] WG <[email-masked]>
Subject: Re: [core] 🔔 Working Group Adoption call for draft-somaraju-core-sid

Hi,
I support also the adoption. SID is a very compact notation needed for constraint networks.
Laurent

On Mon, Aug 15, 2016 at 5:06 PM, Jaime Jiménez <[email-masked]<mailto:[email-masked]>> wrote:
Dear CoRE-WG,

Thanks,
Jaime and Carsten

--
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit :
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |  http://class.touta.in
| [email-masked]<mailto:[email-masked]>         | [email-masked]<mailto:[email-masked]>    |
+--------------------------+----------------------------------------+

---

From: "Kovatsch, Matthias" <[email-masked]>
Date: Fri, 26 Aug 2016 13:22:58 +0000

+1 for adoption

Enabling YANG for constrained network management through CBOR is useful.

While reading the draft, I noticed that the introduction, in particular the technical summary in the abstract, could be improved. Based on the document, it took me a while to understand what exactly is defined for CBOR and to what it corresponds in YANG and the classic conf protocols. It is really simple, thus I was surprised why it took so long to understand based on the text :)

Best regards
Matthias

Von: core [mailto:[email-masked]] Im Auftrag von Jaime Jiménez
Gesendet: Montag, 15. August 2016 17:07
An: [email-masked] WG
Cc: [email-masked]
Betreff: [core] 🔔 Working Group Adoption call for draft-somaraju-core-sid

Dear CoRE-WG,

Thanks,
Jaime and Carsten