Subject: Re: [core] Spencer Dawkins' Discuss on draft-ietf-core-http-mapping-14: (with DISCUSS and COMMENT)

From: "Fossati, Thomas (Nokia - GB)" <[email-masked]>
Date: Sun, 2 Oct 2016 11:23:19 +0000

Hi Alexey,

On 30/09/2016 18:49, "Alexey Melnikov" <[email-masked]> wrote:
>On 30 Sep 2016, at 02:51, Fossati, Thomas (Nokia - GB)
><[email-masked]> wrote:
>>>Can the HTTP client tell whether the result used coaps://?
>> 
>> No, if it's using the simple form and there is no OOB agreement.  So, I
>> guess the question is: do you think it'd be better to spell this out
>> explicitly?  If so, we could say that a Target CoAP URI without the
>>scheme
>> is not allowed unless there is an OOB agreement between client and HC
>> proxy (client MUST NOT emit / proxy MUST return 4xx on receipt).  Or do
>> you have something different in mind?
>
>An alternative is to always require coaps in this case. Might not work
>for your type of document though.

Yep.  But, in this case, I think it's better to fail early and hard (with
a 4xx on the HTTP side of the proxy), because we can safely assume that
the Target URI is syntactically incorrect.  This way we also avoid
injecting a (possibly useless) request in to the constrained network --
and returning a slightly confusing 504 in case the endpoint doesn't reply
back if it's not listening for coaps requests.

Cheers, t

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 3 Oct 2016 09:19:30 +0300

Hi Thomas,

> On 2 Oct 2016, at 14:23, Fossati, Thomas (Nokia - GB) <[email-masked]> wrote:
> 
> Hi Alexey,
> 

Fair enough.

---

From: "Fossati, Thomas (Nokia - GB)" <[email-masked]>
Date: Mon, 3 Oct 2016 18:15:33 +0000

Hi,

We have just posted -15 which should clear most of the comments and discuss points.

In particular, we addressed:
- Kathleen's DISCUSS and COMMENTs;
- Stephen's COMMENTs;
- Suresh's DISCUSS; and
- Spencer's DISCUSS and COMMENTs.

The diff is at https://www.ietf.org/rfcdiff?url1=draft-ietf-core-http-mapping-14&url2=draft-ietf-core-http-mapping-15 — please check if I forgot anything.

This should leave Stephen's DISCUSS as the only remaining item, which we plan to address in the next few days.

Thanks very much to everyone involved in the discussion so far.  Much appreciated.

Cheers, t.

On 03/10/2016 07:19, "Alexey Melnikov" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Thomas,

On 2 Oct 2016, at 14:23, Fossati, Thomas (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alexey,
On 30/09/2016 18:49, "Alexey Melnikov" <[email-masked]<mailto:[email-masked]>> wrote:
<[email-masked]<mailto:[email-masked]>> wrote:

Fair enough.

---

From: Jaime Jiménez <[email-masked]>
Date: Fri, 21 Oct 2016 15:14:24 +0000

Hi all,

Just to catch up on this. From the mails, to my understanding most of the comments have currently been addressed. As we are approaching the 31st Oct maybe we could do a quick recap of outstanding items. 

Much of Stephen’s comments have already been addressed by addressing Kathleen’s. If Stephen feels comfortable with the changes he can change the ballot or comment on the new version. The remaining ballot is Ben’s, that would require some changes to the phrasing to make sure the document remains informational in format.

Ciao,
- - Jaime Jiménez

> On 03 Oct 2016, at 21:15, Fossati, Thomas (Nokia - GB) <[email-masked]> wrote:
> 
> Hi,
> 
> The diff is at https://www.ietf.org/rfcdiff?url1=draft-ietf-core-http-mapping-14&url2=draft-ietf-core-http-mapping-15 <https://www.ietf.org/rfcdiff?url1=draft-ietf-core-http-mapping-14&url2=draft-ietf-core-http-mapping-15> — please check if I forgot anything.
> 
> On 03/10/2016 07:19, "Alexey Melnikov" <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi Thomas,
>> 
>>> On 2 Oct 2016, at 14:23, Fossati, Thomas (Nokia - GB) <[email-masked] <mailto:[email-masked]>> wrote:
>>> Hi Alexey,
>>>> On 30/09/2016 18:49, "Alexey Melnikov" <[email-masked] <mailto:[email-masked]>> wrote:
>>>> <[email-masked] <mailto:[email-masked]>> wrote:

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 21 Oct 2016 16:19:31 +0100

Hi Jaime,

On 21/10/2016 16:14, Jaime Jiménez wrote:
> Hi all,
>
> Just to catch up on this. From the mails, to my understanding most of 
> the comments have currently been addressed. As we are approaching the 
> 31st Oct maybe we could do a quick recap of outstanding items.
>
> Much of Stephen’s comments have already been addressed by addressing 
> Kathleen’s. If Stephen feels comfortable with the changes he can 
> change the ballot or comment on the new version. The remaining ballot 
> is Ben’s, that would require some changes to the phrasing to make sure 
> the document remains informational in format.
Or we change it to Proposed Standard.

Stephen's DISCUSS is still not addressed. Thomas, Stephen and I are 
hoping to arrange for a phone call to discuss. No specific date/time was 
set yet.
> Ciao,
> - - Jaime Jiménez
>
>> On 03 Oct 2016, at 21:15, Fossati, Thomas (Nokia - GB) 
>> The diff is at 
>> https://www.ietf.org/rfcdiff?url1=draft-ietf-core-http-mapping-14&url2=draft-ietf-core-http-mapping-15 — 
>> please check if I forgot anything.
>>
>>>> On 2 Oct 2016, at 14:23, Fossati, Thomas (Nokia - GB) 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: "Fossati, Thomas (Nokia - GB)" <[email-masked]>
Date: Fri, 21 Oct 2016 15:29:55 +0000

Hi Jaime,

We still have a couple of valid points raised by Larry that I'd like to address ASAP (early next week).

Then, as Alexey pointed out, Stephen's DISCUSS is still unresolved.  I'm going to try and arrange a call in next few days to understand the scope of Stephen's request.  Would you like to be involved?  (I think it'd be good having you on the call in your double role as co-chair and shepherd of the document.)

Cheers, t

From: Jaime Jiménez <[email-masked]<mailto:[email-masked]>>
Date: Friday, 21 October 2016 16:14
To: "Fossati, Thomas (Nokia - GB)" <[email-masked]<mailto:[email-masked]>>
Cc: Alexey Melnikov <[email-masked]<mailto:[email-masked]>>, Spencer Dawkins <[email-masked]<mailto:[email-masked]>>, The IESG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [core] Spencer Dawkins' Discuss on draft-ietf-core-http-mapping-14: (with DISCUSS and COMMENT)

Hi all,

Ciao,
- - Jaime Jiménez

On 03 Oct 2016, at 21:15, Fossati, Thomas (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Cheers, t.

Fair enough.

---

From: Jaime Jiménez <[email-masked]>
Date: Fri, 21 Oct 2016 15:32:57 +0000

Hi,

Ok, thanks, I missed the part about the call. I’d assume that changing it to Proposed Standard would trigger more comments from the rest of the reviewers, right? I think the original idea within the WG was to keep it as Informational but I guess the authors can decide. 

Thanks! 
- - Jaime Jiménez

> On 21 Oct 2016, at 18:19, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi Jaime,
> 
> 
> Stephen's DISCUSS is still not addressed. Thomas, Stephen and I are hoping to arrange for a phone call to discuss. No specific date/time was set yet.
>> Ciao,
>> - - Jaime Jiménez
>> 
>>> On 03 Oct 2016, at 21:15, Fossati, Thomas (Nokia - GB) <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi,
>>> 
>>>>>>>> Can the HTTP client tell whether the result used coaps://? <coaps://?>No, if it's using the simple form and there is no OOB agreement.  So, I
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/core <https://www.ietf.org/mailman/listinfo/core>
> 
>

---

From: Jaime Jiménez <[email-masked]>
Date: Fri, 21 Oct 2016 15:36:41 +0000

Hi,

Sounds good, sure I can join, no problem.

Ciao,
- - Jaime Jiménez

> On 21 Oct 2016, at 18:29, Fossati, Thomas (Nokia - GB) <[email-masked]> wrote:
> 
> Hi Jaime,
> 
> From: Jaime Jiménez <[email-masked] <mailto:[email-masked]>>
> To: "Fossati, Thomas (Nokia - GB)" <[email-masked] <mailto:[email-masked]>>
> Cc: Alexey Melnikov <[email-masked] <mailto:[email-masked]>>, Spencer Dawkins <[email-masked] <mailto:[email-masked]>>, The IESG <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>

---

From: "Fossati, Thomas (Nokia - GB)" <[email-masked]>
Date: Fri, 21 Oct 2016 15:38:40 +0000

Hi Jaime, excellent, thanks.

Date: Friday, 21 October 2016 16:36

Hi,

Ciao,
- - Jaime Jiménez

On 21 Oct 2016, at 18:29, Fossati, Thomas (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jaime,

Cheers, t

Hi all,

Ciao,
- - Jaime Jiménez

Hi,

Cheers, t.

Fair enough.

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 21 Oct 2016 16:45:40 +0100

Hi Jaime,

On 21/10/2016 16:32, Jaime Jiménez wrote:
> Hi,
>
> Ok, thanks, I missed the part about the call. I’d assume that changing 
> it to Proposed Standard would trigger more comments from the rest of 
> the reviewers, right?
It is possible, but unlikely. Most of IESG already reviewed the document 
anyway!

> I think the original idea within the WG was to keep it as 
> Informational but I guess the authors can decide.
>
> Thanks!
> - - Jaime Jiménez
>
>> On 21 Oct 2016, at 18:19, Alexey Melnikov <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi Jaime,
>>
>>
>>> Just to catch up on this. From the mails, to my understanding most 
>>> of the comments have currently been addressed. As we are approaching 
>>> the 31st Oct maybe we could do a quick recap of outstanding items.
>>>
>>> change the ballot or comment on the new version. The remaining 
>>> ballot is Ben’s, that would require some changes to the phrasing to 
>>> make sure the document remains informational in format.
>> hoping to arrange for a phone call to discuss. No specific date/time 
>> was set yet.
>>> Ciao,
>>> - - Jaime Jiménez
>>>
>>>> This should leave Stephen's DISCUSS as the only remaining item, 
>>>> which we plan to address in the next few days.
>>>>
>>>>>>>>> Can the HTTP client tell whether the result usedcoaps://?