Subject: Re: [core] 🔔 Working Group Adoption of draft-koster-core-coap-pubsub

From: Jaime Jiménez <[email-masked]>
Date: Tue, 18 Oct 2016 08:07:30 +0000

Dear CoRE-WG,

From the room and the email discussion there seems a clear consensus for adoption. As I am a coauthor, Carsten will be handling this draft. I believe that we will need to do several changes before it is in shape and we would welcome comments and reviewers for it. Peter van der Stok and James Nguyen provided useful input, maybe the authors can take it form there and revise the document accordingly. 

Authors please resubmit the current draft as draft-ietf-core-coap-pubsub-00.txt 
This draft is not being tracked at the moment on https://github.com/core-wg/ <https://github.com/core-wg/>  but if the authors consider it appropriate they can add it there.

Thanks,
- - Jaime Jiménez

> On 31 Aug 2016, at 13:23, Alexander Pelov <[email-masked]> wrote:
> 
> Dear all,
> 
> +1 on the adoption of this draft. For me, the PubSub functionality is essential and without it we’re leaving a big hole in the CoAP realm.
> 
> There are of course things which we should discuss, and most have been pointed out by the other supporters. 
> 
> A point on which we should be aware is that if we want application level security, this will imply the use of Asymmetric keys / Certificates. If we want to keep PSK as a way of authentication, then probably we should provide some mechanisms for the Broker to be used as a trusted third-party, which validates the end-devices.
> 
> Best,
> Alexander
> 
> 
>> Le 30 août 2016 à 20:41, James Nguyen <[email-masked] <mailto:[email-masked]>> a écrit :
>> 
>> Hi,
>> 
>> I support this I-D as I think it's useful.  
>> 
>> I have a question.
>> 
>> Section 3.5 Brokerless pubsub
>> 
>> - I suggest to move this section to section 3.1.
>>  
>> - This architecture is more applicable to CoAP Proxy.  
>> 
>> - I also suggest to add the pubsub capability at CoAP Proxy.
>> 
>> James
>> 
>> 
>> On Mon, Aug 15, 2016 at 11:10 AM, Jaime Jiménez <[email-masked] <mailto:[email-masked]>> wrote:
>> Dear CoRE-WG,
>> 
>> As we discussed at last IETF96, working group adoption has been requested for draft-koster-core-coap-pubsub. At the IETF meeting the room consensus was strongly supporting adoption (~10 people). Please reply to the list with your comments, including although not limited to whether or not you support adoption. Non-authors are especially encouraged to comment.
>> 
>> Since there are several concurrent WGA calls, we will end the call on August 26, 2016.
>> 
>> Thanks,
>> Jaime and Carsten
>> 
>> 
>> _______________________________________________
>> core mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/core <https://www.ietf.org/mailman/listinfo/core>
>> 
>> 
>> 
>> 
>> -- 
>> James Nguyen
>> Email: [email-masked] <mailto:[email-masked]>_______________________________________________
>> core mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/core
>

---

From: Michael Koster <[email-masked]>
Date: Fri, 21 Oct 2016 09:08:02 -0700

Hi Jaime,

I submitted the wg draft. How does adding the draft to the core github work? Do I need to be invited as a member of the org and make a repo? 

Thanks,

Michael

> On Oct 18, 2016, at 1:07 AM, Jaime Jiménez <[email-masked]> wrote:
>

---

From: Michael Koster <[email-masked]>
Date: Fri, 21 Oct 2016 09:09:29 -0700

Oh wait you're an author. You could add it to the CoRE Github repo. 

Cheers,

Michael

> On Oct 21, 2016, at 9:08 AM, Michael Koster <[email-masked]> wrote:
> 
> Hi Jaime,
> 
>> On Oct 18, 2016, at 1:07 AM, Jaime Jiménez <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 24 Oct 2016 10:30:54 +0000

Hehe, yes. I can add the repo no problem. 
I will do as with interfaces and dynlink

- - Jaime Jiménez

> On 21 Oct 2016, at 19:09, Michael Koster <[email-masked]> wrote:
> 
>> On Oct 21, 2016, at 9:08 AM, Michael Koster <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Jaime,
>>

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 24 Oct 2016 10:38:17 +0000

Michael, could you send me the latest markdown version? 

The repo is https://github.com/core-wg/pubsub but I need the current draft to make it.
Do we actually have a markdown version of the doc? It’d be nice, otherwise I can see to convert the current XML one when I have a bit of time. If that’s OK with you of course.

Ciao,
- - Jaime Jiménez

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 24 Oct 2016 15:08:41 +0000

Hi Michael,

the new version is now available at the repo: https://github.com/core-wg/pubsub <https://github.com/core-wg/pubsub>
Thanks Carsten for the quick translation to Markdown and the help setting ghpages.

We can continue off-list now. 

Ciao,
- - Jaime Jiménez

> On 24 Oct 2016, at 13:38, Jaime Jiménez <[email-masked]> wrote:
> 
> The repo is https://github.com/core-wg/pubsub <https://github.com/core-wg/pubsub> but I need the current draft to make it.
>> On 21 Oct 2016, at 19:09, Michael Koster <[email-masked] <mailto:[email-masked]>> wrote:
>>