Subject: [core] 🔔 WGLC on draft-ietf-core-coap-tcp-tls

From: Jaime Jiménez <[email-masked]>
Date: Tue, 18 Oct 2016 09:22:16 +0000

Dear CoRE WG,

The core-coap-tcp-tls draft has gotten to a state that the authors feel is in good shape for WGLC. 
We would like to ask the group to start checking this last version and the issues on the Github repository. 

https://tools.ietf.org/html/draft-ietf-core-coap-tcp-tls-05 <https://tools.ietf.org/html/draft-ietf-core-coap-tcp-tls-05>  

There is at the moment one open issue left in the tracker ( https://github.com/core-wg/coap-tcp-tls/issues/31 <https://github.com/core-wg/coap-tcp-tls/issues/31>  ) which is mostly editorial. The issues raised during last IETF - about Observe over reliable transports -  have been closed and new text has been added to the appendix: https://github.com/core-wg/coap-tcp-tls/issues/5 <https://github.com/core-wg/coap-tcp-tls/issues/5> 

Best Regards,
- - Jaime Jiménez

---

From: "weigengyu" <[email-masked]>
Date: Fri, 28 Oct 2016 16:34:39 +0800

Hi， 

There is one question. 

In this draft, it includes “ 2.2. UDP-to-TCP gateways”
This seems to imply that CoAP runs over UDP, then goes through a gateway of “UDP-to-TCP”, and CoAP runs over TCP. 
By CoAP request/response semantics,  if a CoAP request goes through the gateway of “UDP-to-TCP”,
the CoAP response will go through  the gateway of “TCP-to-UDP”. 
With the gateway of “TCP-to-UDP” CoAP can work at least. 

Where is the place of the specitications of “TCP-to-UDP gateway” ?

Regards, 

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Jaime Jiménez 
Sent: Tuesday, October 18, 2016 5:22 PM
To: mailto:[email-masked] 
Cc: Klaus Hartke ; [email-masked] ; Hannes Tschofenig 
Subject: [core] 🔔 WGLC on draft-ietf-core-coap-tcp-tls

Dear CoRE WG,

https://tools.ietf.org/html/draft-ietf-core-coap-tcp-tls-05  

There is at the moment one open issue left in the tracker ( https://github.com/core-wg/coap-tcp-tls/issues/31  ) which is mostly editorial. The issues raised during last IETF - about Observe over reliable transports -  have been closed and new text has been added to the appendix: https://github.com/core-wg/coap-tcp-tls/issues/5 

Best Regards,
- - Jaime Jiménez

--------------------------------------------------------------------------------
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core