Subject: [decade] 答复: WG review of draft-ietf-decade-integration-example-02

From: Chenxiaohui <[email-masked]>
Date: Wed, 11 Jan 2012 01:13:20 +0000

Thanks for your comments.

·         I think the document could generally be improved if the following information were added (or expanded):

o   Some more details of the actual protocols used in the different integration scenarios should be given.  For example, what were the underlying protocols for the “P2P LiveStreaming Client (P2PLS)”?   As an example, HTTP/TCP are the protocols used for web browsing.  What were the protocols for P2PLS?  Also some details for the protocols should be given even for the “BitTorrent” example.  As not all readers will have knowledge of how BitTorrent works.

o   Some more details of the file/object naming scheme used in the different integration scenarios should be given.  This is a critical part of DECADE and the approached used in the experiments for naming must be given for a complete understanding of what was done.

o   In the Intro (and elsewhere) there needs to be some clear references to DECADE WG documents such as the Problem Statement, Requirements or Architecture (and the associated concepts defined in those documents).  Note that there can be deviations from the concepts defined in the DECADE WG documents, but these need to be clearly explained.

·         Some detailed comments on specific sections:

o   The Abstract is a bit detailed and it is hard to understand.  For example there should not be a list (points 1-6) in an abstract.

o   In section 2.9 (Remote Controller), I did not understand what “a major operating platform” meant?

o   I did not understand the “limited connection slot” issue (sec. 4.2.1).  My understanding is that a DECADE client will have an association with a given DECADE server, and not every other possible server.  Is this the assumption that was used in the integration?

o   Editorial: The word DECADE is spelled incorrectly in Figure 2 and 3.

o   I did not understand the relation between a DECADE client and server in the ALTO + DECADE integration (section 6)?  Does ALTO get invoked for both PUT and GET from a DECADE client?  Or is it only for a GET?

§  Similarly, I did not understand the Performance Analysis of the ALTO+DECADE Performance Analysis (section 8.2.3).

o   Should better define what a “small instance” is in the Amazon EC2 framework (section 7.2.1)

o   A short Conclusion section should be added to the document briefly summarizing the lessons learned and some suggestions for the DECADE design.  As right now the conclusions are spread over several sections.

o   The Security section (sec. 9) should not be empty as there must have been some security related assumptions in the integration.  For example, was any DECADE client able to read from any DECADE server without authentication?  Yes or No?  Either way this should be described.  (In section 5.3, for example, there was a reference to an “authorization token”).

         ----good advice, we will  perfect them next version.

For the comment from Ning Zong, sure, there are some problem as following, we will address them next version also.
I also have following comments & suggestions:

1)      In Section 1 “Introduction”, it seems that only P2P live streaming is mentioned. We should also mention file sharing application (e.g. Vuze) and Content Distribution Platform for CP;

2)      In Section 2, “DECADE Module” and “DECADE Plugin” should be the same. We should merge these two definition and use one term in the whole draft.

3)      In Section 2, “DECADE-Enabled Vuze” is covered by “DECADE Client”. In the whole draft, we could either use two terms – “DECADE-enabled Vuze” & “DECADE-enable PPLS”, or just use “DECADE Client” for general purpose.

4)      I think Section 6 needs more editorial work.

5)      In Section 6, I think we’d better to call it “content distribution platform for CP” rather than “ALTO+DECADE platform”, as we don’t focus on describing an ALTO+DECADE architecture in this draft.

6)      In Section 6, we’d better to use DECADE service provider rather than ISP in Figure 4. We also need more explanation to Figure 4, as the connections are unclear, e.g. are these data or signaling links? Do we need more components such as ALTO server and content origins?

7)      In Section 7, test settings for distribution platform for CP is missing, e.g. how many and which types of servers are used, which CPs are tested?

8)      In Section 8, I think we’d better to give a content distribution performance example, e.g. how long to complete a content distribution, to how many users, how about the bandwidth usage?

From: Songhaibin
Sent: Friday, December 23, 2011 5:06 PM
To: 'Rahman, Akbar'; [email-masked]
Subject: RE: WG review of draft-ietf-decade-integration-example-02

Hi Akbar,

Thanks for the comments. The authors please discuss/address these comments.

BR,
-Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Tuesday, November 29, 2011 3:17 PM
To: [email-masked]
Subject: [decade] WG review of draft-ietf-decade-integration-example-02

Hi,

As per the request of the DECADE chairs in IETF 82, I did a review of the “Integration Examples of DECADE System” (draft-ietf-decade-integration-example-02) and have the following comments:

·         Overall, I found the document very useful in providing excellent insights into how DECADE could be used in a real network.  Also, I took it as a good example of “running code” for DECADE.  Thanks for the good work!

·         I think the document could generally be improved if the following information were added (or expanded):

o   Some more details of the actual protocols used in the different integration scenarios should be given.  For example, what were the underlying protocols for the “P2P LiveStreaming Client (P2PLS)”?   As an example, HTTP/TCP are the protocols used for web browsing.  What were the protocols for P2PLS?  Also some details for the protocols should be given even for the “BitTorrent” example.  As not all readers will have knowledge of how BitTorrent works.

o   Some more details of the file/object naming scheme used in the different integration scenarios should be given.  This is a critical part of DECADE and the approached used in the experiments for naming must be given for a complete understanding of what was done.

o   In the Intro (and elsewhere) there needs to be some clear references to DECADE WG documents such as the Problem Statement, Requirements or Architecture (and the associated concepts defined in those documents).  Note that there can be deviations from the concepts defined in the DECADE WG documents, but these need to be clearly explained.

·         Some detailed comments on specific sections:

o   The Abstract is a bit detailed and it is hard to understand.  For example there should not be a list (points 1-6) in an abstract.

o   In section 2.9 (Remote Controller), I did not understand what “a major operating platform” meant?

o   I did not understand the “limited connection slot” issue (sec. 4.2.1).  My understanding is that a DECADE client will have an association with a given DECADE server, and not every other possible server.  Is this the assumption that was used in the integration?

o   Editorial: The word DECADE is spelled incorrectly in Figure 2 and 3.

o   I did not understand the relation between a DECADE client and server in the ALTO + DECADE integration (section 6)?  Does ALTO get invoked for both PUT and GET from a DECADE client?  Or is it only for a GET?

§  Similarly, I did not understand the Performance Analysis of the ALTO+DECADE Performance Analysis (section 8.2.3).

o   Should better define what a “small instance” is in the Amazon EC2 framework (section 7.2.1)

o   A short Conclusion section should be added to the document briefly summarizing the lessons learned and some suggestions for the DECADE design.  As right now the conclusions are spread over several sections.

o   The Security section (sec. 9) should not be empty as there must have been some security related assumptions in the integration.  For example, was any DECADE client able to read from any DECADE server without authentication?  Yes or No?  Either way this should be described.  (In section 5.3, for example, there was a reference to an “authorization token”).

That’s all.

Akbar

---

From: Chenxiaohui <[email-masked]>
Date: Thu, 12 Jan 2012 03:37:05 +0000

For the questions, I will explain as following:

         ------HTTP is the protocol used for P2PLS. Some details for the protocol like “BitTorrent” will be given in next version.

o   Some more details of the file/object naming scheme used in the different integration scenarios should be given.  This is a critical part of DECADE and the approached used in the experiments for naming must be given for a complete understanding of what was done.
                                        ------We will give them in next version.

                        ------We will explain them in next version.

o   The Abstract is a bit detailed and it is hard to understand.  For example there should not be a list (points 1-6) in an abstract.
                                     ------Good advice, We will perfect the “Abstract” in next version

o   In section 2.9 (Remote Controller), I did not understand what “a major operating platform” meant?
                                    ------“a major operating platform” means: in the trail, we always use “Remote Controller” to control Vuze server and Vuze clients,
                                               We look Remote Controller as a operating platform to start/stop a trail, and collect debug information.

------Yes, It is an assumption under the condition that if only one DECADE Server in storage network.

o   Editorial: The word DECADE is spelled incorrectly in Figure 2 and 3.
                                    ------ We will perfect the “Abstract” in next version

------In principle, ALTO can service both PUT and GET.

                    ------ The Performance Analysis present the using rate of bandwidth in each DECADE Server and total online users can be support in One

                             DECADE Server.

                     ------We will define it in next version.

                     ------We will add in next version.

                     ------No, authentication is needed, We will add it in next version.

------We will perfect it in next version.

           ------OK, We will perfect it in next version.

           ------OK, We will perfect it in next version.

4)      I think Section 6 needs more editorial work.
                   ------OK, We will perfect it in next version.

5)      In Section 6, I think we’d better to call it “content distribution platform for CP” rather than “ALTO+DECADE platform”, as we don’t focus on describing an ALTO+DECADE architecture in this draft.
                   ------OK, We will perfect it in next version.

6)      In Section 6, we’d better to use DECADE service provider rather than ISP in Figure 4. We also need more explanation to Figure 4, as the connections are unclear, e.g. are these data or signaling links? Do we need more components such as ALTO server and content origins?
                  ------OK, We will perfect it in next version.

7)      In Section 7, test settings for distribution platform for CP is missing, e.g. how many and which types of servers are used, which CPs are tested?
                   ------OK, We will add test setting in next version.

8)      In Section 8, I think we’d better to give a content distribution performance example, e.g. how long to complete a content distribution, to how many users, how about the bandwidth usage?
                   ------OK, We will perfect it in next version.

发件人: [email-masked] [mailto:[email-masked]] 代表 Chenxiaohui
发送时间: 2012年1月11日 9:13
收件人: [email-masked]
抄送: Lijiang Chen; Weihanyu; Hongqiang Liu; Andy Huang(Zhigang)
主题: [decade] 答复: WG review of draft-ietf-decade-integration-example-02

9)      In Section 1 “Introduction”, it seems that only P2P live streaming is mentioned. We should also mention file sharing application (e.g. Vuze) and Content Distribution Platform for CP;

10)   In Section 2, “DECADE Module” and “DECADE Plugin” should be the same. We should merge these two definition and use one term in the whole draft.

11)   In Section 2, “DECADE-Enabled Vuze” is covered by “DECADE Client”. In the whole draft, we could either use two terms – “DECADE-enabled Vuze” & “DECADE-enable PPLS”, or just use “DECADE Client” for general purpose.

12)   I think Section 6 needs more editorial work.

13)   In Section 6, I think we’d better to call it “content distribution platform for CP” rather than “ALTO+DECADE platform”, as we don’t focus on describing an ALTO+DECADE architecture in this draft.

14)   In Section 6, we’d better to use DECADE service provider rather than ISP in Figure 4. We also need more explanation to Figure 4, as the connections are unclear, e.g. are these data or signaling links? Do we need more components such as ALTO server and content origins?

15)   In Section 7, test settings for distribution platform for CP is missing, e.g. how many and which types of servers are used, which CPs are tested?

16)   In Section 8, I think we’d better to give a content distribution performance example, e.g. how long to complete a content distribution, to how many users, how about the bandwidth usage?

From: Songhaibin

Hi Akbar,

BR,
-Haibin

Hi,

That’s all.

Akbar