Subject: Re: [decade] I-D Action: draft-ietf-decade-reqs-06.txt

From: ALEX <[email-masked]>
Date: Mon, 2 Jul 2012 12:27:58 +0800 (CST)

A quick question needs clarification:
 
"4.4.5.  Offline Usage
   REQUIREMENT(S):  A DECADE-compatible client MAY provide authorized
       access from remote clients to its in-network storage even if the
       DECADE client is actively running or connected to a DECADE-
       compatible server."
 
Should it be  " ....even if the DECADE client is NOT actively running or connected to a DECADE-
compatible server...." ? Or I mis-understood the point here?

At 2012-03-13 04:47:23,[email-masked] wrote:
>
>A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Decoupled Application Data Enroute Working Group of the IETF.
>
>	Title           : DECADE Requirements
>	Author(s)       : Yingjie Gu
>                          David A. Bryan
>                          Yang Richard Yang
>                          Richard Alimi
>	Filename        : draft-ietf-decade-reqs-06.txt
>	Pages           : 23
>	Date            : 2012-03-12
>
>   The target of the DECoupled Application Data Enroute (DECADE) system
>   is to provide an open and standard in-network storage system for
>   applications, primarily P2P (peer-to-peer) applications, to store,
>   retrieve and manage their data.  This draft enumerates and explains
>   requirements, not only for storage and retrieval, but also for data
>   management, access control and resource control, that should be
>   considered during the design and implementation of a DECADE-
>   compatible system.  These are requirements on the entire system; some
>   of the requirements may eventually be implemented by an existing
>   protocol with/without some extensions (e.g., a protocol used to read
>   and write data from the storage system).  The requirements in this
>   document are intended to ensure that a DECADE-compatible system
>   architecture includes all of the desired functionality for intended
>   applications.
>
>
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-ietf-decade-reqs-06.txt
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>This Internet-Draft can be retrieved at:
>ftp://ftp.ietf.org/internet-drafts/draft-ietf-decade-reqs-06.txt
>

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 2 Jul 2012 13:48:27 +0800

Dear Alex,

> compatible server...." ? Or I mis-understood the point here?

You are right. It is a typo that we will fix. Thanks for pointing it out.

Richard

>
> At 2012-03-13 04:47:23,[email-masked] <javascript:_e({}, 'cvml', [email-masked]');> wrote:
> >
> It