Subject: Re: [decade] FW: I-D Action: draft-ietf-decade-integration-example-04.txt

From: "C. Alexandre Tian" <[email-masked]>
Date: Sat, 7 Jul 2012 13:25:35 +0800 (CST)

Hi Ning,

I just reviewed the new revision. Thanks for the efforts!

A quick comment for "6. Integration of ALTO and INS System for File Distribution" is that: the scenario setting seems quit complex, which includes both ALTO and INS extension in browsers. The complexity directly makes the readers wondering: what is the killer-app that could serve as the motivation of such a complex system? My opinion is that a simple setting would help the audience understanding the broad-applicability and benefits of DECADE.

Let’s exploit the value of DECADE from the reverse direction: check the state-of-art of a specific content distribution technology; figure out why DECADE could make its design much better.

Hereby I give an example. I have been involved in a “transparent cache” project. To reduce the backbone traffic, ISP deploys “transparent cache” for a leading VoD CP in network edge. Note that this technique has become more and more prevalent. However, due to the information isolation between ISP and CP, this in-network storage does not perform well as it should be. I am thinking of changing the transparent caches to INS servers. The CP can directly write/configure the storage; CP then use http-redirection to direct clients to INS servers.

In this example, CP, instead of INS, interact w/wo ALTO service.  INS servers become dump Software-Definable-Network-Storage. It only needs to support the INS server interface and standard HTTP protocol. INS client in End-User could be skipped in this scenario.

The example can convey two information (which I think also relates with WG recharter)

(1)  INS Client is only optional

(2) Besides P2P applications, DECADE has a great value to general content distribution networks, which is more important in nowadays Internet.  

Alexandre

At 2012-06-21 11:18:17,Zongning <[email-masked]> wrote:
>Hi, Folks,
>
>Please see the new revision of DECADE integration examples draft.
>Thanks to Rich. Alimi, Akbar, Haibin for your valuable comments. Please let me know if any comments are still not addressed in the new revision.
>
>-Ning
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>> Of [email-masked]
>> Sent: Thursday, June 21, 2012 11:14 AM
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: [decade] I-D Action: draft-ietf-decade-integration-example-04.txt
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>  This draft is a work item of the Decoupled Application Data Enroute Working
>> Group of the IETF.
>> 
>> 	Title           : Integration Examples of DECADE System
>> 	Author(s)       : Ning Zong
>>                           Xiaohui Chen
>>                           Zhigang Huang
>>                           Lijiang Chen
>>                           Hongqiang Liu
>> 	Filename        : draft-ietf-decade-integration-example-04.txt
>> 	Pages           : 23
>> 	Date            : 2012-06-20
>> 
>> Abstract:
>>    Decoupled Application Data Enroute (DECADE) system is an in-network
>>    storage infrastructure which is still under discussion in IETF.  This
>>    document presents two detailed examples of how to integrate such in-
>>    network storage infrastructure into peer-to-peer (P2P) applications
>>    to achieve more efficient content distribution, and Application Layer
>>    Traffic Optimization (ALTO) system to build a content distribution
>>    platform for Content Providers (CPs).
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-decade-integration-example
>> 
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/draft-ietf-decade-integration-example-04
>> 
>> A diff from previous version is available at:
>> http://tools.ietf.org/rfcdiff?url2=draft-ietf-decade-integration-example-04
>> 
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>

---

From: Zongning <[email-masked]>
Date: Mon, 9 Jul 2012 06:10:20 +0000

Hi, Chen,

Thank you for your valuable comments. Please see in-line.

From: C. Alexandre Tian [mailto:[email-masked]]
Sent: Saturday, July 07, 2012 1:26 PM
To: Zongning
Cc: [email-masked]
Subject: Re:[decade] FW: I-D Action: draft-ietf-decade-integration-example-04.txt

Hi Ning,

[Ning]: In the draft, the end-user browser only needs to support INS extension, and the ALTO is between INS portal and ALTO server. Anyway I agree that what you have suggested - simple decoupled structure is very beneficial to DECADE.

Let's exploit the value of DECADE from the reverse direction: check the state-of-art of a specific content distribution technology; figure out why DECADE could make its design much better.

[Ning]: This is good design pattern indeed...

Hereby I give an example. I have been involved in a "transparent cache" project. To reduce the backbone traffic, ISP deploys "transparent cache" for a leading VoD CP in network edge. Note that this technique has become more and more prevalent. However, due to the information isolation between ISP and CP, this in-network storage does not perform well as it should be. I am thinking of changing the transparent caches to INS servers. The CP can directly write/configure the storage; CP then use http-redirection to direct clients to INS servers.

[Ning]: One open issue of the integration of ALTO and INS system is who will deploy which part of the system. There could be multiple options including 1) ISP deploys dumb INS servers + CP controls whole content distribution; 2) ISP deploys and manages INS servers and provides portal + CP talks to the portal; 3) third-party broker deploys the INS system + CP talks to the broker; etc. Which one of these options is most suitable to ISP/CP could be interesting question and we welcome more discussions on this list.

[Ning]: I agree that how DECADE could be valuable to more general content distribution system is important to DECADE re-charter discussion. Designing DECADE as a software-definable content distribution platform is an interesting direction.

Alexandre

>> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf

>> Of [email-masked]<mailto:[email-masked]>

>> To: [email-masked]<mailto:[email-masked]>

>> Cc: [email-masked]<mailto:[email-masked]>