Subject: Re: [eman] Temperature

From: Bruce Nordman <[email-masked]>
Date: Tue, 31 Jan 2012 16:34:56 -0800

I'd like to return to this thread from October and come to resolution.
I don't recall any objection to this on the list or at the meeting in
Taipei.

My proposal was for a single, optional, variable for an entire device for
the ambient air temperature around the device.  There would be no
complexities like internal temperatures or representations of accuracy.

Doing a google search on"temperature site:datatracker.ietf.org"
produces links to documents that seem to point to temperature as
something that may be important or may be communicated, but do
not speak directly to how it is communicated.  There are several
references to temperature-based alarms, e.g. RFC 3877.
None seem to speak to how temperature should be represented
(except for an April 1 RFC for coffee-pot internal temperature,
an integer32 of degrees Centigrade).

Ambient temperatures may be negative, but I think that integral
Centigrade values should be sufficient for energy management purposes.

Which MIB would this go into?

--Bruce

On Tue, Oct 11, 2011 at 1:45 PM, Ira McDonald <[email-masked]>wrote:

> Hi Bruce,
>
> I agree - whole device ambient temperature - not internal
> temperature at or near components (they have their own
> operational sensors where needed in hardcopy devices).
>
>
> Cheers,
> - Ira
>
>
> Ira McDonald (Musician / Software Architect)
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG IPP WG
> Chair - TCG Embedded Systems Hardcopy SG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music/High North Inc
> http://sites.google.com/site/blueroofmusic
> http://sites.google.com/site/highnorthinc
> mailto:[email-masked]
> Winter  579 Park Place  Saline, MI  48176  734-944-0094
> Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434
>
>
>
> On Tue, Oct 11, 2011 at 4:07 PM, Bruce Nordman <[email-masked]> wrote:
>
>> I have in mind just a single ambient temperature value for the entire
>> device
>> (not for components that is).  A management system could query the device
>> as often as it cares to track max, min, average, etc.
>>
>> If someone else wants to propose *internal* temperatures, which would
>> then
>> be appropriate by component, they can - but that is distinct from what I
>> have raised.
>>
>> Thanks,
>>
>> --Bruce
>>
>>
>> On Mon, Oct 10, 2011 at 10:35 PM, Georgios Karagiannis <
>> [email-masked]> wrote:
>>
>>> Hi Bruce
>>>
>>> I agree that adding optional temperature variables
>>> to EMAN reporting for ambient temperature are useful for energy
>>> management purposes.
>>>
>>> I am not sure if only one variable is enough (e.g., set of average,
>>> maximum, minimum values might be needed)!
>>>
>>> Best regards,
>>> Georgios
>>>
>>> On 10/10/2011, "Bruce Nordman" <[email-masked]> wrote:
>>>
>>> >In the battery MIB, we enable reporting of temperature, since
>>> >temperature is an important indicator in assessing battery health.
>>> >
>>> >For energy management, ambient temperature can affect the
>>> >energy required for many devices (particularly those that require
>>> >cooling or heating to maintain a satisfactory internal temperature)
>>> >so can be important to know.  In addition, large amounts of energy
>>> >are expended by buildings to maintain ambient room temperatures
>>> >within acceptable ranges, and many systems would benefit from
>>> >more building temperature data than they have.
>>> >
>>> >Thus, it seems to me that adding a single optional temperature variable
>>> >to EMAN reporting for ambient temperature would be very useful
>>> >for energy management purposes.  The increasing number of devices
>>> >that have such internal sensors could then readily make this information
>>> >available to the EMS.  One prominent example is data centers so
>>> >this would be an appropriate use case to drive a requirement.
>>> >
>>> >There may always be a need for dedicated temperature sensor
>>> >devices, but ones integrated into larger products will be cheaper
>>> >to purchase, install, and maintain, and so be more widely available.
>>> >The suggestion is NOT to support stand-alone sensors - only sensors
>>> >integral to a EMAN device.
>>> >
>>> >Units would be Celsius.  Probably integral degrees is sufficient,
>>> >but certainly tenths of a degree would satisfy any ordinary use.
>>> >
>>> >Proposal is for a single optional value only.
>>> >
>>> >Comments?
>>> >
>>> >--Bruce
>>> >
>>> >--
>>> >*Bruce Nordman*
>>> >Lawrence Berkeley National Laboratory
>>> >eetd.lbl.gov/ea/nordman
>>> >[email-masked]
>>> >510-486-7089
>>> >m: 510-501-7943
>>>
>>
>>
>>
>> --
>> *Bruce Nordman*
>>
>> Lawrence Berkeley National Laboratory
>> eetd.lbl.gov/ea/nordman
>> [email-masked]
>> 510-486-7089
>> m: 510-501-7943
>>
>>
>> _______________________________________________
>> eman mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/eman
>>
>>
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Brad Schoening <[email-masked]>
Date: Tue, 31 Jan 2012 20:07:56 -0600

Bruce,

I don't see the clear relevance of 'temperature' to the EMAN requirements.

While there is a large list of environmental and system performance metrics, these have not been mentioned in EMAN requirements.  Sensor measurements for temperature, relative humidity, lumens, etc seem more appropriately left to an ENVIRONMENTAL-SENSOR-MIB.

Brad Schoening
e: [email-masked] ⟐ m: 917-304-7190

<http://www.coraid.com/> Redefining Storage Economics

From: Bruce Nordman <[email-masked]<mailto:[email-masked]>>
Date: Tue, 31 Jan 2012 18:34:56 -0600
To: eman mailing list <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] Temperature

I'd like to return to this thread from October and come to resolution.
I don't recall any objection to this on the list or at the meeting in Taipei.

Doing a google search on"temperature site:datatracker.ietf.org<http://datatracker.ietf.org>"

--Bruce

On Tue, Oct 11, 2011 at 1:45 PM, Ira McDonald <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bruce,

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]<mailto:[email-masked]>
Winter  579 Park Place  Saline, MI  48176  734-944-0094<tel:734-944-0094>
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434<tel:906-494-2434>

On Tue, Oct 11, 2011 at 4:07 PM, Bruce Nordman <[email-masked]<mailto:[email-masked]>> wrote:
I have in mind just a single ambient temperature value for the entire device
(not for components that is).  A management system could query the device
as often as it cares to track max, min, average, etc.

If someone else wants to propose internal temperatures, which would then
be appropriate by component, they can - but that is distinct from what I
have raised.

Thanks,

--Bruce

On Mon, Oct 10, 2011 at 10:35 PM, Georgios Karagiannis <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bruce

Best regards,
Georgios

On 10/10/2011, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

>eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
>[email-masked]<mailto:[email-masked]>
>510-486-7089<tel:510-486-7089>
>m: 510-501-7943<tel:510-501-7943>

--
Bruce Nordman

Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089<tel:510-486-7089>
m: 510-501-7943<tel:510-501-7943>

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 1 Feb 2012 07:36:08 +0100

> While there is a large list of environmental and system performance metrics, these have not been mentioned in EMAN requirements.  Sensor measurements for temperature, relative humidity, lumens, etc…

The ENTITY-SENSOR-MIB does report temperatures.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>