Subject: [eman] Power Quality versus Power Characteristics

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 24 Jan 2012 09:38:05 -0800

Hi,

I'm looking at the minutes from IETF-82 and it looks as if there was a
request to change the term "power quality" to "power characteristics"

I was about to make the change but saw that I am using the term "power
quality" as directly defined by IEC 60050 and there is no such term as
"power characteristics"

The definition from IEC60050 is:
http://www.electropedia.org/iev/iev.nsf/display?openform&ievref=617-01-0
5

"""
Power Quality 
Characteristics of the electric current, voltage and frequencies at a
given point in an electric power system, evaluated against a set of
reference technical parameters. These parameters might, in some cases,
relate to the compatibility between electricity supplied in an electric
power system and the loads connected to that electric power system.
"""

I'm reluctant to change that to power characteristics as the method of
definition is that we take from a source directly at first. I see no
source for power characteristics only power quality.

Since I can't find a source for power characteristics, a quick search on
how "power characteristics" is used shows that it refers more times on
how a device uses power. 

So to contrast  "power quality" describes the electrical characteristics
(voltage and frequency). "Power characteristics" however  more commonly
refers to (example) a device using say 100W at boot up and the 50W at a
steady state over time.

So while the minutes state this...
"""
[BN] - Proposed to refer to these as Power Characteristics instead of
Power 
Quality to avoid confusion.

[BC] - Asks room if Power Characteristics is OK.  Notes no objections.

Other terms that discussed on the list:
- Power State Set
- Energy Object Relationship

[BN] - Proposed to just continue the discussion on the list.
"""

Very easy research shows that  "power quality" and "power
characteristics" are two distinct terms and not  interchangeable.

So I'm asking "Are you sure?"

I proposed to keep "power quality" as defined by IEC60050 and if needed
I can add "power characteristics" as described above if someone has a
reference. I strongly propose not to use them interchangeably.

Feedback?
Jp

---

From: Ira McDonald <[email-masked]>
Date: Tue, 24 Jan 2012 12:47:19 -0500

Hi John,

I agree with you that "power quality" and "power characteristics"
are not interchangeable.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Jan 24, 2012 at 12:38 PM, John Parello (jparello) <
[email-masked]> wrote:

> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 25 Jan 2012 22:35:39 -0800

I am mindful that whatever we decide, it doesn't change the
implementation of EMAN, but you make some good points.

My reading of the Power Quality definition below is that it is
a judgment of suitability of some power with respect to its
usage context, so is a value judgment.
Power Characteristics was intended to not be judgmental,
and independent of any usage context.
For something like voltage, EMAN is just reporting what it
measures.  From what we know from an EMAN perspective,
there is no knowledge of what values are preferred to others.

I don't have my IEEE Dictionary handy to see if there is anything
suitable there.  I do agree that Quality and Characteristics do
mean different things.

--Bruce

On Tue, Jan 24, 2012 at 9:38 AM, John Parello (jparello) <[email-masked]
> wrote:

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Jan 2012 10:51:22 +0100

Dear all,

 From the meeting minutes 
(http://www.ietf.org/proceedings/82/minutes/eman.txt):

    Three categories of power quality:
    1. Nominal power supply
    2. Power quality, deviation from nominal
    3. Power usage

    [MC] - Power Quality has a very specific meaning in some contexts.  Power
    quality mostly encompasses #2.  Many of the variables we are considering
    would be considered more generally additional power characteristics than
    power quality.

    [BN] - Proposed to refer to these as Power Characteristics instead of Power
    Quality to avoid confusion.

So the current definition of "Power Quality" in 
http://tools.ietf.org/html/draft-parello-eman-definitions-04 covers 
correctly "2.", right?
So, is Power Characteristics "1.", "2.", and "3."?

At the end, I'm not sure which problem we try to solve...

Regards, Benoit.

> On Tue, Jan 24, 2012 at 9:38 AM, John Parello (jparello) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     <http://www.electropedia.org/iev/iev.nsf/display?openform&ievref=617-01-0>
>     5
>
>     """
>     Power Quality
>     [email-masked] <mailto:[email-masked]>
> eetd.lbl.gov/ea/nordman <http://eetd.lbl.gov/ea/nordman>
> [email-masked]
> 510-486-7089
> m: 510-501-7943
>
>
>

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 31 Jan 2012 16:05:50 -0800

Per Benoit's email below, I agree that the current Power Quality definition
is 2.
Since Power Quality has a specific meaning other than how we use it, I don't
think using it works.

The Requirements draft (
http://www.ietf.org/id/draft-ietf-eman-requirements-05.txt)
uses Power Quality to refer to a collection of useful attributes of power.

The framework draft uses Power Quality to refer to everything other than
Power, Energy, and Demand.  PQ groups 22 values beginning with voltage
and current.

The framework uses the phrase "electrical characteristics".  The
requirements
refers to "qualitative properties".  These generic terms are clear enough
on their
own to not require definition, and are not trying to impart highly specific
information.

So, I think the answer to our problem is to not define "power quality", and
so not
use it to have specific meaning.  We can use it as a generic term, along
with
"characteristics", "properties", "measurements", or similar terms.

Going through the IEEE Dictionary, there is no defined term that matches how
we use Power Quality.  This is because we are using it as a catchall phrase
to
cover all metrics other than Energy, Power, and Demand.  It is a "Other" or
"Miscellaneous"
grouping.

This seems a very workable solution for all the drafts except possibly the
Monitoring MIB
draft (http://www.ietf.org/id/draft-ietf-eman-energy-monitoring-mib-01.txt).
It defines a powerQualityMIB to hold these various values.  Is it a problem
if Power Quality
is not defined?  If we need a term, then it is simplest to define it as we
use it - all
characteristics other than Energy, Power, and Demand.  Some term like
'additional',
'extra', 'optional', 'detailed', or such would be clear.

--Bruce

On Thu, Jan 26, 2012 at 1:51 AM, Benoit Claise <[email-masked]> wrote:

>  Dear all,
>
> From the meeting minutes (
> http://www.ietf.org/proceedings/82/minutes/eman.txt):
>
> On Tue, Jan 24, 2012 at 9:38 AM, John Parello (jparello) <
> eman mailing [email-masked]://www.ietf.org/mailman/listinfo/eman
>
>
>

---

From: Brad Schoening <[email-masked]>
Date: Tue, 31 Jan 2012 19:52:40 -0600

Hi Bruce,

I don't understand the context for choosing those three categories., 1, 2 & 3 or how they were derived?  These categories seem pretty much ad hoc .

In contrast, our EMAN Terminology states, directly quoting IEC 60050:

http://tools.ietf.org/html/draft-parello-eman-definitions-04

  Power Quality

       Characteristics of the electric current, voltage and

       frequencies at a given point in an electric power

       system, evaluated against a set of reference technical

       parameters. These parameters might, in some cases,

       relate to the compatibility between electricity

       supplied in an electric power system and the loads

       connected to that electric power system.

       Reference: [IEC60050<http://tools.ietf.org/html/draft-parello-eman-definitions-04#ref-IEC60050>]

This seems both adequate and clear.

The EMAN requirements draft states:

Power quality parameters include the actual voltage, the actual frequency, the Total Harmonic Distortion (THD) of voltage and current, the impedance of an AC phase or of the DC Supply.

That also seems perfectly fine and clear.

The framework draft lists the following 22 attributes, but many are redundant due to separate tables for single-phase, delta-phase, and wye-phase.  Of these, only current isn't obviously a power quality characteristic.

         +------------------+--------------------+

         |         ACQuality                     |

         |---------------------------------------|

         | acConfiguration : enum {SNGL, DEL,WYE}|

         | avgVoltage   : long                   |

         | avgCurrent   : long                   |

         | frequency    : long                   |

         | unitMultiplier  : int                 |

         | accuracy  : int                       |

         | totalActivePower  : long              |

         | totalReactivePower : long             |

         | totalApparentPower : long             |

         | totalPowerFactor : long

         +---------------------------------------+

         +------------------------------------+

         |         ACPhase                    |

         |------------------------------------|

         | phaseIndex : long                  |

         | avgCurrent : long                  |

         | activePower : long                 |

         | reactivePower : long               |

         | apparentPower : long               |

         | powerFactor : long                 |

         +------------------------------------+

         +-------------------------------+---+

         |        DelPhase                   |

         |-----------------------------------|

         |phaseToNextPhaseVoltage  : long    |

         |thdVoltage : long                  |

         |thdCurrent : long                  |

         +-----------------------------------+

         +------------------+-----------+

         |        WYEPhase              |

         |------------------------------|

         |phaseToNeutralVoltage : long  |

         |thdCurrent : long             |

         |thdVoltage : long             |

         +------------------------------+

Reviewing this, I can't understand the issue here from the meeting. Can we perhaps get more clarity or simply close this issue?

e: [email-masked] ⟐ m: 917-304-7190

<http://www.coraid.com/> Redefining Storage Economics

From: Bruce Nordman <[email-masked]<mailto:[email-masked]>>
Date: Tue, 31 Jan 2012 18:05:50 -0600
To: Benoit Claise <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] Power Quality versus Power Characteristics

Per Benoit's email below, I agree that the current Power Quality definition is 2.
Since Power Quality has a specific meaning other than how we use it, I don't
think using it works.

The Requirements draft (http://www.ietf.org/id/draft-ietf-eman-requirements-05.txt)
uses Power Quality to refer to a collection of useful attributes of power.

The framework uses the phrase "electrical characteristics".  The requirements
refers to "qualitative properties".  These generic terms are clear enough on their
own to not require definition, and are not trying to impart highly specific information.

So, I think the answer to our problem is to not define "power quality", and so not
use it to have specific meaning.  We can use it as a generic term, along with
"characteristics", "properties", "measurements", or similar terms.

Going through the IEEE Dictionary, there is no defined term that matches how
we use Power Quality.  This is because we are using it as a catchall phrase to
cover all metrics other than Energy, Power, and Demand.  It is a "Other" or "Miscellaneous"
grouping.

This seems a very workable solution for all the drafts except possibly the Monitoring MIB
draft (http://www.ietf.org/id/draft-ietf-eman-energy-monitoring-mib-01.txt).
It defines a powerQualityMIB to hold these various values.  Is it a problem if Power Quality
is not defined?  If we need a term, then it is simplest to define it as we use it - all
characteristics other than Energy, Power, and Demand.  Some term like 'additional',
'extra', 'optional', 'detailed', or such would be clear.

--Bruce

On Thu, Jan 26, 2012 at 1:51 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

From the meeting minutes (http://www.ietf.org/proceedings/82/minutes/eman.txt):

So the current definition of "Power Quality" in http://tools.ietf.org/html/draft-parello-eman-definitions-04 covers correctly "2.", right?
So, is Power Characteristics "1.", "2.", and "3."?

Regards, Benoit.

--Bruce

On Tue, Jan 24, 2012 at 9:38 AM, John Parello (jparello) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

"""
Power Quality

Feedback?
Jp

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089<tel:510-486-7089>
m: 510-501-7943<tel:510-501-7943>

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943