Subject: [eman] Index about eoEnergyTable

From: <[email-masked]>
Date: Sat, 14 Jan 2012 20:02:46 +0900

Hi Mouli, Claise

There is a thing I confrim.

eoEnergyTable is indexed by eoPowerIndex, eoEnergyParametersIntervalMode and eoEnergyIntervalStartTime.

If manager send a GetRequest using snmp protocol to get an entity's energy consumption,  
how manager specifies the OID ? 

We consider following example.

EnergyObjectMibObjects.eoEnergyTable.eoEnergyIntervalEnergyConsumed.10.2.xxx                                                                        

Though manager knows these two index(eoPowerIndex(10) and eoEnergyParametersIntervalMode(2)) in advance,
manager doues't be able to know another index at eoEnergyIntervalStartTime becase it's sysUpTime.   
To specify the OID, another index is needed instead of eoEnergyIntervalStartTime ?

How about using following etherHistoryTable as a reference?  

RFC 1757

        etherHistoryTable OBJECT-TYPE
                         ・・・
          EtherHistoryEntry ::= SEQUENCE {
              etherHistoryIndex                 INTEGER (1..65535),
              etherHistorySampleIndex           INTEGER (1..2147483647),
              etherHistoryIntervalStart         TimeTicks,
                         ・・・
                        
   etherHistorySampleIndex OBJECT-TYPE
              SYNTAX INTEGER (1..2147483647)
              ACCESS read-only
              STATUS mandatory
              DESCRIPTION
                  "An index that uniquely identifies the particular
                  sample this entry represents among all samples
                  associated with the same historyControlEntry.
                  This index starts at 1 and increases by one
                  as each new sample is taken."
              ::= { etherHistoryEntry 2 }

     etherHistoryIntervalStart OBJECT-TYPE
              SYNTAX TimeTicks
              ACCESS read-only
              STATUS mandatory
              DESCRIPTION
                  "The value of sysUpTime at the start of the interval
                  over which this sample was measured.  If the probe
                  keeps track of the time of day, it should start
                  the first sample of the history at a time such that
                  when the next hour of the day begins, a sample is
                  started at that instant.  Note that following this
                  rule may require the probe to delay collecting the
                  first sample of the history, as each sample must be
                  of the same interval.  Also note that the sample which
                  is currently being collected is not accessible in this
                  table until the end of its interval."
              ::= { etherHistoryEntry 3 }

Regards,
Hiroto

---

From: Brad Schoening <[email-masked]>
Date: Sun, 15 Jan 2012 13:38:02 -0600

Hiroto,

Just to ensure I'm clear on what you're suggesting, it's to :

1. Add a new index variable eoEnergyIntervalSampleIndex
2. Modify eoEnergyIntervalStartTime so it is no longer part of the table
index.

This seems like a good suggestion to me.

Regards,

Brad

On 1/14/12 6:02 AM, "[email-masked]" <[email-masked]>
wrote:

>Though manager knows these two index(eoPowerIndex(10) and
>eoEnergyParametersIntervalMode(2)) in advance,
>manager doues't be able to know another index at
>eoEnergyIntervalStartTime becase it's sysUpTime.
>_______________________________________________
>eman mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/eman
>

---

From: <[email-masked]>
Date: Wed, 18 Jan 2012 22:39:55 +0900

Hi Brad

thank you for your comment.

>1. Add a new index variable eoEnergyIntervalSampleIndex

 exactly, yes.
 we shall add a new index like eoEnergyIntervalSampleIndex.
 But, it's be careful of us to use or refer this etherHistorySampleIndex.
 The problem that manager can't specify the latest index has been remained, 
 because etherHistorySampleIndex is starts at 1 and increases by one as each new sample is taken.
 
 See example below, SampleIndex increases by one as new sample is taken, 
 manager cant's specify the latest index.
 
 SampleIndex  |  StartTime
 --------------------------
       1      |    10000 ** oldest
 --------------------------
       2      |    10020
 --------------------------
       3      |    10040
 --------------------------
       4      |    10060 ** latest
 --------------------------
             
 To resolve this, I suggest following specification.
 See example below, although SampleIndex increases by one as new sample is taken, 
 latest StartTime is at any time to be the SampleIndex "1".  
 This method enables manager to specify the latest index and manager is able to get latest energy consumption. 

 SampleIndex  |  StartTime
 --------------------------
       1      |    10060 ** latest
 --------------------------
       2      |    10040
 --------------------------
       3      |    10020
 --------------------------
       4      |    10000 ** oldest
 --------------------------   
  
 but, this method faces following problem.
 As new sample is taken, SampleIndex changes it's value(StartTime).

>2. Modify eoEnergyIntervalStartTime so it is no longer part of the table
 
 exactly, yes.
 we remove the eoEnergyIntervalStartTime from the part of the table index.
 
Regards,
Hiroto