Subject: [eman] Time series of power measurements

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Fri, 3 Feb 2012 05:18:11 -0600

Hello all, 

This has been one of the long standing open issue that has been
discussed extensively. 

http://www.ietf.org/mail-archive/web/eman/current/msg00792.html

At the IETF 82,  WG meeting, there was a lot of discussion on this
topic,  if another requirement for Time Series of Power was required.
Please refer to the minutes of the meeting. 

www.ietf.org/proceedings/82/minutes/eman.txt

On the WG meeting, there was rough consensus was to support time series
of power measurements. The mechanism to enable reporting power (push or
pull) shall need to be defined. The concern of smaller devices may not
have storage to implement is addressed by the statement i.e. the
requirements specified concern the means that the standard shall provide
and not necessarily to be implemented on all devices.  

Currently, we have a requirement 5.5.4. Time Series of Energy values . 

Thus the proposed requirement for Time series of Power would be the
following. 

5.4.11. Time series of power values

The energy management standard must provide means for collecting time
series of power values for an Energy Object. A solution for collecting
the time series for an Energy Object can use the pull or push mechanism
for recovering the information.

Your thoughts/suggestions. 

Thanks

Mouli

---

From: Bruce Nordman <[email-masked]>
Date: Sun, 5 Feb 2012 22:51:50 -0800

I look forward to comment from others on the mechanism to
report time-series data.

I think we can and should say that this is a convenience function
which will result in the same data result if the device were polled
at the individual intervals reported on in the time series.

While reporting transient power levels is part of EMAN, the
time-series data of usual interest in energy monitoring is
accumulated energy consumption.  We should adjust all
the time-series discussion to point to this as the values to
be reported.   The time-series data will be a series of meter
readings associated with time-stamps at regular intervals.
The average power consumed during each interval can then
be readily calculated.

Time series reporting will require some advance specification
of the duration of the time periods, and possibly time synchronisation
of those readings.  I think it reasonable for devices to only support
a single set of duration/synch settings

--Bruce

On Fri, Feb 3, 2012 at 3:18 AM, Mouli Chandramouli (moulchan) <
[email-masked]> wrote:

> Hello all, ****
>
> This has been one of the long standing open issue that has been discussed
> extensively. ****
>
> http://www.ietf.org/mail-archive/web/eman/current/msg00792.html****
>
> At the IETF 82,  WG meeting, there was a lot of discussion on this topic,
>  if another requirement for Time Series of Power was required.  Please
> refer to the minutes of the meeting. ****
>
> www.ietf.org/proceedings/82/minutes/eman.txt****
>
> On the WG meeting, there was rough consensus was to support time series of
> power measurements. The mechanism to enable reporting power (push or pull)
> shall need to be defined. The concern of smaller devices may not have
> storage to implement is addressed by the statement i.e. the requirements
> specified concern the means that the standard shall provide and not
> necessarily to be implemented on all devices.  ****
>
> Currently, we have a requirement 5.5.4. Time Series of Energy values . ***
> *
>
> following. ****
> 5.4.11. Time series of power values****
>
> series of power values for an Energy Object. A solution for collecting the
> time series for an Energy Object can use the pull or push mechanism for
> recovering the information.****
>
> Your thoughts/suggestions. ****
>
>
> Thanks****
>
> Mouli****
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: <[email-masked]>
Date: Mon, 6 Feb 2012 19:33:09 +0900

Hi all,

I'm not sure that there is a need to use interval monitoring in parallel.
But I would say that the need that 'period' and 'total' are used together
may exist.  I think that total energy monitoring does not have to exist
with other time-series monitoring.
How about separating 'Total Energy' from EoEnergyIntervalEntry?
It seems reasonable for small devices to monitor energy consumption without
using IntervalEntry.

Best regards,
Minoru

--
Minoru Teraoka
Yokogawa Electric Corporation

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bruce Nordman
Sent: Monday, February 06, 2012 3:52 PM
To: Mouli Chandramouli (moulchan)
Cc: [email-masked]
Subject: Re: [eman] Time series of power measurements

--Bruce
On Fri, Feb 3, 2012 at 3:18 AM, Mouli Chandramouli (moulchan) <[email-masked]<mailto:[email-masked]>> wrote:
Hello all,
This has been one of the long standing open issue that has been discussed extensively.
http://www.ietf.org/mail-archive/web/eman/current/msg00792.html
At the IETF 82,  WG meeting, there was a lot of discussion on this topic,  if another requirement for Time Series of Power was required.  Please refer to the minutes of the meeting.
www.ietf.org/proceedings/82/minutes/eman.txt<http://www.ietf.org/proceedings/82/minutes/eman.txt>
On the WG meeting, there was rough consensus was to support time series of power measurements. The mechanism to enable reporting power (push or pull) shall need to be defined. The concern of smaller devices may not have storage to implement is addressed by the statement i.e. the requirements specified concern the means that the standard shall provide and not necessarily to be implemented on all devices.
Currently, we have a requirement 5.5.4. Time Series of Energy values .
Thus the proposed requirement for Time series of Power would be the following.
5.4.11. Time series of power values
The energy management standard must provide means for collecting time series of power values for an Energy Object. A solution for collecting the time series for an Energy Object can use the pull or push mechanism for recovering the information.
Your thoughts/suggestions.

Thanks
Mouli

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943