Subject: [eman] Directional metering of Energy

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Fri, 3 Feb 2012 06:57:30 -0600

Regarding the question of measurement of directional measurement of
Energy - this was discussed at IETF 82 WG meeting. 

Slide 10  -  http://tools.ietf.org/agenda/82/slides/eman-6.pdf

Energy meters 

*	EnergyConsumed
*	EnergyProduced
*	EnergyNet

At the WG meeting, it was proposed that to have a requirement with
directional measurement of energy to be consistent with ODVA and WG
silent majority was fine. 
Seeking input from the WG email list. 

Thanks
Mouli 

5.5.5.   It is also possible to consider different meters of energy
consumption taking into  consideration the direction, one meter for
energy consumed, one meter for energy provided and the third meter for
the net, which is the sum of consumer and producer.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Benoit Claise (bclaise)
Sent: Thursday, December 01, 2011 11:32 PM
To: eman mailing list
Subject: [eman] draft minutes for the EMAN meeting

Dear all,

Here are our draft minutes.
http://www.ietf.org/proceedings/82/minutes/eman.txt

Please send any corrections or improvements to us.

Regards, Bruce and Benoit.
_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: Brad Schoening <[email-masked]>
Date: Sat, 4 Feb 2012 09:54:40 -0600

Mouli,

I'm confused by this proposal.  Principally, it doesn't seem to be consistent with the way meters today work.  Current transformer (CT) meters work by measuring the amount of current flowing.  Many are bi-directional, meaning they can only measure the "net" current into and out of a system.  Such a meter can't measure separately the "produced" energy and "consumed" energy.   You would need at least two independent meters to provide the data to perform that calculation.  These two (not three) meters could be thousands of feet apart and not directly connected to each other.

Given these two meters, you could calculate all three values:

Energy Produced = kWh of inverter meter
Energy Consumed = kwh of inverter meter + kWh of utility meter
Net Energy = kWh of utility meter

Also, knowledge of the system topology is critical to calculating these values.   If you consider this same building before the solar panels were installed, a BMS would have a different calculation:

  Energy Produced = 0
Energy Consumed = kWh of utility meter
Net Energy = Energy Consumed

The utility meter doesn't know if its a 'net' meter or a 'consumption' meter.  Only the BMS that reads all of the meters should know that.  Thus, these values should be considered calculated values by a management system, not attributes read by a meter itself.

Thanks,

Brad

Brad Schoening
e: [email-masked] ⟐ m: 917-304-7190

<http://www.coraid.com/> Redefining Storage Economics

From: "Mouli Chandramouli (moulchan)" <[email-masked]<mailto:[email-masked]>>
Date: Fri, 3 Feb 2012 06:57:30 -0600
To: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, eman mailing list <[email-masked]<mailto:[email-masked]>>
Subject: [eman] Directional metering of Energy

Regarding the question of measurement of directional measurement of Energy - this was discussed at IETF 82 WG meeting.

Energy meters

•       EnergyConsumed

•       EnergyProduced

•       EnergyNet

At the WG meeting, it was proposed that to have a requirement with directional measurement of energy to be consistent with ODVA and WG silent majority was fine.

Thanks

Mouli

5.5.5.   It is also possible to consider different meters of energy consumption taking into  consideration the direction, one meter for energy consumed, one meter for energy provided and the third meter for the net, which is the sum of consumer and producer.

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Benoit Claise (bclaise)
Sent: Thursday, December 01, 2011 11:32 PM
To: eman mailing list
Subject: [eman] draft minutes for the EMAN meeting

Dear all,

eman mailing list

[email-masked]<mailto:[email-masked]>

---

From: Bruce Nordman <[email-masked]>
Date: Sun, 5 Feb 2012 21:58:01 -0800

I think I agree with Brad.
The language of "produced" and "consumed"
has bothered me since it was introduced, since
I don't think EMAN is making any claim about
the ultimate source or ultimate destination of
power, only its rate of transfer.  So, at a minimum,
I think the terminology is not apt for our application.

EMAN tracks power as it flows across interfaces at the
edge of devices, or to/from components.  There is
certainly a directionality in that the flow is positive
or negative.  The great majority of interfaces are
today, and likely to be in future, only one-way.

For devices with two-way power exchange with
another device, it could be modeled as a single
interface, with the power value going positive or
negative, and the energy meter then moving up
or down accordingly.  Or, the device could expose
two power interfaces, one for each direction.  The
power value would then be zero in at least one
direction at all times.

I agree that it is the management system that will
ultimately make sense of the meaning of the meter
data, and such a system would recognize each of
these implementations and act accordingly.

So, to answer Mouli's question, I think we do not
need or want the 3-part meter construction of
produced/consumed/net.  That said, a device that
wanted to most clearly align itself with ODVA could
have two meters at a power interface, one for
incoming power and the second for outgoing.
The management system would observe that
they were between the same pair of devices
and could calculate the net any time it wanted to.
Thus, we can be functionally harmonized with ODVA.

--Bruce

On Sat, Feb 4, 2012 at 7:54 AM, Brad Schoening <[email-masked]> wrote:

> Mouli,
>
> I'm confused by this proposal.  Principally, it doesn't seem to be
> consistent with the way meters today work.  Current transformer (CT) meters
> work by measuring the amount of current flowing.  Many are bi-directional,
> meaning they can only measure the "net" current into and out of a system.
>  Such a meter can't measure separately the "produced" energy and "consumed"
> energy.   You would need at least two independent meters to provide the
> data to perform that calculation.  These two (not three) meters could be
> thousands of feet apart and not directly connected to each other.
>
> Also, knowledge of the system topology is critical to calculating these
> values.   If you consider this same building before the solar panels were
> installed, a BMS would have a different calculation:
>
>   Energy Produced = 0
> The utility meter doesn't know if its a 'net' meter or a 'consumption'
> meter.  Only the BMS that reads all of the meters should know that.  Thus,
> these values should be considered calculated values by a management system,
> not attributes read by a meter itself.
>
> Thanks,
>
> Brad
>
>
> Brad Schoening
>  <http://www.coraid.com/> Redefining
> Storage Economics****
>
> ** **
>
> From: "Mouli Chandramouli (moulchan)" <[email-masked]>
> To: "Benoit Claise (bclaise)" <[email-masked]>, eman mailing list <
> [email-masked]>
> Regarding the question of measurement of directional measurement of Energy
> - this was discussed at IETF 82 WG meeting.
>
> Slide 10  -  *http://tools.ietf.org/agenda/82/slides/eman-6.pdf*<http://tools.ietf.org/agenda/82/slides/eman-6.pdf>
>
> Energy meters
>
> ·       EnergyConsumed
>
> ·       EnergyProduced
>
> ·       EnergyNet
>
> directional measurement of energy to be consistent with ODVA and WG silent
> majority was fine.
>
> energy consumed, one meter for energy provided and the third meter for the
> net, which is the sum of consumer and producer.
>
>
> From: [email-masked]* <[email-masked]> *
> [mailto:[email-masked]]* <[mailto:[email-masked]]> On
> Behalf Of Benoit Claise (bclaise)
> *http://www.ietf.org/proceedings/82/minutes/eman.txt*<http://www.ietf.org/proceedings/82/minutes/eman.txt>
>
> [email-masked]* <[email-masked]>
>
> *https://www.ietf.org/mailman/listinfo/eman*<https://www.ietf.org/mailman/listinfo/eman>
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: <[email-masked]>
Date: Tue, 7 Feb 2012 07:15:25 +0000

Hi Bruce, Hi Brad,

Currently the values of the produced and consumed energy are important, but they are not realy being used in efficiently managing the

energy production and energy consumption. This is also the reason of why today the energy meters are not realy optimized to support this feature.

By introducing new energy sources, w.g., photovoltaic energy sources, wind turbines, mChPs, this situation is changing.

The energy that flows (bidirectinally) from/towards the energy grid towards/from a neighborhood (that incorporates new energy sources) or towards a builiding (that incorporates new energy sources)

has to be dynamically managed. In other words the energy flow needs to be balanced. This can only be done by frequently monitoring and reporting the direction and the quantity of the energy flowing in both directions.

Threfore, I think that means of reporting the quantity and direction of energy flow are needed.

Best regards,

Georgios

________________________________
Van: [email-masked] [[email-masked]] namens Bruce Nordman [[email-masked]]
Verzonden: maandag 6 februari 2012 6:58
Aan: Brad Schoening
CC: eman mailing list
Onderwerp: Re: [eman] Directional metering of Energy

--Bruce

On Sat, Feb 4, 2012 at 7:54 AM, Brad Schoening <[email-masked]<mailto:[email-masked]>> wrote:
Mouli,

  Energy Produced = 0

Thanks,

Brad

Brad Schoening
e: [email-masked]<mailto:[email-masked]> ⟐ m: 917-304-7190<tel:917-304-7190>

[Description: Coraid+Logo_reallysmall]<http://www.coraid.com/> Redefining Storage Economics

Energy meters

•       EnergyConsumed

•       EnergyProduced

•       EnergyNet

Thanks

Mouli

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Benoit Claise (bclaise)
Sent: Thursday, December 01, 2011 11:32 PM
To: eman mailing list
Subject: [eman] draft minutes for the EMAN meeting

Dear all,

eman mailing list

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]
510-486-7089
m: 510-501-7943