Subject: [eman] I-D Action: draft-ietf-eman-energy-aware-mib-04.txt

From: [email-masked]
Date: Thu, 16 Feb 2012 10:44:16 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Energy Management Working Group of the IETF.

	Title           : Energy-aware Networks and Devices MIB
	Author(s)       : John Parello
                          Benoit Claise
	Filename        : draft-ietf-eman-energy-aware-mib-04.txt
	Pages           : 42
	Date            : 2012-02-16

        This document defines a subset of a Management Information Base
        (MIB) for energy management of devices.  The module addresses
        device identification, context information, and the
        relationships between reporting devices, remote devices, and
        monitoring devices.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-eman-energy-aware-mib-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-eman-energy-aware-mib-04.txt

---

From: Benoit Claise <[email-masked]>
Date: Thu, 16 Feb 2012 19:55:03 +0100

Dear all,

Here is a new draft
-   Feedback from Bill Mielke inserted. 
http://www.ietf.org/mail-archive/web/eman/current/msg00998.html
     There are many changes based on the email thread.
-   Copied the terminology from john Parello draft version 4
-   Removed the eoPhysicalEntity (PhysicalIndexOrZero) as the 
entPhysIndex index from the ENTITY-MIB is required
-   Use zero-length string instead of null, as suggested by Juergen 
Schoenwalder.
-   Expressed that the entPhysicalUris, inherited from the ENTITY-MIB, 
is read-write.
-  And many more improvements

Here are the diffs with the previous version.
http://tools.ietf.org/rfcdiff?url2=draft-ietf-eman-energy-aware-mib-04.txt

Please review.

Only one open issue left: I had not time to check the following

  - Is the UUID always 45 bytes? eoProxyParentUUID has a current
         size of " OCTET STRING (SIZE(0..45))".

Regards, John and Benoit (as a contributor)
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 16 Feb 2012 20:24:22 +0100

>         size of " OCTET STRING (SIZE(0..45))".

I can't answer the question for sure but I suggest that TCs are used
for the UUIDs that declare proper DISPLAY-HINTs so that tools render
things properly.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ira McDonald <[email-masked]>
Date: Thu, 16 Feb 2012 14:40:49 -0500

Hi,

About UUIDs:

If the UUID is expressed as a URI following the ABNF
in RFC 4122, then yes, the length is always *exactly*
45 octets.

See page 4 of RFC 4122, which includes this example:

urn:uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6

I suggest the EMAN WG not "compact" this into a
binary format, though that might make sense if a
large number of UUIDs must be stored (e.g., for
complex parent/child relationships).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: Benoit Claise <[email-masked]>
Date: Fri, 17 Feb 2012 15:02:13 +0100

Hi Juergen,
> for the UUIDs that declare proper DISPLAY-HINTs so that tools render
That makes a lot of sense.
Would you able to help on this one? ;-)

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Fri, 17 Feb 2012 15:17:27 +0100

Hi Juergen,

Thinking some more about this one.
eoProxyParentUUID is only used as an index.
Note: I know, it's not ideal to have an OCTET STRING as an index! If 
anybody has a better idea...
Since that eoProxyParentUUID index is "not-accessible", does it still 
have make sense to have a TC with the proper DISPLAY-HINTs?

Regards, Benoit.

---

From: Ira McDonald <[email-masked]>
Date: Fri, 17 Feb 2012 20:41:50 -0500

Hi Benoit and Juergen,

If the UUID is represented as a URI that conforms
to RFC 4122, the correct datatype is DisplayString
(i.e., visible ASCII) - non-ASCII octets are impossible
in the RFC 4122 encoding.

Cheers,
- Ira

On Fri, Feb 17, 2012 at 9:17 AM, Benoit Claise <[email-masked]> wrote:

> Since that eoProxyParentUUID index is "not-accessible", does it still have
> make sense to have a TC with the proper DISPLAY-HINTs?
>
> Regards, Benoit.
>
>  Hi Juergen,
>>
>> ______________________________**_________________
>> eman mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/eman<https://www.ietf.org/mailman/listinfo/eman>
>>
>>
>>
> ______________________________**_________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/eman<https://www.ietf.org/mailman/listinfo/eman>
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 18 Feb 2012 08:31:03 +0100

On Fri, Feb 17, 2012 at 03:17:27PM +0100, Benoit Claise wrote:

> Since that eoProxyParentUUID index is "not-accessible", does it
> still have make sense to have a TC with the proper DISPLAY-HINTs?

Yes. Tools are smart enough to 'unpack' the instance identifier
and to render the values according to DISPLAY-HINTs.

/js