Subject: [eman] EMAN-FMWK: Dependency Relationship

From: Benoit Claise <[email-masked]>
Date: Fri, 24 Feb 2012 15:27:50 +0100

Dear all,

Here is what the current terminology draft contains:

    Dependency Relationship

An Energy Object may be a component of or rely completely upon another 
Energy Object to operate and is referred to as a Dependency Relationship.

Example: A Switch chassis with multiple line cards.

The [EMAN-FMWK] also contains a reference to this "dependency relationship".

Since every Energy Object must have UUID, and since we can use the 
ENTITY-MIB containment tree for this "dependency relationship" 
(typically to know that this line card belong to this switch, as 
expressed in the example), I believe that we don't need this 
relationship type.

Please let me know otherwise, otherwise, consider it removed.

Regards, Benoit (as a contributor for EMAN-FMWK)

---

From: "John Parello (jparello)" <[email-masked]>
Date: Mon, 27 Feb 2012 13:47:13 -0800

I don't mind if this is removed

Jp

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Benoit Claise (bclaise)
Sent: Friday, February 24, 2012 6:28 AM
To: eman mailing list
Subject: [eman] EMAN-FMWK: Dependency Relationship

Dear all,

Dependency Relationship

An Energy Object may be a component of or rely completely upon another
Energy Object to operate and is referred to as a Dependency
Relationship.  

The [EMAN-FMWK] also contains a reference to this "dependency
relationship".

---

From: Rolf Winter <[email-masked]>
Date: Tue, 28 Feb 2012 08:43:01 +0000

Benoit,

As the minutes from the last meeting note, I actually couldn't always tell when a dependency relationship applies vs. other types of relationship in the document. That was one of my main criticisms of the relationship concept vs. the wiring topology which doesn't have such ambiguities. The same section of the minutes have some more points which I will check against the new version of the document.

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> Benoit Claise
> Sent: Freitag, 24. Februar 2012 15:28
> To: eman mailing list

---

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Feb 2012 12:04:34 +0100

Hi Rolf,
> Benoit,
>
> As the minutes from the last meeting note, I actually couldn't always tell when a dependency relationship applies vs. other types of relationship in the document.
You're right. The dependency relationship was inserted before we based 
the [EMAN-AWARE] on the ENTITY-MIB entPhysicalIndex.
So this removal should go in the direction of simplification.
> That was one of my main criticisms of the relationship concept vs. the wiring topology which doesn't have such ambiguities. The same section of the minutes have some more points which I will check against the new version of the document.
Sure.
Your comment was:

    [RW] - Wasn't always clear what relationship to choose.  For example, one of
    the examples it talks about dependency and he expected that to be the
    relationship but then when he looked it wasn't there.  So it is not clear
    cut.  Parent/child isn't clearly defined.  Sometimes the framework is very
    specific and may be introducing requirements.  The requirements should in the
    requirements document.  Also the framework was detailed about some aspect of
    the battery relationships when it is an open issue in the battery MIB.

And this is to address one point in there, that this email thread was 
created.

Regards, Benoit (as a contributor for the EMAN-FMWK)