Subject: Re: [eman] Power Quality versus Power Characteristics

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 1 Feb 2012 10:25:31 +0000

+1

Sent from my iPad

On Feb 1, 2012, at 1:53 AM, "Brad Schoening" <[email-masked]> wrote:

> Hi Bruce,
> 
> I don't understand the context for choosing those three categories., 1, 2 & 3 or how they were derived?  These categories seem pretty much ad hoc .
> 
> In contrast, our EMAN Terminology states, directly quoting IEC 60050:
> http://tools.ietf.org/html/draft-parello-eman-definitions-04
> 
>   Power Quality
>      
>        Characteristics of the electric current, voltage and
>        frequencies at a given point in an electric power
>        system, evaluated against a set of reference technical
>        parameters. These parameters might, in some cases,
>        relate to the compatibility between electricity
>        supplied in an electric power system and the loads
>        connected to that electric power system.
>      
>        Reference: [IEC60050]
> 
> This seems both adequate and clear. 
> The EMAN requirements draft states:
> 
> Power quality parameters include the actual voltage, the actual frequency, the Total Harmonic Distortion (THD) of voltage and current, the impedance of an AC phase or of the DC Supply.
> 
> That also seems perfectly fine and clear.
> 
> The framework draft lists the following 22 attributes, but many are redundant due to separate tables for single-phase, delta-phase, and wye-phase.  Of these, only current isn't obviously a power quality characteristic. 
> 
>          +------------------+--------------------+  
>          |         ACQuality                     | 
>          |---------------------------------------|  
>          | acConfiguration : enum {SNGL, DEL,WYE}|  
>          | avgVoltage   : long                   | 
>          | avgCurrent   : long                   | 
>          | frequency    : long                   | 
>          | unitMultiplier  : int                 | 
>          | accuracy  : int                       | 
>          | totalActivePower  : long              | 
>          | totalReactivePower : long             | 
>          | totalApparentPower : long             | 
>          | totalPowerFactor : long  
>          +---------------------------------------+
> 
>          +------------------------------------+ 
>          |         ACPhase                    | 
>          |------------------------------------| 
>          | phaseIndex : long                  | 
>          | avgCurrent : long                  | 
>          | activePower : long                 | 
>          | reactivePower : long               | 
>          | apparentPower : long               | 
>          | powerFactor : long                 | 
>          +------------------------------------+ 
> 
>          +-------------------------------+---+    
>          |        DelPhase                   |      
>          |-----------------------------------|   
>          |phaseToNextPhaseVoltage  : long    |     
>          |thdVoltage : long                  |      
>          |thdCurrent : long                  |      
>          +-----------------------------------+
> 
>          +------------------+-----------+ 
>          |        WYEPhase              | 
>          |------------------------------| 
>          |phaseToNeutralVoltage : long  | 
>          |thdCurrent : long             | 
>          |thdVoltage : long             | 
>          +------------------------------+ 
>  
> 
> Reviewing this, I can't understand the issue here from the meeting. Can we perhaps get more clarity or simply close this issue?
> 
> 
> e: [email-masked] ⟐ m: 917-304-7190
> 
> <68E3C3EC-27AF-42E8-8F70-14A7C87B9B6F[108].png> Redefining Storage Economics
>  
> 
> From: Bruce Nordman <[email-masked]>
> Date: Tue, 31 Jan 2012 18:05:50 -0600
> To: Benoit Claise <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: [eman] Power Quality versus Power Characteristics
> 
> Per Benoit's email below, I agree that the current Power Quality definition is 2.
> Since Power Quality has a specific meaning other than how we use it, I don't
> think using it works.
> 
> The Requirements draft (http://www.ietf.org/id/draft-ietf-eman-requirements-05.txt) 
> uses Power Quality to refer to a collection of useful attributes of power.
> 
> The framework draft uses Power Quality to refer to everything other than
> Power, Energy, and Demand.  PQ groups 22 values beginning with voltage
> and current.
> 
> The framework uses the phrase "electrical characteristics".  The requirements
> refers to "qualitative properties".  These generic terms are clear enough on their
> own to not require definition, and are not trying to impart highly specific information.
> 
> So, I think the answer to our problem is to not define "power quality", and so not
> use it to have specific meaning.  We can use it as a generic term, along with
> "characteristics", "properties", "measurements", or similar terms.
> 
> Going through the IEEE Dictionary, there is no defined term that matches how
> we use Power Quality.  This is because we are using it as a catchall phrase to
> cover all metrics other than Energy, Power, and Demand.  It is a "Other" or "Miscellaneous"
> grouping.
> 
> This seems a very workable solution for all the drafts except possibly the Monitoring MIB
> draft (http://www.ietf.org/id/draft-ietf-eman-energy-monitoring-mib-01.txt).
> It defines a powerQualityMIB to hold these various values.  Is it a problem if Power Quality
> is not defined?  If we need a term, then it is simplest to define it as we use it - all
> characteristics other than Energy, Power, and Demand.  Some term like 'additional',
> 'extra', 'optional', 'detailed', or such would be clear.
> 
> --Bruce
> 
> 
> On Thu, Jan 26, 2012 at 1:51 AM, Benoit Claise <[email-masked]> wrote:
> Dear all,
> 
> From the meeting minutes (http://www.ietf.org/proceedings/82/minutes/eman.txt):
> Three categories of power quality:
> 1. Nominal power supply
> 2. Power quality, deviation from nominal
> 3. Power usage
> 
> [MC] - Power Quality has a very specific meaning in some contexts.  Power 
> quality mostly encompasses #2.  Many of the variables we are considering 
> would be considered more generally additional power characteristics than 
> power quality.
> 
> [BN] - Proposed to refer to these as Power Characteristics instead of Power 
> Quality to avoid confusion.
> So the current definition of "Power Quality" in http://tools.ietf.org/html/draft-parello-eman-definitions-04 covers correctly "2.", right?
> So, is Power Characteristics "1.", "2.", and "3."?
> 
> At the end, I'm not sure which problem we try to solve...
> 
> Regards, Benoit.
> 
> 
>> I am mindful that whatever we decide, it doesn't change the
>> implementation of EMAN, but you make some good points.
>> 
>> My reading of the Power Quality definition below is that it is
>> a judgment of suitability of some power with respect to its
>> usage context, so is a value judgment.
>> Power Characteristics was intended to not be judgmental,
>> and independent of any usage context.
>> For something like voltage, EMAN is just reporting what it
>> measures.  From what we know from an EMAN perspective,
>> there is no knowledge of what values are preferred to others.
>> 
>> I don't have my IEEE Dictionary handy to see if there is anything
>> suitable there.  I do agree that Quality and Characteristics do
>> mean different things.
>> 
>> --Bruce
>> 
>> On Tue, Jan 24, 2012 at 9:38 AM, John Parello (jparello) <[email-masked]> wrote:
>> Hi,
>> 
>> I'm looking at the minutes from IETF-82 and it looks as if there was a
>> request to change the term "power quality" to "power characteristics"
>> 
>> I was about to make the change but saw that I am using the term "power
>> quality" as directly defined by IEC 60050 and there is no such term as
>> "power characteristics"
>> 
>> The definition from IEC60050 is:
>> http://www.electropedia.org/iev/iev.nsf/display?openform&ievref=617-01-0
>> 5
>> 
>> """
>> Power Quality
>> Characteristics of the electric current, voltage and frequencies at a
>> given point in an electric power system, evaluated against a set of
>> reference technical parameters. These parameters might, in some cases,
>> relate to the compatibility between electricity supplied in an electric
>> power system and the loads connected to that electric power system.
>> """
>> 
>> I'm reluctant to change that to power characteristics as the method of
>> definition is that we take from a source directly at first. I see no
>> source for power characteristics only power quality.
>> 
>> Since I can't find a source for power characteristics, a quick search on
>> how "power characteristics" is used shows that it refers more times on
>> how a device uses power.
>> 
>> So to contrast  "power quality" describes the electrical characteristics
>> (voltage and frequency). "Power characteristics" however  more commonly
>> refers to (example) a device using say 100W at boot up and the 50W at a
>> steady state over time.
>> 
>> 
>> So while the minutes state this...
>> """
>> [BN] - Proposed to refer to these as Power Characteristics instead of
>> Power
>> Quality to avoid confusion.
>> 
>> [BC] - Asks room if Power Characteristics is OK.  Notes no objections.
>> 
>> Other terms that discussed on the list:
>> - Power State Set
>> - Energy Object Relationship
>> 
>> [BN] - Proposed to just continue the discussion on the list.
>> """
>> 
>> Very easy research shows that  "power quality" and "power
>> characteristics" are two distinct terms and not  interchangeable.
>> 
>> So I'm asking "Are you sure?"
>> 
>> I proposed to keep "power quality" as defined by IEC60050 and if needed
>> I can add "power characteristics" as described above if someone has a
>> reference. I strongly propose not to use them interchangeably.
>> 
>> Feedback?
>> Jp
>> 
>> _______________________________________________
>> eman mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/eman
>> 
>> 
>> 
>> -- 
>> Bruce Nordman
>> Lawrence Berkeley National Laboratory
>> eetd.lbl.gov/ea/nordman
>> [email-masked]
>> 510-486-7089
>> m: 510-501-7943
>> 
>> 
>> 
>> _______________________________________________
>> eman mailing list
>> [email-masked]://www.ietf.org/mailman/listinfo/eman
> 
> 
> 
> 
> -- 
> Bruce Nordman
> Lawrence Berkeley National Laboratory
> eetd.lbl.gov/ea/nordman
> [email-masked]
> 510-486-7089
> m: 510-501-7943
> 
> <Understaing Power Quality Problems by Bollen Table of Contents.pdf>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Benoit Claise <[email-masked]>
Date: Mon, 13 Feb 2012 17:31:21 +0100

Dear all,

I would like appreciate if someone could rephrase the problem 
description (if any), as there is some confusion.
According to this email thread, the power quality definition is fine and 
the EMAN requirements draft is in line with this definition.

Is the problem that the eoACPwrQualityTable EMAN monitoring MIB module 
contains at the same time:
- "power quality" variables
- non "power quality" variables, i.e not "evaluated against a set of 
reference technical parameters"? Example: current
Hence the table name should NOT contain "Power Quality" and the 
[EMAN-FMWK] wordings might have to be updated.

Please let us know.

Regards, Benoit.
> Hi Bruce,
>
> I don't understand the context for choosing those three categories., 
> 1, 2 & 3 or how they were derived?  These categories seem pretty much 
> ad hoc .
>
>        Reference: [IEC60050 
> <http://tools.ietf.org/html/draft-parello-eman-definitions-04#ref-IEC60050>]
>
>
>     Power quality parameters include the actual voltage, the actual
>     frequency, the Total Harmonic Distortion (THD) of voltage and
>     current, the impedance of an AC phase or of the DC Supply.
>
>
> The framework draft lists the following 22 attributes, but many are 
> redundant due to separate tables for single-phase, delta-phase, and 
> wye-phase.  Of these, only current isn't obviously a power quality 
> characteristic.
>
>
> Reviewing this, I can't understand the issue here from the meeting. 
> Can we perhaps get more clarity or simply close this issue?
>
>
>
> Description: Coraid+Logo_reallysmall 
> <http://www.coraid.com/> Redefining Storage Economics
>
>
> From: Bruce Nordman <[email-masked] <mailto:[email-masked]>>
> To: Benoit Claise <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> The Requirements draft 
> (http://www.ietf.org/id/draft-ietf-eman-requirements-05.txt)
> draft 
> (http://www.ietf.org/id/draft-ietf-eman-energy-monitoring-mib-01.txt).
> On Thu, Jan 26, 2012 at 1:51 AM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Dear all,
>
>     From the meeting minutes
>     (http://www.ietf.org/proceedings/82/minutes/eman.txt):
>
>     So the current definition of "Power Quality" in
>     covers correctly "2.", right?
>>     On Tue, Jan 24, 2012 at 9:38 AM, John Parello (jparello)
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         Hi,
>>
>>         <http://www.electropedia.org/iev/iev.nsf/display?openform&ievref=617-01-0>
>>         5
>>
>>         """
>>         Power Quality
>>         frequencies at a
>>         [email-masked] <mailto:[email-masked]>
>>     *Bruce Nordman*
>>     eetd.lbl.gov/ea/nordman <http://eetd.lbl.gov/ea/nordman>
>>     [email-masked] <mailto:[email-masked]>
>>     510-486-7089 <tel:510-486-7089>
>>     m: 510-501-7943 <tel:510-501-7943>
>>
>>
>>
>>     [email-masked]  <mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/eman
>
>
>
>
> -- 
> *Bruce Nordman*
> eetd.lbl.gov/ea/nordman <http://eetd.lbl.gov/ea/nordman>
> [email-masked] <mailto:[email-masked]>
> 510-486-7089
> m: 510-501-7943
>

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Tue, 14 Feb 2012 04:30:07 -0600

Hi Benoit,

This is another one of those threads discussed for a long time.   

First question was on what was the relevant IEC standards applicable to EMAN - 

IEC 61000-4-30, Electromagnetic compatibility (EMC) – Part 4-30: Testing and measurement techniques – Power quality measurement methods 

or 

IEC 61850-7-4 Ed.2: Communication networks and systems for power utility  automation - Part 7-4: 

Basic communication structure - Compatible logical node classes and data object classes 

which has led to the discussion of the definition of Power Quality. 

The  use of the term Power quality had a different connotation; according to the email of Michael Suchoff.   

http://www.ietf.org/mail-archive/web/eman/current/msg00631.html

and my response 

http://www.ietf.org/mail-archive/web/eman/current/msg00846.html

In IEC 61850-7-4; page 57 has a table of Logical Node – MMXU  - (which has some of the parameters measured)  – which is not referred to as Power Quality.  

From the reading some articles,  the deviation from Sinosoidal wave is referred to  as Power Quality such as  -  Voltage Sags, Flickr,   …

The book Brad has referred to  - some of the chapters are focused on this -  

Long Interruptions and Reliability Evaluation, Short Interruptions ,  Voltage Sags—Characterization, Mitigation of Interruptions and Voltage Sags.

Given this context, the first question is:

1.       What are the most important indices to be measured from an EMAN point of view ?  

There is general consensus that  Power, Voltage, current, Total power, Active power, reactive power, Power Factor ,….) 

In the ODVA document also there was a measurement of Real Power, Apparent Power, Reactive Power,  Total Power, and Power Factor 

2.       For some of indices collected  - What is the correct name/terminology ?  

At the WG, it was concluded these variables are additional power attributes and  can be referred to power characteristics. 

Thanks

Mouli

From: [email-masked] [mailto:[email-masked]] On Behalf Of Benoit Claise (bclaise)
Sent: Monday, February 13, 2012 10:01 PM
To: Brad Schoening
Cc: [email-masked]
Subject: Re: [eman] Power Quality versus Power Characteristics

Dear all,

I would like appreciate if someone could rephrase the problem description (if any), as there is some confusion.
According to this email thread, the power quality definition is fine and the EMAN requirements draft is in line with this definition.

Is the problem that the eoACPwrQualityTable EMAN monitoring MIB module contains at the same time:
- "power quality" variables
- non "power quality" variables, i.e not "evaluated against a set of reference technical parameters"? Example: current
Hence the table name should NOT contain "Power Quality" and the [EMAN-FMWK] wordings might have to be updated.

Please let us know.

Regards, Benoit.

Hi Bruce,

  Power Quality

       Reference: [IEC60050 <http://tools.ietf.org/html/draft-parello-eman-definitions-04#ref-IEC60050> ]

         |         ACQuality                     | 

         | avgVoltage   : long                   | 

         | avgCurrent   : long                   | 

         | frequency    : long                   | 

         | unitMultiplier  : int                 | 

         | accuracy  : int                       | 

         |         ACPhase                    | 

         | phaseIndex : long                  | 

         | avgCurrent : long                  | 

         | activePower : long                 | 

         | reactivePower : long               | 

         | apparentPower : long               | 

         | powerFactor : long                 | 

         |        DelPhase                   |      

         |thdVoltage : long                  |      

         |thdCurrent : long                  |      

         |        WYEPhase              | 

         |thdCurrent : long             | 

         |thdVoltage : long             | 

 

 

 

--Bruce

Dear all,

 

Regards, Benoit. 

--Bruce

Hi,

"""
Power Quality

Feedback?
Jp

---

From: Brad Schoening <[email-masked]>
Date: Tue, 14 Feb 2012 08:01:58 -0600

Benoit,

I hope that the terminology draft has clarified the meaning of 'power quality' and put this issue to rest.

Brad Schoening

From: Benoit Claise <[email-masked]<mailto:[email-masked]>>
Date: Mon, 13 Feb 2012 10:31:21 -0600
To: Brad Schoening <[email-masked]<mailto:[email-masked]>>
Cc: Bruce Nordman <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] Power Quality versus Power Characteristics

Dear all,

Please let us know.

Regards, Benoit.
Hi Bruce,

  Power Quality

       Reference: [IEC60050<http://tools.ietf.org/html/draft-parello-eman-definitions-04#ref-IEC60050>]

         |         ACQuality                     |

         | avgVoltage   : long                   |

         | avgCurrent   : long                   |

         | frequency    : long                   |

         | unitMultiplier  : int                 |

         | accuracy  : int                       |

         |         ACPhase                    |

         | phaseIndex : long                  |

         | avgCurrent : long                  |

         | activePower : long                 |

         | reactivePower : long               |

         | apparentPower : long               |

         | powerFactor : long                 |

         |        DelPhase                   |

         |thdVoltage : long                  |

         |thdCurrent : long                  |

         |        WYEPhase              |

         |thdCurrent : long             |

         |thdVoltage : long             |

e: [email-masked]<mailto:[email-masked]> ⟐ m: 917-304-7190

From: Bruce Nordman <[email-masked]<mailto:[email-masked]>>
Date: Tue, 31 Jan 2012 18:05:50 -0600
To: Benoit Claise <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] Power Quality versus Power Characteristics

--Bruce

On Thu, Jan 26, 2012 at 1:51 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Regards, Benoit.

--Bruce

On Tue, Jan 24, 2012 at 9:38 AM, John Parello (jparello) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

"""
Power Quality

Feedback?
Jp

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089<tel:510-486-7089>
m: 510-501-7943<tel:510-501-7943>

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943

---

From: Brad Schoening <[email-masked]>
Date: Tue, 14 Feb 2012 08:14:07 -0600

Mouli,

As noted earlier, our terminology definition for 'power quality' is taken from IEC 60050.   My belief is we should stick with that.  Let's keep any discussion centered on this terminology definition.

Brad Schoening

From: "Mouli Chandramouli (moulchan)" <[email-masked]<mailto:[email-masked]>>
Date: Tue, 14 Feb 2012 04:30:07 -0600
To: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, Brad Schoening <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [eman] Power Quality versus Power Characteristics

Hi Benoit,

or

and my response

Thanks
Mouli

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Benoit Claise (bclaise)
Sent: Monday, February 13, 2012 10:01 PM
To: Brad Schoening
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [eman] Power Quality versus Power Characteristics

Dear all,

Please let us know.

Regards, Benoit.

Hi Bruce,

  Power Quality

         |         ACQuality                     |

         | avgVoltage   : long                   |

         | avgCurrent   : long                   |

         | frequency    : long                   |

         | unitMultiplier  : int                 |

         | accuracy  : int                       |

         |         ACPhase                    |

         | phaseIndex : long                  |

         | avgCurrent : long                  |

         | activePower : long                 |

         | reactivePower : long               |

         | apparentPower : long               |

         | powerFactor : long                 |

         |        DelPhase                   |

         |thdVoltage : long                  |

         |thdCurrent : long                  |

         |        WYEPhase              |

         |thdCurrent : long             |

         |thdVoltage : long             |

--Bruce

1. Nominal power supply

3. Power usage

power quality.

Regards, Benoit.

--Bruce

"""
Power Quality

Feedback?
Jp

eman mailing list

---

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Feb 2012 16:39:46 +0100

Hi Brad,
> quality' and put this issue to rest.
I hope so. Therefore, I consider this issue close.

Regards, Benoit.
> From: Benoit Claise <[email-masked] <mailto:[email-masked]>>
> To: Brad Schoening <[email-masked] <mailto:[email-masked]>>
> Cc: Bruce Nordman <[email-masked] <mailto:[email-masked]>>, 
> "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> According to this email thread, the power quality definition is fine 
> and the EMAN requirements draft is in line with this definition.
>

---

From: Bruce Nordman <[email-masked]>
Date: Sun, 19 Feb 2012 22:43:34 -0800

It seems to me that the definition of power quality
implies a reference point for evaluating quality
that is absent in the EMAN context - making it
unsuitable to reference.
There is actually no need to reference the term
"power quality" at all in the drafts, and therefore
no need to have a definition for it.
While it would be best to not use the term at all in
the drafts, using it as a general descriptor of power
characteristics would likely not mislead people, but
this would not require a definition.
The monitoring MIB draft does use "PwrQuality"
in many of the entries.  These can simply be changed
to "Power".
Problem solved.
--Bruce

On Tue, Feb 14, 2012 at 7:39 AM, Benoit Claise <[email-masked]> wrote:

>   <http://www.coraid.com/> Redefining
> Storage Economics****
>
> ** **
>
>  From: Benoit Claise <[email-masked]>
> To: Brad Schoening <[email-masked]>
> Cc: Bruce Nordman <[email-masked]>, "[email-masked]" <[email-masked]>
>  I don't understand the context for choosing those three categories., 1,
> 2 & 3 or how they were derived?  These categories seem pretty much ad hoc .
>
> frequency, the Total Harmonic Distortion (THD) of voltage and current, the
> impedance of an AC phase or of the DC Supply.
>
>
>  Reviewing this, I can't understand the issue here from the meeting. Can
> we perhaps get more clarity or simply close this issue?
>
>
>
>   <http://www.coraid.com/> Redefining
> Storage Economics****
>
> ** **
>
> The Requirements draft (
> http://www.ietf.org/id/draft-ietf-eman-requirements-05.txt)
>> From the meeting minutes (
>> http://www.ietf.org/proceedings/82/minutes/eman.txt):
>>
>> http://tools.ietf.org/html/draft-parello-eman-definitions-04 covers
>> correctly "2.", right?
>> eman mailing [email-masked]://www.ietf.org/mailman/listinfo/eman
>>
>>
>>
>
>
> --
> *Bruce Nordman*

---

From: Brad Schoening <[email-masked]>
Date: Mon, 20 Feb 2012 09:03:48 -0600

Hi Bruce,

Your statement here is incorrect.  If you carefully review the details, you will see that the majority of these attributes incorporate a reference point.  For example, total harmonic distortion is a ratio of the distortion relative to the reference frequency.  Or consider, power factor which is a ratio of the real power to the apparent power, where real power is the reference point.

Clearly, measuring distortion and reactive power (wasted energy) are 'power quality' characteristics.

Regards,

Brad

Brad Schoening

From: Bruce Nordman <[email-masked]<mailto:[email-masked]>>
Date: Mon, 20 Feb 2012 00:43:34 -0600
To: Benoit Claise <[email-masked]<mailto:[email-masked]>>
Cc: Brad Schoening <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] Power Quality versus Power Characteristics

On Tue, Feb 14, 2012 at 7:39 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Hi Brad,

Benoit,

Regards, Benoit.

Brad Schoening
e: [email-masked]<mailto:[email-masked]> ⟐ m: 917-304-7190<tel:917-304-7190>

Dear all,

Please let us know.

Regards, Benoit.
Hi Bruce,

  Power Quality

         |         ACQuality                     |

         | avgVoltage   : long                   |

         | avgCurrent   : long                   |

         | frequency    : long                   |

         | unitMultiplier  : int                 |

         | accuracy  : int                       |

         |         ACPhase                    |

         | phaseIndex : long                  |

         | avgCurrent : long                  |

         | activePower : long                 |

         | reactivePower : long               |

         | apparentPower : long               |

         | powerFactor : long                 |

         |        DelPhase                   |

         |thdVoltage : long                  |

         |thdCurrent : long                  |

         |        WYEPhase              |

         |thdCurrent : long             |

         |thdVoltage : long             |

e: [email-masked]<mailto:[email-masked]> ⟐ m: 917-304-7190<tel:917-304-7190>

--Bruce

Regards, Benoit.

--Bruce

"""
Power Quality

Feedback?
Jp

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 22 Feb 2012 10:28:25 -0800

On Mon, Feb 20, 2012 at 7:03 AM, Brad Schoening <[email-masked]> wrote:

> Hi Bruce,
>
> Your statement here is incorrect.  If you carefully review the details,
> you will see that the majority of these attributes incorporate a reference
> point.  For example, total harmonic distortion is a ratio of the distortion
> relative to the reference frequency.  Or consider, power factor which is a
> ratio of the real power to the apparent power, where real power is the
> reference point.
>

Below I have extracted the 24 entries in draft-ietf-eman-requirements-05
that are labeled "PwrQuality".  The interested reader can count how many of
these incorporate a reference point in the EMAN reporting context.

--Bruce

        powerACPwrQualityMIBTableGroup OBJECT-GROUP
                             eoACPwrQualityConfiguration,
                             eoACPwrQualityAvgVoltage,
                             eoACPwrQualityAvgCurrent,
                             eoACPwrQualityFrequency,
                             eoACPwrQualityPowerUnitMultiplier,
                             eoACPwrQualityPowerAccuracy,
                             eoACPwrQualityTotalActivePower,
                             eoACPwrQualityTotalReactivePower,
                             eoACPwrQualityTotalApparentPower,
                             eoACPwrQualityTotalPowerFactor,
                             eoACPwrQualityThdAmpheres,
                             eoACPwrQualityThdVoltage
        powerACPwrQualityPhaseMIBTableGroup OBJECT-GROUP
                             eoACPwrQualityPhaseAvgCurrent,
                             eoACPwrQualityPhaseActivePower,
                             eoACPwrQualityPhaseReactivePower,
                             eoACPwrQualityPhaseApparentPower,
                             eoACPwrQualityPhasePowerFactor,
                             eoACPwrQualityPhaseImpedance
        powerACPwrQualityDelPhaseMIBTableGroup OBJECT-GROUP
                            eoACPwrQualityDelPhaseToNextPhaseVoltage ,
                            eoACPwrQualityDelThdPhaseToNextPhaseVoltage,
                            eoACPwrQualityDelThdCurrent
        powerACPwrQualityWyePhaseMIBTableGroup OBJECT-GROUP
                            eoACPwrQualityWyePhaseToNeutralVoltage,
                            eoACPwrQualityWyePhaseCurrent,
                            eoACPwrQualityWyeThdPhaseToNeutralVoltage

> Cc: Brad Schoening <[email-masked]>, "[email-masked]" <[email-masked]>
>
>> draft (
>> http://www.ietf.org/id/draft-ietf-eman-energy-monitoring-mib-01.txt).

---

From: Brad Schoening <[email-masked]>
Date: Wed, 22 Feb 2012 12:49:33 -0600

Hi Bruce,

My count is 18 measurement attributes having an explicit reference point or ratio with three additional attributes are informational for the table: Configuration, UnitMultiplier, and Accuracy.

Which attributes are you having an issue with?

Regards,

Brad

Brad Schoening

From: Bruce Nordman <[email-masked]<mailto:[email-masked]>>
Date: Wed, 22 Feb 2012 12:28:25 -0600
To: Brad Schoening <[email-masked]<mailto:[email-masked]>>
Cc: Benoit Claise <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] Power Quality versus Power Characteristics

On Mon, Feb 20, 2012 at 7:03 AM, Brad Schoening <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bruce,

--Bruce

Regards,

Brad

Brad Schoening

Benoit,

Regards, Benoit.

Brad Schoening

Dear all,

Please let us know.

Regards, Benoit.
Hi Bruce,

  Power Quality

         |         ACQuality                     |

         | avgVoltage   : long                   |

         | avgCurrent   : long                   |

         | frequency    : long                   |

         | unitMultiplier  : int                 |

         | accuracy  : int                       |

         |         ACPhase                    |

         | phaseIndex : long                  |

         | avgCurrent : long                  |

         | activePower : long                 |

         | reactivePower : long               |

         | apparentPower : long               |

         | powerFactor : long                 |

         |        DelPhase                   |

         |thdVoltage : long                  |

         |thdCurrent : long                  |

         |        WYEPhase              |

         |thdCurrent : long             |

         |thdVoltage : long             |

--Bruce

Regards, Benoit.

--Bruce

"""
Power Quality

Feedback?
Jp

---

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Feb 2012 16:18:04 +0100

Bruce, Brad,

Can we please close this issue.

Regards, Benoit. (as a contributor for  the EMAN-FMWK)
> Hi Bruce,
>
> My count is 18 measurement attributes having an explicit reference 
> point or ratio with three additional attributes are informational for 
> the table: Configuration, UnitMultiplier, and Accuracy.
>
> Cc: Benoit Claise <[email-masked] <mailto:[email-masked]>>, 
>     Your statement here is incorrect.  If you carefully review the
>     details, you will see that the majority of these attributes
>     incorporate a reference point.  For example, total harmonic
>     distortion is a ratio of the distortion relative to the reference
>     frequency.  Or consider, power factor which is a ratio of the real
>     power to the apparent power, where real power is the reference point.
>
>
>     e: [email-masked] <mailto:[email-masked]> ⟐ m:917-304-7190
>     <tel:917-304-7190>
>
>
>     Cc: Brad Schoening <[email-masked] <mailto:[email-masked]>>,
>>         I hope that the terminology draft has clarified the meaning
>>         of 'power quality' and put this issue to rest.
>>         e: [email-masked] <mailto:[email-masked]>
>>         ⟐ m:917-304-7190 <tel:917-304-7190>
>>
>>
>>         Cc: Bruce Nordman <[email-masked]
>>         <mailto:[email-masked]>>, "[email-masked]
>>         <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>>         According to this email thread, the power quality definition
>>         is fine and the EMAN requirements draft is in line with this
>>         definition.
>>
>>         - non "power quality" variables, i.e not "evaluated against a
>>         set of reference technical parameters"? Example: current
>>         Hence the table name should NOT contain "Power Quality" and
>>         the [EMAN-FMWK] wordings might have to be updated.
>>
>>         Please let us know.
>>
>>         Regards, Benoit.
>>>         Hi Bruce,
>>>
>>>         I don't understand the context for choosing those three
>>>         categories., 1, 2 & 3 or how they were derived?  These
>>>         categories seem pretty much ad hoc .
>>>
>>>             Power quality parameters include the actual voltage, the
>>>             actual frequency, the Total Harmonic Distortion (THD)
>>>             of voltage and current, the impedance of an AC phase or
>>>             of the DC Supply.
>>>
>>>
>>>         The framework draft lists the following 22 attributes, but
>>>         many are redundant due to separate tables for single-phase,
>>>         delta-phase, and wye-phase.  Of these, only current isn't
>>>         obviously a power quality characteristic.
>>>
>>>
>>>         Reviewing this, I can't understand the issue here from the
>>>         meeting. Can we perhaps get more clarity or simply close
>>>         this issue?
>>>
>>>
>>>
>>>         e: [email-masked] <mailto:[email-masked]>
>>>         ⟐ m:917-304-7190 <tel:917-304-7190>
>>>
>>>
>>>         On Thu, Jan 26, 2012 at 1:51 AM, Benoit Claise
>>>         <[email-masked] <mailto:[email-masked]>> wrote:
>>>
>>>             Dear all,
>>>
>>>             From the meeting minutes
>>>>             On Tue, Jan 24, 2012 at 9:38 AM, John Parello
>>>>             (jparello) <[email-masked]
>>>>             <mailto:[email-masked]>> wrote:
>>>>
>>>>                 Hi,
>>>>
>>>>                 supplied in an electric

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 29 Feb 2012 14:25:28 -0800

I agree this should be closed ASAP.

To try to summarize, we have a definition of Power Quality in:
   http://datatracker.ietf.org/doc/draft-parello-eman-definitions/
that reads (emphasis added by me):
Characteristics of the electric current, voltage and frequencies at a given
point in
an electric power system, *evaluated against a set of reference technical
parameters*.
These parameters might, in some cases,relate to the compatibility between
electricity
supplied in an electric power system and the loads connected to that
electric power system.
Further, there are 24 MIB variables with Quality as part of their name in:

            eoACPwrQualityConfiguration       INTEGER,
            eoACPwrQualityAvgVoltage          Integer32,
            eoACPwrQualityAvgCurrent          Integer32,
            eoACPwrQualityFrequency           Integer32,
            eoACPwrQualityPowerUnitMultiplier UnitMultiplier,
            eoACPwrQualityPowerAccuracy       Integer32,
            eoACPwrQualityTotalActivePower    Integer32,
            eoACPwrQualityTotalReactivePower  Integer32,
            eoACPwrQualityTotalApparentPower  Integer32,
            eoACPwrQualityTotalPowerFactor    Integer32,
            eoACPwrQualityThdAmpheres         Integer32,
            eoACPwrQualityThdVoltage          Integer32
                eoACPwrQualityPhaseAvgCurrent      Integer32,
                eoACPwrQualityPhaseActivePower     Integer32,
                eoACPwrQualityPhaseReactivePower   Integer32,
                eoACPwrQualityPhaseApparentPower   Integer32,
                eoACPwrQualityPhasePowerFactor     Integer32,
                eoACPwrQualityPhaseImpedance       Integer32
            eoACPwrQualityDelPhaseToNextPhaseVoltage      Integer32,
            eoACPwrQualityDelThdPhaseToNextPhaseVoltage   Integer32,
            eoACPwrQualityDelThdCurrent                   Integer32
                eoACPwrQualityWyePhaseToNeutralVoltage       Integer32,
                eoACPwrQualityWyePhaseCurrent                Integer32,
                eoACPwrQualityWyeThdPhaseToNeutralVoltage    Integer32

As the definition of power quality makes clear, these are "characteristics".
By my reading, they become "power quality" when "*evaluated against a set
of reference technical parameters*. "
It seems to me that EMAN does not contain "reference technical parameters"
and does no evaluation.
Outside of the scope of EMAN, some management systems may have such
reference parameters and may do such evaluations.

Finally, I see no advantages to including the definition and the use of the
term
quality.  I see definite disadvantages.  No implementation will ever be
different
based on the outcome of this decision.

A simple solution is to simply drop the word Quality out of these MIB names,
at which point the definition becomes unnecessary to include.

--Bruce

On Tue, Feb 28, 2012 at 7:18 AM, Benoit Claise <[email-masked]> wrote:

>  My count is 18 measurement attributes having an explicit reference point
> or ratio with three additional attributes are informational for the table:
> Configuration, UnitMultiplier, and Accuracy.
>
> Cc: Benoit Claise <[email-masked]>, "[email-masked]" <[email-masked]>
>> Storage Economics
>>  On Tue, Feb 14, 2012 at 7:39 AM, Benoit Claise <[email-masked]>wrote:
>>
>>>  Hi Brad,
>>>
>>>   Benoit,
>>>
>>> Storage Economics
>>> 1, 2 & 3 or how they were derived?  These categories seem pretty much ad
>>> hoc .
>>>
>>> Storage Economics
>>> On Thu, Jan 26, 2012 at 1:51 AM, Benoit Claise <[email-masked]>wrote:
>>>
>>>>  Dear all,
>>>>

---

From: Brad Schoening <[email-masked]>
Date: Wed, 29 Feb 2012 16:30:59 -0600

Bruce,

I believe we are talking past each other.  The majority of these 24 MIB variables *do* have a reference value as noted in my earlier email.  Could you be specific about which ones you feel don't have a reference parameter.

Brad Schoening

Date: Wed, 29 Feb 2012 16:25:28 -0600

To try to summarize, we have a definition of Power Quality in:
   http://datatracker.ietf.org/doc/draft-parello-eman-definitions/
that reads (emphasis added by me):
Characteristics of the electric current, voltage and frequencies at a given point in
an electric power system, evaluated against a set of reference technical parameters.
These parameters might, in some cases,relate to the compatibility between electricity
supplied in an electric power system and the loads connected to that electric power system.
Further, there are 24 MIB variables with Quality as part of their name in:

By my reading, they become "power quality" when "evaluated against a set of reference technical parameters. "

Finally, I see no advantages to including the definition and the use of the term
quality.  I see definite disadvantages.  No implementation will ever be different
based on the outcome of this decision.

--Bruce

On Tue, Feb 28, 2012 at 7:18 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Bruce, Brad,

Regards,

Brad

Brad Schoening

--Bruce

Regards,

Brad

Brad Schoening

Benoit,

Regards, Benoit.

Brad Schoening

Dear all,

Please let us know.

Regards, Benoit.
Hi Bruce,

  Power Quality

         |         ACQuality                     |

         | avgVoltage   : long                   |

         | avgCurrent   : long                   |

         | frequency    : long                   |

         | unitMultiplier  : int                 |

         | accuracy  : int                       |

         |         ACPhase                    |

         | phaseIndex : long                  |

         | avgCurrent : long                  |

         | activePower : long                 |

         | reactivePower : long               |

         | apparentPower : long               |

         | powerFactor : long                 |

         |        DelPhase                   |

         |thdVoltage : long                  |

         |thdCurrent : long                  |

         |        WYEPhase              |

         |thdCurrent : long             |

         |thdVoltage : long             |

--Bruce

Regards, Benoit.

--Bruce

"""
Power Quality

Feedback?
Jp

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 29 Feb 2012 14:39:28 -0800

What are the reference values for each then?
Listing them specifically would help us understand
how EMAN evaluates them.
--Bruce

On Wed, Feb 29, 2012 at 2:30 PM, Brad Schoening <[email-masked]> wrote:

> Bruce,
>
> I believe we are talking past each other.  The majority of these 24 MIB
> variables *do* have a reference value as noted in my earlier email.  Could
> you be specific about which ones you feel don't have a reference parameter.
>
>
> Brad Schoening
> given point in
>> point or ratio with three additional attributes are informational for the
>> table: Configuration, UnitMultiplier, and Accuracy.
>>
>>> details, you will see that the majority of these attributes incorporate a
>>> reference point.  For example, total harmonic distortion is a ratio of the
>>> distortion relative to the reference frequency.  Or consider, power factor
>>> which is a ratio of the real power to the apparent power, where real power
>>> is the reference point.
>>>
>>

---

From: Brad Schoening <[email-masked]>
Date: Wed, 29 Feb 2012 16:42:41 -0600

Bruce,

I already gave two examples on Feb 20th :

For example, total harmonic distortion is a ratio of the distortion relative to the reference frequency.  Or consider, power factor which is a ratio of the real power to the apparent power, where real power is the reference point.

Brad Schoening

Date: Wed, 29 Feb 2012 16:39:28 -0600

On Wed, Feb 29, 2012 at 2:30 PM, Brad Schoening <[email-masked]<mailto:[email-masked]>> wrote:
Bruce,

Brad Schoening

--Bruce

Regards,

Brad

Brad Schoening

--Bruce

Regards,

Brad

Brad Schoening

Benoit,

Regards, Benoit.

Brad Schoening

Dear all,

Please let us know.

Regards, Benoit.
Hi Bruce,

  Power Quality

         |         ACQuality                     |

         | avgVoltage   : long                   |

         | avgCurrent   : long                   |

         | frequency    : long                   |

         | unitMultiplier  : int                 |

         | accuracy  : int                       |

         |         ACPhase                    |

         | phaseIndex : long                  |

         | avgCurrent : long                  |

         | activePower : long                 |

         | reactivePower : long               |

         | apparentPower : long               |

         | powerFactor : long                 |

         |        DelPhase                   |

         |thdVoltage : long                  |

         |thdCurrent : long                  |

         |        WYEPhase              |

         |thdCurrent : long             |

         |thdVoltage : long             |

--Bruce

Regards, Benoit.

--Bruce

"""
Power Quality

Feedback?
Jp