Subject: [eman] EMAN-FMWK: An Energy Object is part of a single Energy Management Domain

From: Benoit Claise <[email-masked]>
Date: Fri, 24 Feb 2012 15:20:28 +0100

Dear all,

In the current [EMAN-FMWK], we can read "An Energy Object is part of a 
single Energy Management Domain"

Feedback received from Bill Mielke:
"I don't think that this is a valid assumption. How do we address the 
case of an energy object which has redundant and diverse power sources 
for reliability, or an energy object which has access to alternative 
power sources with the ability to dynamically switch between them to 
optimize cost and/or carbon footprint impacts. Are these not examples of 
different metering domains?"

The Energy Domain definition has been updated, with some example

    Energy Management Domain

An Energy Management Domain is a set of Energy Objects where all objects 
in the domain are considered one unit of management.

For example, power distribution units and all of the attached Energy 
Objects are part of the same Energy Management Domain.

For example, all EEO's drawing power from the same distribution panel 
with the same AC voltage within a building, or all EEO's in a building 
for which there is one main meter, would comprise an Energy Management 
Domain.

NOTES:

1. Typically, this set will have as members all EO's that are powered 
from the same source.

Is this enough?

Please let us know.

Regards, Benoit. (contributor for [EMAN-FMWK])

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 24 Feb 2012 16:16:12 +0000

Hi all,

I would have an alternative proposal to solve Bill's issue
on devices with redundant and diverse power sources.

Having an only entire devices (aka Energy Objects)
may lead to problems if the energy object has multiple
power inlets from different domains.

Instead of having entire energy objects as domain members,
we should rather have memberships for the power interfaces
of the energy objects.

Then a single energy object can have different power
Interfaces (in Bill's scenario: power inlets) being member
of different domains. And our energy management model would
exactly match the real world scenario that Bill pointed us to.

And we can easily add this corollary: If all power interface of
an energy object are in the same domain, then it is safe to state
that the entire energy object is in that domain.

Thanks,
    Juergen

On 24.02.12 15:20, "Benoit Claise" <[email-masked]> wrote:

>
>  
>  
>    Dear all,
>    
>    In the current [EMAN-FMWK], we can read "An Energy Object is part of
>    a single Energy Management Domain"
>    
>    ³I don't think that this is a valid
>      assumption.
>      How do we address the case of an energy object which has redundant
>      and diverse
>      power sources for reliability, or an energy object which has
>      access to
>      alternative power sources with the ability to dynamically switch
>      between them
>      to optimize cost and/or carbon footprint impacts. Are these not
>      examples of
>      different metering domains?²
>    
>    
>    
>    
>    
>    
>    
>    
>    Energy
>      Management Domain
>    An
>      Energy Management Domain is a set of Energy Objects where
>      all objects in the domain are considered one unit of management.
>     
>    For
>      example, power distribution units and all of the attached
>      Energy Objects are part of the same Energy Management Domain.
>     
>    For
>      example, all EEO's drawing power from the same distribution panel
>      with the same
>      AC voltage within a building, or all EEO's in a building for which
>      there is one
>      main meter, would comprise an Energy Management Domain.
>     
>    NOTES:
>    
>    1.
>      Typically,
>      this set will have as members all EO's that are powered from the
>      same source.
>     
>    
>    
>    
>    
>    
>    
>    
>    Is this enough?
>    
>    Please let us know.
>    
>_______________________________________________
>eman mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/eman