Subject: Re: [eman] I-D Action: draft-ietf-eman-applicability-statement-00.txt

From: Gigi Proserpio <[email-masked]>
Date: Mon, 12 Mar 2012 08:31:57 +0100

Hello,
I recently join this interesting mailing list and reading the
"draft-ietf-eman-applicability-statement-00.txt" document I have some
comment about it, hoping that it could be of some interest for a discussion.

_____________________________________________________

*4.1. Data Model and Reporting*

*4.1.1. IEC - CIM*

*The International Electro-technical Commission (IEC) has developed a broad
set of standards for power management. Among these, the most applicable to
EMAN is IEC 61850, a standard for the design of electric utility
automation.The abstract data model defined in 61850 is built upon and
extends the
Common Information Model (CIM)**. *

Comment:

The two standard, IEC61850 and CIM born indipendently, with different
objective, IEC TC57 WG19 is now working for harmonize them.

   1.

   IEC 61850: Communications Networks and Systems for Power Utility
   Automation;
   IEC61850 standard defines communications within transmission and
   distribution substations for automation and protection. It is being
   extended to cover communications beyond the substation to integration of
   distributed resources and between substations.

   1.

   CIM
   CIM is only the data model section contained both in IEC61970 and
   IEC61968 standard

 -IEC 61968: Common Information Model (CIM) and Messaging Interfaces for
Distribution Management;

-IEC 61970: Energy Management System Application Program Interface
(EMS-API);

 IEC61850 is more operative (i.e. open/close a breaker,  Voltage measure)
while IEC61970 and IEC61968 are more related to enterprise integration and
Power System Model description (i.e. CPSM).
These standards are complementary, even thought there are some parts of
them that overlaps (i.e. common power system model).

  -----------------

*4.1.1. IEC - CIM*

*...
*

*This set of standards was originally conceived to automate control of a
substation (facilities which transfer electricity from the transmission to
the distribution system). While the original domain of 61850 is substation
automation, the extensive data model has been widely used in other
domains, including
Energy Management Systems (EMS).*

Comment:
As cited in definition of standards in previous comment, EMS is more
related to IEC61970 than IEC61850.
IEC-61850 use is extending to other domain like Distributed Energy
Resources (like solar, wind …) but not to EMS.

------------------------

9. Open Issues

OPEN ISSUE 1: Relevant IEC standards for application for EMAN Applicability
Statement document can provide guidance on the issue of what is appropriate
standard used by EMAN

IEC 61850-7-4 has been extensively used in EMAN WG documents.

The other IEC documents referred for possible use are IEC 61000-4-30, IEC
62053-21 and IEC 62301.

There is feedback that IEC 61850-7-4 applies only to substations ?

 Comment:

IEC61850-7-4 Data model is being extended to cover communications beyond
the substation, for example to integration of distributed resources and
between substations.

The objects defined in IEC61850-7-4 are related to substation domain, but
they could also be used in other domain (i.e. A Circuit Breaker (XCBR) or a
Measurement (MMXU) object could be used to model a DER plant or a Hydro
power plant too).

There are additional data model in IEC61850 that define other object for
specific domain (i.e. IEC61850-7-420 for DER, IEC61850-7-410 for Hydro
power plant, IEC 61850-90-7 - Object Models for DER Inverters, ..)

Kind Regards,
Gianluigi Proserpio

---

From: Gianluigi Proserpio <[email-masked]>
Date: Mon, 12 Mar 2012 08:50:29 +0100

Hello,

*4.1.1. IEC - CIM*

Comment:

   1.

   1.

   CIM

  -----------------

*4.1.1. IEC - CIM*

*...
*

Comment:

------------------------

9. Open Issues

 Comment:

Kind Regards,
Gianluigi Proserpio

---

From: Brad Schoening <[email-masked]>
Date: Thu, 22 Mar 2012 08:58:50 -0500

Gianluigi,

Thanks for your comments.  Although they're complimentary, as you note, I agree that we should distinguish between IEC 61850 and 61970 more clearly.  We have adapted the MMUX measurement data model from the former in our draft-ietf-energy-monitoring-mib.

Regards,

Brad

Brad Schoening
e: [email-masked] ⟐ m: 917-304-7190

<http://www.coraid.com/> Redefining Storage Economics

From: Gianluigi Proserpio <[email-masked]<mailto:[email-masked]>>
Date: Mon, 12 Mar 2012 02:50:29 -0500
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] I-D Action: draft-ietf-eman-applicability-statement-00.txt

Hello,
I recently join this interesting mailing list and reading the "draft-ietf-eman-applicability-statement-00.txt" document I have some comment about it, hoping that it could be of some interest for a discussion.

4.1. Data Model and Reporting

4.1.1. IEC - CIM

The International Electro-technical Commission (IEC) has developed a broad set of standards for power management. Among these, the most applicable to EMAN is IEC 61850, a standard for the design of electric utility automation. The abstract data model defined in 61850 is built upon and extends the Common Information Model (CIM).

Comment:

The two standard, IEC61850 and CIM born indipendently, with different objective, IEC TC57 WG19 is now working for harmonize them.

 1.  IEC 61850: Communications Networks and Systems for Power Utility Automation;
IEC61850 standard defines communications within transmission and distribution substations for automation and protection. It is being extended to cover communications beyond the substation to integration of distributed resources and between substations.

 1.  CIM
CIM is only the data model section contained both in IEC61970 and IEC61968 standard

-IEC 61968: Common Information Model (CIM) and Messaging Interfaces for Distribution Management;

-IEC 61970: Energy Management System Application Program Interface (EMS-API);

IEC61850 is more operative (i.e. open/close a breaker,  Voltage measure) while IEC61970 and IEC61968 are more related to enterprise integration and Power System Model description (i.e. CPSM).
These standards are complementary, even thought there are some parts of them that overlaps (i.e. common power system model).

-----------------

4.1.1. IEC - CIM

...

This set of standards was originally conceived to automate control of a substation (facilities which transfer electricity from the transmission to the distribution system). While the original domain of 61850 is substation automation, the extensive data model has been widely used in other domains, including Energy Management Systems (EMS).

Comment:

As cited in definition of standards in previous comment, EMS is more related to IEC61970 than IEC61850.
IEC-61850 use is extending to other domain like Distributed Energy Resources (like solar, wind …) but not to EMS.

------------------------

9. Open Issues

OPEN ISSUE 1: Relevant IEC standards for application for EMAN Applicability Statement document can provide guidance on the issue of what is appropriate standard used by EMAN

The other IEC documents referred for possible use are IEC 61000-4-30, IEC 62053-21 and IEC 62301.

Comment:

IEC61850-7-4 Data model is being extended to cover communications beyond the substation, for example to integration of distributed resources and between substations.

The objects defined in IEC61850-7-4 are related to substation domain, but they could also be used in other domain (i.e. A Circuit Breaker (XCBR) or a Measurement (MMXU) object could be used to model a DER plant or a Hydro power plant too).

There are additional data model in IEC61850 that define other object for specific domain (i.e. IEC61850-7-420 for DER, IEC61850-7-410 for Hydro power plant, IEC 61850-90-7 - Object Models for DER Inverters, ..)

Kind Regards,
Gianluigi Proserpio

---

From: Gianluigi Proserpio <[email-masked]>
Date: Fri, 23 Mar 2012 07:47:45 +0100

Thank you Brad for your answer.
I'll try to be more concise:

   - Although I haven't read all documents, I haven't found  any reference
   to CIM (with  IEC semantic).
   Is it used in any section ?

   - If instead there are (or will be)  reference to CIM,  I suggest:

   - to distinguish between two type of "Common Information Model" with
      something like "IEC-CIM" and "DMTF-CIM"
      - To delete in 4.1.1 the sentence " is built upon and extends the
      Common Information Model (CIM)".
      If that sentence were true, there won't be any need to harmonize
      IEC61850 and CIM, like WG19 is trying to do.

Kind Regards,
Gianluigi

2012/3/22 Brad Schoening <[email-masked]>

> Gianluigi,
>
> Thanks for your comments.  Although they're complimentary, as you note, I
> agree that we should distinguish between IEC 61850 and 61970 more clearly.
>  We have adapted the MMUX measurement data model from the former in our
> draft-ietf-energy-monitoring-mib.
>
> Regards,
>
> Brad
>
> Brad Schoening
>  <http://www.coraid.com/> Redefining
> Storage Economics****
>
> ** **
>
> From: Gianluigi Proserpio <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: Re: [eman] I-D Action:
> draft-ietf-eman-applicability-statement-00.txt
>
> Hello,
> *The International Electro-technical Commission (IEC) has developed a
> broad set of standards for power management. Among these, the most
> applicable to EMAN is IEC 61850, a standard for the design of electric
> utility automation. The abstract data model defined in 61850 is built
> upon and extends the Common Information Model (CIM)**. *
>
> Comment:
>
> automation, the extensive data model has been widely used in other domains, including
> OPEN ISSUE 1: Relevant IEC standards for application for EMAN
> Applicability Statement document can provide guidance on the issue of what
> is appropriate standard used by EMAN
>