Subject: [eman] EMAN-REQ: the notion of importance

From: "McAndrew, Niall" <[email-masked]>
Date: Mon, 5 Mar 2012 10:46:36 +0000

Hello,

I am writing to you in relation to the proposed importance field.

In our Intelligent Infrastructure Solution, iPatch we have energy
management features. We can individually control each switchport (or
circuit) based on the physical location (eg. desk in a room) of the
connected device. We also integrate with partners who control individual
outlet ports at the same location. This information is available for the
device and for each port or outlet.

We use an importance value to further filter devices.
For example, we can apply Energy Management policy to devices in a given
location - excluding those with importance greater than a certain value.

Since we are already using an importance value to measure energy usage
in a given location - for 'important' devices (thereby filtering-out
devices of low importance we'd appreciate keeping this notion in the
standard.

Thank you.
Best regards,
Niall Mc Andrew.

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 14 Mar 2012 02:25:21 +0000

Dear Niall,

Thank you very much for your valuable input.

Can you point us to a documentation of your solution that contains a
specification of your importance parameter?  This could potentially help
us to clearly specify the semantics of it.

Thanks,
    Juergen

On 05.03.12 11:46, "McAndrew, Niall" <[email-masked]> wrote:

>_______________________________________________ eman mailing list
>[email-masked]://www.ietf.org/mailman/listinfo/eman

---

From: "McAndrew, Niall" <[email-masked]>
Date: Wed, 14 Mar 2012 11:12:12 +0000

Hello Jeurgen,

We can select a location, and create a regular policy for everything in that location.  Our intelligent infrastructure solution maps in real-time all of the connectivity in the selected location, which ensures that the right policy is applied to the right outlet (eg switchport or circuit) at the right time.

In the example below (see snapshot) we can select a room ('Meeting Room'), and then apply a regular policy to everything in the room.  In this example, our regular policy will automatically power-on everything at 7am on weekdays, and then power-off at 8pm.

Here's a link which shows a short video demonstration:

http://www.youtube.com/watch?v=8_BaDSQHBK4

With the 'importance' field, we could automatically skip devices with importance > 80 (for example).  This means that the policy would apply

to everything in the selected location - but *excluding* important devices (for example: security cameras, access control devices, emergency telephones, etc.)

We have been asked before how to exclude certain equipment from a policy,

because the end-user will have certain important devices which need to be left alone.  Using the 'importance' field would enable us to do that.

Best regards,

Niall.

(see snapshot below)

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]]
Sent: 14 March 2012 02:25
To: McAndrew, Niall; eman mailing list
Cc: German, Michael
Subject: Re: [eman] EMAN-REQ: the notion of importance

Dear Niall,

Thanks,

    Juergen

---

From: Emmanuel Tychon <[email-masked]>
Date: Wed, 21 Mar 2012 14:02:57 +0100

Hello Juergen, Niall,

This is a good point. In other words, the "importance" is a variable mapping the business context. 

Another use case that I can think of, is in case of power failure. 

 - Right after loosing power: keep all equipment running on the UPS for the first two minutes, leaving time for the mains to come back while no one even notice. Maybe only 50% of the lights are protected, so that employees knows there's a power cut. They can prepare themselves by saving unsaved documents, or letting the other person on the phone know they might get cut.

 - After two minutes, to last longer on batteries/generator, I can start to turn off equipment with low business importance (some printers, phones, vendor machines, etc…).

 - After 10 minutes, shut down projectors, meeting room phones, and leave only 20% of the lights on.

etc… you get the picture? Here's an example based on the example above:

Importance 0: some lights
Importance 20: printers, vendor machines, 
Importance 40: projector, public use phones
Importante 60: video conferencing systems, fridge
Importance 80: Airconditioning system, all phones, PCs, non-critical servers (graceful shutdown), etc… 
Importance 100: Emergency phones, video surveillance camera, critical servers

Hope this helps,
Emmanuel

On 14 Mar 2012, at 12:12, McAndrew, Niall wrote:

> In the example below (see snapshot) we can select a room (‘Meeting Room’), and then apply a regular policy to everything in the room.  In this example, our regular policy will automatically power-on everything at 7am on weekdays, and then power-off at 8pm.
>  
> Here’s a link which shows a short video demonstration:
> With the ‘importance’ field, we could automatically skip devices with importance > 80 (for example).  This means that the policy would apply
> to everything in the selected location – but *excluding* important devices (for example: security cameras, access control devices, emergency telephones, etc.)
>  
> because the end-user will have certain important devices which need to be left alone.  Using the ‘importance’ field would enable us to do that.
>  
> Best regards,
> Niall.
>  
> (see snapshot below)
>  
>  
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 27 Mar 2012 07:49:37 +0200

Hi Emmanuel,

This is another great use case. Here you use 'importance' for defining a 'power down' order. 

Thanks,
    Juergen