Subject: Re: [eman] [EMAN-FMWK] versus [EMAN-REF]: Power Source Relationship and power interface

From: Juergen Quittek <[email-masked]>
Date: Thu, 1 Mar 2012 13:11:32 +0000

Hi Benoit,

Thanks for pointing out these two issues.
Please find comments inline.

On 28.02.12 00:49, "Benoit Claise" <[email-masked]> wrote:

>    Dear all,
>    
>    [EMAN-FMWK] =
>    http://datatracker.ietf.org/doc/draft-ietf-eman-framework/, the
>    official EMAN document
>    [EMAN-REF] =
>    http://datatracker.ietf.org/doc/draft-quittek-eman-reference-model/
>    
>    Discussing about the differences between [EMAN-FMWK] and [EMAN-REF]
>    with one author of the [EMAN-REF], there is one open issue that
>    needs to be resolved.
>    
>    [EMAN-FMWK], specifies, via the terminology draft:
>    
>    
>    
>    Power Source Relationship
>    An
>      Energy Object may be the source of or distributor of Power to
>      another Energy
>      Object(s) and is referred to as a Power Source Relationship.
>     
>    Example:
>      a PDU provides power for a connected host.
>    
>    
>    
>    
>    
>    
>    
>    This relationship is modeled by  eoMeteredBy in [EMAN-AWARE-MIB],
>    http://www.ietf.org/id/draft-ietf-eman-energy-aware-mib-04.txt
>    
>    Issue 1: 
>    [EMAN-FMWK] has the poweredBy relationship, which imposes a
>    direction "from A to B"
>    [EMAN-REF] wants to have a kind of "wiring topology" relationship,
>    and then the power direction is deduced from the counters
>    As far as I understand, [EMAN-REF] is after a "power relationship".
>    
>    Issue 2:
>    [EMAN-REF] mentions the notion of power interface.
>    Taking into account the terminology from [EMAN-FMWK]
>        A power interface is an Energy Object that has one Power Source
>    Relationship 
>        Note: it may have other relationships (such as Metering or Proxy
>    Relationship, like in POE)
>    Do we need this notion in the [EMAN-FMWK]?
>    
>    Please share your thoughts on both issues, which are linked,
>    
>      
>      
>      
>      
>      
>    
>
>    I put the problem on the table, to start the discussion, and I'll
>    give my feedback later.
>    
>    Regards, Benoit (as a contributor for the [EMAN-FMWK]
>    
>    
>    
>    
>    
>    
>  
>
>_______________________________________________
>eman mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 1 Mar 2012 13:27:59 +0000

Hi Benoit,

Sorry, my previous email slipped to the outbox before it was complete.

> As far as I understand, [EMAN-REF] is after a "power relationship".

One significant difference between the EMAN-FMWK and EMAN-REF is the
following:

Let's assume a PDU powering a PoE switch powering a PoE desktop phone.
That's not a funny theoretical case.
That's how the phone on my desk is powered.

PDU---powers-->SWITCH---powers-->PHONE

According to EMAN-REF, the phone has a power interphase
that has a poweredBy relation to an interface of the switch.
In the EMAN-REF model, the phone has no direct relationship
with the PDU, but of course the switch has one.

According to EMAN-FMWK, the phone as a device has two poweredBy
relationships, one with the switch device and one with the PDU
Device.

I think this shows better the difference between the two models.

For network nerds: EMAN-REF defines something like link layer
relations between ports, EMAN-FMWK defines something like
network layer relations between devices.  Both have their value.

    Juergen

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 1 Mar 2012 13:57:38 +0000

Hi Benoit,

Here is a reply of issue 2.

> A power interface is an Energy Object that has one

I would not see an interface being an energy object.
I would rather say that an energy object has one or more
power interfaces.  Just like a host having network interfaces.

The power interfaces can be unconnected or connected by a
transmission medium.  The typical medium is a wire and it
transmits power.

Again, this is comparable to the link layer for data transmission.
The EMAN-FMWK rather argues on the network layer, i.e. Which
device is connected to which other device.  The EMAN-FMWK
poweredBy relationship does not not show which power outlet
of a power source is used to power a powered device.  It abstracts
from it like the network layer abstracts from the link layer.

    Juergen

---

From: Benoit Claise <[email-masked]>
Date: Fri, 09 Mar 2012 23:52:52 +0100

Hi Juergen,
> relationships, one with the switch device and one with the PDU
Not really.
- the phone has a poweredBy relationship with the switch port
- the switch has a poweredBy relationship with the PDU outlet
   Note that if the switch has two power inlet, then ...
   the switch inlet has a poweredBy relationship with the PDU outlet

However, the current EMAN framework is too liberal and a new section on 
"relationship conventions and guidelines" is required. Point taken.

Regards, Benoit.
> On 01.03.12 14:11, "Juergen Quittek"<[email-masked]>  wrote:
>
>> Hi Benoit,
>>
>> On 28.02.12 00:49, "Benoit Claise"<[email-masked]>  wrote:
>>
>>>     Dear all,
>>>
>>>     [EMAN-FMWK] =

---

From: Bruce Nordman <[email-masked]>
Date: Sun, 11 Mar 2012 22:39:33 -0700

For the situation described below, describing these relationships as between
power interfaces is unambiguous and no further detail is needed.

If the relationships are described as being between devices, then some
use cases lead to ambiguity, which can only be resolved by describing
which interface is connected to which other power interface.

If one allows a component contained in device A to have a direct power
relationship
to a component in device B, then complexity is greatly increased.  I do not
know of a use case which requires this.

--Bruce (as contributor)

On Fri, Mar 9, 2012 at 2:52 PM, Benoit Claise <[email-masked]> wrote:

>> PDU---powers-->SWITCH---**powers-->PHONE
>>
>>>>    http://datatracker.ietf.org/**doc/draft-ietf-eman-framework/<http://datatracker.ietf.org/doc/draft-ietf-eman-framework/>
>>>> **, the
>>>>    official EMAN document
>>>>    [EMAN-REF] =
>>>>    http://datatracker.ietf.org/**doc/draft-quittek-eman-**
>>>> reference-model/<http://datatracker.ietf.org/doc/draft-quittek-eman-reference-model/>
>>>>
>>>>    http://www.ietf.org/id/draft-**ietf-eman-energy-aware-mib-04.**txt<http://www.ietf.org/id/draft-ietf-eman-energy-aware-mib-04.txt>
>>>>
>>>>    Issue 1:
>>>> ______________________________**_________________
>>>> eman mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/**listinfo/eman<https://www.ietf.org/mailman/listinfo/eman>
>>>>
>>>
>>
>>
> ______________________________**_________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/eman<https://www.ietf.org/mailman/listinfo/eman>
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: "John Parello (jparello)" <[email-masked]>
Date: Mon, 12 Mar 2012 12:49:15 -0700

See Inline 

I agree that the power interfaces are useful and unambiguous when used
but they are not required in all cases. 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bruce Nordman
Sent: Sunday, March 11, 2012 10:40 PM
To: Benoit Claise (bclaise)
Cc: eman mailing list
Subject: Re: [eman] [EMAN-FMWK] versus [EMAN-REF]: Power Source
Relationship and power interface

For the situation described below, describing these relationships as
between
power interfaces is unambiguous and no further detail is needed.

[jp] agree love the concept and use when you have them

[jp] disagree. It is not the only way to resolve or be useful

If one allows a component contained in device A to have a direct power
relationship
to a component in device B, then complexity is greatly increased.  I do
not
know of a use case which requires this.

[jp] You state that it increases the complexity but how? I think it
reduces complexity (see below) As for use case it's in the framework
(latest draft)  and applicability but here is one below again.

Let's take the simple case of a PDU and PC's that all cannot measure
power per outlet / inlet and only can attribute values to the entire
device. Quick look at the catalog of PDU vendors and you'll see tons
that do this. For PC's think just about all.

With just say a simple four outlet PDU that can measure only power for
the entire unit and three  PCs attached (100W each) and again the units
can only tell their total power. The PC's report 100W each and the PDU
reports 300W. If I know they have a poweredby relationship to the PDU
it's very simple and unambiguous to know that 300W "total" from the PDU
is attributed to the 3 PC's. Now if you get a 400W reading from the PDU
and still 100W each from the PCs while you may not know the topology you
certainly do know that the totals do not balance and you probably have a
fourth unmanaged device attached.

Very useful and very common. 

While having the interfaces is a better description on the topology the
common case will not have it and can still be managed nicely. 

How would you do this if the device has no notion of outlet or inlet
measurements? Create duplicate objects and put the same reading in for
the PCs? How about the PDU how do you propose to proportion the power
among outlets in the information model when the device can't do it?  If
I can only connect inlets and outlets you're saying I can't associate
theses PC to the PDU? 

Sounds more complex to me. 

Power interfaces are great but don't make them required when they don't
exist on the devices.

Jp

--Bruce (as contributor)

Hi Juergen,

	Hi Benoit,
	
	Sorry, my previous email slipped to the outbox before it was
complete.
	Here is the missing content:

	Issue 1:
	[EMAN-FMWK] has the poweredBy relationship, which imposes a
	direction "from A to B"
	[EMAN-REF] wants to have a kind of "wiring topology"
relationship,
	and then the power direction is deduced from the counters
	As far as I understand, [EMAN-REF] is after a "power
relationship".

	One significant difference between the EMAN-FMWK and EMAN-REF is
the
	following:
	
	Let's assume a PDU powering a PoE switch powering a PoE desktop
phone.
	That's not a funny theoretical case.
	That's how the phone on my desk is powered.

	

Not really.

Regards, Benoit.

	
	
	    Juergen

	Hi Benoit,

	   Dear all,
	
	   [EMAN-FMWK] =
	   http://datatracker.ietf.org/doc/draft-ietf-eman-framework/,
the
	   official EMAN document
	   [EMAN-REF] =

	   Discussing about the differences between [EMAN-FMWK] and
[EMAN-REF]
	   with one author of the [EMAN-REF], there is one open issue
that
	   needs to be resolved.

	
	   Power Source Relationship
	   An
	     Energy Object may be the source of or distributor of Power
to
	     another Energy
	     Object(s) and is referred to as a Power Source
Relationship.
	
	   Example:

	
	
	   This relationship is modeled by  eoMeteredBy in
[EMAN-AWARE-MIB],

	   Issue 1:
	   [EMAN-FMWK] has the poweredBy relationship, which imposes a
	   direction "from A to B"
	   [EMAN-REF] wants to have a kind of "wiring topology"
relationship,
	   and then the power direction is deduced from the counters
	   As far as I understand, [EMAN-REF] is after a "power
relationship".
	
	   Issue 2:
	   [EMAN-REF] mentions the notion of power interface.
	   Taking into account the terminology from [EMAN-FMWK]
	       A power interface is an Energy Object that has one Power
Source
	   Relationship
	       Note: it may have other relationships (such as Metering
or Proxy
	   Relationship, like in POE)
	   Do we need this notion in the [EMAN-FMWK]?

	

	   I put the problem on the table, to start the discussion, and
I'll
	   give my feedback later.

	

-- 
Bruce Nordman

---

From: Brad Schoening <[email-masked]>
Date: Mon, 12 Mar 2012 14:55:18 -0500

I've been concerned about this terminology also.  Bus-bars which distribute power to a building and non-invasive CT meters are two examples where you really don't have an interface.  By over specifying this for the general case (where you would have inlets and outlets), you disregard the other ways in which power can be distributed and monitored.

Brad Schoening
e: [email-masked] ⟐ m: 917-304-7190

<http://www.coraid.com/> Redefining Storage Economics

From: "John Parello (jparello)" <[email-masked]<mailto:[email-masked]>>
Date: Mon, 12 Mar 2012 14:49:15 -0500
To: Bruce Nordman <[email-masked]<mailto:[email-masked]>>, "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Cc: eman mailing list <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] [EMAN-FMWK] versus [EMAN-REF]: Power Source Relationship and power interface

See Inline

I agree that the power interfaces are useful and unambiguous when used but they are not required in all cases.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Bruce Nordman
Sent: Sunday, March 11, 2012 10:40 PM
To: Benoit Claise (bclaise)
Cc: eman mailing list
Subject: Re: [eman] [EMAN-FMWK] versus [EMAN-REF]: Power Source Relationship and power interface

If one allows a component contained in device A to have a direct power relationship
to a component in device B, then complexity is greatly increased.  I do not
know of a use case which requires this.

[jp] You state that it increases the complexity but how? I think it reduces complexity (see below) As for use case it’s in the framework (latest draft)  and applicability but here is one below again.
Let’s take the simple case of a PDU and PC’s that all cannot measure power per outlet / inlet and only can attribute values to the entire device. Quick look at the catalog of PDU vendors and you’ll see tons that do this. For PC’s think just about all.
With just say a simple four outlet PDU that can measure only power for the entire unit and three  PCs attached (100W each) and again the units can only tell their total power. The PC’s report 100W each and the PDU reports 300W. If I know they have a poweredby relationship to the PDU it’s very simple and unambiguous to know that 300W “total” from the PDU is attributed to the 3 PC’s. Now if you get a 400W reading from the PDU and still 100W each from the PCs while you may not know the topology you certainly do know that the totals do not balance and you probably have a fourth unmanaged device attached.
Very useful and very common.
While having the interfaces is a better description on the topology the common case will not have it and can still be managed nicely.
How would you do this if the device has no notion of outlet or inlet measurements? Create duplicate objects and put the same reading in for the PCs? How about the PDU how do you propose to proportion the power among outlets in the information model when the device can’t do it?  If I can only connect inlets and outlets you’re saying I can’t associate theses PC to the PDU?
Sounds more complex to me.
Power interfaces are great but don’t make them required when they don’t exist on the devices.
Jp

--Bruce (as contributor)

On Fri, Mar 9, 2012 at 2:52 PM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Hi Juergen,

Hi Benoit,

However, the current EMAN framework is too liberal and a new section on "relationship conventions and guidelines" is required. Point taken.

Regards, Benoit.

    Juergen

On 01.03.12 14:11, "Juergen Quittek"<[email-masked]<mailto:[email-masked]>>  wrote:
Hi Benoit,

On 28.02.12 00:49, "Benoit Claise"<[email-masked]<mailto:[email-masked]>>  wrote:
   Dear all,

   [EMAN-FMWK] =

   Example:

   Issue 1:

   Issue 2:

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943