Subject: Re: [eman] EMAN-REQ: the notion of importance

From: "David Prantl" <[email-masked]>
Date: Sun, 4 Mar 2012 22:21:06 +0100

+1
for us as from a Energy Management System view Importance in comparison to priority provides more useful context - not only for controlling device-groups but also for reporting.

In terms of where this data is stored we clearly prefer the device itself as this allows this it to be configured locale during deployment without having to go through the energy management station. After deployment we can then pick it up automatically (as can any other application managing the energy-domain)

Best Regards,
David Prantl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John Parello (jparello)
Sent: Dienstag, 28. Februar 2012 00:30
To: Juergen Quittek; Brad Schoening; Benoit Claise (bclaise); emanmailing list
Subject: Re: [eman] EMAN-REQ: the notion of importance

Let's be precise in our terms please. Priority describes precedence while importance describes significance.

Those are two different concepts. So a power priority is describing the power granting, while importance as defined in the framework describes the context of the device. So one is rating the powering order while the other the devices context or use.

For example I could order three devices based on how important they are to my organization as (A,B,C).  For providing power the priority could be (B,A,C) if B is required to be supplied power before A on say start up.

The order in which you are served does not equal the importance in a steady running state.

Importance as defined is for context not ordering.

Jp

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Juergen Quittek
Sent: Monday, February 27, 2012 11:22 AM
To: Brad Schoening; Benoit Claise (bclaise); emanmailing list
Subject: Re: [eman] EMAN-REQ: the notion of importance

Hi Brad,

"Power priority" seems to be a much clearer concept than "importance".

Thanks,
    Juergen

On 27.02.12 18:10, "Brad Schoening" <[email-masked]> wrote:

>Benoit,
>
>There is a precedence for doing this on the device in the PoE MIB,
>rfc3621 which defines pethPsePortPowerPriority:
>   pethPsePortPowerPriority OBJECT-TYPE
>    SYNTAX INTEGER   {
>               critical(1),
>               high(2),
>               low(3)
>     }
>    MAX-ACCESS read-write
>    STATUS current
>    DESCRIPTION
>        "This object controls the priority of the port from the point
>         of view of a power management algorithm.  The priority that
>         is set by this variable could be used by a control mechanism
>         that prevents over current situations by disconnecting first
>         ports with lower power priority.  Ports that connect devices
>         critical to the operation of the network - like the E911
>         telephones ports - should be set to higher priority."
>    ::= { pethPsePortEntry 7 }
>
>
>Brad Schoening
>e: [email-masked] ⟐ m: 917-304-7190
>
> <http://www.coraid.com/> Redefining Storage Economics
> 
>
>
>
>
>
>From:  Benoit Claise <[email-masked]>
>Date:  Mon, 27 Feb 2012 05:17:24 -0600
>To:  eman mailing list <[email-masked]>
>Subject:  [eman] EMAN-REQ: the notion of importance
>
>
>  
>
>    
>  
>  
>    Dear all, 
>    
>    There is a discussion amongst the "EMAN requirements" authors right
>    now about the notion of importance.
>    We're trying to evaluate the requirements related to the
>    "importance".
>    
>    The current
>      draft version
><http://tools.ietf.org/html/draft-ietf-eman-requirements-05> only
>mentions:
>    
>    5.1.2.  Context information on powered entities   The energy
>management standard must provide means for retrieving and
>   reporting context information on powered entities, for example, tags
>   associated with a powered entity that indicate the powered entity's
>   role, or importance.
>    
>    So there are no justifications why the importance is required.
>    The people who want this, please provide some more
>    text/justifications
>    
>    Some extra questions:
>    - Is this importance specific to EMAN or is this generic also for
>    non Energy Objects?
>    - Importance is important related to ...?
>    
>    Regards, Benoit (as a contributor for the EMAN-REQ)
>    
>    
>    
>  
>
>_______________________________________________
>eman mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/eman

_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman
_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: "Anthony Barrera" <[email-masked]>
Date: Tue, 13 Mar 2012 10:06:45 -0700

Hello all,

My name is Anthony Barrera, I work for the PDU vendor Western Telematic.
We have been working with Cisco on implementing EnergyWise for the past
2.5 years or so. With respect to energy management, we have found the
concept of importance useful for ranking the various entities in our
managed systems. The importance parameter has been used to partition our
deployments into different levels, and we can therefore power up, power
down,  and report on those different partitions very easily. We would
prefer to include this concept in the energy management standard.

As far as terminology, we feel that the term "importance" is fitting,
and as mentioned we like the fact that it is somewhat of a more general
term to include more possible use cases and greater flexibility.
Changing the name to something more specific like "power down priority"
does seem to limit the use cases, and based on our experience with
energy management we do use it for much more than powering down parts of
our deployment.

Thanks for your consideration,

Anthony Barrera