Subject: [eman] EMAN draft agenda posted

From: Bruce Nordman <[email-masked]>
Date: Wed, 14 Mar 2012 16:31:33 -0700

Draft agenda on:
  https://datatracker.ietf.org/meeting/83/agenda.html
or directly at:
  http://www.ietf.org/proceedings/83/agenda/agenda-83-eman.txt
and reproduced below.

Please send Nevil and I comments or additional requests.

Cheers,

--Bruce

EMAN draft agenda, IETF 83
Tuesday, 27 March 2012, Room, 241

1. Note well, agenda bashing, note takers, blue sheets, 5 min

2. Update from last meeting / WG Status                 5 min

3. Terminology
  draft-parello-eman-definitions-05, Jon Parello, 5 min

4. Requirements for Energy Management,
  draft-ietf-eman-requirements-06, Juergen Quittek, 15 min

5. Energy Management Framework,
  draft-ietf-eman-framework-04, Benoit Claise 30 min

  Other draft:
     draft-quittek-eman-reference-model-03, Juergen Quittek, 10 min

6. MIBs

  6.a. Energy-aware Networks and Devices MIB
  draft-ietf-eman-energy-aware-mib-03, Benoit Claise, 20 min

  6.b. Power and Energy Monitoring MIB
  draft-ietf-eman-energy-monitoring-mib-02, Mouli Chandramouli, 15 min

  6.c. Definition of Managed Objects for Battery Monitoring
  draft-ietf-eman-battery-mib-05, Rolf Winter, 5 min

7. Energy Management (EMAN) Applicability Statement,
   draft-ietf-eman-applicability-statement-00, Mouli Chandramouli, 10 min

8. Open microphone: whatever time is left

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Mar 2012 15:48:48 +0100

Bruce,

Two remarks. See inline.
>       draft-quittek-eman-reference-model-03, Juergen Quittek, 10 min
Why do we have to present this draft again?
I've been spending a lot of time trying to integrate much of 
draft-quittek-eman-reference-model-03 in draft-ietf-eman-framework-04, 
to have a single of list of open issues within a single document.
>    draft-ietf-eman-energy-aware-mib-03, Benoit Claise, 20 min
Like in the last IETF, it might be better to show this draft before the 
Energy Management Framework, as its data model will help.

Regards, Benoit (as a contributor)
> eetd.lbl.gov/ea/nordman <http://eetd.lbl.gov/ea/nordman>
> [email-masked]
> 510-486-7089
> m: 510-501-7943
>
>
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 20 Mar 2012 21:49:44 -0700

For the Reference Model, there was a partial integration into the
Framework so purpose would be to cover items not integrated
and not in the Framework open issues.  Since there are fewer
of those than last time, time was moved from the Ref Model
to the Framework.

Fine with me to move the Energy ... MIB before the Framework.
I will assume the Power ... MIB stays where it is unless I hear otherwise.

Thanks,

--Bruce

On Tue, Mar 20, 2012 at 7:48 AM, Benoit Claise <[email-masked]> wrote:

> draft-quittek-eman-reference-model-03 in draft-ietf-eman-framework-04, to
> have a single of list of open issues within a single document.
>
> 6. MIBs
>
> eman mailing [email-masked]://www.ietf.org/mailman/listinfo/eman
>
>
>

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 21 Mar 2012 02:01:05 -0500

Hello all,

Regarding one of the open issues in the requirements draft -
draft-ietf-eman-requirements-06

Open issue 12.2 - Directional metering of Power and Energy  

There has been discussion supporting directional measurement of energy
and there seem to be rough consensus on the need for a requirement for
such a measurement and the discussion is focused on terminology. 

We have 3 proposals -  

EnergyTransmitted   /  EnergyTransmitted   /   EnergySupplied 

 EnergySupplied         /   EnergyReceived        /    EnergyReecieved 

 EnergyNet                   /   EnergyNet                  /
EnergyNet

What is more important is the idea (as emphasized by Georgios)  and the
naming  we can go with the WG consensus.  

Requirement  can be phrased as - 

5.5.4   Direction of energy flow

   In addition to the measurement of energy, the standard must report
the direction of energy flow from a device perspective; 

    energy received or energy supplied or the net which is a resultant
of the energy received and consumed by a device.  

Thanks

Mouli

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 21 Mar 2012 03:26:43 -0500

Hello all,

Open issue 12.5 -  Reporting on other devices 

This needs to be considered whether it is devices or interfaces or
entities that are to be reported on.

Currently, 5.3.1  requirement phasing is restrictive to measuring power
only at a power interface.   

Energy Management standard requirements can be neutral with respect to
the solution approach.  

The solution can be addressed in the framework. 

The requirement 5.3.1 should be modified  to consider the measurement of
power for a device or an Energy Object. 

Before 

5.3.1. Real power

   The standard must provide means for reporting the real power for each

   power interface, including the direction of power flow.

After 

5.3.1. Real power

   The standard must provide means for reporting the real power for each
device or Energy Object  or a Power Interface including the direction of
power flow.

Same comment with Requirement 5.3.5.   Actual voltage and current  

Which mentions about measurement of Voltage and Current only at a power
interface. The device or Energy Object perspective should be also
included in this requiremet  

Same with Requirement 5.3.7.   Complex Power 

Which mentions about measurement of Active Power, Reactive Power and
Total Power only at a power interface. The device or Energy Object
perspective should be also included in this requirement.  

Thanks

Mouli

---

From: Brad Schoening <[email-masked]>
Date: Wed, 21 Mar 2012 11:30:27 -0500

Mouli,

I noticed the Shark meter ModBus mappings (pg 86) uses the terminology W-hours Received/Delivered/Net with further clarification that:

* "Wh received & delivered always have opposite signs"

* "Wh received is positive for 'view as load', delivered is positive for 'view as generator' "

Ref:  Shark 100 Installation & Operation Manual R 1.12, May 15, 2008

Brad Schoening
e: [email-masked] ⟐ m: 917-304-7190

<http://www.coraid.com/> Redefining Storage Economics

From: "Mouli Chandramouli (moulchan)" <[email-masked]<mailto:[email-masked]>>
Date: Wed, 21 Mar 2012 02:01:05 -0500
To: eman mailing list <[email-masked]<mailto:[email-masked]>>
Subject: [eman] draft-ietf-eman-requirements-06 - Open Issue 12.2

Hello all,

Regarding one of the open issues in the requirements draft -  draft-ietf-eman-requirements-06

There has been discussion supporting directional measurement of energy and there seem to be rough consensus on the need for a requirement for such a measurement and the discussion is focused on terminology.

We have 3 proposals -

EnergyTransmitted   /  EnergyTransmitted   /   EnergySupplied
 EnergySupplied         /   EnergyReceived        /    EnergyReecieved
 EnergyNet                   /   EnergyNet                  /     EnergyNet

What is more important is the idea (as emphasized by Georgios)  and the naming  we can go with the WG consensus.

   In addition to the measurement of energy, the standard must report the direction of energy flow from a device perspective;
    energy received or energy supplied or the net which is a resultant of the energy received and consumed by a device.

Thanks
Mouli

---

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 21 Mar 2012 09:31:15 -0700

HI,

Bruce, Jeurgen, since you are also authors of the WG draft would you
mind sharing what items are not covered on the list in advance of the
meeting. It seems counterproductive to have two presos that don't know
about the items until we convene at the mic in Paris.

Happy to address any items and work together in the context of the WG
draft and then cover all these issues as one session on the WG draft
instead of two.

Simpler agenda IMO.

Jp

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bruce Nordman
Sent: Tuesday, March 20, 2012 9:50 PM
To: Benoit Claise (bclaise)
Cc: eman mailing list
Subject: Re: [eman] EMAN draft agenda posted

Fine with me to move the Energy ... MIB before the Framework.
I will assume the Power ... MIB stays where it is unless I hear
otherwise.

Thanks,

--Bruce

On Tue, Mar 20, 2012 at 7:48 AM, Benoit Claise <[email-masked]>
wrote:

Bruce, 

Two remarks. See inline.

Draft agenda on:

Cheers,

--Bruce

 
 
3. Terminology

 
  Other draft:

	6. MIBs

 

7. Energy Management (EMAN) Applicability Statement,
   draft-ietf-eman-applicability-statement-00, Mouli Chandramouli, 10
min

-- 
Bruce Nordman

-- 
Bruce Nordman

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 21 Mar 2012 22:53:52 -0700

Sounds good to me.  The time can all be consolidated into the Framework
draft discussion.

--Bruce

On Wed, Mar 21, 2012 at 9:31 AM, John Parello (jparello) <[email-masked]

> HI,****
>
> ** **
>
> Bruce, Jeurgen, since you are also authors of the WG draft would you mind
> sharing what items are not covered on the list in advance of the meeting.
> It seems counterproductive to have two presos that don’t know about the
> items until we convene at the mic in Paris.****
>
> ** **
>
> instead of two.****
> Simpler agenda IMO.****
> ** **
> Jp****
> ** **
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Bruce Nordman
> *Sent:* Tuesday, March 20, 2012 9:50 PM
> *To:* Benoit Claise (bclaise)
> *Cc:* eman mailing list
>
> *Subject:* Re: [eman] EMAN draft agenda posted****
>
> ** **
>
> --Bruce****
> On Tue, Mar 20, 2012 at 7:48 AM, Benoit Claise <[email-masked]> wrote:*
> ***
>
> Bruce,
>
> Two remarks. See inline.****
>
>
>
> ****
>
> Draft agenda on:
> ****
> EMAN draft agenda, IETF 83****
>
> Tuesday, 27 March 2012, Room, 241****
>
> ** **
>
> ** **
>
> 1. Note well, agenda bashing, note takers, blue sheets, 5 min****
>
> ** **
>
> 2. Update from last meeting / WG Status                 5 min****
>
> ** **
>
> 3. Terminology****
>
>   draft-parello-eman-definitions-05, Jon Parello, 5 min****
>
> ** **
>
> 4. Requirements for Energy Management,****
>
>   draft-ietf-eman-requirements-06, Juergen Quittek, 15 min****
>
> ** **
>
> 5. Energy Management Framework, ****
>
>   draft-ietf-eman-framework-04, Benoit Claise 30 min****
>
> ** **
>
>   Other draft:****
>
>      draft-quittek-eman-reference-model-03, Juergen Quittek, 10 min****
>
> have a single of list of open issues within a single document. ****
>
> 6. MIBs****
>
> ** **
>
>   6.a. Energy-aware Networks and Devices MIB****
>
>   draft-ietf-eman-energy-aware-mib-03, Benoit Claise, 20 min****
>
> ****
>   6.b. Power and Energy Monitoring MIB****
>
>   draft-ietf-eman-energy-monitoring-mib-02, Mouli Chandramouli, 15 min****
>
> ** **
>
>   6.c. Definition of Managed Objects for Battery Monitoring****
>
>   draft-ietf-eman-battery-mib-05, Rolf Winter, 5 min****
>
> ** **
>
> ** **
>
> 7. Energy Management (EMAN) Applicability Statement,****
>
>    draft-ietf-eman-applicability-statement-00, Mouli Chandramouli, 10 min****
>
> ** **
>
> 8. Open microphone: whatever time is left****
>
>
>
> --
> *Bruce Nordman*
> ****
> _______________________________________________****
>
> eman mailing list****
>
> [email-masked]****
>
> https://www.ietf.org/mailman/listinfo/eman****
>
> ** **
>
>
>
>
> --
> *Bruce Nordman*
> m: 510-501-7943****

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 27 Mar 2012 10:51:48 +0000

Dear Mouli, 

I agree that we do require reporting real power and energy not just for
power interfaces but also for entire devices.

Thanks,
    Juergen

---

From: Duanxiaoling <[email-masked]>
Date: Tue, 27 Mar 2012 12:48:38 +0000

Why did not you discuss the open issue of  " OPEN ISSUE 8  Directional Metering of Energy not in requirements " in document of "draft-ietf-eman-energy-monitoring-mib-02.txt"

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Juergen Quittek
发送时间: 2012年3月27日 18:52
收件人: Mouli Chandramouli (moulchan); eman mailing list
主题: Re: [eman] draft-ietf-eman-requirements-06 - Open Issue 12.5

Dear Mouli, 

Thanks,
    Juergen

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Tue, 27 Mar 2012 15:47:41 -0500

Hello,

Directional metering was listed as a open issue in the EMAN-MON-MIB, the current MIB design has that capability. 
But we needed to specify that in the requirements.  As discussed in the requirements presentation, a requirement on directional metering shall be added to that effect. 

Thanks
Mouli

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Juergen Quittek
发送时间: 2012年3月27日 18:52
收件人: Mouli Chandramouli (moulchan); eman mailing list
主题: Re: [eman] draft-ietf-eman-requirements-06 - Open Issue 12.5

Dear Mouli, 

Thanks,
    Juergen

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 28 Mar 2012 00:22:08 +0200

The requirements draft does refer to electricity going in both directions
already.
The section on power interfaces begins as follows.
Thanks,
--Bruce

5.2. Power interfaces
A power interface is either an inlet or an outlet. A few switch between
these two but most never change.

2012/3/27 Duanxiaoling <[email-masked]>

> Why did not you discuss the open issue of  " OPEN ISSUE 8  Directional
> Metering of Energy not in requirements " in document of
> "draft-ietf-eman-energy-monitoring-mib-02.txt"
>
> -----邮件原件-----

---

From: Duanxiaoling <[email-masked]>
Date: Wed, 28 Mar 2012 00:40:47 +0000

Sorry, in fact, I want to know the conclusion of this issue ”Directional metering of Power and Energy” in “draft-ietf-eman-requirements-06.txt”
Do we have the consensus conclusion? What is that?

Thanks!

发件人: Bruce Nordman [mailto:[email-masked]]
发送时间: 2012年3月28日 6:22
收件人: Duanxiaoling
抄送: Juergen Quittek; Mouli Chandramouli (moulchan); eman mailing list
主题: Re: [eman] draft-ietf-eman-requirements-06 - Open Issue 12.5

The requirements draft does refer to electricity going in both directions already.
The section on power interfaces begins as follows.
Thanks,
--Bruce

5.2. Power interfaces
A power interface is either an inlet or an outlet. A few switch between these two but most never change.
2012/3/27 Duanxiaoling <[email-masked]<mailto:[email-masked]>>
Why did not you discuss the open issue of  " OPEN ISSUE 8  Directional Metering of Energy not in requirements " in document of "draft-ietf-eman-energy-monitoring-mib-02.txt"

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] 代表 Juergen Quittek
发送时间: 2012年3月27日 18:52
收件人: Mouli Chandramouli (moulchan); eman mailing list
主题: Re: [eman] draft-ietf-eman-requirements-06 - Open Issue 12.5

Dear Mouli,

Thanks,
   Juergen

On 21.03.12 09:26, "Mouli Chandramouli (moulchan)" <[email-masked]<mailto:[email-masked]>>
wrote:

>[email-masked]<mailto:[email-masked]>

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman
_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]
510-486-7089
m: 510-501-7943

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 28 Mar 2012 06:30:37 -0500

Hello,

This was the proposal to close the open issue on directional metering on in “draft-ietf-eman-requirements-06.txt”. 

 

We shall propose suitable text on the requirement and send to the mailing list. 

Thanks

Mouli

From: Duanxiaoling [mailto:[email-masked]] 
Sent: Wednesday, March 28, 2012 6:11 AM
To: Bruce Nordman
Cc: Juergen Quittek; Mouli Chandramouli (moulchan); eman mailing list
Subject: 答复: [eman] draft-ietf-eman-requirements-06 - Open Issue 12.5

Thanks!

5.2. Power interfaces

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Juergen Quittek
发送时间: 2012年3月27日 18:52
收件人: Mouli Chandramouli (moulchan); eman mailing list
主题: Re: [eman] draft-ietf-eman-requirements-06 - Open Issue 12.5

Dear Mouli,

Thanks,
   Juergen