Subject: [eman] Fwd: ASHRAE/NEMA Standard 201P Advisory Public Review Announcement

From: Bruce Nordman <[email-masked]>
Date: Fri, 20 Jul 2012 08:12:49 -0700

EMAN--

  For a long time, we have been told that a key document that we should
review and
reference for the Applicability Statement is "ASHRAE 201P", currently under
development.
Today it was finally released for "Public Review", as the email below
states.

  This is to be a core reference document for data models for "Smart Grid"
efforts in the
U.S. and likely influential in other countries as well.
  The document is currently the last link on the page referenced below.
Note that the draft
is 621 pages long.

  I am intending to come up with a brief summary of how 201P compares with
EMAN in
scope/coverage and in details and expect a few others of us will also do
this.  These will
help focus our EMAN discussion to a few specific topics.
  My general understanding is as follows, though I need to review this
draft to be sure:
--Most of the 201P content is on areas we do not address
--A significant part of EMAN is topics that 201P does not address
--For those areas of overlap, there are definite differences in terminology
and in details,
  but no issues that suggest a major problem.
Again, this is just a preliminary assessment.

For more context, "BSR" is "Board of Standards Review", part of the main
U.S. national
standards body, ANSI.  NEMA is the National Electrical Manufacturers
Association, which
is a U.S. trade association that also has standards development
activities.  ASHRAE was
tasked with developing this document by the Smart Grid Interoperability
Panel through the
"PAP17" activity:

http://collaborate.nist.gov/twiki-sggrid/bin/view/SmartGrid/PAP17FacilitySmartGridInformationStandard
That page notes that there will be a web-based meeting on this document, on
the morning (0900-1100
Pacific Time) of the day of our EMAN meeting August 1.

--Bruce

---------- Forwarded message ----------
From: LeBlanc,Susan <[email-masked]>
Date: Fri, Jul 20, 2012 at 7:26 AM
Subject: ASHRAE/NEMA Standard 201P Advisory Public Review Announcement
To: [email-masked]

BSR/ASHRAE/NEMA Standard 201P, *Facility Smart Grid Information Model *is
now available for a 45 day Advisory Public Review (APR) beginning today
through September 3, 2012.

This APR reflects a state of development where the project committee
determined that input from the public would be a valuable contribution
toward completing the standard. In addition to a text document, this
standard will be published in a machine readable Universal Modeling
Language (UML) format. For reviewers who have expertise in using UML
software tools, a UML version of the draft standard is available (as a
Related Archive Document in the Online Comment Database). This file can be
imported into a UML software tool to use its features to explore and
understand the richness of the FSGIM. If assistance is needed to access
this file please contact Susan LeBlanc, ASHRAE Staff Liaison to SPC 201P at
[email-masked]* <[email-masked]>.

The Standard 201P APR draft can be accessed by going to ASHRAE’s Standards,
Research & Technology/Public Review Drafts web page and following the
instructions to access the online comment database, or by clicking on the
following link:
*http://www.ashrae.org/public-review-drafts*<http://www.ashrae.org/public-review-drafts>.

Susan LeBlanc, Standards Administrator
ASHRAE
1791 Tullie Cir. Atlanta, GA 30329
Direct Line: 678-539-1175     Fax: 678-539-2175     eMail:
[email-masked]     Web: http://www.ashrae.org/

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
nordman.lbl.gov <http://eetd.lbl.gov/ea/nordman>
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Bruce Nordman <[email-masked]>
Date: Sun, 29 Jul 2012 00:12:55 -0700

EMAN--

  Following is a review of the ASHRAE 201 document.  I don't see any
particular
changes that EMAN should take in response to this draft, other than to amend
the Applicability Statement to briefly summarize the relationship between
the two
documents.  It is not apparent that EMAN indicates any particular changes to
the 201 draft.

--Bruce

 Comments on ASHRAE SPC 201 Facility Smart Grid Information Model

Bruce Nordman

July 28, 2012

This is a summary of how the ASHRAE document intersects with IETF/EMAN
drafts.

The ASHRAE document outlines an information model for how data about
entities within buildings might be communicated to the grid.  This model
could also be applied to communication to entities within a building.  The
scope lists 10 basic types of interactions, two of which have particular
relevance to EMAN: “end load monitoring (sub metering)” and “direct load
control”.

While there is commonality in many concepts between ASHRAE 201 and EMAN,
the terms used are mostly different.  As examples, in 201, an “entity” is
“a person or organization …”.  “A physical end-use device that consumers or
supplies electricity” is and “End Device”.  The supervisory system is
called the “Energy Management System”.  “Demand” is with respect to “…a
given instant or averaged over any designated interval of time”.  An
“Intelligent End Point” is “A system that internally measures, collects,
and analyzes its *energy cost*/consumption”.

The 201 model has four components:

“Generator” which “produces electricity”,

“Load” which “consumes electricity”,

“Meter” which “measures electricity or emissions”, and

“Energy Manager” which “makes control decisions”.

An Energy Manager may acquire information from Internal Energy Managers.  The
Internal entity only interacts with devices in the building.  The Energy
Manager may interact with external entities.

The concept of Load is oriented to how the Load may be useful to the grid,
particularly in reducing demand when requested.

The concept of Meter is anything which measures, so covers both devices
which only do metering as well as devices which measure their own
consumption.  Tracking time-series data is assigned to the Energy Manager,
not the meter.  A meter is associated with a “UsagePoint” – that entity
which is actually being measured.  The Electric Meter subset of Meter has
three parts: power, energy, and power quality.

EMAN is principally concerned with measurement of energy and power, which
is the domain of the Meter in 201.  Most of what is covered by the
Generator and Load concepts and 201 are outside the scope of EMAN.

201 has the concept of a “GlobalID” which is much like a UUID – unique.

Measurements in 201 can be actual, nominal, estimated, or derived.  Only
the actual example seems relevant to EMAN.  The estimated concept is
described as being applied to forecasts, not current consumption.

Units used in 201 are from “NAESM PAP10 EUI” and include W, VA, and Wh.

To summarize, 201 focuses on information about individual entities.  It
does not address how entities relate to each other.  Thus, many aspects of
EMAN which focus on relationships do not apply to 201.  Almost all of the
overlap between EMAN and 201 is in the concept of a meter.  Both models
assume that there are distinct measures of energy and power, and both
assume a management system that receives reports.  201 does not have the
concept of power state.  201 does not address power supply control.

On Fri, Jul 20, 2012 at 8:12 AM, Bruce Nordman <[email-masked]> wrote:

> reference for the Applicability Statement is "ASHRAE 201P", currently
> under development.
> --For those areas of overlap, there are definite differences in
> terminology and in details,
> That page notes that there will be a web-based meeting on this document,
> on the morning (0900-1100
> The Standard 201P APR draft can be accessed by going to ASHRAE’s
> Standards, Research & Technology/Public Review Drafts web page and
> following the instructions to access the online comment database, or by
> clicking on the following link: *
> http://www.ashrae.org/public-review-drafts*<http://www.ashrae.org/public-review-drafts>.
>
>
>
>
>

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 31 Jul 2012 19:49:59 +0000

Hi Bruce,

Thanks for the review. We definitely need to be in line with this spec as it is going to be a central specification for facilities and the intersection with IT equipment.

Please see in line with some deletia for better reading.

Jp

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bruce Nordman
Sent: Sunday, July 29, 2012 12:13 AM
To: eman mailing list
Subject: Re: [eman] ASHRAE/NEMA Standard 201P Advisory Public Review Announcement

EMAN--

  Following is a review of the ASHRAE 201 document.  I don't see any particular

The ASHRAE document outlines an information model for how data about entities within buildings might be communicated to the grid.  This model could also be applied to communication to entities within a building.  The scope lists 10 basic types of interactions, two of which have particular relevance to EMAN: “end load monitoring (sub metering)” and “direct load control”.

While there is commonality in many concepts between ASHRAE 201 and EMAN, the terms used are mostly different.  As examples, in 201, an “entity” is “a person or organization …”.  “A physical end-use device that consumers or supplies electricity” is and “End Device”.  The supervisory system is called the “Energy Management System”.  “Demand” is with respect to “…a given instant or averaged over any designated interval of time”.  An “Intelligent End Point” is “A system that internally measures, collects, and analyzes its energy cost/consumption”.

[jp] WE started to use the term entity to refer to physical devices. I think at ASHRAE that will mean people and IETF’ers will think MIB. They do have a great term called ASSET which I think the requirement authors could use well.

An Energy Manager may acquire information from Internal Energy Managers.  The Internal entity only interacts with devices in the building.  The Energy Manager may interact with external entities.

The concept of Load is oriented to how the Load may be useful to the grid, particularly in reducing demand when requested.

The concept of Meter is anything which measures, so covers both devices which only do metering as well as devices which measure their own consumption.  Tracking time-series data is assigned to the Energy Manager, not the meter.  A meter is associated with a “UsagePoint” – that entity which is actually being measured.  The Electric Meter subset of Meter has three parts: power, energy, and power quality.

EMAN is principally concerned with measurement of energy and power, which is the domain of the Meter in 201.  Most of what is covered by the Generator and Load concepts and 201 are outside the scope of EMAN.

Measurements in 201 can be actual, nominal, estimated, or derived.  Only the actual example seems relevant to EMAN.  The estimated concept is described as being applied to forecasts, not current consumption.

[jp] Actual measurements is not the only thing relevant to EMAN. I have systems which model all of the above that ASHRAE covers as well. If you look at the caliber field in the monitor draft that’s the exact concept. I do hope we are not limiting to just actual as I’ll have classes of devices and systems which would  be excluded from the standard. So  hope that’s just an oversight and not a statement of direction.

To summarize, 201 focuses on information about individual entities.  It does not address how entities relate to each other.  Thus, many aspects of EMAN which focus on relationships do not apply to 201.  Almost all of the overlap between EMAN and 201 is in the concept of a meter.  Both models assume that there are distinct measures of energy and power, and both assume a management system that receives reports.  201 does not have the concept of power state.  201 does not address power supply control.

[jp] 201p most certainly deals with relationships between assets. The power source enumeration 5.3.4.7 is the exact construct as  the power source relationships. Also the notion of aggregation is the same. Down to the need for the same clarifications we have on EMS aggregation versus device aggregation  (see their open issues)

[jp] 201p most certainly has the notion of power state. If you recall the first draft of the framework had a notion of levels and when we merged documents we decided to use the term state. Power states as described in the framework are EXACTLY the same construct as curtailment levels in 201p. Even to the point of the idea that they are definable in set size. See Line 945 CurtailmentLoad and applicability to devices.

Thanks again!
Jp