Subject: [eman] add Powered Entity to eman terminology?

From: Juergen Quittek <[email-masked]>
Date: Wed, 4 Jul 2012 14:59:01 +0000

Dear all,

When working on the eman requirements we were looking for a term to refer
to all energy "consumers"/"receivers" or "producers"/"providers" in the
network, because these are the core subject of energy management.
Initially we thought about using the term "Energy Object" which sounded
descriptive for what we wanted to say, but the way it is currently defined
in draft-ietf-eman-framework-04 is different:

>    An Energy Object (EO) is a piece of equipment
>    that is part of or attached to a
>    communications network that is monitored,
>    controlled, or aids in the management of
>    another device for Energy Management.

Here also meters, power interfaces, and other "aiding pieces of equipment"
are included.

Therefore we introduced the term "Powered Entity" defined as

>      A Powered Entity is either a device or one of a device's
>      components that is subject to energy monitoring or control or
>      both.

in draft-ietf-eman-requirements.  We should either converge these terms
or add "Powered Entity"  to the list of eman terms.

Comments are highly appreciated.

Thanks,
    Juergen

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 4 Jul 2012 17:42:14 +0200

Hi,

According to the definition that you suggest, would a battery be a
'powered entity' if is subject to energy monitoring or control? This
seems counter-intuitive, but I am not very familiar with terminology in
energy monitoring.

I had a different understanding of what a powered entity means. RFC 3611
has a concept of 'PD - Powered Device' which is borrowed from the IEEE
802.3af standard where 'powered' roughly means that the device receives
power from a source external to the device.  

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Juergen Quittek
> Sent: Wednesday, July 04, 2012 5:59 PM
> To: eman mailing list
> Subject: [eman] add Powered Entity to eman terminology?
> 
> Dear all,
> 
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Rolf Winter <[email-masked]>
Date: Wed, 4 Jul 2012 16:02:56 +0000

Hi Dan,

is it counter-intuitive because batteries are typically associated with powering rather than being powered? At least secondary batteries can be charged and therefore are powered at times. But you are right, in past discussions we had difficulties accommodating batteries when we started to generalize things. The current text does include batteries as powered entities, see e.g. section 4 which states:

"An entity may be an entire device or a component of it.  Examples of
components of interest are a hard drive, a battery, or a line card."

I personally would rather soonish close terminology discussions since they have thrown us back in the past a bunch of times unless we really feel we have a problem here (e.g. we use terms that have a different meaning or implication in other parts of the industry).

Best,

Rolf 

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Romascanu, Dan (Dan)
> Sent: Mittwoch, 4. Juli 2012 17:42
> To: Juergen Quittek; eman mailing list
> Subject: Re: [eman] add Powered Entity to eman terminology?
> 
> Hi,
> 
> I had a different understanding of what a powered entity means. RFC
> 3611 has a concept of 'PD - Powered Device' which is borrowed from the
> IEEE 802.3af standard where 'powered' roughly means that the device
> receives power from a source external to the device.
> 
> Regards,
> 
> Dan
> 
> 
> > When working on the eman requirements we were looking for a term to
> > refer to all energy "consumers"/"receivers" or
> "producers"/"providers"
> > in
> the
> > descriptive for what we wanted to say, but the way it is currently
> > defined in draft-ietf-eman-framework-04 is different:
> >

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 4 Jul 2012 18:45:53 +0200

Hi Rolf, 

Yes, it is counter-intuitive, or so it seems to me. Why 'powered' when
the entities may not necessarily be powered? Why not 'power-managed'?
this would fit better IMO to 'subject to energy monitoring or control or
both'.

I do not intent to make the terminology discussion longer, and will not
insist if everybody else is happy, but I am trying to understand. 

Regards,

Dan

> From: Rolf Winter [mailto:[email-masked]]
> Sent: Wednesday, July 04, 2012 7:03 PM
> To: Romascanu, Dan (Dan); Juergen Quittek; eman mailing list
> Subject: RE: [eman] add Powered Entity to eman terminology?
> 
> Hi Dan,
> 
> is it counter-intuitive because batteries are typically associated
with
> powering rather than being powered? At least secondary batteries can
be
> charged and therefore are powered at times. But you are right, in past
> discussions we had difficulties accommodating batteries when we
started
> to generalize things. The current text does include batteries as
powered
> entities, see e.g. section 4 which states:
> 
> I personally would rather soonish close terminology discussions since
> they have thrown us back in the past a bunch of times unless we really
> feel we have a problem here (e.g. we use terms that have a different
> meaning or implication in other parts of the industry).
> 
> 
> Best,
> 
> Rolf
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> 
>

---

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 4 Jul 2012 17:16:35 +0000

Hi,

If you wish to add a Powered Entity according to your definition to restrict a subset of devices/object that seems reasonable but I think you'd have to concede that an Energy Object is the encompassing super class first.  

So if you have Energy Object with two sub classes as Powered Entity and Battery that might be clearer for Dan's concerns.

IMO they are not needed as the general super class of Energy Object should suffice. The notion of Energy Object is exactly how ASHREA and CIP are modeling devices. I tend to agree with that approach and see no need for a sub class called powered entity that is ambiguous

But if you see a need for a powered entity (and of course battery) then we should be clear as to what subset/sublass they belong. 

I think Energy Object is the super class with these two as sub-types is clearer than if they stand alone.

Jp 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Wednesday, July 04, 2012 9:46 AM
To: Rolf Winter; Juergen Quittek; eman mailing list
Subject: Re: [eman] add Powered Entity to eman terminology?

Hi Rolf, 

Yes, it is counter-intuitive, or so it seems to me. Why 'powered' when the entities may not necessarily be powered? Why not 'power-managed'?
this would fit better IMO to 'subject to energy monitoring or control or both'.

I do not intent to make the terminology discussion longer, and will not insist if everybody else is happy, but I am trying to understand. 

Regards,

Dan

with
be
started
powered

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 4 Jul 2012 19:19:16 +0200

I agree. 

Dan

> From: John Parello (jparello) [mailto:[email-masked]]
> Sent: Wednesday, July 04, 2012 8:17 PM
> To: Romascanu, Dan (Dan); Rolf Winter; Juergen Quittek; eman mailing
> list
> If you wish to add a Powered Entity according to your definition to
> restrict a subset of devices/object that seems reasonable but I think
> you'd have to concede that an Energy Object is the encompassing super
> class first.
> 
> So if you have Energy Object with two sub classes as Powered Entity
and
> Battery that might be clearer for Dan's concerns.
> 
> IMO they are not needed as the general super class of Energy Object
> should suffice. The notion of Energy Object is exactly how ASHREA and
> CIP are modeling devices. I tend to agree with that approach and see
no
> need for a sub class called powered entity that is ambiguous
> 
> But if you see a need for a powered entity (and of course battery)
then
> we should be clear as to what subset/sublass they belong.
> 
> I think Energy Object is the super class with these two as sub-types
is
> clearer than if they stand alone.
> 
> Jp
> 
> 
Of
> > > seems counter-intuitive, but I am not very familiar with
terminology
> > > > >      components that is subject to energy monitoring or
control
> or
> > > > >      both.
> > > >
> > > >
> > > > in draft-ietf-eman-requirements.  We should either converge
these
> > > terms

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 4 Jul 2012 17:24:38 +0000

Hello Juergen,

I thought after much discussion as a WG we agreed on the terminology of Energy Object. 

I might be more useful to get a consensus on the nomenclature, "the basic object that is monitored".

Then the requirements can be applicable to agreed terminology. 

Thanks
Mouli

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Wednesday, July 04, 2012 10:49 PM
To: John Parello (jparello); Rolf Winter; Juergen Quittek; eman mailing list
Subject: Re: [eman] add Powered Entity to eman terminology?

I agree. 

Dan

and
no
then
is
Of
terminology
control
these

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 4 Jul 2012 22:27:50 +0000

Hi Dan,

Thanks for your comment.

I agree that "powered" is not descriptive but rather misleading in our
case.
"power-managed" appears to be more appropriate.

Thanks,
    Juergen