Subject: [eman] Minutes of Vancouver meeting

From: Nevil Brownlee <[email-masked]>
Date: Wed, 29 Aug 2012 15:07:04 +1200

Hi all:

Catching up after Vancouver, here's the final version of the minutes,
including all corrections received to date.

Cheers, Nevil

Minutes of the EMAN meeting at IETF 84 in Vancouver
Scribes: Nevil Brownlee
Co-chairs: Bruce Nordman & Nevil Brownlee

Legend
------
[AR] = Alvaro Retona    [GK] = Georgios Karigianis
[BC] = Benoit Claise    [JP] = John Parello
[BN] = Bruce Nordman    [MC] = Mouli Chandramouli
[DR] = Dan Romascanu

Terminology draft
-----------------
Presented by Jon Parello.
- We use Entity = 'Device or Component'
- Compared EMAN terminology with ASHRAE 201p
     They use Asset to describe 'Device or Component.'
     EMAN should use 'Entity,' to be consistent with
       Entity MIB [DR]
- ASHRAE use 'Nameplate Power'
     EMAN should add 'Manufacturer Rating' to the Nameplate
       definition
- We need to clarify 'interfaces' so that they dont seem to be
     for connecting components [BC]
= The terminology is nearly all moved into the Requirements and
   Framework drafts.

Requirements for Energy Management -08
--------------------------------------
Presented by Juergen Quittek (via Skype)
- Made changes suggested since IETF-83
- Open issues:
    + Reporting of device info - "what info for which device(s)?"
      . Report for devices, components and interfaces? [JP]
      . Report for objects in Entity MIB [DR]
      = Use the Entity MIB, so that interfaces, components and
          devices are treated in the same way [DR]
- 'Phasor measurements' had been discussed on the list, should these
     be included in Requirements? [GK]
   . Little support at the meeting, continue on list.
- Need to add a requirement for windowing of measurements,
     as discussed on the list [MC]
- We need to keep the same model for interfaces, components and
     devices. That design should be in models, not requirements -
     that keeps it simple to implement [JP, DR]
= The authors will publish one more revision, then we will start
     its WG Last Call.

Energy Management Framework -05
-------------------------------
Presented by John Parello
- Added 'reference topology and guidelines' for power sources,
   metering, proxies and aggregation
- Open items
   . Edit pass: authors to check each section, and decide whether it
       should me kept/trimmed/moved/deleted
   . Check to see that draft's UML matches that in latest
       Monitoring MIB
   + States and Levels
     . ASHRAE uses 'curtailment levels,' should we?
     . The draft lists levels from several other organisations;
       should we set out an 'EMAN levels' list? [JP, AR]
       = Meeting was strongly in favour of this, with the
         EMAN levels indicated as the preferred set
     . Chairs to ask the printer working group to ask whether we
         should add their levels to the planned IANA registry
   * Our AD [BC] pointed out that we need to track issues more
     carefully, so that we don't revisit an issue once it's been
     closed.  Chairs (Nevil, since BN is a document author) will
     do this using the DataTracker
= New revision needed, WGLC once all issues are closed.

Energy-aware Networks and Devices MIB -06
-----------------------------------------
Presented by John Parello.
- Textual Convention added for EnergyRelations
- Now compatible with object in Entity MIBv4
- Open issues
   + Persistence of objects (when they're power-cycled or moved)
     = Objects that can change should be represented by objects in
       Entity MIBv4, that's enough [DR]
= New version once Requirements draft is frozen.

Entity MIBv4 -01
----------------
New draft written by Mouli Chandramouli, Presented by Dan Romascanu.
- Identifies devices using the Energy-Aware MIB
- Open Issue
   + Need a compact UUID for entPhysicalUris
     . Assume that devices comply with RFC 4122 [DR]
- This is an initial version of the MIB, comments welcome on list
- Is EMAN the right wg to produce this MIB?
= Yes, Chairs will ask AD to add it to EMAN charter.
   . add a new MIB oid specifically for UUID,
       instead of reusing the ENTITY-MIB URI OID
   . repeat that there is persistence,
       even if it's implicit from RFC4122
   . IANA considerations to be added for the new registry

Power and Energy Monitoring MIB -03
-----------------------------------
Presented by John Parello (for Mouli Chandramouli).
- Complete, now waiting until Requirements and Framework are complete
- Could Printer MIB be included?  Support for this in meting.

Battery MIB -05
---------------
Presented by Juergen Quittek.
- Five open issues, need feedback from list!
   . Authors will make suggestions
= Waiting on Entity MIBv4

Applicability Statement -01
---------------------------
Presented by Bruce Nordman.
- Open issues from IETF-83 now closed
- Use Cases and Related Standards sections almost complete
   . [BN. JP] have sent comments on ASHRAE 201p to the list;
     need EMAN folk to consider these and comment on the list
   . Could Implementation Guidelines be in this draft?
     Not yet, we need some implementation experience [BC]
   . Could other use cases be added? [GK]
     Yes, please send text to authors (via the list)
= Could be ready for WGLC once Requirements and Framework are done.

Milestones
----------
The Chairs presented a list of proposed new dates .
- Requirements                    Oct 2012
- Framework (after discussion)  April 2013
- MIBs, Applicability Statement  June 2013

Other Drafts
------------
ECAP Requirements (Alberto Retona)
- This draft is from rtwg, its goal is to optimise power consumption
     in the network while maintaining an acceptable service level.

Green Usage MIB (Satoru Izumi)
- A tiny MIB providing energy state information for various devices

Nanogrids (Bruce Nordham)
- No time for this, alas.  Please read the draft

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: Bruce Nordman <[email-masked]>
Date: Thu, 30 Aug 2012 21:11:30 -0700

On Tue, Aug 28, 2012 at 8:07 PM, Nevil Brownlee
<[email-masked]>wrote:

> ...
> ------------------------------**-
> ...

During the meeting I didn't want to derail the discussion
on this but the "EMAN levels" I understood to be power
levels distinct from the power state sets we have been
discussing.  Since no other power levels have been
proposed, I think we can simply list them as "the"
set of power levels - since they will be the only ones
they are EMAN and clearly preferred.  This seems
to be a great solution.

Also, I did confer with the printer working group and they
would like their power state set added to the ones to the
other power state sets that IANA sets up.

--Bruce (as contributor)

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
nordman.lbl.gov <http://eetd.lbl.gov/ea/nordman>
[email-masked]
510-486-7089
m: 510-501-7943