Subject: [eman] DRAFT minutes for Vancouver meeting

From: Nevil Brownlee <[email-masked]>
Date: Fri, 03 Aug 2012 06:27:28 +1200

Hi all:

Here are my draft-00 minutes from our meeting yesterday.
Please send me corrections, suggestions for improvements, etc.

Cheers, Nevil

DRAFT-00 Minutes of the EMAN meeting at IETF 84 in Vancouver
Scribes: Nevil Brownlee & ?
Co-chairs: Bruce Nordman & Nevil Brownlee

Legend
------

[AR] = Alberto Retona
[BC] = Benoit Claise
[BN] = Bruce Nordman
[DR] = Dan Romascanu
[GK] = Georgios Karigianis
[JP] = John Parello
[MC] = Mouli Chandramouli

Terminology draft
-----------------
Presented by Jon Parello.
- We use Entity = 'Device or Component'
- Compared EMAN terminology with ASHRAE 201p
     They use Asset to describe 'Device or Component.'
     EMAN should use 'Entity,' to be consistent with Entity MIB [DR]
- ASHRAE use 'Nameplate Power'
     EMAN should use 'Manufacture Rating'
= The terminology is nearly all moved into the Requirements and
   Framework drafts.

Requirements for Energy Management -08
--------------------------------------
Presented by Juergen Quittek (via Skype)
- Made changes suggested since IETF-83
- Open issues:
    + Reporting of device info - "what info for which device(s)?"
      . Report for devices, components and interfaces? [JP]
      . Report for objects in Entity MIB [DR]
      = Use the Entity MIB
- 'Phasor measurements' had been discussed on the list, should these
     be included in Requirements? [GK]
   Little support at the meeting, continue on list.
- Need to add a requirement for windowing of measurements,
     as discussed on the list [MC]
= The authors will publish one more revision, then we will start
   its WG Last Call.

Energy Management Framework -05
-------------------------------
Presented by John Parello
- Added 'reference topology and guidelines' for power sources,
   metering, proxies and aggregation
- Open items
   . Edit pass: authors to check each section, and decide whether it
       should me kept/trimmed/moved/deleted
   . Check to see that draft's UML matches that in latest Monitoring MIB
   + States and Levels
     . ASHRAE uses 'curtailment levels,' should we?
     . The draft lists levels from several other organisations;
       should we set out an 'EMAN levels' list? [JP, AR]
       = Meeting was strongly in favour of this; discussion will
         continue on list
   * Our AD [BC] pointed out that we need to track issues more carefully,
     so that we don't revisit an issue once it's been closed.
     Chairs (Nevil, since BN is a document author) will so this using
     the DataTracker
= New revision needed, WGLC once all issues are closed.

Energy-aware Networks and Devices MIB -06
-----------------------------------------
Presented by John Parello.
- Textual Convention added for EnergyRelations
- Now compatible with object in Entity MIBv4
- Open issues
   + Persistence of objects (when they're power-cycled or moved)
     = Objects that can change should be represented by objects in
       Entity MIBv4, that's enough [DR]
= New version once Requirements draft is frozen.

Entity MIBv4 -01
----------------
New draft written by Mouli Chandramouli, Presented by Dan Romascanu.
- Identifies devices using the Energy-Aware MIB
- Open Issue
   + Need a compact UUID for entPhysicalUris
     . Assume that devices comply with RFC 4122 [DR]
- This is an initial version of the MIB, comments welcome on list
- Is EMAN the right wg to produce this MIB?
= Yes, Chairs will ask AD to add it to EMAN charter.

Power and Energy Monitoring MIB -03
-----------------------------------
Presented by John Parello (for Mouli Chandramouli).
- Complete, now waiting until Requirements and Framework are complete
- Could Printer MIB be included?  Support for this in meting.

Battery MIB -05
---------------
Presented by Juergen Quittek.
- Five open issues, need feedback from list!
   . Authors will make suggestions
= Waiting on Entity MIBv4

Applicability Statement -01
---------------------------
Presented by Bruce Nordman.
- Open issues from IETF-83 now closed
- Use Cases and Related Standards sections almost complete
   . [BN. JP] have sent comments on ASHRAE 201p to the list;
     need EMAN folk to consider these and comment on the list
   . Could Implementation Guidelines be in this draft?
     Not yet, we need some implementation experience [BC]
   . Could other use cases be added? [GK]
     Yes, please send text to authors (via the list)
= Could be ready for WGLC once Requirements and Framework are done.

Milestones
----------
The Chairs presented a list of proposed new dates .
- Requirements                    Oct 2012
- Framework (after discussion)  April 2013
- MIBs, Applicability Statement  June 2013

Other Drafts
------------
ECAP Requirements (Alberto Retona)
- This draft is from rtwg, its goal is to optimise power consumption
     in the network while maintaining an acceptable service level.

Green Usage MIB (Satoru Izumi)
- A tiny MIB providing energy state information for various devices

Nanogrids (Bruce Nordham)
- No time for this, alas.  Please read the draft

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 2 Aug 2012 19:41:57 +0000

See inline...

Sent from my iPad 
(expect ridiculous spelling mistakes) 

> [MC] = Mouli Chandramouli
correction of above it was should add manufacturer rating to the nameplate definition
- Benoit asked for clarification on interfaces so that they dont seem to be for connecting components
> Requirements for Energy Management -08
John - at mic in our implementations we keep the same model for interfaces, components and devices. And thatbdesign should be in modelsmnot requirements. That keeps it simple to implement. Dan seconded in his comments at mic as this is what entity does. 
> Energy Management Framework -05
-Alvarado from rtwg asked for a reccomended set of levels. Asked if EMAN could be indicated as the prefered. 
     -We discussed John  asked the floor for discussion and it concluded that we will add that to draft.
-The chairs will send a note to the printer working group to ask if we should add their levels to the planned IANA regiatry for inclusion.
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Aug 2012 13:08:43 -0700

Dear all,

See inline.
>> Energy-aware Networks and Devices MIB -06
My notes read:

add a new MIB oid specifically for UUID, instead of reusing the 
ENTITY-MIB URI OID

repeat that there is persistence, even if it's implicit from RFC4122

IANA considerations to be added for the new registry

Regards, Benoit