Subject: Re: [eman] #16: c. What does parent/child mean when the direction of power flow between two devices can reverse?

From: <[email-masked]>
Date: Sun, 4 Nov 2012 20:45:48 +0000

Hi all,

I assume that this comment refers to the situation where bidirectional power interfaces are used?
I agre that this the parent/child energy object relationship needs to be defined for the situation that bidirectional power interfaces are used!

Best regards,
Georgios

________________________________________
Van: [email-masked] [[email-masked]] namens eman issue tracker [[email-masked]]
Verzonden: donderdag 25 oktober 2012 4:47
To: [email-masked]; [email-masked]
Cc: [email-masked]
Onderwerp: Re: [eman] #16: c. What does parent/child mean when the direction of power flow between two devices can reverse?

#16: c. What does parent/child mean when the direction of power flow  between
two devices can reverse?

Comment (by brads@…):

 I presume the the question regards when a child uses its battery to power
 a parent.  This seems a limited duration use case that doesn't change the
 normal flow of power from parent to child.

--
--------------------------+-------------------------
 Reporter:  n.brownlee@…  |       Owner:  all
     Type:  defect        |      Status:  new
 Priority:  minor         |   Milestone:  milestone1
Component:  framework     |     Version:  1.0
 Severity:  -             |  Resolution:
 Keywords:                |
--------------------------+-------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/16#comment:2>
eman <http://tools.ietf.org/eman/>

_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: "John Parello (jparello)" <[email-masked]>
Date: Mon, 5 Nov 2012 04:14:35 +0000

Hi All,

In the draft we defined parent child as a generic relationship between two entities. Then we define specific relationships: power by, metered by etc.

The direction of energy expressed by the sign of the power is orthogonal to the relationships so I think this is covered and not an issue.

Jp

Sent from my iPad 
(expect ridiculous spelling mistakes)

---

From: <[email-masked]>
Date: Mon, 5 Nov 2012 11:58:30 +0000

Hi John,

Thank you for the clarification!

Best regards,
Georgios

________________________________________
Van: John Parello (jparello) [[email-masked]]
Verzonden: maandag 5 november 2012 5:14
To: Karagiannis, G. (EWI)
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Onderwerp: Re: [eman] #16: c. What does parent/child mean when the direction of power flow between two devices can reverse?

Hi All,

Jp

Sent from my iPad

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 6 Nov 2012 03:53:29 +0000

Hi John,

I do not understand why the "powered-by" relationship would be independent
of the direction of energy.  Wouldn't it change somehow if the direction
of energy changes at a device?

Thanks,
    Juergen

On 04.11.12 23:14, "John Parello (jparello)" <[email-masked]> wrote:

>Hi All,
>
>In the draft we defined parent child as a generic relationship between
>two entities. Then we define specific relationships: power by, metered by
>etc.
>
>The direction of energy expressed by the sign of the power is orthogonal
>to the relationships so I think this is covered and not an issue.
>
>Jp
>
>
>
>Sent from my iPad 
>> I agre that this the parent/child energy object relationship needs to
>>be defined for the situation that bidirectional power interfaces are
>>used!
>> 
>> Best regards,
>> Georgios
>> 
>> Van: [email-masked] [[email-masked]] namens eman issue
>>tracker [[email-masked]]
>> Onderwerp: Re: [eman] #16: c. What does parent/child mean when the
>>direction of power flow between two devices can reverse?
>> 
>> Comment (by brads@Š):
>> Reporter:  n.brownlee@Š  |       Owner:  all
>> Ticket URL: 
>><http://trac.tools.ietf.org/wg/eman/trac/ticket/16#comment:2>

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 6 Nov 2012 17:25:37 +0000

Yes in that specific relationship one could change but not required (the sign of power could change and the relationship remain and indicate and error condition. Etc)

That aside the question and issue here was about parent child and the concept. I'm referring to the definition of parent and child as generic terms and concept for a relationship. That has nothing to with power and direction.

       Energy Object Parent 

          An Energy Object Parent is an Energy Object that 
          participates in an Energy Object Relationships 
          and is considered as providing the capabilities 
          in the relationship.   
           
          Example: in a Metering Relationship, the Energy 
          Object that is metering is called the Energy 
          Object Parent, while the Energy Object that is 
          metered is called the Energy Object Child.  

       Energy Object Child 

          An Energy Object Child is an Energy Object that 
          participates in an Energy Object Relationships 
          and is considered as receiving the capabilities 
          in the relationship. 

Sent from my iPad

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 6 Nov 2012 19:47:40 +0000

Hi John,

On 06.11.12 12:25, "John Parello (jparello)" <[email-masked]> wrote:

>Yes in that specific relationship one could change but not required (the
>sign of power could change and the relationship remain and indicate and
>error condition. Etc)

I am not sure I fully understand this: Do you mean that a changed power
direction would be an error condition?

>
>That aside the question and issue here was about parent child and the
>concept. I'm referring to the definition of parent and child as generic
>terms and concept for a relationship. That has nothing to with power and
>direction.

Indeed it was.  If you go down the email thread below you'll find the
question:

"What does parent/child mean when the direction of power flow between two
devices can reverse?"

And I would answer: Yes, the parent child relationship between two devices
can reverse over time.

Thanks,
    Juergen

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 6 Nov 2012 20:54:45 +0000

Sent from my iPad 

> direction would be an error condition?

You can have a condition where the power source is fixed and the power sign changes. In that case it could be used as a way of indicating to an EnMS of an anomalous condition. It's  not a data modeling error it's a condition that can be interpreted as an problem.

> And I would answer: Yes, the parent child relationship between two devices

Ack on that - it can - but doesn't have to if the direction changes. Depends on the devices in question

---

From: "eman issue tracker" <[email-masked]>
Date: Wed, 07 Nov 2012 15:42:16 -0000

Changes (by n.brownlee@…):

 * status:  new => closed
 * resolution:   => fixed

-- 
--------------------------+-------------------------
 Reporter:  n.brownlee@…  |       Owner:  all
     Type:  defect        |      Status:  closed
 Priority:  minor         |   Milestone:  milestone1
Component:  framework     |     Version:  1.0
 Severity:  -             |  Resolution:  fixed
 Keywords:                |
--------------------------+-------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/16#comment:3>
eman <http://tools.ietf.org/eman/>