Subject: Re: [Gendispatch] I-D Action: draft-thomson-gendispatch-no-expiry-00.txt

From: John Mattsson <[email-masked]>
Date: Mon, 18 Nov 2019 10:51:44 +0000

I agree with the arguments put forward in this draft. I agree that expiry should be removed, any negative shortcomings of this should be solved by updates to the tools. If a draft under special conditions does not expiry already today, having an expiry date in the actual draft is even wrong (it is then more expected expiry).

Some comments on the NEW text (the comments are more related to RFC 2418 than draft-thomson-gendispatch-no-expiry)

   "NEW:

      Internet-Drafts are draft documents that may be updated, replaced,
      or obsoleted by other documents at any time.  It is inappropriate
      to use Internet-Drafts as reference material or to cite them other
      than as "work in progress."

The text on citing seems to not align with the text in RFC 2418

     "*   Under no circumstances should an Internet-Draft    *
      *   be referenced by any paper, report, or Request-    *
      *   for-Proposal, nor should a vendor claim compliance *
      *   with an Internet-Draft.                            *"

Also the wording "updated, replaced, or obsoleted" can easily be confused with the terminology "updates" and "obsoletes" that are used for RFCs. 

/John

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 19 Nov 2019 13:04:35 +1300

John,
On 18-Nov-19 23:51, John Mattsson wrote:
> I agree with the arguments put forward in this draft. I agree that expiry should be removed, any negative shortcomings of this should be solved by updates to the tools.

That doesn't come free. I don't see the alleged harm done by the expiry date as serious enough to be worth fixing (for real $$). In particular, this from earlier discussion:

>>> I also think that if one is searching for a particular (current) I-D, 
>>> the default search results shouldn't be flooded with drafts that are 
>>> arbitrarily old.  
>> 
>> Yes, that's an important practical point. I regularly make use of the 3rd
>> radio button in the tracker's "Additional search criteria ", namely
>> "Internet-Draft (expired, replaced or withdrawn)". If there was no standard
>> expiry lifetime, I'd need an "older than..." button instead. More work for
>> the tools team...

> If a draft under special conditions does not expiry already today, having an expiry date in the actual draft is even wrong (it is then more expected expiry).

Well, it's not really *wrong* - it's more of a reminder that the IETF is really slow in progressing its work sometimes. 

>       *   with an Internet-Draft.                            *"

I don't see an inconsistency; the boilerplate is a summary. BTW that
text is in RFC 2026, not 2418.
 
> Also the wording "updated, replaced, or obsoleted" can easily be confused with the terminology "updates" and "obsoletes" that are used for RFCs. 

Huh? They are perfectly valid words with the same meaning in both cases.

Regards
     Brian